Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-08-2016 02:39:56

Spirale21
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : i3 version 4.8
Inscription : 26-02-2013

[Résolu] Problème d'authentification wifi avec NetworkManager

bonsoir,
Je vous explique mon problème: Quand je veux me connecter en wifi depuis mon portable, debian (NetworkManager) me demande un mot de passe... je le lui donne et au bout de  min il me dit mot de passe incorrect (une erreur comme ça) pourtant je suis sûr de moi (ma tablette, mon autre ordi et mon téléphone marchent tous avec ce mot de passe) et j'ai fait au moins 5 tentatives, là je suis à bout..

lspci |grep [Nn]etwork


02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)


lsmod



[...]
snd_hda_codec_idt      48946  1
cfg80211              405538  4 ath,ath9k_common,ath9k,mac80211
ttm                    77862  1 nouveau
snd_hda_codec_generic    63181  1 snd_hda_codec_idt
drm_kms_helper         49210  1 nouveau
rfkill                 18867  5 cfg80211,hp_wmi
drm                   249998  6 ttm,drm_kms_helper,nouveau
i2c_algo_bit           12751  1 nouveau
[...]
 


le driver de ma carte wifi c ath9k

dmesg


[...]
[  732.136108] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  738.363174] wlan0: deauthenticated from 02:6f:d7:3e:8e:60 (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
[  739.317629] wlan0: authenticate with 02:6f:d7:3e:8e:60
[  739.329758] wlan0: send auth to 02:6f:d7:3e:8e:60 (try 1/3)
[  739.333438] wlan0: authenticated
[  739.336055] wlan0: associate with 02:6f:d7:3e:8e:60 (try 1/3)
[  739.345071] wlan0: RX AssocResp from 02:6f:d7:3e:8e:60 (capab=0x411 status=0 aid=1)
[  739.345144] wlan0: associated
[  747.340110] wlan0: deauthenticated from 02:6f:d7:3e:8e:60 (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
[  748.003102] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  748.372992] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
 


systemctl status NetworkManager


● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since lun. 2016-08-15 02:13:03 CEST; 14min ago
 Main PID: 2567 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           └─2567 /usr/sbin/NetworkManager --no-daemon

août 15 02:27:39 CQ71 NetworkManager[2567]: <error> [1471220859.852094] [supplicant-manager/nm-supplicant-interface.c:856] interface_add_cb(): (wlan0): error adding interface: wpa_s...is interface.
août 15 02:27:39 CQ71 NetworkManager[2567]: <info> (wlan0): supplicant interface state: starting -> down
août 15 02:27:39 CQ71 NetworkManager[2567]: <error> [1471220859.920095] [supplicant-manager/nm-supplicant-interface.c:856] interface_add_cb(): (wlan0): error adding interface: wpa_s...is interface.
août 15 02:27:39 CQ71 NetworkManager[2567]: <info> (wlan0): supplicant interface state: starting -> down
août 15 02:27:39 CQ71 NetworkManager[2567]: <error> [1471220859.996134] [supplicant-manager/nm-supplicant-interface.c:856] interface_add_cb(): (wlan0): error adding interface: wpa_s...is interface.
août 15 02:27:39 CQ71 NetworkManager[2567]: <info> (wlan0): supplicant interface state: starting -> down
août 15 02:27:40 CQ71 NetworkManager[2567]: <error> [1471220860.068136] [supplicant-manager/nm-supplicant-interface.c:856] interface_add_cb(): (wlan0): error adding interface: wpa_s...is interface.
août 15 02:27:40 CQ71 NetworkManager[2567]: <info> (wlan0): supplicant interface state: starting -> down
août 15 02:27:40 CQ71 NetworkManager[2567]: <error> [1471220860.144393] [supplicant-manager/nm-supplicant-interface.c:856] interface_add_cb(): (wlan0): error adding interface: wpa_s...is interface.
août 15 02:27:40 CQ71 NetworkManager[2567]: <info> (wlan0): supplicant interface state: starting -> down
 


donc d'après ce que j'ai compris mon wifi est par intermittence mais pourtant matériellement tout est correct, et je vois pas ce que je peux faire de plus. Là, j'ai internet en filaire mais bientôt j'aurais que le wifi et donc c'est embêtant lol(c les nerfs)... c pareil avec wicd. Si vous pouviez m'indiquer une piste.
Merci

Dernière modification par Spirale21 (22-08-2016 22:40:11)


RTFM ça ct avant....

Hors ligne

#2 15-08-2016 08:56:08

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

Spirale21 a écrit :

bonsoir,
Je vous explique mon problème: Quand je veux me connecter en wifi depuis mon portable, debian (NetworkManager) me demande un mot de passe... je le lui donne et au bout de  min il me dit mot de passe incorrect (une erreur comme ça) pourtant je suis sûr de moi (ma tablette, mon autre ordi et mon téléphone marchent tous avec ce mot de passe) et j'ai fait au moins 5 tentatives, là je suis à bout..



pour être clair (parce que j'ai un peu de mal ce matin tongue)
quand tu dis que NetworkManager te demande un mot de passe, c'est bien ton code de sécurité wifi wpa/wep ?


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#3 15-08-2016 09:55:18

Spirale21
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : i3 version 4.8
Inscription : 26-02-2013

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

oui , c ma clé wpa/wpa2 privé, ma clé pour se connecter..  pour le SSID c fbx_local_nono (je suis chez free, j'ai une freebox v4).

RTFM ça ct avant....

Hors ligne

#4 15-08-2016 10:01:52

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

de mémoire avec networkmanager tu peux afficher en clair les caractères que tu tape, donc pas d'erreurs de frappe (clavier mal configuré par exemple ?)
tu n'as pas de soucis de plage IP (tu as déjà 3 appareils connecté, il n'y aurait pas un conflit avec un des autres appareils ?)

après pour le coté plus technique je ne pourrai pas trop t'aider, j'ai pas assez de "barbe" tongue

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#5 15-08-2016 10:56:01

Spirale21
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : i3 version 4.8
Inscription : 26-02-2013

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

Oui, il y a possibilité de voir le mot de passe dans NetworkManager et il est correctement tapé smile
Pour le conflit, j'avoue que tu m'as fait peur... mais non je suis allé sur mon interface de gestion le routeur est activé et j'ai une plage allant du 192.168.1.2 au 192.168.1.200 big_smile
Bref merci pour les pistes mais tout est correct

RTFM ça ct avant....

Hors ligne

#6 15-08-2016 14:28:31

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

Bonjour,

As tu coché pour tous les utilisateurs?  J'ai eu un soucis comme ça avec Kubuntu.

edit: Je viens de regarder sur ma Debian, quand tu tapes le mot de passe, il y a un symbole tout à droite du champ mot de passe et il doit y voir cocher au moins une des deux propositions.

Enregistrer le mot de passe seulement pour cet utilisateur
Enregistrer le mot de passe pour tous les utilisateurs


Chez moi c'est la première proposition qui est cochée.

Hors ligne

#7 15-08-2016 16:57:35

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

Tu dis que tu as essayé avec wicd, est-ce qu'il est encore installé car les deux gestionnaires de réseaux peuvent être en conflit si il sont installés tous les deux.

Hors ligne

#8 15-08-2016 17:37:16

Spirale21
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : i3 version 4.8
Inscription : 26-02-2013

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

alors j'ai désinstaller wicd

systemctl disable wicd



rien à faire ça va encore moins bien... le mot de passe est bon et enregistrer partout pour tout les utilisateurs je pense faire un petit tour dans le BIOS parce que je suis de plus en plus convaincu que la carte marche par intermittence (ou il y a conflit)
@deuthdeb merci pour ses pistes

Edit à toto :
Supprimé "le bloc à supprimer". tongue


RTFM ça ct avant....

Hors ligne

#9 19-08-2016 15:32:45

Spirale21
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : i3 version 4.8
Inscription : 26-02-2013

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

bonjour,
je cherche.... alors je raconte
- dans le BIOS rien d'anormal et j'ai changer le HDD par un Windows et la connexion Wifi marchais comme un charme --> Le problème vient de Linux
- j'ai cherché si ça venait pas du driver (j'hésitais entre ath5k et ath9k) mais le driver correspond bien selon tous les forums et site --> le driver est bien l'ath9k
- Puis je me suis connecté à un wifi libre sans clé (ni WEP ni WPA): FreeWifi (merci free) et là avec un peu de temps ça fonctionne --> NetworkManager et wpa_supplicant

Comme je suis incapable de me connecter à mon réseau protégé en WPA 2 je pense à une incompatibilité de Network manager et de wpa_supplicant qui ne marche pas de concert. ou celui de network manager qui fonctionne mal, mais non! parce que j'aurais pas de soucis avec wicd.
Mon prochain test ça sera de me connecter à mon réseau par le biais de la ligne de commande sans utilisé Network manager. Je vous tiendrais au courant de mes tests big_smilewink

RTFM ça ct avant....

Hors ligne

#10 19-08-2016 15:39:14

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

Salut,
Je vois que tu utilises i3, est-ce que c'est toi qui installé ton système actuel à partir d'une installation Debian minimale (sans DE) ?
Si oui cela veut dire que tu as tout installé à la main, y compris NetworkManager.
En ce cas n'aurais-tu pas oublié un paquet en rapport ? (je pense à gnome-keyring ou à des paquets comme policykit pour avoir le droit de manipuler les interfaces réseaux etc...)

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#11 19-08-2016 20:58:34

Spirale21
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : i3 version 4.8
Inscription : 26-02-2013

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

salut,
alors en fait j'ai oublié de préciser: c mon deuxième ordi un compaq CQ71 avec gnome 3.14 ...

RTFM ça ct avant....

Hors ligne

#12 19-08-2016 22:03:39

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

Deux solutions alternative, tu redémarre la freebox (sa m'est déjà arrivé), ou tu essaye de te connecter en manuel avec wpa_supplicant.

Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#13 22-08-2016 22:39:38

Spirale21
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : i3 version 4.8
Inscription : 26-02-2013

Re : [Résolu] Problème d'authentification wifi avec NetworkManager

Bonsoir...
Alors j'en perds mon latin (heureusement je sais pas le parler wink)...
- eh bien j'ai réinitialiser la freebox --> rien
- J'ai essayer rien qu'avec wpa_supplicant en mode debug (bavard)
déjà

cp /usr/share/doc/wpasupplicant/examples/wpa-psk-tkip.conf-.conf /etc/wpa_supplicant.conf


ensuite j'ai renseigné wpa_supplicant.conf correctement (avec mes valeurs)

wpa_supplicant -D nl80211 -c/etc/wpa_supplicant.conf -i wlan0 -dd


et là... j'ai compris des morceaux de log mais pas tout alors je me suis dit n'installons que Network manager et enlevons wpa_supplicant (le contraire de mon idée initiale en fait)
et là... ça fonctionne mais je sais pas trop pourquoi en fait!! big_smile
la seule chose que j'ai ajouter à mon

vi /etc/network/interfaces


auto wlan0
iface wlan0 inet dhcp


et comme ça fonctionne je ne touche plus à rien big_smile alors peut être que Network manager s'est "bien" réinstaller ou il y avait des conflits parce que Network manager avait laissé des fichiers qui entraient en conflit avec wpa_supplicant, je ne peux pas le certifier...
Le principale c que ça marche!! wink

Edit à 23h25
Je crois avoir compris!! big_smile oui j'ai mis un SSD à la place du HDD donc j'étais obligé de refaire les manip et vlan!! ça fonctionne pas big_smile (j'suis maso mais j'aime quand ça fonctionne pas alors que ça devrait, un espèce de challenge mais bon c pas un forum de psycho wink). Pour vous dire que je crois que il faut dire à Linux que dorénavent c NetworkManager qui s'occupe de tout (du réseau) et que le noyau n'a plus à le géré et ça se passe dans le fichier

/etc/NetworkManager/NetworkManager.conf


il faut mettre dans la section ifupdown la valeur de managed à false

[ifupdown]
managed=true #à la place de false


car ifupdown = gestion du réseau (d'après ce que je comprends). dans wpa_supplicant aussi y'avait ifupdown et je pense que Linux donne préférentiellement le contrôle au fichier /etc/network/interfaces et donc il faut court-circuiter ce penchant de Linux.. Avec mon wpa_supplicant  un peu la flemme de décortiquer les log big_smile mais je suis sûr qu'il n'y avait pas grand chose
Le fichier

/etc/network/interfaces

devient simplement pour la connexion par wifi

#activation de l'interface Wifi au démarrage (démarrage matérielle)
auto wlan0


ensuite redémarrer network-manager et ça marche comme un charme
https://wiki.debian.org/fr/NetworkManag … to_eth0.22 c'est  le lien  qui m'a donné une épiphanie (bon y'a aussi d'autre post mais je ne les ai pas noté)... lol et merci pour toute vos pistes.

Dernière modification par Spirale21 (22-08-2016 23:49:02)


RTFM ça ct avant....

Hors ligne

Pied de page des forums