Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-08-2016 14:52:47

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

[RÉSOLU] Configurer une touche numlock

Bonjour à tous !

L'idée que j'ai va peut-être vous paraître baroque. Il se trouve que j'ai un clavier qui ne dispose pas de pavé numérique. Pour taper un chiffre, je dois donc utiliser la touche Maj. La touche verrouillage majuscule ne permet pas de taper des chiffres (ce qui du reste est bien pratique). Mais comme j'ai besoin de taper souvent des chiffres, je voudrais éviter d'avoir à appuyer sur la touche Maj en permanence (d'autant que mon doigt lâche parfois...)
Je voudrais donc créer une combinaison de touches qui serait l'équivalent du verrouillage majuscule, mais pour les chiffres. Quelqu'un aurait-il une idée ?

Merci d'avance !

Dernière modification par Lancelot du Lac (18-08-2016 09:30:31)


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#2 17-08-2016 15:15:07

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RÉSOLU] Configurer une touche numlock


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 17-08-2016 15:42:00

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RÉSOLU] Configurer une touche numlock

Tu pourrais créer un raccourci clavier qui lancerait la ligne de commandes suivante :

xmodmap -pke | awk '/keycode  1[0-9]/ {temp=$4;$4=$5;$5=temp;print}' > tmpxmodmap && xmodmap tmpxmodmap && rm tmpxmodmap


Il s'agit d'une bascule => Pour revenir à l'état antérieur, relance la même ligne de commandes (en utilisant le raccourci que tu aura défini).

Je n'utilise pas KDE, mais d'autres intervenants pourront t'indiquer comment créer le raccourci clavier qui lancera cette ligne de commandes (ou le script contenant cette ligne de commande).

Dernière modification par MicP (17-08-2016 18:58:41)

Hors ligne

#4 18-08-2016 09:29:55

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RÉSOLU] Configurer une touche numlock

Merci MicP ! Ça fonctionne très bien. Le seul problème, c'est que c'est un peu lent. Par exemple, le 1/& se change rapidement, mais pas 9/ç. Visiblement, c'est xmodmap qui met du temps à reconfigurer. J'ai essayé d'accélérer, sans succès. Pour le moment, je vais me contenter de ça, c'est déjà très bien. Merci beaucoup.
Pour le raccourci clavier : sur KDE (Plasma 5 pour ma part), il faut faire un clic droit sur le menu K > Modifier les applications > Nouvel élément > mettre le lien vers la commande > Avancé > Raccourci clavier > Enregistrer.
Pour ma part, j'ai choisi Meta + N.

Dernière modification par Lancelot du Lac (18-08-2016 09:31:24)


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#5 18-08-2016 10:03:05

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RÉSOLU] Configurer une touche numlock

…c'est un peu lent…

Pas de problème de lenteur sur ma machine (XFCE debian). Je me suis arrangé pour ne redéfinir que les 10 touches concernées.
Mais j'avais aussi constaté cette latence quand je redéfinissait toutes les touches du clavier en une seule commande xmodmap

Dernière modification par MicP (18-08-2016 10:17:59)

Hors ligne

#6 18-08-2016 11:03:05

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RÉSOLU] Configurer une touche numlock

Mais la commande que tu as indiquée redéfinit l'ensemble des touches, ou seulement les touches 0 à 9 ?

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#7 18-08-2016 17:08:40

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RÉSOLU] Configurer une touche numlock

La commande indiquée ne redéfinit que les touches 0 à 9.

Dernière modification par MicP (18-08-2016 17:10:11)

Hors ligne

#8 18-08-2016 17:11:48

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RÉSOLU] Configurer une touche numlock

C'est ce qu'il me semblait. Donc le problème n'a pas de solution, ce sera toujours un peu lent. Enfin, quand je dis lent, ça met quand même moins d'une seconde, mais quand on tape au clavier, ça se ressent. N'empêche, c'est quand même bien commode. Merci encore !

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#9 18-08-2016 21:20:24

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [RÉSOLU] Configurer une touche numlock

Bonsoir,

Par curiosité j'ai essayé la commande donnée par MicP et n'ai pas constaté de lenteur particulière... sinon il y aurait bien une option xkb mais elle redéfinit tout le clavier (enfin la zone alphanumérique) ; pour tester :

setxkbmap -option shift:both_shiftlock #Both Shift keys together toggle ShiftLock


Après 'en dur' ça se passe dans le fichier keyboard (voir la page man correspondante).

Hors ligne

#10 18-08-2016 22:07:50

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RÉSOLU] Configurer une touche numlock

Merci èfpé pour cette solution que je ne connaissais pas

Dernière modification par MicP (22-08-2016 05:47:28)

Hors ligne

#11 19-08-2016 09:23:14

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RÉSOLU] Configurer une touche numlock

èfpé a écrit :

sinon il y aurait bien une option xkb mais elle redéfinit tout le clavier (enfin la zone alphanumérique) ; pour tester :

setxkbmap -option shift:both_shiftlock #Both Shift keys together toggle ShiftLock


Après 'en dur' ça se passe dans le fichier keyboard (voir la page man correspondante).



Chez moi, ça ne produit absolument rien hmm ...
Je regarde keyboard, mais ça m'a l'air coton, je ne suis encore qu'une jeune bleusaille. Merci de la suggestion !


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#12 19-08-2016 09:42:54

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RÉSOLU] Configurer une touche numlock

…Chez moi, ça ne produit absolument rien hmm ...

Effectivement, on ne voit rien, mais si, après avoir lancé cette ligne de commandes, tu appuie sur les deux touches Shift (maj) en même temps,
Les chiffres de la partie alphanumérique du clavier seront directement accessibles, et toutes les autres touches seront en majuscule.

Par contre, je ne connais pas la commande qui permettrait de désactiver uniquement cette option.

Dernière modification par MicP (19-08-2016 09:48:06)

Hors ligne

#13 19-08-2016 11:22:17

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [RÉSOLU] Configurer une touche numlock

Bonjour,

Lancelot du Lac a écrit :

Chez moi, ça ne produit absolument rien :/ ...


J'avoue n'avoir testé cette option que sur un clavier européen 'standard' actuel (105 touches, soit les 102 touches du fameux 'clavier modèle M' des années 80 auxquelles ont été ajoutées 3 touches pour faire 'plaisir' à MS, vers 1995). Si cette option ne fonctionne pas chez toi, cela ne sert à rien d'aller plus loin.

Cette commande permet d'afficher les options xkb actives pour la session en cours :

setxkbmap -query | grep options


Si elle ne produit rien, c'est qu'il n'y en a pas.

MicP a écrit :

Par contre, je ne connais pas la commande qui permettrait de désactiver uniquement cette option.


La page man de setxkbmap laisse peu d'espoir à ce sujet... on pourrait toujours imaginer une commande qui récupère les options, les désactive toutes puis les réactive toutes sauf celle-là, mais bon... qu'elle fonctionne ou pas, cette option aura disparu à la session suivante.

edit: peut-être aurais-je dû préciser qu'il s'agit d'une bascule (toggle) ?

Dernière modification par èfpé (19-08-2016 11:38:17)

Hors ligne

#14 19-08-2016 11:23:30

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RÉSOLU] Configurer une touche numlock

MicP a écrit :

si, après avoir lancé cette ligne de commandes, tu appuie sur les deux touches Shift (maj) en même temps,
Les chiffres de la partie alphanumérique du clavier seront directement accessibles, et toutes les autres touches seront en majuscule.

Par contre, je ne connais pas la commande qui permettrait de désactiver uniquement cette option.



Je n'y comprends rien : quand je tape cette commande, que j'appuie ensuite sur les deux shift en même temps, la partie alphanumérique est effectivement accessible, aussi longtemps que j'appuie, mais les autres lettres ne sont pas en majuscule. Peut-être est-ce KDE qui empêche l'exécution ? Je vais tester sur un autre environnement.


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#15 19-08-2016 12:53:05

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RÉSOLU] Configurer une touche numlock

Je suis en train d'installer debian KDE dans une machine virtuelle pour essayer de comprendre…

=======
@ èfpé Merci beaucoup pour les précisions que tu nous donne dans ton dernier message.

=======
L'installation est terminée et je viens de terminer les tests depuis une machine virtuelle debian KDE => La ligne de commande proposée par èfpé fonctionne.

J'ai aussi testé la ligne de commande (xmodmap …) que je proposais et n'ai pas observé de latence.
Mais bon : L'installation est toute fraîche et je n'y ai rien installé d'autre que le serveur ssh et Midnight Commander

Dernière modification par MicP (19-08-2016 14:32:58)

Hors ligne

#16 19-08-2016 16:16:08

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RÉSOLU] Configurer une touche numlock

Bah, ne vous embêtez pas, c'est peut-être dû au fait que je sois sous Stretch. Au fond, la solution de MicP marche, il ne faut pas être trop tatillon. J'ai quand même essayé la commande suggérée par èfpé :

setxkbmap -query | grep options


options:    shift:both_shiftlock,shift:breaks_caps
 


Je précise que j'ai un clavier 101 touches.


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#17 19-08-2016 16:38:38

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [RÉSOLU] Configurer une touche numlock

Re-,

@Lancelot du Lac: il y a peut-être une incompatibilité entre ces deux options ? Si tu veux tester plus, tu peux commencer par désactiver (ne t'inquiète pas cela n'affecte que la session en cours) toutes les options puis réactiver celle qui nous intéresse :

setxkbmap -option && setxkbmap -option shift:both_shiftlock


et voir ce que ça donne ; pour revenir à l'état antérieur :

setxkbmap -option && setxkbmap -option shift:breaks_caps


Voili voilo, désolé de t'avoir fait perdre du temps hmm
Simple curiosité : il n'y a pas de pavé numérique sur ton clavier 101 touches ?

Dernière modification par èfpé (19-08-2016 16:42:07)

Hors ligne

#18 19-08-2016 17:26:36

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RÉSOLU] Configurer une touche numlock

Simple curiosité : il n'y a pas de pavé numérique sur ton clavier 101 touches ?


Oui : il y a bien un pavé numérique sur le clavier à 101 touches, même pour le 84 touches. Regarde les images retournées avec comme motif de recherche PC keyboard 101

Ça devient très très difficile de trouver un clavier qui soit complet et standard : Ils ont pratiquement tous des spécificités que je trouve complètement inutiles (je suis très gentil) pour l'utilisateur

EDIT: Un "oui" tout seul pouvait prêter à confusion…

Dernière modification par MicP (19-08-2016 18:23:07)

Hors ligne

#19 19-08-2016 17:34:54

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [RÉSOLU] Configurer une touche numlock

@MicP: ok, je m'en étais tenu à ce que j'avais lu et vu ici, mais je vais chercher un peu plus loin, merci smile

De mon côté, je 'confirme' une certaine incompatibilité, voire une incompatibilité certaine, entre ces deux options affectant la touche Maj/Shift : shift:both_shiftlock et shift:breaks_caps (mais c'est assez logique en fait hmm).

Dernière modification par èfpé (19-08-2016 17:38:44)

Hors ligne

#20 19-08-2016 18:24:44

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RÉSOLU] Configurer une touche numlock

@èfpé Le lien que tu cite dans ton dernier message est plus complet et précis que la recherche d'images que je proposais.

Hors ligne

#21 20-08-2016 14:59:50

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RÉSOLU] Configurer une touche numlock

En fait, je dis 101, parce que c'est ce que KDE détecte, mais je viens de me rendre compte que ce n'est pas du tout le cas... C'est un clavier qui fait un peu penser à un clavier de MacIntosh. Il n'y a pas de pavé numérique dessus (à mon grand dam, et d'où ma question). Je laisse tomber pour le moment, de toute façon le problème est réglé, merci encore de vos conseils et suggestions !

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

Pied de page des forums