Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-08-2016 19:52:58

moi4567
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3
Inscription : 22-06-2015

[RESOLU]Conky update_interval ne fonctionne pas

Bonjour à tous smile

Etant un fan absolu de conky, je l'ai installer sur mon debian avec gnome 3. Tous est impeccable au détail près que le "refresh" de conky ne semble pas fonctionner... hmm
Pourtant l'update_interval a pour valeur 1.0 (soit 1 second) mais conky ne s'actualise qu'une fois de temps en temps (une fois toute les 2  ou 3 minutes).

J'ai cherché mais je ne vois pas trop d'où ça peux venir... hmm
Voilà ma config de mon conky si jamais vous en avez besoin:

# Use Xft?
use_xft yes
xftfont DejaVu Sans:size=8
xftalpha 0.8
text_buffer_size 2048

# Update interval in seconds
update_interval 1.0

# This is the number of times Conky will update before quitting.
# Set to zero to run forever.
total_run_times 0

# Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_type normal
own_window_argb_visual yes
own_window_argb_value 255
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# Minimum size of text area
minimum_size 250 0
#maximum_width 200

# Draw shades?
draw_shades no

# Draw outlines?
draw_outline no

# Draw borders around text
draw_borders no

# Stippled borders?
stippled_borders 0

# border margins
border_margin 5

# border width
border_width 1

# Default colors and also border colors
default_color D9D4CC
#default_shade_color black
#default_outline_color white
own_window_colour white

# Text alignment, other possible values are commented
#alignment top_left
alignment top_right
#alignment bottom_left
#alignment bottom_right

# Gap between borders of screen and text
# same thing as passing -x at command line
gap_x 23
gap_y 45

# Subtract file system buffers from used memory?
no_buffers yes

# set to yes if you want all text to be in uppercase
uppercase no

# number of cpu samples to average
# set to 1 to disable averaging
cpu_avg_samples 1

# number of net samples to average
# set to 1 to disable averaging
net_avg_samples 1

# Force UTF8? note that UTF8 support required XFT
override_utf8_locale yes

# Add spaces to keep things from moving about?  This only affects certain objects.
use_spacer none

TEXT
${font :size=10:style=bold}SYSTEM${font} ${hr 1}
${voffset 8}${font OpenLogos:size=20}${color 7B9494}t${color}${font}   ${voffset -6}User:  ${alignr 20}${exec users | cut -d " " -f1}@${nodename}
${voffset 3}         Release:  ${alignr 20}${pre_exec lsb_release -r -s} (${pre_exec lsb_release -c -s})
${voffset 3}         Kernel:  ${alignr 20}${kernel}
${voffset 8}${font StyleBats:size=16}${color 7B9494}A${color}${font}   ${voffset -5}CPU1: ${cpu cpu1}% / ${color 7B9494}${exec sensors | grep "Core 0" | cut -d "+" -f2 | cut -c1-6}C${color}${alignr}${color 7B9494}${cpubar cpu1 8,60}${color}
#${font StyleBats:size=16}${color 7B9494}A${color}${font}   CPU2: ${cpu cpu2}% ${alignr}${cpubar cpu2 8,60}
${voffset 5}${font StyleBats:size=16}${color 7B9494}g${color}${font}   ${voffset -5}RAM: $memperc% ${alignr}${color 7B9494}${membar 8,60}${color}
${voffset 5}${font StyleBats:size=16}${color 7B9494}j${color}${font}   ${voffset -5}SWAP: $swapperc% ${alignr}${color 7B9494}${swapbar 8,60}${color}
${voffset 5}${font Webdings:size=16}${color 7B9494}~${color}${font}  ${voffset -5}Battery: ${battery_percent BAT0}% ${alignr}${color 7B9494}${battery_bar 8,60 BAT0}${color}
${voffset 5}${font StyleBats:size=16}${color 7B9494}q${color}${font}   ${voffset -5}Uptime: ${alignr}${uptime}
${voffset 5}${font StyleBats:size=16}${color 7B9494}k${color}${font}   ${voffset -5}Processes: ${alignr}$processes ($running_processes running)
${voffset 10}${font :size=10:style=bold}FILE SYSTEM${font} ${hr 1}
${voffset 8}${font Poky:size=15}${color 7B9494}y${color}${font}${offset 6}${voffset -7}/: ${font Liberation Sans:size=8}${color 7B9494}${fs_used_perc /}%${font}${color}
${color 7B9494}${voffset 2}${fs_bar 4,20 /}${offset 8}${voffset -2}${color}Free: ${fs_free /}${alignr}Used: ${fs_used /}
${voffset 8}${font Poky:size=15}${color 7B9494}y${color}${font}${offset 6}${voffset -7}Home: ${font Liberation Sans:size=8}${color 7B9494}${fs_used_perc /home}%${font}${color}
${color 7B9494}${voffset 2}${fs_bar 4,20 /home}${offset 8}${voffset -2}${color}Free: ${fs_free /home}${alignr}Used: ${fs_used /home}
${voffset 8}${font :size=10:style=bold}NETWORK${font} ${hr 1}
${if_existing /proc/net/route wlan0}
${voffset 2}${color 7B9494}${voffset 4}${font PizzaDude Bullets:size=14}Z${color}${font}   ${voffset -2}Signal: ${wireless_link_qual wlan0}% ${alignr}${wireless_link_bar 8,60 wlan0}
${voffset 2}${color 7B9494}${voffset 4}${font PizzaDude Bullets:size=14}a${color}${font}   ${voffset -2}Local Ip: ${alignr}${addr wlan0}
${voffset 2}${color 7B9494}${voffset 4}${font PizzaDude Bullets:size=14}b${color}${font}   ${voffset -2}Public Ip: ${alignr}${execi 1 ~/.conky/scripts/ip.sh}
${else}${if_existing /proc/net/route eth0}
${voffset 2}${color 7B9494}${voffset -6}${font PizzaDude Bullets:size=14}O${color}${font}   ${voffset -2}Up: ${upspeed eth0} kb/s ${alignr}${color 7B9494}${upspeedgraph eth0 8,60}${color}
${voffset 2}${color 7B9494}${voffset 4}${font PizzaDude Bullets:size=14}U${color}${font}   ${voffset -2}Down: ${downspeed eth0} kb/s ${alignr}${color 7B9494}${downspeedgraph eth0 8,60}${color}
${voffset 2}${color 7B9494}${voffset 4}${font PizzaDude Bullets:size=14}N${color}${font}   ${voffset -2}Upload: ${alignr}${totalup eth0}
${voffset 2}${color 7B9494}${voffset 4}${font PizzaDude Bullets:size=14}T${color}${font}   ${voffset -2}Download: ${alignr}${totaldown eth0}
${voffset 2}${color 7B9494}${voffset 4}${font PizzaDude Bullets:size=14}a${color}${font}   ${voffset -2}Local Ip: ${alignr}${addr eth0}
${voffset 2}${color 7B9494}${voffset 4}${font PizzaDude Bullets:size=14}b${color}${font}   ${voffset -2}Public Ip: ${alignr}${execi 1 ~/.conky/scripts/ip.sh}
${endif}${else}
${font PizzaDude Bullets:size=14}4${font}   Network Unavailable
${endif}
${endif}



Si certains connaissent la solution je prend smile
Merci d'avance wink

Dernière modification par moi4567 (22-08-2016 00:27:49)

Hors ligne

#2 21-08-2016 21:59:28

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [RESOLU]Conky update_interval ne fonctionne pas

bonsoir
petite question, quelle version de conky utilise tu ?

sinon de mon coté j'ai

update_interval 1


peut être un soucis avec le 1.0

enfin ça fonctionne sur mon pc (pas tout parce que je n'ai pas les scripts, mais update_interval oui)

Dernière modification par Severian (21-08-2016 22:06:05)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#3 21-08-2016 23:47:07

moi4567
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3
Inscription : 22-06-2015

Re : [RESOLU]Conky update_interval ne fonctionne pas

Bonsoir et merci de ta réponse smile

Severian a écrit :

bonsoir
petite question, quelle version de conky utilise tu ?



Je suis à la version 1.9.0-6.

Severian a écrit :


sinon de mon coté j'ai

update_interval 1


peut être un soucis avec le 1.0

enfin ça fonctionne sur mon pc (pas tout parce que je n'ai pas les scripts, mais update_interval oui)



J'ai essayé avec 1 au lieux de 1.0 mais ça ne change rien hmm

Hors ligne

#4 22-08-2016 00:03:16

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [RESOLU]Conky update_interval ne fonctionne pas

étrange

j'ai fais un copier de ton conky et mis à part quelques corrections (placement / comment de la ligne batterie / modif pour ne garder que eth0 sans le script pour récupérer l'IP)
il fonctionne très bien

apt-cache policy conky-all


conky-all:
  Installé : 1.9.0-6
  Candidat : 1.9.0-6
 Table de version :
     1.10.3-1 0
         50 http://httpredir.debian.org/debian/ stretch/main amd64 Packages
     1.10.3-1~bpo8+1 0
        150 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
 *** 1.9.0-6 0
        990 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
 


conky -c ~/.config/conky/test-conkyrc


Conky: desktop window (2cf) is root window
Conky: window type - normal
Conky: drawing to created window (0x2600002)
Conky: drawing to double buffer
 



(tu te méfieras, le lua change avec la version 1.10  https://github.com/brndnmtthws/conky/wi … n-Settings )


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#5 22-08-2016 00:16:09

moi4567
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3
Inscription : 22-06-2015

Re : [RESOLU]Conky update_interval ne fonctionne pas

Hum... Étrange... hmm

J'ai essayé une config qui me serre de teste (ci-dessous) et elle fonctionne à la perfection donc le soucis viens clairement de ma config précédente.

Est-ce possible que la config soit trop lourde pour bien fonctionner? yikes

config de teste:


background no
font Ubuntu:bold:size=9
use_xft yes
xftalpha 0.9
update_interval 1.0
total_run_times 0
own_window yes
own_window_type normal
own_window_argb_visual yes
own_window_argb_value 255
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
minimum_size 180 5
maximum_width 180
draw_shades yes
draw_outline no
draw_borders no
draw_graph_borders yes
default_color cccccc
default_shade_color black
default_outline_color green
alignment top_right
gap_x 12
gap_y 35
no_buffers yes
uppercase no
cpu_avg_samples 4
override_utf8_locale no
uppercase no

TEXT

CPU: ${alignr}${freq} MHz

Core 1 ${alignr}${cpu cpu1}%
${cpubar 4 cpu1}
Core 2 ${alignr}${cpu cpu2}%
${cpubar 4 cpu2}
Core 3 ${alignr}${cpu cpu2}%
${cpubar 4 cpu3}
Core 4 ${alignr}${cpu cpu2}%
${cpubar 4 cpu4}
${top name 1}$alignr${top cpu 1}
${top name 2}$alignr${top cpu 2}
${top name 3}$alignr${top cpu 3}
${top name 4}$alignr${top cpu 4}
${top name 5}$alignr${top cpu 5}

RAM: ${alignr}$memmax

Active: ${alignr}$mem ($memperc%)
${membar 4}
${top_mem name 1}$alignr${top_mem mem 1}
${top_mem name 2}$alignr${top_mem mem 2}
${top_mem name 3}$alignr${top_mem mem 3}
${top_mem name 4}$alignr${top_mem mem 4}
${top_mem name 5}$alignr${top_mem mem 5}

Filesystem

Root: ${alignr}${fs_used /} / ${fs_size /}
${fs_bar 4 /}
Home: ${alignr}${fs_used /home} / ${fs_size /home}
${fs_bar 4 /home}
Amp: ${alignr}${fs_used /Ampersand} / ${fs_size /Ampersand}
${fs_bar 4 /Ampersand}

Network: ${alignr}(${addr wlan0})

Down: ${downspeed wlan0}/s ${alignr}(${totaldown wlan0})
${downspeedgraph wlan0 000000 775555}
Up: ${upspeed wlan0}/s ${alignr}(${totalup wlan0})
${upspeedgraph wlan0 000000 557755}$color



EDIT: J'ai trouvé d'où viens le soucis, le script pour récupérer l'IP publique ralentis l'intégralité du processus conky. Je vais donc chercher une nouvelle façon de récupérer l'info et ça sera parfait smile

Merci à toi smile

Dernière modification par moi4567 (22-08-2016 00:27:25)

Hors ligne

Pied de page des forums