Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-08-2016 11:46:04

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

[Résolu] Apprendre à paramétrer Virtualhost

Bonjour à tous

Mon serveur fonctionne à merveille et je remercie tous ceux et toutes celles qui m'ont aidés pour arriver à ce résultat

Je me suis aperçus que pour Phpmydmin n'avais pas de lien dans /var/www/html mais plutôt un fichier VirtualHost dans /etc/phpmyadmin/apache2 et un lien symbolique fait automatiquement dans /etc/apache2/sites-enabled

Mes sites fonctionnent grâce à deux liens pointant vers ses sites dans  /var/www/html
j'aimerai supprimer ces liens et créer pour chacun de ses sites, un fichier virtualhost
Pour ce faire, j'ai essayé de suivre ce tuto j'ai donc créer deux fichiers .conf (wordpress.conf et quelqueslignes.conf) dans le dossier /etc/apache2/sites-available puis je l'ai ait activé avec la commande a2ensite mais impossible d'avoir mes sites
Même choses en m'inspirant du fichier apache.conf du dossier /etc/phpmyadmin

cat /etc/phpmyadmin/apache.conf


# phpMyAdmin default Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
    Options FollowSymLinks
    DirectoryIndex index.php

    <IfModule mod_php.c>
        <IfModule mod_mime.c>
            AddType application/x-httpd-php .php
        </IfModule>
        <FilesMatch ".+\.php$">
            SetHandler application/x-httpd-php
        </FilesMatch>

        php_flag magic_quotes_gpc Off
        php_flag track_vars On
        php_flag register_globals Off
        php_admin_flag allow_url_fopen On
        php_value include_path .
        php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
        php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/:/usr/share/php/php-gettext/:/usr/share/javascript/:/usr/share/php/tcpdf/:/usr/share/doc/phpmyadmin/:/usr/share/php/phpseclib/
    </IfModule>

</Directory>

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
    <IfModule mod_authz_core.c>
        <IfModule mod_authn_file.c>
            AuthType Basic
            AuthName "phpMyAdmin Setup"
            AuthUserFile /etc/phpmyadmin/htpasswd.setup
        </IfModule>
        Require valid-user
    </IfModule>
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
    Require all denied
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
    Require all denied
</Directory>



J'ai essayé beaucoup de chose, voici la dernière

cat /etc/apache2/sites-available/quelqueslignes.conf


<VirtualHost *:80>
  # The ServerName directive sets the request scheme, hostname and port that
  # the server uses to identify itself. This is used when creating
  # redirection URLs. In the context of virtual hosts, the ServerName
  # specifies what hostname must appear in the request's Host: header to
  # match this virtual host. For the default virtual host (this file) this
  # value is not decisive as it is used as a last resort host regardless.
  # However, you must set it for any further virtual host explicitly.
  #ServerName www.example.com

  ServerAdmin webmaster@localhost
  # DocumentRoot /var/www/html

  # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
  # error, crit, alert, emerg.
  # It is also possible to configure the loglevel for particular
  # modules, e.g.
  #LogLevel info ssl:warn

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

  # For most configuration files from conf-available/, which are
  # enabled or disabled at a global level, it is possible to
  # include a line for only one particular virtual host. For example the
  # following line enables the CGI configuration for this host only
  # after it has been globally disabled with "a2disconf".
  #Include conf-available/serve-cgi-bin.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

      # Alias "/quelqueslignes" "/media/Disque_sdb3/home/Sites/quelqueslignes"
       
  DocumentRoot "/media/Disque_sdb3/home/Sites/quelqueslignes" <--- (1)
      <Directory "/media/Disque_sdb3/home/Sites/quelqueslignes">
  Options +Indexes +FollowSymLinks +MultiViews
  AllowOverride All
  Order allow,deny
  Allow from all
  RedirectMatch ^/$ /index.php
  </Directory>

</VirtualHost>


(1) le dossier contenant mes sites ce trouve en $HOME/.Sites qui est lui même un lien symbolique afin d'éviter la perte de mes données en cas de réinstallation système
le dossier Sites contenant mes sites se trouve en /media/Disque_sdb3/home/Sites, j'ai essayé les deux écritures (en remplaçant $HOME par /home/bienvenue ) mais il n'y a aucune différence

J'ai toujours l'erreur 404, not found

J'aimerai que mes sites apparaissent sur Firefox en tapant

http://localhost/quelqueslignes
http://localhost/wordpress



Merci pour l'aide que vous serez en mesure de m'apporter

Dernière modification par Philanthrope (30-08-2016 19:19:18)


La présent est un passé en évolution

Hors ligne

#2 29-08-2016 19:58:49

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [Résolu] Apprendre à paramétrer Virtualhost

Salut Philanthrope,

A mon avis il ne faut pas toucher au fichier /etc/phpmyadmin/apache.conf.

Si tu veux faire apparaître un index.html qui est à la racine du dossier de ton site quelqueslignes ou un autre pour ton site wordpress


1) Désactive le site de test d'apache :

cd /etc/apache2/sites-available && a2dissite 000-default.conf



2) Modifie  /etc/apache2/sites-available/quelqueslignes.conf pour y mettre que ceci :



<VirtualHost *:80>
  ServerName quelqueslignes.local

  ServerAdmin webmaster@localhost
  DocumentRoot /var/www/quelqueslignes/
  ServerAlias quelqueslignes.local

  <Directory /var/www/quelqueslignes>
             require all granted
       AllowOverride All
        </Directory>

  LogLevel info
  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>
 



3) Donne les bons droits et propriétés sur les dossiers de tes sites :

chown -R philanthrop:www-data /home/.Sites/quelqueslignes/




chmod -R 750 /var/www/quelqueslignes




4) Puis si tu veux que le dossier soit dans /home/.Sites et non dans le même dossier que "déclaré" /var/www/quelqueslignes/ dans le virutahost, alors tu lances cette commande :

ln -s /home/.Sites/quelqueslignes /var/www/quelqueslignes



Cela crée dans dans /var/www/ le lien symbolique nommé quelqueslignes (de même droits et propriétés que le dossier vers lequel il pointe) qui pointe vers dossier (que tu as dû créé pour le code source de ton site) /home/.Sites/quelqueslignes/


5) Recharge apache :

service apache2 reload



6) Après idem pour le autre site wordpress.

Edite /etc/apache2/sites-available/wordpress/ ; donne les bons droits et propriétés sur /home/.Sites/wordpress/ ; le lien symbolique...


7) Enfin, il faut aussi prévenir le serveur de nom qu'il y a deux sites sur localhost ;

édite en root /etc/hosts pour qu'il ressemble à ceci :


127.0.0.1 localhost
127.0.1.1 quelqueslignes.local
127.0.1.1   wordpress.local
 




Et voilà, tu devrais alors faire apparaître dans le navigateur tes sites en faisant :

quelqueslignes.local



puis

wordpress.local




En espérant t'avoir aidé smile

Dernière modification par Hypathie (29-08-2016 20:00:20)

Hors ligne

#3 29-08-2016 21:24:05

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] Apprendre à paramétrer Virtualhost

Bonjour,

Merci pour l'info c'est vraiment sympa

Simplement, je n'ai pas touché au fichier /etc/phpmyadmin/apache.conf mais je m'en suis simplement inspiré

De plus, pour Ubuntu et ses variantes (Xubuntu, Kubuntu, Lubuntu, Edubuntu...), le dossier où insérer les liens est /var/www/html.

Merci encore

Dernière modification par Philanthrope (29-08-2016 21:29:17)


La présent est un passé en évolution

Hors ligne

#4 30-08-2016 10:26:39

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [Résolu] Apprendre à paramétrer Virtualhost

Coucou,

Philanthrope a écrit :

je n'ai pas touché au fichier /etc/phpmyadmin/apache.conf mais je m'en suis simplement inspiré



D'acodac wink

Mais pour info, c'est /etc/apache2/000-default.conf dont il faut s'inspirer.

Philanthrope a écrit :

pour Ubuntu et ses variantes (Xubuntu, Kubuntu, Lubuntu, Edubuntu...), le dossier où insérer les liens est /var/www/html.



Mmmh je ne crois pas, non, le dossier /var/www/html ou si tu préfères "html" est le dossier de code source du virtualhost de test d'apache /etc/apache2/sites-available/000-default.conf.

Si tu veux créer d'autres sites, le lieu par défaut pour placer leur dossier est /var/www/
Par exemple :
/var/www/site1/
/var/www/site2/
/var/www/site3/
...  smile

Pour chacun d'eux tu crées un virtualhost

/etc/apache2/sites-available/site1.conf
/etc/apache2/sites-available/site2.conf
/etc/apache2/sites-available/site3.conf

Puis tu fais pour chacun d'eux :

cd /etc/apache2/sites-available/ && a2ensite site1.conf && service apache2 reload




Mais tu peux les mettre où tu veux.

Le lieu choisi doit être indiqué dans le fichier de configuration de chaque virtualhost par exemple, /etc/apache2/sites-available/site1.conf au niveau des lignes : 
DocumentRoot /var/www/site1/ et <Directory /var/www/site1>

Si tu veux t'éviter de créer un lien symbolique dans /var/www/site1 vers le lieu souhaité  alors indique ce chemin 

/etc/apache2/sites-available/site1.conf

DocumentRoot /home/ou/tu/veux/site1/ et <Directory /var/ou/tu/veux/site1>

Tu peux consulter la documentation officielle : http://httpd.apache.org/docs/2.4/

Ou les wikis D-F :

https://debian-facile.org/utilisateurs: … sur-jessie

https://debian-facile.org/doc:reseau:apache2

Cela est la même chose pour Xubuntu 16.04.xx ou Jessie.

Finalement, as-tu résolu le problème, arrive-tu à faire apparaître dans le navigateur ce que tu veux ?

(Si oui, merci de ne pas oublier de mettre [résolu] dans le titre de ton premier post.)

smile

Hors ligne

#5 30-08-2016 14:16:48

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] Apprendre à paramétrer Virtualhost

Coucou Hypathie,

Pour le moment, je ne suis pas arrivé au bout de ce que je voulais

Ma configuration d'origine c'est
- Je ne me sert ni des Virtualhost ni du paramétrage de hosts
Mon dossier quelqueslignes se trouve en $HOME/.Sites/quelqueslignes
Après avoir inséré la base de données grâce à phpmyadmin, j'ai fait le lien suivant

ln -s $HOME/.Sites/quelqueslignes /var/www/html/quelquesligne



Mon site fonctionne très bien

Ce que je voulais, c'est supprimer ce lien car ce n'est pas ainsi que l'on déclare un site mais en utilisant les virtualhost, ainsi que l'inscription dans le hosts client, (ici le miens)

j'ai donc supprimé le lien dans /var/www/html et conçus un fichier virtualhost qui se nomme quelqueslignes.conf et que j'ai inséré dans /etc/apache2/sites-available

c'est dans ce répertoire que l'on met les fichiers de configuration des sites
Mes problèmes ont été
- les inscriptions dans le fichier configuration quelqueslignes.conf
- l'inscription dans /etc/hosts du site

Une fois ces problèmes réglés, j'ai put voir le site sur mon navigateur, non plus en http://localhost/quelqueslignes mais en http://quelqueslignes
Après, bien entendu avoir validé cette configuration en faisant

a2ensite quelqueslignes


qui met un lien symbolique de la configuration dans le dossier /etc/apache2/sites-enabled
et avoir faire la remise en route d'apache2
J'avais encore un problème de droit

actuellement, je suis revenu à la configuration précédente pour que le site fonctionne normalement en attendant que j'ai résolu le problème

toi tu parles de apache 2 alors qu'il y a eut apache 2.2 et apache 2.4 en suite

j'ai eut mes infos ici
http://forum.ubuntu-fr.org/viewtopic.php?id=1425921
http://forum.ubuntu-fr.org/viewtopic.php?id=1961001
http://forum.ubuntu-fr.org/viewtopic.php?id=1425921

Dommage qu'à cause de pourris, je ne puisse plus demander à Tiramiseb qui est un administrateur système linux quelques informations, il me reste google

Dernière modification par Philanthrope (30-08-2016 15:17:59)


La présent est un passé en évolution

Hors ligne

#6 30-08-2016 17:41:33

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Apprendre à paramétrer Virtualhost

Hypathie a écrit :


Si tu veux créer d'autres sites, le lieu par défaut pour placer leur dossier est /var/www/


Ah oui mais ça c'était avant : à vérifier pour Ubuntu mais sur Jessie par défaut c'est /var/www/html depuis heu... j'sais plus big_smile
Ce qui donne /var/www/html/monsupersite.

Je ne peux guère aider sur ce coup là car pour du exclusivement local je ne me suis pas enquiquinée à paramétrer virtualhost et tout le toutim ; j'ai mis tout mes sites dans /var/www/html/ et j'accède à chacun en tapant localhost/monsite1 ; localhost/mosite2 ; etc ...

C'est pour le côté apprentissage que tu veux faire tout ça ou juste parce que les tutos disent de faire comme ça ?

Philanthrope a écrit :

qui est lui même un lien symbolique afin d'éviter la perte de mes données en cas de réinstallation système


Tu le fais sûrement déjà mais au cas où : n'oublie pas de sauver tes bases de données (via PhpMyadmin ou autres moyens) tongue
Et d'ailleurs si tu ne veux pas te prendre la tête avec les liens symboliques, il suffit d'inclure /var/www/html/ dans les sauvegardes wink


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#7 30-08-2016 17:45:38

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] Apprendre à paramétrer Virtualhost

Je viens de faire le paramétrage à nouveau et mon site c'est à dire, supprimer les liens symboliques de /var/www/html et paramétrer le Virtualhost
Mon site est visible sans soucis
Le problème étant que lorsque je souhaite changer les pages, j'ai le message d'erreur

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@quelqueslignes to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.



Voici la configuration de mon fichier quelqueslignes.conf :

cat /etc/apache2/sites-available/quelqueslignes.conf


<VirtualHost *:80>
  # The ServerName directive sets the request scheme, hostname and port that
  # the server uses to identify itself. This is used when creating
  # redirection URLs. In the context of virtual hosts, the ServerName
  # specifies what hostname must appear in the request's Host: header to
  # match this virtual host. For the default virtual host (this file) this
  # value is not decisive as it is used as a last resort host regardless.
  # However, you must set it for any further virtual host explicitly.
  #ServerName www.example.com

  ServerAdmin webmaster@localhost
  # DocumentRoot /var/www/html

  # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
  # error, crit, alert, emerg.
  # It is also possible to configure the loglevel for particular
  # modules, e.g.
  #LogLevel info ssl:warn

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

  # For most configuration files from conf-available/, which are
  # enabled or disabled at a global level, it is possible to
  # include a line for only one particular virtual host. For example the
  # following line enables the CGI configuration for this host only
  # after it has been globally disabled with "a2disconf".
  #Include conf-available/serve-cgi-bin.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

  <Directory />
      Options FollowSymLinks
      AllowOverride All
  </Directory>

  ServerAdmin webmaster@quelqueslignes
  ServerName local.quelqueslignes
  ServerAlias quelqueslignes
  DocumentRoot /home/bienvenue/.Sites/quelqueslignes

  <Directory /home/bienvenue/.Sites/quelqueslignes >
      Options Indexes FollowSymLinks MultiViews
      Allowoverride All
      Order allow,deny
      Allow from all
      require all granted
  </Directory>

  ErrorLog /var/log/apache2/quelqueslignes/error.log
  LogLevel warn
  CustomLog /var/log/apache2/quelqueslignes/access.log combined

</VirtualHost>



Voici le log de quelqueslignes :

cat /var/log/apache2/quelqueslignes/error.log


[Tue Aug 30 11:13:20.406816 2016] [authz_core:error] [pid 31161] [client 127.0.0.1:32782] AH01630: client denied by server configuration: /home/bienvenue/.Sites/quelqueslignes/
[Tue Aug 30 11:13:21.667248 2016] [authz_core:error] [pid 31161] [client 127.0.0.1:32782] AH01630: client denied by server configuration: /home/bienvenue/.Sites/quelqueslignes/
[Tue Aug 30 11:17:12.722401 2016] [authz_core:error] [pid 31729] [client 127.0.0.1:32818] AH01630: client denied by server configuration: /home/bienvenue/.Sites/quelqueslignes/
[Tue Aug 30 11:17:21.695294 2016] [authz_core:error] [pid 31730] [client 127.0.0.1:32820] AH01630: client denied by server configuration: /home/bienvenue/.Sites/quelqueslignes/
[Tue Aug 30 11:17:22.598954 2016] [authz_core:error] [pid 31730] [client 127.0.0.1:32820] AH01630: client denied by server configuration: /home/bienvenue/.Sites/quelqueslignes/
[Tue Aug 30 11:17:49.919539 2016] [authz_core:error] [pid 31932] [client 127.0.0.1:32822] AH01630: client denied by server configuration: /home/bienvenue/.Sites/quelqueslignes/
[Tue Aug 30 11:17:50.870428 2016] [authz_core:error] [pid 31932] [client 127.0.0.1:32822] AH01630: client denied by server configuration: /home/bienvenue/.Sites/quelqueslignes/
[Tue Aug 30 11:21:37.658764 2016] [authz_core:error] [pid 32569] [client 127.0.0.1:32834] AH01630: client denied by server configuration: /home/bienvenue/.Sites/quelqueslignes/
[Tue Aug 30 13:08:19.023290 2016] [authz_core:error] [pid 2823] [client 127.0.0.1:33994] AH01630: client denied by server configuration: /home/bienvenue/.Sites, referer: http://quelqueslignes/wp-admin/theme-install.php
[Tue Aug 30 13:08:54.557509 2016] [authz_core:error] [pid 1386] [client 127.0.0.1:33998] AH01630: client denied by server configuration: /home/bienvenue/.Sites, referer: http://quelqueslignes/wp-admin/theme-install.php
[Tue Aug 30 16:47:54.140384 2016] [core:error] [pid 8641] [client 127.0.0.1:48678] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
[Tue Aug 30 16:47:54.168608 2016] [core:error] [pid 8642] [client 127.0.0.1:48680] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
[Tue Aug 30 17:11:15.244873 2016] [core:error] [pid 8619] [client 127.0.0.1:48998] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/
[Tue Aug 30 17:12:05.493386 2016] [core:error] [pid 8641] [client 127.0.0.1:49004] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/
[Tue Aug 30 17:12:11.467692 2016] [core:error] [pid 8724] [client 127.0.0.1:49006] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/
[Tue Aug 30 17:22:24.438430 2016] [core:error] [pid 10367] [client 127.0.0.1:49086] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/
[Tue Aug 30 17:22:35.343858 2016] [core:error] [pid 10368] [client 127.0.0.1:49088] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/
[Tue Aug 30 17:24:04.456946 2016] [core:error] [pid 10481] [client 127.0.0.1:49110] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/
[Tue Aug 30 17:27:22.700123 2016] [core:error] [pid 10676] [client 127.0.0.1:49160] AH00124: Request exceeded the limit of 200 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/
[Tue Aug 30 17:27:40.550889 2016] [core:error] [pid 10677] [client 127.0.0.1:49162] AH00124: Request exceeded the limit of 200 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/
[Tue Aug 30 17:32:37.159143 2016] [core:error] [pid 10949] [client 127.0.0.1:49230] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://local.quelqueslignes/

Dernière modification par Philanthrope (02-09-2016 11:09:19)


La présent est un passé en évolution

Hors ligne

#8 30-08-2016 18:04:53

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Apprendre à paramétrer Virtualhost

Philanthrope a écrit :


Le problème étant que lorsque je souhaite changer les pages, j'ai le message d'erreur

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@quelqueslignes to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.


Tu as accès à une seule page du site mais pas aux autres ?
Essaye de vider le cache de ton navigateur pour voir si ta page qui fonctionne s'affiche encore ensuite.

Édit, question bête : les fichiers du site ont quelles permissions ? est-ce que www-data (ou son équivalent si c'est différent sur Ubuntu) a les bons droits dessus ?

Dernière modification par Mercredi (30-08-2016 18:12:25)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#9 30-08-2016 19:18:40

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] Apprendre à paramétrer Virtualhost

Bonsoir Mercredi
Oui c'est exactement ça
alors, le dossier était en bienvenue:bienvenue
J'ai d'abord regardé les droits dans le fichier quelqueslignes.conf et j'ai ajouté la ligne

RewriteEngine on


Ne voyant rien venir, après recherche sur la toile, j'ai supprimé le fichier .htaccess ce qui a modifié mon erreur en "not found"
dans Worpress, j'ai pris le permalien par défaut et là ça fonctionnait mais pas les autres
Nul trace d'un nouveau .htaccess, j'ai donc recherché sur la toile et je l'ai créé moi même
Là tout est redevenu normal

En suite, je me suis posé la question des droits et j'ai modifié en www-data:www-data et supprimé une nouvelle fois le  .htaccess
J'ai refait les manipulations avec le parmaliens de wordpress et le fichier .htaccess s'est recréé tout seul

Problème résolu

PS: J'ai tout de même eut, en cours de route, un problème avec les wingets de mon thème, j'ai dut les recréer après avoir désactivé le mode accessibilité (option de l'écran)

Tout est opérationnel

voici mon fichier virtualhost

cat /etc/apache2/sites-available/quelqueslignes.conf


<VirtualHost *:80>
  # The ServerName directive sets the request scheme, hostname and port that
  # the server uses to identify itself. This is used when creating
  # redirection URLs. In the context of virtual hosts, the ServerName
  # specifies what hostname must appear in the request's Host: header to
  # match this virtual host. For the default virtual host (this file) this
  # value is not decisive as it is used as a last resort host regardless.
  # However, you must set it for any further virtual host explicitly.
  #ServerName www.example.com

  # ServerAdmin webmaster@localhost
  # DocumentRoot /var/www/html

  # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
  # error, crit, alert, emerg.
  # It is also possible to configure the loglevel for particular
  # modules, e.g.
  #LogLevel info ssl:warn

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

  # For most configuration files from conf-available/, which are
  # enabled or disabled at a global level, it is possible to
  # include a line for only one particular virtual host. For example the
  # following line enables the CGI configuration for this host only
  # after it has been globally disabled with "a2disconf".
  #Include conf-available/serve-cgi-bin.conf

  <Directory />
      AllowOverride None
  </Directory>

  ServerAdmin webmaster@quelqueslignes
  ServerName local.quelqueslignes
  ServerAlias quelqueslignes
  DocumentRoot /home/bienvenue/.Sites/quelqueslignes

  <Directory /home/bienvenue/.Sites/quelqueslignes >
      Options Indexes FollowSymLinks MultiViews
      Allowoverride All
      require all granted
      RewriteEngine on
  </Directory>

  ErrorLog /var/log/apache2/quelqueslignes/error.log
  LogLevel warn
  CustomLog /var/log/apache2/quelqueslignes/access.log combined

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

</VirtualHost>



Si non, pour Ubuntu et ses variantes, ils sont passés de /var/www à /var/www/html depuis la version trusty c'est à dire avril 2014

Merci à vous deux smile

Dernière modification par Philanthrope (02-09-2016 12:19:32)


La présent est un passé en évolution

Hors ligne

#10 30-08-2016 21:11:20

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Apprendre à paramétrer Virtualhost

Super !
En plus c'est cool d'avoir remis ton fichier de conf qui marche, ça servira sûrement d'exemple pour d'autres cool

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

Pied de page des forums