Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-08-2016 19:20:56

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

[RESOLU] Steam et paquet manquant "libGL.so.1"

Bonsoir à tous,

j'ai tenté d'installé Steam sur ma Debian.
J'ai bien effectué la manip suivante :

# dpkg --add-architecture i386
# aptitude update



puis lancé l'installation de Steam:

# aptitude install steam



malheureusement :

Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1




donc j'ai effectué un :

Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1



mais là j'ai obtenu :

Les NOUVEAUX paquets suivants vont être installés :    
  libatk1.0-0:i386{a} libaudit1:i386{a} libavahi-client3:i386{a}
  libavahi-common-data:i386{a} libavahi-common3:i386{a} libbz2-1.0:i386{a}
  libcairo2:i386{a} libcomerr2:i386{a} libcups2:i386{a} libdatrie1:i386{a}
  libdbus-1-3:i386{a} libegl1-mesa:i386{a} libegl1-mesa-drivers:i386{a}
  libegl1-nvidia:i386{ab} libepoxy0:i386{ab} libfontconfig1:i386{a}
  libfontenc1:i386{a} libfreetype6:i386{a} libgbm1:i386{a}
  libgcrypt20:i386{a} libgdk-pixbuf2.0-0:i386{a} libgl1-nvidia-glx:i386{b}
  libgles1-nvidia:i386{ab} libgles2-nvidia:i386{ab} libglib2.0-0:i386{a}
  libgmp10:i386{a} libgnutls-deb0-28:i386{a} libgpg-error0:i386{a}
  libgraphite2-3:i386{a} libgssapi-krb5-2:i386{a} libgtk2.0-0:i386{a}
  libharfbuzz0b:i386{a} libhogweed2:i386{a} libjansson4:i386{a}
  libjasper1:i386{a} libjbig0:i386{a} libjpeg62-turbo:i386{a}
  libk5crypto3:i386{a} libkeyutils1:i386{a} libkrb5-3:i386{a}
  libkrb5support0:i386{a} liblzma5:i386{a} libnettle4:i386{a}
  libnvidia-eglcore:i386{ab} libnvidia-ml1:i386{ab} libopenvg1-mesa:i386{a}
  libp11-kit0:i386{a} libpango-1.0-0:i386{a} libpangocairo-1.0-0:i386{a}
  libpangoft2-1.0-0:i386{a} libpcre3:i386{a} libpixman-1-0:i386{a}
  libpng12-0:i386{a} libselinux1:i386{a} libtasn1-6:i386{a} libthai0:i386{a}
  libtiff5:i386{a} libvdpau1:i386{ab} libwayland-client0:i386{a}
  libwayland-egl1-mesa:i386{a} libwayland-server0:i386{a}
  libxcb-render0:i386{a} libxcb-shape0:i386{a} libxcb-shm0:i386{a}
  libxcb-xfixes0:i386{a} libxcomposite1:i386{a} libxcursor1:i386{a}
  libxfont1:i386{a} libxi6:i386{a} libxnvctrl0:i386{ab} libxrandr2:i386{a}
  libxrender1:i386{a} nvidia-alternative:i386{ab} nvidia-driver:i386{ab}
  nvidia-driver-bin:i386{ab} nvidia-kernel-common:i386{ab}
  nvidia-kernel-dkms:i386{ab} nvidia-modprobe:i386{ab}
  nvidia-settings:i386{ab} nvidia-vdpau-driver:i386{ab}
  xserver-xorg-core:i386{ab} xserver-xorg-video-nvidia:i386{ab}
0 paquets mis à jour, 82 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de télécharger 49,3 Mo d'archives. Après dépaquetage, 182 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 nvidia-alternative : Casse: nvidia-driver:i386 (< 343.22-2~) mais 340.96-1 doit être installé.
                      Est en conflit avec: nvidia-alternative:i386 mais 340.96-1 doit être installé.
 nvidia-alternative:i386 : Est en conflit avec: nvidia-alternative mais 352.79-10~bpo8+1 est installé.
 libegl1-nvidia : Casse: libegl1-nvidia:i386 (!= 352.79-10~bpo8+1) mais 340.96-1 doit être installé.
 libegl1-nvidia:i386 : Casse: libegl1-nvidia (!= 340.96-1) mais 352.79-10~bpo8+1 est installé.
 libnvidia-cfg1 : Casse: libgl1-nvidia-glx:i386 (< 352.79-9~) mais 340.96-1 doit être installé.
 libgles2-nvidia : Casse: libgles2-nvidia:i386 (!= 352.79-10~bpo8+1) mais 340.96-1 doit être installé.
 libgles2-nvidia:i386 : Casse: libgles2-nvidia (!= 340.96-1) mais 352.79-10~bpo8+1 est installé.
 nvidia-driver : Est en conflit avec: nvidia-driver:i386 mais 340.96-1 doit être installé.
 nvidia-driver:i386 : Est en conflit avec: nvidia-driver mais 352.79-10~bpo8+1 est installé.
 libepoxy0 : Est en conflit avec: libepoxy0:i386 mais 1.2-1 doit être installé.
 libepoxy0:i386 : Est en conflit avec: libepoxy0 mais 1.2-1 est installé.
 xserver-xorg-video-nvidia : Est en conflit avec: xserver-xorg-video-nvidia:i386 mais 340.96-1 doit être installé.
 xserver-xorg-video-nvidia:i386 : Est en conflit avec: xserver-xorg-video-nvidia mais 352.79-10~bpo8+1 est installé.
 nvidia-settings : Est en conflit avec: nvidia-settings:i386 mais 340.46-2 doit être installé.
 nvidia-settings:i386 : Est en conflit avec: nvidia-settings mais 340.93-1~bpo8+1 est installé.
 libnvidia-glcore : Casse: libgl1-nvidia-glx:i386 (< 352.79-9~) mais 340.96-1 doit être installé.
 nvidia-modprobe : Est en conflit avec: nvidia-modprobe:i386 mais 340.46-1 doit être installé.
 nvidia-modprobe:i386 : Est en conflit avec: nvidia-modprobe mais 358.09-1~bpo8+1 est installé.
 xserver-xorg-core : Est en conflit avec: xserver-xorg-core:i386 mais 2:1.16.4-1 doit être installé.
 xserver-xorg-core:i386 : Est en conflit avec: xserver-xorg-core mais 2:1.16.4-1 est installé.
 libgl1-nvidia-glx : Casse: libgl1-nvidia-glx:i386 (!= 352.79-10~bpo8+1) mais 340.96-1 doit être installé.
 libgl1-nvidia-glx:i386 : Casse: libgl1-nvidia-glx (!= 340.96-1) mais 352.79-10~bpo8+1 est installé.
 nvidia-kernel-dkms : Est en conflit avec: nvidia-kernel-dkms:i386 mais 340.96-1 doit être installé.
 nvidia-kernel-dkms:i386 : Est en conflit avec: nvidia-kernel-dkms mais 352.79-10~bpo8+1 est installé.
 libgles1-nvidia : Casse: libgles1-nvidia:i386 (!= 352.79-10~bpo8+1) mais 340.96-1 doit être installé.
 libgles1-nvidia:i386 : Casse: libgles1-nvidia (!= 340.96-1) mais 352.79-10~bpo8+1 est installé.
 libnvidia-ml1 : Casse: libnvidia-ml1:i386 (!= 352.79-10~bpo8+1) mais 340.96-1 doit être installé.
 libnvidia-ml1:i386 : Casse: libnvidia-ml1 (!= 340.96-1) mais 352.79-10~bpo8+1 est installé.
 glx-alternative-nvidia : Casse: nvidia-alternative (< 341) mais 352.79-10~bpo8+1 est installé.
                          Casse: nvidia-alternative:i386 (< 341) mais 340.96-1 doit être installé.
 nvidia-vdpau-driver : Casse: nvidia-vdpau-driver:i386 (!= 352.79-10~bpo8+1) mais 340.96-1 doit être installé.
 nvidia-vdpau-driver:i386 : Casse: nvidia-vdpau-driver (!= 340.96-1) mais 352.79-10~bpo8+1 est installé.
 nvidia-driver-bin : Casse: nvidia-driver:i386 (< 343.22-2~) mais 340.96-1 doit être installé.
                     Est en conflit avec: nvidia-driver-bin:i386 mais 340.96-1 doit être installé.
 nvidia-driver-bin:i386 : Est en conflit avec: nvidia-driver-bin mais 352.79-10~bpo8+1 est installé.
 nvidia-kernel-common : Est en conflit avec: nvidia-kernel-common:i386 mais 20141201+1 doit être installé.
 nvidia-kernel-common:i386 : Est en conflit avec: nvidia-kernel-common mais 20151021+1~bpo8+1 est installé.
 libvdpau1 : Casse: libvdpau1:i386 (!= 1.1.1-1~bpo8+1) mais 0.8-3+deb8u2 doit être installé.
 libvdpau1:i386 : Casse: libvdpau1 (!= 0.8-3+deb8u2) mais 1.1.1-1~bpo8+1 est installé.
 libnvidia-eglcore : Casse: libnvidia-eglcore:i386 (!= 352.79-10~bpo8+1) mais 340.96-1 doit être installé.
 libnvidia-eglcore:i386 : Casse: libnvidia-eglcore (!= 340.96-1) mais 352.79-10~bpo8+1 est installé.
 libxnvctrl0 : Casse: libxnvctrl0:i386 (!= 340.93-1~bpo8+1) mais 340.46-2 doit être installé.
 libxnvctrl0:i386 : Est en conflit avec: libxnvctrl0 mais 340.93-1~bpo8+1 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                          
1)      gdm3                                                                    
2)      gnome                                                                    
3)      gnome-core                                                              
4)      gnome-session                                                            
5)      gnome-session-bin                                                        
6)      gnome-shell-extensions                                                  
7)      libegl1-nvidia                                                          
8)      libepoxy0                                                                
9)      libgl1-nvidia-glx                                                        
10)     libgles1-nvidia                                                          
11)     libgles2-nvidia                                                          
12)     libnvidia-cfg1                                                          
13)     libnvidia-ml1                                                            
14)     nvidia-alternative                                                      
15)     nvidia-driver                                                            
16)     nvidia-driver-bin                                                        
17)     nvidia-driver-libs                                                      
18)     nvidia-kernel-dkms                                                      
19)     nvidia-kernel-support                                                    
20)     nvidia-modprobe                                                          
21)     nvidia-settings                                                          
22)     nvidia-vdpau-driver                                                      
23)     task-desktop                                                            
24)     task-gnome-desktop                                                      
25)     xorg                                                                    
26)     xserver-xephyr                                                          
27)     xserver-xorg                                                            
28)     xserver-xorg-core                                                        
29)     xserver-xorg-input-all                                                  
30)     xserver-xorg-input-evdev                                                
31)     xserver-xorg-input-mouse                                                
32)     xserver-xorg-input-synaptics                                            
33)     xserver-xorg-input-vmmouse                                              
34)     xserver-xorg-input-wacom                                                
35)     xserver-xorg-video-all                                                  
36)     xserver-xorg-video-ati                                                  
37)     xserver-xorg-video-cirrus                                                
38)     xserver-xorg-video-fbdev                                                
39)     xserver-xorg-video-intel                                                
40)     xserver-xorg-video-mach64                                                
41)     xserver-xorg-video-mga                                                  
42)     xserver-xorg-video-modesetting                                          
43)     xserver-xorg-video-neomagic                                              
44)     xserver-xorg-video-nouveau                                              
45)     xserver-xorg-video-nvidia                                                
46)     xserver-xorg-video-openchrome                                            
47)     xserver-xorg-video-qxl                                                  
48)     xserver-xorg-video-r128                                                  
49)     xserver-xorg-video-radeon                                                
50)     xserver-xorg-video-savage                                                
51)     xserver-xorg-video-siliconmotion                                        
52)     xserver-xorg-video-sisusb                                                
53)     xserver-xorg-video-tdfx                                                  
54)     xserver-xorg-video-trident                                              
55)     xserver-xorg-video-vesa                                                  
56)     xserver-xorg-video-vmware                                                
57)     xwayland                                                                

      Conserver les paquets suivants dans leur version actuelle :                
58)     libegl1-nvidia:i386 [Non installé]                                      
59)     libgl1-nvidia-glx:i386 [Non installé]                                    
60)     libgles1-nvidia:i386 [Non installé]                                      
61)     libgles2-nvidia:i386 [Non installé]                                      
62)     libnvidia-eglcore:i386 [Non installé]                                    
63)     libnvidia-ml1:i386 [Non installé]                                        
64)     libvdpau1:i386 [Non installé]                                            
65)     libxnvctrl0:i386 [Non installé]                                          
66)     nvidia-alternative:i386 [Non installé]                                  
67)     nvidia-driver:i386 [Non installé]                                        
68)     nvidia-driver-bin:i386 [Non installé]                                    
69)     nvidia-kernel-common:i386 [Non installé]                                
70)     nvidia-kernel-dkms:i386 [Non installé]                                  
71)     nvidia-settings:i386 [Non installé]                                      
72)     nvidia-vdpau-driver:i386 [Non installé]                                  
73)     xserver-xorg-video-nvidia:i386 [Non installé]                            

      Laisser les dépendances suivantes non satisfaites :                        
74)     gdm3 recommande xserver-xephyr                                          
75)     gdm3 recommande xserver-xorg                                            
76)     gnome-shell recommande gdm3 (>= 3.10.0.1-3~)                            
77)     metacity recommande gnome-session | x-session-manager                    
78)     mutter recommande gnome-session | x-session-manager                      
79)     open-vm-tools-desktop recommande xserver-xorg-input-vmmouse              
80)     open-vm-tools-desktop recommande xserver-xorg-video-vmware              
81)     xinit recommande xserver-xorg | xserver                                  
82)     xserver-xorg-input-all recommande xserver-xorg-input-wacom              
83)     nvidia-xconfig recommande libgl1-nvidia-glx-any                          
84)     nvidia-settings:i386 recommande libgl1-nvidia-glx:i386                  
85)     libgl1-nvidia-glx:i386 recommande nvidia-kernel-dkms:i386 (= 340.96-1) |
86)     nvidia-driver-bin:i386 recommande nvidia-driver:i386                    
87)     nvidia-vdpau-driver:i386 recommande nvidia-kernel-dkms:i386 (= 340.96-1)
88)     xserver-xorg-video-nvidia:i386 recommande nvidia-driver:i386 (>= 340.96)
89)     xserver-xorg-video-nvidia:i386 recommande nvidia-kernel-dkms:i386 (= 340.
90)     nvidia-driver-bin recommande nvidia-driver                              
91)     nvidia-driver-libs recommande libnvidia-cfg1 (= 352.79-10~bpo8+1)        
92)     nvidia-kernel-dkms recommande nvidia-driver (>= 352.79) | libcuda1 (>= 35
93)     nvidia-settings recommande libgl1-nvidia-glx                            


Accepter cette solution ? [Y/n/q/?] q
Abandon de tous les efforts pour rechercher une solution à ces dépendances.
Abandon.



et donc j'ai quitté l'install de peur de tout cassé dans ma config au niveau pilotes graphiques Nvidia !
Qu'en pensez-vous ?

Dernière modification par Neko62 (07-09-2016 21:54:40)


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#2 30-08-2016 21:03:57

Allain
Membre
Inscription : 30-07-2016

Re : [RESOLU] Steam et paquet manquant "libGL.so.1"

Hors ligne

#3 30-08-2016 21:04:58

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [RESOLU] Steam et paquet manquant "libGL.so.1"

regarde la doc https://wiki.debian.org/Steam

tu as du te tromper de commande dans le message du coup, c'est pas très clair.
sinon, tu as bien fait d’arrêter l'installation.

indique ton fichier sources.list en même temps et comment tu as installé les pilotes

En ligne

#4 04-09-2016 15:57:05

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : [RESOLU] Steam et paquet manquant "libGL.so.1"

Bonjour à tous,

donc j'ai effectué la commande suivante :

root@Debian-Nanchen:/home/nicolas# ldconfig -p | grep libGL.so.1
  libGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGL.so.1



j'ai donc d'après le forum proposé, effectué la manip suivante :

ln -s /usr/lib/x86_64-linux-gnu/libGL.so.1 ~/.steam/bin/



cependant, quand je lance Steam, il me dit toujours ne pas trouver le librairie "libGL.so.1" et me claque un :
"Fatal Error : Failed to load steamui.so"

Qu'en pensez-vous ?
Dois installer d'autres librairies ?
D'avance merci.


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#5 04-09-2016 16:05:17

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : [RESOLU] Steam et paquet manquant "libGL.so.1"

Ci-dessous un lien vers une copie d'écran de Synaptic avec les librairies installées :
http://pix.toile-libre.org/upload/origi … 997785.png

Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#6 07-09-2016 21:01:46

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : [RESOLU] Steam et paquet manquant "libGL.so.1"

Effectivement je me suis mal exprimé en début de discussion.

En fait suite au :

Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1



j'ai effectué un :

apt-get install libgl1-nvidia-glx-i386


mais cela m'a donné :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgl1-nvidia-glx-i386:i386 : Dépend: libgl1-nvidia-glx:i386 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#7 07-09-2016 21:54:19

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : [RESOLU] Steam et paquet manquant "libGL.so.1"

C'est passé avec :

apt-get -t jessie-backports install libgl1-nvidia-glx-i386


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

Pied de page des forums