Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 02-09-2016 14:29:15

debian-alain
Membre
Distrib. : DEBIAN JESSIE 8.5.0
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : GNOME
Inscription : 31-08-2016

Re : [résolu] VLC dépendance(s) non résolue(s) ah ben si justement !

Le smile

Déjà dit plus haut, mais essaye de répondre non à aptitude.

Essaies

aptitude -s install vlc


En répondant non a chaque fois, et donne elle retour (dans des balises code wink )




le code wink n'existe pas , désolé bendia


root@debian-alain:/home/alain-bellec#
root@debian-alain:/home/alain-bellec# aptitude -s install vlc
Les NOUVEAUX paquets suivants vont être installés :    
  libgles1-mesa{ab} libsdl-image1.2{a} libva-drm1{a} libva-x11-1{a}
  libvncclient0{a} libxcb-composite0{a} vlc vlc-plugin-notify{a}
  vlc-plugin-samba{a}
0 paquets mis à jour, 9 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1 756 ko d'archives. Après dépaquetage, 5 332 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libgles1-mesa : Dépend: libglapi-mesa (= 10.3.2-1+deb8u1) mais 11.1.3-1~bpo8+1 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     libgles1-mesa [Non installé]                            
2)     vlc [Non installé]                                      



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

     Réinstaller à une version antérieure les paquets suivants :                
1)     libgl1-mesa-glx [11.1.3-1~bpo8+1 (jessie-backports, now) -> 10.3.2-1+deb8
2)     libglapi-mesa [11.1.3-1~bpo8+1 (jessie-backports, now) -> 10.3.2-1+deb8u1
3)     libgles2-mesa [11.1.3-1~bpo8+1 (jessie-backports, now) -> 10.3.2-1+deb8u1



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                          
1)      caribou                                                                
2)      caribou-antler                                                          
3)      cheese                                                                  
4)      empathy                                                                
5)      evolution                                                              
6)      evolution-plugins                                                      
7)      gdm3                                                                    
8)      gir1.2-champlain-0.12                                                  
9)      gir1.2-clutter-1.0                                                      
10)     gir1.2-clutter-gst-2.0                                                  
11)     gir1.2-cogl-1.0                                                        
12)     gir1.2-coglpango-1.0                                                    
13)     gir1.2-gtkchamplain-0.12                                                
14)     gir1.2-gtkclutter-1.0                                                  
15)     gir1.2-mutter-3.0                                                      
16)     gir1.2-totem-1.0                                                        
17)     gnome-contacts                                                          
18)     gnome-control-center                                                    
19)     gnome-games                                                            
20)     gnome-maps                                                              
21)     gnome-nibbles                                                          
22)     gnome-session                                                          
23)     gnome-shell                                                            
24)     gnome-shell-extension-weather                                          
25)     gnome-shell-extensions                                                  
26)     gnome-sushi                                                            
27)     gstreamer1.0-clutter                                                    
28)     libchamplain-0.12-0                                                    
29)     libchamplain-gtk-0.12-0                                                
30)     libcheese-gtk23                                                        
31)     libcheese7                                                              
32)     libclutter-1.0-0                                                        
33)     libclutter-gst-2.0-0                                                    
34)     libclutter-gtk-1.0-0                                                    
35)     libcogl-pango20                                                        
36)     libcogl-path20                                                          
37)     libcogl20                                                              
38)     libevolution                                                            
39)     libgl1-mesa-glx                                                        
40)     libmutter0e                                                            
41)     libtotem0                                                              
42)     lightsoff                                                              
43)     mutter                                                                  
44)     quadrapassel                                                            
45)     swell-foop                                                              
46)     totem                                                                  
47)     totem-plugins                                                          

      Installer les paquets suivants :                                          
48)     giblib1 [1.2.4-10 (stable)]                                            
49)     libgl1-mesa-swx11 [10.3.2-1+deb8u1 (stable)]                            
50)     libimlib2 [1.4.6-2+deb8u2 (stable)]                                    
51)     libobrender29 [3.5.2-8 (stable)]                                        
52)     libobt2 [3.5.2-8 (stable)]                                              
53)     libosmesa6 [10.3.2-1+deb8u1 (stable)]                                  
54)     obconf [1:2.0.4-2 (stable)]                                            
55)     openbox [3.5.2-8 (stable)]                                              
56)     scrot [0.8-13 (stable)]                                                

      Réinstaller à une version antérieure les paquets suivants :              
57)     libglapi-mesa [11.1.3-1~bpo8+1 (jessie-backports, now) -> 10.3.2-1+deb8u
58)     libgles2-mesa [11.1.3-1~bpo8+1 (jessie-backports, now) -> 10.3.2-1+deb8u

      Laisser les dépendances suivantes non satisfaites :                      
59)     evolution-common recommande evolution                                  
60)     gnome-bluetooth recommande gnome-control-center                        
61)     gnome-control-center-data recommande gnome-control-center (>= 1:3.14.2-3
62)     gnome-media recommande gnome-control-center                            
63)     gnome-online-accounts recommande gnome-control-center (>= 3.6.1)        
64)     gnome-shell recommande gnome-contacts                                  
65)     gnome-shell recommande gnome-control-center                            
66)     mousetweaks recommande gnome-control-center                            
67)     nautilus recommande gnome-sushi                                        
68)     libreoffice-evolution recommande evolution                              


Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                          
1)      caribou                                                                
2)      caribou-antler                                                          
3)      cheese                                                                  
4)      empathy                                                                
5)      evolution                                                              
6)      evolution-plugins                                                      
7)      gdm3                                                                    
8)      gir1.2-champlain-0.12                                                  
9)      gir1.2-clutter-1.0                                                      
10)     gir1.2-clutter-gst-2.0                                                  
11)     gir1.2-cogl-1.0                                                        
12)     gir1.2-coglpango-1.0                                                    
13)     gir1.2-gtkchamplain-0.12                                                
14)     gir1.2-gtkclutter-1.0                                                  
15)     gir1.2-mutter-3.0                                                      
16)     gir1.2-totem-1.0                                                        
17)     gnome-contacts                                                          
18)     gnome-control-center                                                    
19)     gnome-games                                                            
20)     gnome-maps                                                              
21)     gnome-nibbles                                                          
22)     gnome-session                                                          
23)     gnome-shell                                                            
24)     gnome-shell-extension-weather                                          
25)     gnome-shell-extensions                                                  
26)     gnome-sushi                                                            
27)     gstreamer1.0-clutter                                                    
28)     libchamplain-0.12-0                                                    
29)     libchamplain-gtk-0.12-0                                                
30)     libcheese-gtk23                                                        
31)     libcheese7                                                              
32)     libclutter-1.0-0                                                        
33)     libclutter-gst-2.0-0                                                    
34)     libclutter-gtk-1.0-0                                                    
35)     libcogl-pango20                                                        
36)     libcogl-path20                                                          
37)     libcogl20                                                              
38)     libevolution                                                            
39)     libgl1-mesa-glx                                                        
40)     libmutter0e                                                            
41)     libtotem0                                                              
42)     lightsoff                                                              
43)     mutter                                                                  
44)     quadrapassel                                                            
45)     swell-foop                                                              
46)     totem                                                                  
47)     totem-plugins                                                          

      Installer les paquets suivants :                                          
48)     libgl1-mesa-swx11 [10.3.2-1+deb8u1 (stable)]                            
49)     libosmesa6 [10.3.2-1+deb8u1 (stable)]                                  
50)     libqt4-phonon [4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 (stable)]          
51)     libqtxdg0 [0.5.2-4 (stable)]                                            
52)     librazorqt0 [0.5.2-4 (stable)]                                          
53)     menu [2.1.47 (stable)]                                                  
54)     menu-xdg [0.5 (stable)]                                                
55)     qt4-qtconfig [4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 (stable)]            
56)     razorqt-config [0.5.2-4 (stable)]                                      
57)     razorqt-data [0.5.2-4 (stable)]                                        
58)     razorqt-desktop [0.5.2-4 (stable)]                                      
59)     razorqt-session [0.5.2-4 (stable)]                                      

      Réinstaller à une version antérieure les paquets suivants :              
60)     libglapi-mesa [11.1.3-1~bpo8+1 (jessie-backports, now) -> 10.3.2-1+deb8u
61)     libgles2-mesa [11.1.3-1~bpo8+1 (jessie-backports, now) -> 10.3.2-1+deb8u

      Laisser les dépendances suivantes non satisfaites :                      
62)     evolution-common recommande evolution                                  
63)     gnome-bluetooth recommande gnome-control-center                        
64)     gnome-control-center-data recommande gnome-control-center (>= 1:3.14.2-3
65)     gnome-media recommande gnome-control-center                            
66)     gnome-online-accounts recommande gnome-control-center (>= 3.6.1)        
67)     gnome-shell recommande gnome-contacts                                  
68)     gnome-shell recommande gnome-control-center                            
69)     mousetweaks recommande gnome-control-center                            
70)     nautilus recommande gnome-sushi                                        
71)     libreoffice-evolution recommande evolution                              


Accepter cette solution ? [Y/n/q/?] q
Abandon de tous les efforts pour rechercher une solution à ces dépendances.
Abandon.
root@debian-alain:/home/alain-bellec#

Dernière modification par debian-alain (02-09-2016 14:36:05)

Hors ligne

#27 02-09-2016 14:42:03

debian-alain
Membre
Distrib. : DEBIAN JESSIE 8.5.0
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : GNOME
Inscription : 31-08-2016

Re : [résolu] VLC dépendance(s) non résolue(s) ah ben si justement !

si je ne me trompe pas ,

libgles1-mesa : Dépend: libglapi-mesa (= 10.3.2-1+deb8u1) mais 11.1.3-1~bpo8+1 est installé.

la version des backports  ( 11.1.3-1~bpo8+1) est installée en lieu et place de la version "officielle" (libglapi-mesa (= 10.3.2-1+deb8u1))

c'est bien ça ?

comment rectifier le tir ? (si oui)

Dernière modification par debian-alain (02-09-2016 14:42:53)

Hors ligne

#28 02-09-2016 14:58:55

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [résolu] VLC dépendance(s) non résolue(s) ah ben si justement !

debian-alain a écrit :

c'est bien ça ?

oui

Réponds oui a la solution n°2 de la même commande (toujours avec -s pour simulation) et donne le retour


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#29 02-09-2016 16:35:46

debian-alain
Membre
Distrib. : DEBIAN JESSIE 8.5.0
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : GNOME
Inscription : 31-08-2016

Re : [résolu] VLC dépendance(s) non résolue(s) ah ben si justement !

je crois que j'ai trouvé la solution.

comme libgles1-mesa  voulait s'installer en backports  ,
voilà ce que j'ai fait

root@debian-alain:/home/alain-bellec# apt-get -t jessie-backports install libgles1-mesa
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Les NOUVEAUX paquets suivants seront installés :
  libgles1-mesa
0 mis à jour, 1 nouvellement installés, 0 à enlever et 55 non mis à jour.
Il est nécessaire de prendre 43,8 ko dans les archives.
Après cette opération, 65,5 ko d'espace disque supplémentaires seront utilisés.
Réception de : 1 http://httpredir.debian.org/debian/ jessie-backports/main libgles1-mesa amd64 11.1.3-1~bpo8+1 [43,8 kB]
43,8 ko réceptionnés en 0s (155 ko/s)
Sélection du paquet libgles1-mesa:amd64 précédemment désélectionné.
(Lecture de la base de données... 159425 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libgles1-mesa_11.1.3-1~bpo8+1_amd64.deb ...
Dépaquetage de libgles1-mesa:amd64 (11.1.3-1~bpo8+1) ...
Paramétrage de libgles1-mesa:amd64 (11.1.3-1~bpo8+1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u4) ...
root@debian-alain:/home/alain-bellec#



j'explique : libgles1-mesa etait une librairie qui posait problème dans l'installation de vlc

il a fallu forcer , comme elle le demandait , son installation via les backports

l'installation de vlc , par la suite , n'a pas posé le moindre problème .

jugez plutôt


root@debian-alain:/home/alain-bellec# apt-get install vlc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Les paquets supplémentaires suivants seront installés :
  libsdl-image1.2 libva-drm1 libva-x11-1 libvncclient0 libxcb-composite0
  vlc-plugin-notify vlc-plugin-samba
Paquets suggérés :
  videolan-doc
Les NOUVEAUX paquets suivants seront installés :
  libsdl-image1.2 libva-drm1 libva-x11-1 libvncclient0 libxcb-composite0 vlc
  vlc-plugin-notify vlc-plugin-samba
0 mis à jour, 8 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1 713 ko dans les archives.
Après cette opération, 5 218 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de : 1 http://security.debian.org/ jessie/updates/main vlc amd64 2.2.4-1~deb8u1 [1 501 kB]
Réception de : 2 http://httpredir.debian.org/debian/ jessie/main libsdl-image1.2 amd64 1.2.12-5+b5 [35,1 kB]
Réception de : 3 http://httpredir.debian.org/debian/ jessie/main libva-x11-1 amd64 1.4.1-1 [17,6 kB]
Réception de : 4 http://security.debian.org/ jessie/updates/main vlc-plugin-notify amd64 2.2.4-1~deb8u1 [5 406 B]
Réception de : 5 http://httpredir.debian.org/debian/ jessie/main libva-drm1 amd64 1.4.1-1 [13,1 kB]
Réception de : 6 http://security.debian.org/ jessie/updates/main vlc-plugin-samba amd64 2.2.4-1~deb8u1 [4 914 B]
Réception de : 7 http://httpredir.debian.org/debian/ jessie/main libvncclient0 amd64 0.9.9+dfsg2-6.1+deb8u1 [125 kB]
Réception de : 8 http://httpredir.debian.org/debian/ jessie/main libxcb-composite0 amd64 1.10-3+b1 [11,1 kB]
1 713 ko réceptionnés en 0s (3 433 ko/s)    
Sélection du paquet libsdl-image1.2:amd64 précédemment désélectionné.
(Lecture de la base de données... 159434 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libsdl-image1.2_1.2.12-5+b5_amd64.deb ...
Dépaquetage de libsdl-image1.2:amd64 (1.2.12-5+b5) ...
Sélection du paquet libva-drm1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libva-drm1_1.4.1-1_amd64.deb ...
Dépaquetage de libva-drm1:amd64 (1.4.1-1) ...
Sélection du paquet libva-x11-1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libva-x11-1_1.4.1-1_amd64.deb ...
Dépaquetage de libva-x11-1:amd64 (1.4.1-1) ...
Sélection du paquet libvncclient0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libvncclient0_0.9.9+dfsg2-6.1+deb8u1_amd64.deb ...
Dépaquetage de libvncclient0:amd64 (0.9.9+dfsg2-6.1+deb8u1) ...
Sélection du paquet libxcb-composite0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libxcb-composite0_1.10-3+b1_amd64.deb ...
Dépaquetage de libxcb-composite0:amd64 (1.10-3+b1) ...
Sélection du paquet vlc précédemment désélectionné.
Préparation du dépaquetage de .../vlc_2.2.4-1~deb8u1_amd64.deb ...
Dépaquetage de vlc (2.2.4-1~deb8u1) ...
Sélection du paquet vlc-plugin-notify précédemment désélectionné.
Préparation du dépaquetage de .../vlc-plugin-notify_2.2.4-1~deb8u1_amd64.deb ...
Dépaquetage de vlc-plugin-notify (2.2.4-1~deb8u1) ...
Sélection du paquet vlc-plugin-samba précédemment désélectionné.
Préparation du dépaquetage de .../vlc-plugin-samba_2.2.4-1~deb8u1_amd64.deb ...
Dépaquetage de vlc-plugin-samba (2.2.4-1~deb8u1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour vlc-nox (2.2.4-1~deb8u1) ...
Paramétrage de libsdl-image1.2:amd64 (1.2.12-5+b5) ...
Paramétrage de libva-drm1:amd64 (1.4.1-1) ...
Paramétrage de libva-x11-1:amd64 (1.4.1-1) ...
Paramétrage de libvncclient0:amd64 (0.9.9+dfsg2-6.1+deb8u1) ...
Paramétrage de libxcb-composite0:amd64 (1.10-3+b1) ...
Paramétrage de vlc (2.2.4-1~deb8u1) ...
Paramétrage de vlc-plugin-notify (2.2.4-1~deb8u1) ...
Paramétrage de vlc-plugin-samba (2.2.4-1~deb8u1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u4) ...
root@debian-alain:/home/alain-bellec#



maintenant vlc est bien installé et fonc tionne avec des librairies backports mais ça , c'est pas grave .

merci pour votre contribution et votre aide a tous .

merci smolski ., allain  , et les autres

Dernière modification par debian-alain (02-09-2016 16:44:14)

Hors ligne

#30 02-09-2016 16:44:13

Allain
Membre
Inscription : 30-07-2016

Re : [résolu] VLC dépendance(s) non résolue(s) ah ben si justement !

Alain a donc utilisé la commande

apt-get install -t jessie-backports libgle1s-mesa



apparemment apt avait des infos comme quoi il est obligé d'aller chercher des librairies dans backports alors qu'il a un Debian stable

Hors ligne

Pied de page des forums