Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-09-2016 00:30:17

Abuishaq
Membre
Lieu : Ermite des Pyrénées
Distrib. : Debian 8.5 (Jessie) " (x86-64)
Noyau : 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 10-07-2016

"Impossible de corriger les problèmes.." Installation Bitmask

Salut à tous !

Voila je voulais installer le petit logiciel libre Bitmask (VPN) sur mon laptop mais j'ai eu un petit soucis contrairement à l'installation que j'avais effectué sur ma bécane principale. (En même temps je lui fais la pub' en passant, j'en suis pleinement satisfait)

Bon, simplement je commence la procédure d'installation comme décrite sur le site de Riseup :

apt-get install apt-transport-tor
echo "deb tor://deb.bitmask.net/debian jessie main" | sudo tee -a /etc/apt/sources.list.d/bitmask.list
curl https://dl.bitmask.net/apt.key | sudo apt-key add -
apt-get update
apt-get install bitmask leap-keyring


C'est arrivé à la dernière commande que je rencontre un soucis, j'ai vu que c'était assez courant en fin de compte mais j'ai donc le résultat :

# apt-get install leap-keymanager
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 leap-keymanager : Dépend: python-gnupg-ng (>= 1.4.0) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Bon je préfère venir faire un post au final, apparemment si j'ai bien compris, le problème viendrait des mise-à-jour (unstable, backports ..)
Dans mon cas, j'ai eu des dépôts backports dont je ne me suis pas servi au final. Peut-être que ça viendrait de ça ?

Je file en même temps un aperçu de mon sources.list :

# cat /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 8.2.0_Jessie_ - Official amd64 DVD Binary-1 20150906-11:13]/ jessie contrib main
# deb cdrom:[Debian GNU/Linux 8.2.0_Jessie_ - Official amd64 DVD Binary-2 20150906-11:13]/ jessie contrib main
# deb cdrom:[Debian GNU/Linux 8.2.0_Jessie_ - Official amd64 DVD Binary-3 20150906-11:13]/ jessie contrib main

deb http://httpredir.debian.org/debian/ jessie main contrib non-free
#deb-src http://httpredir.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free

deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
#deb-src deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free

# PeerGuardian
deb http://moblock-deb.sourceforge.net/debian/ jessie main
#deb-src http://moblock-deb.sourceforge.net/debian/ jessie main

# Tor
deb http://deb.torproject.org/torproject.org/ jessie main
#deb-src http://deb.torproject.org/torproject.org/ jessie main


J'ai aussi essayé d'installer les paquets qui manqueraient pour essayer de régler le problème mais ça n'a rien donné.

D'ailleurs, petite parenthèse, pour ceux qui utilisent un VPN, n'est-il pas préférable au final d'utiliser les dépôts le plus proche de chez soi et donc de remplacer "httpredir" ?

Merci d'avance ! smile

Hors ligne

Pied de page des forums