Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-09-2016 11:32:02

vavalm
Membre
Inscription : 05-09-2016

[RESOLU]Problème de redirection 127.0.0.1

Bonjour,
je monte actuellement un serveurr Vtiger en entreprise.
Tout est bien configuré, le serveur fonctionne.
Cependant, lorsque j'essai d'accéder au serveur avec une autre machine,
l'adresse (ex 192.168.0.22/vtiger) se transpose en localhost (127.0.0.1/vtiger). Donc pas de soucis pour accéder au crm à partir du serveur mais impossible à partir d'un autre PC.

Lorsque je tape l'adresse IP du serveur je peux accéder au message d'apache "IT WORKS" mais pas au dossier vtiger (les droits sont en 755 pourtant).


voici mon vhost :

1 <VirtualHost *:80>
2
3 DocumentRoot /var/www/html/vtiger/
4 ServerName localhost/vtiger
5 # ServerAlias 127.0.0.1/vtiger
6
7 <Directory /var/www/html/vtiger/>
8 Options FollowSymLinks
9 AllowOverride All
10 Allow from all
11 </Directory>
12
13 ErrorLog /var/log/apache2/vtiger-error_log
14 CustomLog /var/log/apache2/vtiger-access_log common
15 </VirtualHost>
16
17



j'ai tenté cette config pour voir si le problème persiste :

1 <VirtualHost 192.168.0.22:80>
2
3 DocumentRoot /var/www/html/vtiger/
4 ServerName 192.168.0.22/vtiger
5
6 <Directory /var/www/html/vtiger/>
7 Options FollowSymLinks
8 AllowOverride All
9 Allow from all
10 </Directory>
11
12 ErrorLog /var/log/apache2/vtiger-error_log
13 CustomLog /var/log/apache2/vtiger-access_log common
14 </VirtualHost>





toujours le même problème !
j'ai plutôt l'impression que cela vient d'une redirection que mon serveur linux fait. Cependant le fichier /etc/hosts est vide !

Avez vous une idée ?
Merci d'avance !

Dernière modification par vavalm (06-09-2016 09:05:07)

Hors ligne

#2 05-09-2016 12:23:02

vavalm
Membre
Inscription : 05-09-2016

Re : [RESOLU]Problème de redirection 127.0.0.1

En modifiant les droits en 777 et le vhost comme ceci ;

  1 <VirtualHost *:80>
  2
  3     DocumentRoot /var/www/html/vtiger/
  4     ServerName vtiger.local
  5         <Directory /var/www/html/vtiger/>
  6             Options FollowSymLinks
  7             AllowOverride All
  8             Allow from all
  9             Require all granted
 10            # DirectoryIndex index.php
 11         </Directory>
 12
 13     ErrorLog /var/log/apache2/vtiger-error_log
 14     CustomLog /var/log/apache2/vtiger-access_log common
 15 </VirtualHost>
 



Je ne suis plus redirigé vers le 127.0.0.1 depuis un autre ordinateur mais bien sur le 192.168.0.22/vtiger

Cependant j'ai une erreur : the requested URL 192.168.0.22/vtiger/ was not found on this server
même résultat pour 192.168.0.22/vtiger/index.php

Merci d'avance de votre aide.

Hors ligne

#3 05-09-2016 15:52:06

littlejohn75
Membre
Lieu : Paris
Inscription : 31-08-2016

Re : [RESOLU]Problème de redirection 127.0.0.1

vavalm a écrit :

je monte actuellement un serveurr Vtiger en entreprise.
Tout est bien configuré, le serveur fonctionne.


Félicitations ! (je ne sais pas ce qu'est un serveur vtiger ). En cherchant ça cause de CRM, je suppose gestion des relations clients ?

vavalm a écrit :

pas de soucis pour accéder au crm à partir du serveur mais impossible à partir d'un autre PC.


Pas très bien configuré finalement ? (je suis méchant ) :|

vavalm a écrit :


ServerName localhost/vtiger


et diverses variantes sur ce thème.

Dans la directive ServerName  vous avez le droit de mettre des points ('.'  dots in englesh) mais pas des '/' qui séparent des répertoires dans un chemin.
Vous travaillez en entreprise, travaillons comme des pros.

Pour la directive ServerName il est d'usage de mettre le nom complet (fqdn) du serveur tel que vu par le client, et dans la directive ServerAlias on met le nom sans la partie relative au domaine, de telle sorte que le client peut demander http://nom/ sans être obligé de mettre http://nom.maboite.fr/ sachant que dans maboite.fr les DNS sont OK.

Voici un exemple qui marche :
J'ai demandé d'inscrire dans les DNS la machine  _samlp_


fp2x@drhpcm01:~$ getent hosts samlp
10.67.6.180     samlp.eua.bvcorp.corp samlp
fp2x@drhpcm01:~$
fp2x@drhpcm01:~$ getent hosts www-drsvn
10.67.6.180     www-drsvn.eua.bvcorp.corp
fp2x@drhpcm01:~$ getent hosts svn-drsvn
10.67.6.180     svn-drsvn.eua.bvcorp.corp
fp2x@drhpcm01:~$


Vous voyez qu'il n'y a qu'une IP pour ce serveur.

Si je tape http://samlp.eua.bvcorp.corp j'obtiens la page par défaut du serveur Apache de Debian configuré dans 000-default.conf avec


<VirtualHost *:80>
        ServerName samlp.eua.bvcorp.corp
        ServerAlias samlp www.samlp
        ServerAdmin francois.petitjean@bureauveritas.com
        DocumentRoot /var/www/html
  ..
</VirtualHost>
 



Par contre avec http://www-drsvn j'arrive sur la page d'accueil (index.html) de ce serveur trac/subversion avec la liste des dépôts. Configuration dans fichier www-drsvn.conf


<VirtualHost *:80>
        ServerName www-drsvn.eua.bvcorp.corp
        ServerAlias  www-drsvn
        ServerAdmin francois.petitjean@bureauveritas.com
        DocumentRoot /var/www
  ..
</VirtualHost>
 



Et pour http://svn-drsvn  avec une configuration dans /etc/apache2/sites-available/svn-drsvn.conf c'est assez semblable au cas précédent, mais les URLs gérées sont limitées à http://svn-drsvn/dr/nomDepot ou http://svn-drsvn/dev/nomDepot via des directives


<Location "/dr/$name">
    DAV svn
...
</Location>

<Location "/dev/$name">
 



Bref, une URL se traduit à peu près comme http://ServerAlias:port/Location

Cordialement,
Regards,
Mit freundlichen Grüßen,
مع  تحياتي الخالصة
---
F. Petitjean
Ingénieur civil du Génie Maritime.

« On ne perd pas son temps en aiguisant ses outils. »
    Proverbe français

Hors ligne

#4 05-09-2016 16:13:25

vavalm
Membre
Inscription : 05-09-2016

Re : [RESOLU]Problème de redirection 127.0.0.1

Merci littlejohn75,

j'ai bien corrigé le slash dans le ServerName.
Un CRM sert effectivement à gérer les bases de données des clients, des prospects et des leads.
Je n'ai pas mis d'URL dans le ServerName car nous n'avons pas de serveur DNS centralisé pour le moment, nous voudrions déjà pouvoir y accéder à partir de l'IP, cela serait un bon début.
Le CRM est configuré correctement, c'est plutôt le vhost d'apache ou un des fichiers qui est y lié qui est mal configuré mais je ne sais pas lequel.

Hors ligne

#5 05-09-2016 17:27:36

littlejohn75
Membre
Lieu : Paris
Inscription : 31-08-2016

Re : [RESOLU]Problème de redirection 127.0.0.1

vavalm a écrit :

Je n'ai pas mis d'URL dans le ServerName


Je suppose qu'il faut lire : je n'ai pas mis de nom d'hôte complet (fqdn) dans la directive ServerName ...

Je sais, je pinaille, mais c'est en étant précis, rigoureux dans les termes employés qu'on se fait le mieux comprendre (et qu'on comprend mieux sot-même ) smile

vavalm a écrit :

nous n'avons pas de serveur DNS centralisé pour le moment


Je vous conseille d'établir une table d'hôtes /etc/hosts qui permettra de bien savoir de quoi on parle. Dans un premier temps, vous transférez via scp, ensuite vous pourrez envisager un serveur DNS ou à défaut un serveur NIS (en fait beaucoup de boulot si c'est pour une table _hosts_ d'une dizaine de machines.

vavalm a écrit :

c'est plutôt le vhost d'apache ou un des fichiers qui est y lié qui est mal configuré


Et en mettant plusieurs noms dans ServerAlias et en consultant les fichiers de /var/log/apache2/ ?

La page par défaut du serveur Apache de Debian donne accès à la documentation avec toutes les directives smile

Cordialement,
Regards,
Mit freundlichen Grüßen,
مع  تحياتي الخالصة
---
F. Petitjean

« Ce que l'on conçoit bien s'énonce clairement,
  Et les mots pour le dire arrivent aisément.  »
             Boileau   De L'Art poétique   (Chant I)

Hors ligne

#6 06-09-2016 09:04:43

vavalm
Membre
Inscription : 05-09-2016

Re : [RESOLU]Problème de redirection 127.0.0.1

Merci de votre aide concernant cela.

Le problème est désormais résolu.
Pour tous ceux qui chercheront la solution comme moi :

Vtiger est configuré par défaut pour fonctionner en local. Il faut modifier le fichier config.inc.php :

nano /var/www/html/vtiger/config.inc.php



Ligne 90 il faut remplacer ce qu'il y a entre apostrophe parce votre adresse IP ou le nom de domaine correspondant à votre machine.

Sujet Résolu smile

Edit à toto :
Mis la ligne de commande en balise Commande user pour faciliter la lecture par tous.

Hors ligne

#7 06-09-2016 10:45:24

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [RESOLU]Problème de redirection 127.0.0.1

En principe on ne met rien dans /var/www/http
On insert son site dans le répertoire /srv  (perso je l'ai mis dans un répertoire de mon $HOME)
On insert la configuration de son site dans (si apache est le serveur) /etc/apache2/sites-available
Pour activer le site on fait la procédure suivante

a2ensite monsupersite.conf   # Si le serveur est apache2


puis un reload du serveur

service apache2 reload        # Si le serveur est apache2



Tout dépend, en suite de quel serveur a été installé sur le système

Dernière modification par Philanthrope (06-09-2016 12:49:02)


La présent est un passé en évolution

Hors ligne

#8 06-09-2016 11:12:13

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [RESOLU]Problème de redirection 127.0.0.1

Bonjour,

Philanthrope a écrit :

En principe on ne met rien dans /var/www/http


D'autant que ce répertoire n'existe pas tant que tu ne l'as pas créé.

Philanthrope a écrit :

On insert son site dans le répertoire /srv


Tu as vu ça ou? Ça ne correspond à aucune règle existante à ma connaissance.

Philanthrope=Philanthrope a écrit :

a2ensites monsupersite.conf


la commande est a2ensite (sans S final) et "monsupersite.conf" doit être le nom donné au fichier de configuration créé précédemment dans /etc/apache2/sites-available/ pour que ça ait un sens.

Et au vu des fichiers de conf fournis par l'OP, le serveur est bien Apache2, il n'y a aucun doute là dessus. ;-)

Bref, sujet résolu. big_smile

Hors ligne

#9 06-09-2016 12:48:40

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [RESOLU]Problème de redirection 127.0.0.1

tux12

J'ai fait ça vite fait, merci d'avoir rectifié les quelques bourdes

concernant le répertoire, perso je ne l'ai pas eut à le créer, celui s'est créé tout seul lors de l’installation d'apache, d'ailleurs lorsqu'Apache est installé, en faisant
http://localhost
on voit le fichier html qui se trouve dans ce même répertoire

concernant le dossier /srv, c'est un dossier de service
voici ce qu'en dit Sébastien Maccagnoni-Munch (administrateur Linux)

Sébastien Maccagnoni-Munch (tiramiseb) a écrit :


J'ajouterais que, depuis 2004, on doit mettre les sites sous /srv (arborescence à notre convenance).
Les répertoires /var/www ou /var/www/html, ce sont des répertoires par défaut, éventuellement utilisables par des procédures automatisées mais à éviter manuellement.

adgenodux, tes fichiers de config me semblent bien compliqués.

Voici un exemple simple qui devrait fonctionner, qui est propre et correctement sécurisé :

<VirtualHost *:80>
        ServerAdmin webmaster@example.com
        ServerName www.example.com
        ServerAlias example.com
        DocumentRoot /srv/www.example.com
        <Directory /srv/www.example.com>
                AllowOverride None
                require all granted
         </Directory>
        ErrorLog /var/log/apache2/www.example.com/error.log
        LogLevel warn
        CustomLog /var/log/apache2/www.example.com/access.log combined
</VirtualHost>


Et si on veut un hôte par défaut qui n'affiche, on peut mettre dans le fichier "000-default.conf" par exemple :

<VirtualHost *:80>
        ServerAdmin webmaster@example.com
        DocumentRoot /srv/www-default
        <Directory /srv/www-default>
                AllowOverride None
                require all granted
         </Directory>
        ErrorLog /var/log/apache2/error.log
        LogLevel warn
        CustomLog /var/log/apache2/access.log combined
</VirtualHost>



Effectivement je me suis trompé, j'ai confondu avec l'adresse du dossier que tu as cité à savoir /etc/apache2/sites-available/
c'est bien

a2ensite monsupersite.conf


avec le fichier de configuration monsupersite.conf qui se trouve dans le dossier /etc/apache2/sites-available/
à l'appelle de la commande, un lien symbolique de créera dans /etc/apache2/sites-enabled

Enfin, comme tu dis, l'important est que ça fonctionne mais il est préférable d'agir comme un professionnel wink

si non, sujet résolu en effet big_smile


La présent est un passé en évolution

Hors ligne

Pied de page des forums