Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-09-2016 11:24:04

jm-le-libre
Membre
Distrib. : HandyLinux-2.3-Ian
Noyau : Linux 4.5.0-0.bpo.2-686-pae
(G)UI : xfce
Inscription : 20-08-2016

Questions sur beamer (ma pemière utilisation de LaTeX !)

Bonjour,

Je suis en train de préparer une présentation sous beamer, à partir de emacs/org-mode.

C'est la première fois que je fais ça (je suis depuis plusieurs années en cure de désintoxixation des outils Micr*s*ft, j'ai déjà bien progressé, mais au boulot, c'est P*werP*int à tous les étages...).

Et ça marche !!! J'arrive donc, à partir de mon .org, à lancer la commande d'export qui va bien, qui appelle pdfTeX, et j'obtiens bien mon pdf. Donc tout va bien smile


Mais ... j'ai quand même des questions, évidemment ...:P


1. J'utilise un thème qui s'appelle Metropolis https://github.com/matze/mtheme
- celui-ci fait appel à une police dite "fira", présente dans le paquet texlive-fonts-extra

apt-cache search fira



pymca - Python applications and toolkit for X-ray fluorescence analysis
texlive-fonts-extra - TeX Live: Additional fonts
 


d'où

apt-get install texlive-fonts-extra


(l'installation est ok)



- or ma recompilation via pdfTex emacsn'utilise toujours pas la dite police
=> j'ai oublié quelque chose ?

2. je veux tester le thème "Verona" https://www.ctan.org/pkg/beamer-verona
Il est présent dans la texlive d'après le lien ci-dessus

or ma compil conduit à :

! LaTeX Error: File `beamerthemeVerona.sty' not found.



=> euh ... même question : qu'ais-je bien pu oublier ???

3. Question bonus : qui a des beauxx thèmes à proposer ? pour faire pro, et pas de cadres arrondis ...


Merci !

Dernière modification par jm-le-libre (10-09-2016 19:24:34)

Hors ligne

#2 11-09-2016 09:55:02

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Coucou,

Une petite recherche avec apt-file (voir wiki)

apt-file search beamerthemeVerona.sty


texlive-publishers: /usr/share/texlive/texmf-dist/tex/latex/beamer-verona/beamerthemeVerona.sty


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 11-09-2016 12:12:42

Starsheep
Adhérent(e)
Lieu : Certainement devant l'ordi.
Distrib. : ArchLinux
Noyau : Linux 4.6.3
(G)UI : Xfce
Inscription : 01-07-2016
Site Web

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Bonjour !

En attendant que tu donnes la réponse à captnfab, je vais répondre à ta question bonus.

Dans le cadre d'une présentation personnelle j'ai utilisé ce thème :
https://github.com/RatulSaha/presento
dont tu peux voir un exemple ici :
http://www.comp.nus.edu.sg/%7Eratul/public/presento.pdf

.:: MouTonLibre ::. .:: 3hg ::.

Hors ligne

#4 11-09-2016 18:40:02

jm-le-libre
Membre
Distrib. : HandyLinux-2.3-Ian
Noyau : Linux 4.5.0-0.bpo.2-686-pae
(G)UI : xfce
Inscription : 20-08-2016

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Merci à vous de vous intéresser à mon problème.

captnfab a écrit :

Coucou,

Une petite recherche avec apt-file (voir wiki)

apt-file search beamerthemeVerona.sty


texlive-publishers: /usr/share/texlive/texmf-dist/tex/latex/beamer-verona/beamerthemeVerona.sty



Merci ! J'ai beau utiliser des distrib Debian depuis un moment, je ne suis toujours pas à l'aise avec ces recherches ...

Donc :

apt-file update


(car jamais fait !!)

Puis :

apt-file search beamerthemeVerona.sty


=> ne renvoie rien.

Mais je ne sais vraiment pas ce que j'ai en terme de Tex et LaTeX sur mon ordi, et je ne sais pas quelle commande peut m'y faire voir clair ...


Starsheep a écrit :

Bonjour !

En attendant que tu donnes la réponse à captnfab, je vais répondre à ta question bonus.

Dans le cadre d'une présentation personnelle j'ai utilisé ce thème :
https://github.com/RatulSaha/presento
dont tu peux voir un exemple ici :
http://www.comp.nus.edu.sg/%7Eratul/public/presento.pdf



Magnifique ! ça fait envie !!
On l'installe comment ?

Un :

git clone https://github.com/RatulSaha/presento.git


suffit ? et où ?
J'ai réussi à faire marcher mon thème, mais c'est à force de bricolage. Je suis preneur de la façon orthodoxe ...

Hors ligne

#5 11-09-2016 18:54:55

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Pardon, j'ai été un peu succinct.
Il te faut encore faire

apt-get install texlive-publishers



Pour que apt-file update fonctionne, il faut l'avoir installé avant avec

apt-get install apt-file


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#6 11-09-2016 18:57:43

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Bonjour smile

Puis :
apt-file search beamerthemeVerona.sty


=> ne renvoie rien.

Mais je ne sais vraiment pas ce que j'ai en terme de Tex et LaTeX sur mon ordi, et je ne sais pas quelle commande peut m'y faire voir clair ...


Chez moi non plus. Et pourtant le paquet texLive-publishers est bien installé wink
captnfab est sur stretch/sid alors que moi sur jessie stable. Il est possible que la version du paquet TexLive-publishers de jessie (plus ancienne) ne contienne pas le thème verona.

Edit : apt-file doit être installé "de base" dans Handylinux car je l'ai sans l'avoir installé moi-même à moins que ce soit une dépendance d'autre chose...

Dernière modification par chalu (11-09-2016 19:02:57)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#7 11-09-2016 19:04:00

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Bien vu Chalu smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 11-09-2016 19:59:12

jm-le-libre
Membre
Distrib. : HandyLinux-2.3-Ian
Noyau : Linux 4.5.0-0.bpo.2-686-pae
(G)UI : xfce
Inscription : 20-08-2016

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

captnfab a écrit :

Pardon, j'ai été un peu succinct.
Il te faut encore faire

apt-get install texlive-publishers



Pour que apt-file update fonctionne, il faut l'avoir installé avant avec

apt-get install apt-file




apt-file était bien déjà installé

Par contre, je ne connais rien à l'installation de TeX, LaTeX et consorts, et je dois finir ma présentation pour demain ... Elle a une tête acceptable avec mon thème metropolis, mais n'est pas finie.
Donc je ne voudrais pas qu'une commande malencontreuse ma casse quelque chose. Mais avec le apt-get install texlive-publishers, on ne fait qu'ajouter quelque chose, donc je ne risque rien ??

Hors ligne

#9 11-09-2016 20:14:11

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Non tu ne risques rien si tu n'as pas mis le bazar dans ton sources.list.
à mon avis le paquet est déjà installé, tu peux le savoir avec

apt-cache policy texlive-publishers


S'il est installé, ça confirmera mon message précédent sur le fait que la version de ce paquet n'est pas assez récente dans jessie pour contenir le thème que tu veux.

Dernière modification par chalu (11-09-2016 20:14:42)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#10 11-09-2016 23:33:36

jm-le-libre
Membre
Distrib. : HandyLinux-2.3-Ian
Noyau : Linux 4.5.0-0.bpo.2-686-pae
(G)UI : xfce
Inscription : 20-08-2016

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

apt-cache policy texlive-publishers


(... pas installé...)




sudo apt-get install texlive-publishers


(...OK...)



apt-cache policy texlive-publishers
 


texlive-publishers:
  Installé : 2014.20141024-1
  Candidat : 2014.20141024-1
 Table de version :
 *** 2014.20141024-1 0
        500 http://httpredir.debian.org/debian/ jessie/main i386 Packages
        100 /var/lib/dpkg/status



Donc c'est installé maintenant.

apt-file search beamerthemeVerona.sty


(... ne renvoie rien...




Zut alors, tu dois avoir raison, pas assez récent le package ... Tant pis pour ce soir, mais par après y aurait quoi comme solutions ?

Hors ligne

#11 12-09-2016 07:46:58

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Utiliser un autre thème sympa inclus dans jessie et attendre la sortie de Debian stretch ?

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#12 12-09-2016 08:58:31

Starsheep
Adhérent(e)
Lieu : Certainement devant l'ordi.
Distrib. : ArchLinux
Noyau : Linux 4.6.3
(G)UI : Xfce
Inscription : 01-07-2016
Site Web

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Coucou !

Pour le thème presento, tu n'as rien à installer. Il faut cloner le dépôt comme tu as déjà fait avec la commande

git clone https://github.com/RatulSaha/presento.git

et ensuite il te suffit de modifier les différents fichiers *.tex smile

Dernière modification par Starsheep (12-09-2016 08:59:04)


.:: MouTonLibre ::. .:: 3hg ::.

Hors ligne

#13 12-09-2016 23:13:42

jm-le-libre
Membre
Distrib. : HandyLinux-2.3-Ian
Noyau : Linux 4.5.0-0.bpo.2-686-pae
(G)UI : xfce
Inscription : 20-08-2016

Re : Questions sur beamer (ma pemière utilisation de LaTeX !)

Starsheep a écrit :

Coucou !

Pour le thème presento, tu n'as rien à installer. Il faut cloner le dépôt comme tu as déjà fait avec la commande

git clone https://github.com/RatulSaha/presento.git

et ensuite il te suffit de modifier les différents fichiers *.tex smile




Justement, ma question, c'est :
- "où sur mon système est il intelligent/habile/sensé de cloner ce dépot ?"
- puis :
- comment indiquer à LaTeX et je ne sais qui encore où il va trouver ce dépot


Merci


JM

Hors ligne

Pied de page des forums