Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-09-2016 09:49:56

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

[Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Bonjour,

quelqu'un a t-il essayé d'installer ffmpeg par les backports ces derniers temps ( avant ça passait bien pour ma part)

apt-get ou aptitude, pas moyen. " vous demandez l'impossible"

Un sources.list basique :


deb file:/media/patrick/MIRROR/JESSIE/mirror/ftp.fr.debian.org/debian/ jessie main contrib non-free
deb file:/media/patrick/MIRROR/JESSIE/mirror/security.debian.org/ jessie/updates main contrib non-free
deb file:/media/patrick/MIRROR/JESSIE/mirror/ftp.fr.debian.org/debian/ jessie-backports main contrib non-free
deb file:/media/patrick/MIRROR/JESSIE/mirror/mozilla.debian.net/ jessie-backports firefox-release
 

Dernière modification par golgot200 (26-09-2016 19:36:16)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#2 25-09-2016 09:57:03

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Salut smile

Je l'ai installé hier ou avant hier, et pas de soucis. J'ai même pas eu à expliciter que je voulais une installation via les backports d'ailleurs. J'ai fait un banal

apt install ffmpeg


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 25-09-2016 11:06:28

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

ffmpeg n'est pas dispo pour jessie donc, ça me semble logique.
https://packages.debian.org/search?keyw … lla-search

Hors ligne

#4 25-09-2016 11:08:02

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Il est dispo dans jessie-backports cependant wink https://packages.debian.org/jessie-backports/ffmpeg

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#5 25-09-2016 12:29:23

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Bonjour,
Un problème de dépendances ? C'est quoi le retour complet du terminal ?

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#6 25-09-2016 13:36:11

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Bonjour à vous.

voilà :


root@debian:/home/patrick# apt install ffmpeg
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 ffmpeg : Dépend: libavcodec57 (>= 7:3.0) mais ne sera pas installé ou
                   libavcodec-extra57 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavdevice57 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavfilter6 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavformat57 (>= 7:3.0) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@debian:/home/patrick#
 




root@debian:/home/patrick# apt-get -t jessie-backports install ffmpeg
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 ffmpeg : Dépend: libavcodec57 (>= 7:3.0) mais ne sera pas installé ou
                   libavcodec-extra57 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavdevice57 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavfilter6 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavformat57 (>= 7:3.0) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@debian:/home/patrick#
 



et aptitude :


root@debian:/home/patrick# apt-get -t jessie-backports install ffmpeg
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 ffmpeg : Dépend: libavcodec57 (>= 7:3.0) mais ne sera pas installé ou
                   libavcodec-extra57 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavdevice57 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavfilter6 (>= 7:3.0) mais ne sera pas installé
          Dépend: libavformat57 (>= 7:3.0) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@debian:/home/patrick# aptitude install ffmpeg
Les NOUVEAUX paquets suivants vont être installés :    
  ffmpeg{b} libavcodec57{ab} libavdevice57{a} libavfilter6{a}
  libavformat57{a} libavresample3{a} libavutil55{a} libcrystalhd3{a}
  libopenjp2-7{a} libpgm-5.1-0{a} libpostproc54{a} librubberband2{a}
  libshine3{a} libsnappy1{a} libsodium13{a} libsoxr0{a} libssh-gcrypt-4{a}
  libswresample2{a} libswscale4{a} libzmq3{a} libzvbi-common{a} libzvbi0{a}
0 paquets mis à jour, 22 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o/9 822 ko d'archives. Après dépaquetage, 26,7 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 ffmpeg : Casse: libav-tools (< 6:12~~) mais 6:11.7-1~deb8u1 est installé.
 libavcodec57 : Dépend: libx265-79 (>= 1.9) qui est un paquet virtuel
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     ffmpeg [Non installé]                                    
2)     libavcodec57 [Non installé]                              
3)     libavdevice57 [Non installé]                            
4)     libavfilter6 [Non installé]                              
5)     libavformat57 [Non installé]                            



Accepter cette solution ? [Y/n/q/?]
 


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#7 25-09-2016 13:42:22

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Essaye de répondre Non à aptitude pour voir les autres options. Il faut peut-être supprimer libav-tools avant ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#8 25-09-2016 13:56:24

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Et peut être mettre à jour le dépot local

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#9 25-09-2016 14:00:55

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Est ce que la solution pourrait être de mettre à jour libav-tools avec la version des backports qui assure la transition vers ffmpeg ?
https://packages.debian.org/jessie-back … ibav-tools

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#10 25-09-2016 14:06:38

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Merci.

le  dépôt local est jour. Je viens de virer libav-tool. Mais je je ne comprend pas pour la libx265-79

https://packages.debian.org/jessie-backports/libx265-79   


hmm

@chalu

je regarde auusi ça wink

Dernière modification par golgot200 (25-09-2016 14:07:39)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#11 25-09-2016 14:07:02

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

en fait j'ai l'impression que le problème vient de la dépendance libavcodec57 (7:3.0.2-4~bpo8+1)

qui elle même dépend de libx265-79 (>= 1.9) (paquet indisponible)
https://packages.debian.org/jessie-back … bavcodec57

https://packages.debian.org/search?keyw … ection=all

Dernière modification par Severian (25-09-2016 14:08:10)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#12 25-09-2016 14:08:37

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

@severian

Bien vu smile

d'ou mon post 10

Dernière modification par golgot200 (25-09-2016 14:09:09)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#13 25-09-2016 19:59:51

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Si tu l'as pas dans un coin on peut te le déposer quelque part ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#14 26-09-2016 08:10:10

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

@phlinux

Bah, Je vais modifier le fichier de contrôle du paquet  libx265-87, ça devrait le faire.  Le bug vient d'être signalé apparement.
En tout cas merci. wink

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#15 26-09-2016 19:33:27

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu Bug, par mise à jour aujourd'hui]ffmpeg par les Backports

Bonsoir,

il y a 30 minutes :

Des mises à jour.


http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/ffmpeg_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/ffmpeg-doc_3.1.3-1~bpo8+1_all.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libav-tools_3.1.3-1~bpo8+1_all.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavcodec-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavcodec-extra_3.1.3-1~bpo8+1_all.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavcodec-extra57_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavcodec57_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavdevice-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavdevice57_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavfilter-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavfilter6_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavformat-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavformat57_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavresample-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavresample3_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavutil-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libavutil55_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libpostproc-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libpostproc54_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libswresample-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libswresample2_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libswscale-dev_3.1.3-1~bpo8+1_amd64.deb
http://ftp.fr.debian.org/debian/pool/main/f/ffmpeg/libswscale4_3.1.3-1~bpo8+1_amd64.deb
 



Et par magie :


root@debian:/home/patrick# apt-get install ffmpeg
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3
  libavutil55 libcrystalhd3 libnuma1 libopenjp2-7 libpgm-5.1-0 libpostproc54
  librubberband2 libshine3 libsnappy1 libsodium13 libsoxr0 libssh-gcrypt-4
  libswresample2 libswscale4 libx265-87 libzmq3 libzvbi-common libzvbi0
Paquets suggérés :
  ffmpeg-doc firmware-crystalhd
Les paquets suivants seront ENLEVÉS :
  libav-tools
Les NOUVEAUX paquets suivants seront installés :
  ffmpeg libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3
  libavutil55 libcrystalhd3 libnuma1 libopenjp2-7 libpgm-5.1-0 libpostproc54
  librubberband2 libshine3 libsnappy1 libsodium13 libsoxr0 libssh-gcrypt-4
  libswresample2 libswscale4 libx265-87 libzmq3 libzvbi-common libzvbi0
0 mis à jour, 24 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/10,7 Mo dans les archives.
Après cette opération, 34,0 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
 



Résolu smile


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

Pied de page des forums