Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-10-2016 00:41:27

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Mélange de langues (suite à des changement du language du système)

Coucou,
Comme expliqué dans le titre — après avoir passé mon système en anglais & japonais pour enfin revenir au français — j'ai maintenant du français mêlé à de l'anglais. scratchhead.gif
Pas très pratique, mais aussi plutôt disgracieux.

J'ai cherché, mais rien trouvé à ce sujet. Alors si quelqu'un à une idée, elle est la bien venue. smile

A bientôt.
Merci d'avance.

Dernière modification par BobsleiiG (02-10-2016 02:23:36)

Hors ligne

#2 02-10-2016 03:57:35

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.14.0-3-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Mélange de langues (suite à des changement du language du système)

Salut

Dans un premier temps, tu peux nous donner le résultat de la commande suivante :

locale




Après, il est possible de reconfigurer son environnement à l'aide de la commande suivante :

dpkg-reconfigure locales



afin de choisir, par exemple, fr_FR.UTF-8


bloc à supprimer si la commande n’affiche rien


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 02-10-2016 04:09:23

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

Merci pour ta réponse.
Visiblement tout est bien configuré... A moins que l'absence de critère à « LANGUAGE= » & « LC_ALL= » ne soit pas normal.

LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY=fr_FR.UTF-8
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER=fr_FR.UTF-8
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

Hors ligne

#4 02-10-2016 04:14:49

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.14.0-3-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Mélange de langues (suite à des changement du language du système)

Salut

Pour ma part, j'ai : LANGUAGE=fr_CA:fr et LC_ALL=

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 02-10-2016 04:20:52

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

Peut être ça alors...

Je viens de taper un petit

dpkg-reconfigure locales


locales-all installed, skipping locales generation



Mais idem :

locale


LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY=fr_FR.UTF-8
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER=fr_FR.UTF-8
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=



scratchhead.gif

Tu sais de quel fichier il s'agit ?
Je dois pouvoir rentrer ça à la main non ?

Hors ligne

#6 02-10-2016 04:26:55

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.14.0-3-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Mélange de langues (suite à des changement du language du système)

Bizarre la commande avec dpkg ne devrait pas donner ce résultat. Le paquet locales est bien installé ?

Sinon, que donne :

cat /etc/default/locale


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 02-10-2016 04:32:57

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

Je pense que oui.
Avant ce résultat, j'ai quand même eu accès aux réglages de langages. (que j'ai validés en fr_FR.UTF-8 et oublié de préciser ici)

Sinon, « cat /etc/default/locale » me donne :

#  File generated by update-locale
LANG=fr_FR.UTF-8

Hors ligne

#8 02-10-2016 04:35:41

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

Oui, « locales » est bien installé :

apt install locales


Reading package lists... Done
Building dependency tree      
Reading state information... Done
locales is already the newest version (2.23-5).
The following packages were automatically installed and are no longer required:
  libglew1.13 liblouis10
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Hors ligne

#9 02-10-2016 04:42:32

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.14.0-3-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Mélange de langues (suite à des changement du language du système)

Chez moi :

cat /etc/default/locale
#  File generated by update-locale
LANG="fr_CA.UTF-8"
LANGUAGE="fr_CA:fr"
 



Là, à part éditer le fichier /etc/environment pour y mettre LANGUAGE=fr, je ne vois pas trop.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#10 02-10-2016 04:48:30

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.14.0-3-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Mélange de langues (suite à des changement du language du système)

Il serait bon que tu nous précises comment exactement de quelle façon, au départ, tu as fais passer ton système en anglais & japonais pour enfin revenir au français.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#11 02-10-2016 04:52:48

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

En mode graphique tout simplement. Via les réglages.
All Settings > Pays & Langues > Langages/Formats

Je suis en train de lire ça aussi.
https://www.debian-fr.org/t/locale-setting/22301

Hors ligne

#12 02-10-2016 05:03:38

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

Suite à cette lecture (paragraphe 3.3.1), je viens d'ajouter « LANGUAGE=fr » au fichier « /etc/environment (vierge auparavant)».
Je vais reboot et voir ce que cela donne...


Edit :
Je viens de voir que c'est ce que tu me suggérais. ^^

martinux_qc a écrit :

Là, à part éditer le fichier /etc/environment pour y mettre LANGUAGE=fr, je ne vois pas trop.


Mais rien de changé. Et toujours « LANGUAGE= »
(Pour le coup, j'ai supprimé ce que je venais de rentrer dans /etc/environment. Histoire de ne pas laisser des modifs un peu partout)

Dernière modification par BobsleiiG (02-10-2016 05:14:55)

Hors ligne

#13 02-10-2016 05:31:20

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

En tout cas, merci pour ton aide à cette heure tardive. wink
Et je finirai bien par y arriver !

Hors ligne

#14 02-10-2016 09:06:46

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Mélange de langues (suite à des changement du language du système)

bonsoir

je n'ai pas compris à quel niveau tu avais le mélange de langue,
c'est dans l'affichage ? dans les paquets que tu as installé ?

peut être as tu installé certains paquets quand tu étais avec ton système en EN donc les paquets n'ont que les traductions EN

Hors ligne

#15 02-10-2016 09:24:54

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : Mélange de langues (suite à des changement du language du système)

Bonjour,
Pour les parties en anglais, si ça touche des logiciels, ça pourrait être normal si tu n'as pas installé les paquets fr qui vont avec.

Hors ligne

#16 02-10-2016 17:12:53

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

Severian a écrit :

bonsoir

je n'ai pas compris à quel niveau tu avais le mélange de langue,
c'est dans l'affichage ? dans les paquets que tu as installé ?

peut être as tu installé certains paquets quand tu étais avec ton système en EN donc les paquets n'ont que les traductions EN


Pour ce qui est mélangé, c'est à peu près à tout niveaux.
Par exemple, lors de l'écran de connexion, j'ai « user » puis « mot de passe » ; gimp par exemple est complètement passé en anglais ; dans le terminal on me parle en anglais et les réglages nommés « all settings » m'offrent par exemple « Pays & Langues » et pour finir en cliquant sur mon nom, tout est en anglais (« switch user » etc).
Ce ne sont là que quelques exemples.

Je n'ai pas installé de paquets EN à proprement parlé et je ne crois pas avoir fait de mise à jour quand mon système était en anglais. Quoi que je me rappelle avoir fait des « apt update/upgrade/dist-upgrade ». Mais mon système était il en englais ou en français à ce moment là ? Je suis quasi sûr que non, car je ne l'ai pas laissé longtemps ainsi.
(mais si tel avait été le cas, quoi faire alors ?)

chalu a écrit :

Bonjour,
Pour les parties en anglais, si ça touche des logiciels, ça pourrait être normal si tu n'as pas installé les paquets fr qui vont avec.


Malheureusement, comme expliqué au dessus... cela touche tout (plus ou moins).

Hors ligne

#17 02-10-2016 17:50:24

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : Mélange de langues (suite à des changement du language du système)

ton système est basé sur quelle version de Debian ? J'ai remarqué en testant stretch sur virtualbox que j'avais ce type de phénomène.
Par exemple Synaptic en français presque partout et puis des boutons en anglais ... Je pense qu'il y a des traductions encore incomplètes sur testing.

Hors ligne

#18 02-10-2016 21:18:12

BobsleiiG
Membre
Lieu : France
Distrib. : Kali GNU/Linux Rolling
Noyau : 4.6.4-1kali1 amd64
(G)UI : GNOME 3.22.0
Inscription : 25-06-2016

Re : Mélange de langues (suite à des changement du language du système)

Je suis sur Kali GNU/Linux Rolling.
Mais j'avais bien tout en français initialement. Mais peut être que c'est dû à la version rolling. qui est mise à jour en continue... scratchhead.gif

Hors ligne

#19 03-10-2016 01:08:23

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.14.0-3-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Mélange de langues (suite à des changement du language du système)

chalu a écrit :

ton système est basé sur quelle version de Debian ? J'ai remarqué en testant stretch sur virtualbox que j'avais ce type de phénomène.
Par exemple Synaptic en français presque partout et puis des boutons en anglais ... Je pense qu'il y a des traductions encore incomplètes sur testing.



Salut

En effet, avec les rolling release il se peut fort bien que si certains mots ou boutons ne sont pas en français c'est que certaines traductions soient incomplètes. Sous sid j'ai déjà rencontré ce genre de problème quoique limité à une application à la fois. Dans ce cas-ci je trouve par contre qu'il semble y a beaucoup (trop) de ces traductions incomplètes.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#20 08-08-2018 01:51:27

Klepto
Membre
Lieu : Quelque part ! :D
Distrib. : Kali Linux 2018.2
Noyau : Linux 4.17.0-kali1-amd64
(G)UI : Gnome 3.28.2
Inscription : 07-06-2018

Re : Mélange de langues (suite à des changement du language du système)

Désolé pour le déterrage, mais j'ai le problème aussi, voici ce que j'ai fait :



1. Mise à jour, et réinstallation des locales en fr_FR.UTF8

apt-get update && apt-get upgrade
apt-get install keyboard-configuration locales
dpkg-reconfigure keyboard-configuration
dpkg-reconfigure locales



Lorsque je fais :

dpkg-reconfigure locales

j'ai cette erreur : locales-all installed, skipping locales generation

J'ai coché uniquement : fr_FR.UTF8 UTF8

Puis j'ai redémarré, mais rien.



2. La commande locale renvoie :

LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=





3. J'ai installé les paquets suivants :

apt-get install debian-edu-doc-fr debian-faq-fr debian-history debian-reference-fr doc-debian-fr doc-linux-fr-html doc-linux-fr-pdf doc-linux-fr-ps doc-linux-fr-text libclaw-i18n libmed-doc maint-guide-fr manpages-fr manpages-fr-dev manpages-fr-extra myspell-fr




Puis j'ai redémarré, mais rien.



4. La commande uname -a me renvoie uniquement ce message :

Linux kali 4.17.0-kali1-amd64 #1 SMP Debian 4.17.8-1kali1 (2018-07-24) x86_64 GNU/Linux





5. La commande cat /etc/debian_version me renvoie uniquement ce message :

kali-rolling





6. La commande cat /etc/default/locale me renvoie uniquement ce message :

LANG=fr_FR.UTF-8





7. La commande cat /etc/environment me renvoie uniquement ce message :

LANGUAGE=fr





8. En mode graphique, dans : All Settings > Pays & Langues > Langages/Formats tout est en français, puis j'ai redémarré, mais rien.



9. J'ai dé-commencé la ligne fr_FR.UTF-8 UTF-8 dans le fichier /etc/locale.gen, puis j'ai redémarré, mais rien.



10. Exemple de soucis via cette capture d'écran : https://image.ibb.co/iVEziz/Screenshot_ … _48_47.png

Certains logiciels sont en français, mais 80% sont en anglais, je n'y comprends rien.



J’espère avoir été le plus précis possible.

Des idées pour régler ce fichu problème ?

Dernière modification par Klepto (08-08-2018 23:56:41)


Debian Experience : 40%

Hors ligne

#21 08-08-2018 02:13:55

Beta-Pictoris
Membre
Distrib. : Debian Stretch
Inscription : 12-08-2015

Re : Mélange de langues (suite à des changement du language du système)

Éventuellement, dé-commenter les lignes qui t'intéressent dans "/etc/locale.gen" et lancer un "locale-gen".

Cela fait, que donne ?

localectl
localectl list-locales

Dernière modification par Beta-Pictoris (08-08-2018 02:29:06)

Hors ligne

#22 09-08-2018 00:01:57

Klepto
Membre
Lieu : Quelque part ! :D
Distrib. : Kali Linux 2018.2
Noyau : Linux 4.17.0-kali1-amd64
(G)UI : Gnome 3.28.2
Inscription : 07-06-2018

Re : Mélange de langues (suite à des changement du language du système)

Beta-Pictoris a écrit :

Éventuellement, dé-commenter les lignes qui t'intéressent dans "/etc/locale.gen" et lancer un "locale-gen".

Cela fait, que donne ?

localectl
localectl list-locales



La ligne fr_FR.UTF-8 UTF-8 était déjà dé-commentée, mais j'ai refait, au cas où, car il me semble que j'avais déjà effectuée cette opération, qui n'a, forcément, rien donné tongue

root@kali:~# nano /etc/locale.gen
root@kali:~# locale-gen
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.



Sinon la commande localectl list-locales me renvoie :

root@kali:~# localectl
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr
      X11 Layout: fr
     X11 Variant: azerty



La commande localectl me renvoie :

root@kali:~# localectl list-locales
C.UTF-8
aa_DJ
aa_DJ.utf8
aa_ER
aa_ER@saaho
aa_ET
af_ZA
af_ZA.utf8
agr_PE
ak_GH
am_ET
.etc



Il y a trop de page, donc toutes les langues.


Sur la page où je dois m'identifier, dans le champ du nom d'utilisateur c'est en anglais, donc "Login" et sur la page du mot de passe, c'est en français, le champ est donc : "Mot de passe". Incompréhensible.


Il est coriace ce bug !

Dernière modification par Klepto (09-08-2018 00:37:42)


Debian Experience : 40%

Hors ligne

#23 09-08-2018 01:25:45

Beta-Pictoris
Membre
Distrib. : Debian Stretch
Inscription : 12-08-2015

Re : Mélange de langues (suite à des changement du language du système)

Que donne ?

ls /usr/share/locale/fr/LC_MESSAGES/gnome*

Hors ligne

#24 09-08-2018 07:31:57

MicP
Membre
Inscription : 29-02-2016

Re : Mélange de langues (suite à des changement du language du système)

Bonjour

…locales-all installed, skipping locales generation…

Puisque sa présence empêche l'exécution complète de dpkg-reconfigure locales
désinstalle d'abord le paquetage locale-all

Dernière modification par MicP (09-08-2018 07:36:06)

Hors ligne

#25 09-08-2018 14:16:47

Beta-Pictoris
Membre
Distrib. : Debian Stretch
Inscription : 12-08-2015

Re : Mélange de langues (suite à des changement du language du système)

MicP a écrit :

Bonjour

…locales-all installed, skipping locales generation…

Puisque sa présence empêche l'exécution complète de dpkg-reconfigure locales
désinstalle d'abord le paquetage locale-all


Oui, ce n'est pas normal. Il faudrait connaître les différents paquets "locales" installés:

dpkg -l locale\*

Hors ligne

Pied de page des forums