Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-07-2009 16:25:00

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

[Résolu]clavier en qwerty

gros souci au demarrage ce matin le clavier est passe en qwerty
je suis sous lxde et sid je ne sais comment modifier les parametres
par avance merci

Dernière modification par mouloud7 (05-07-2009 23:34:08)


La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#2 05-07-2009 17:18:55

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]clavier en qwerty

quand je veux modifier console data il me sort ca

it:/home/mouloud# dpkg-reconfigure console-data
Looking for keymap to install:
amiga-fr
dpkg : avertissement : option obsolète « --print-installation-architecture », veuillez utiliser « --print-architecture » à la place.
lepetit:/home/mouloud# dpkg-reconfigure console-data
dpkg : avertissement : option obsolète « --print-installation-architecture », veuillez utiliser « --print-architecture » à la place.
Looking for keymap to install:
dpkg : avertissement : option obsolète « --print-installation-architecture », veuillez utiliser « --print-architecture » à la place.
mac-usb-fr
dpkg : avertissement : option obsolète « --print-installation-architecture », veuillez utiliser « --print-architecture » à la place.
lepetit:/home/mouloud#

que faire

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#3 05-07-2009 19:44:29

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]clavier en qwerty

Salut

Comme tu utilises Sid, lance la commande suivante :

# dpkg-reconfigure -plow console-setup


Cette commande permet de sélectionner les options suivantes :

Modèle du clavier : → Generic 105-key (Intl) PC
Origine du clavier : → France
Disposition du clavier : → France - (Legacy) Alternative
Touche de remplacement d'AltGr : → Touche Alt de droite
Touche « compose » : → Pas de touche « compose »
Codage de la console : → UTF-8
Jeu de caractères devant être pris en charge par la police de la console : → # latin1 et latin5 : langues de l'Europe de l'ouest et turc
Police de caractères pour la console : → Fixed
Taille de la police : → 18
Consoles virtuelles utilisées : → /dev/tty[1-6]


Pour chaque élément, l'exemple montré peut bien entendu être changé ; c'est le but de cette commande.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#4 05-07-2009 20:12:19

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]clavier en qwerty

suivi point par point... et mon clavier est tjs en qwerty..... que faire

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#5 05-07-2009 21:42:23

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]clavier en qwerty

Bon. Les choses se compliquent. Normalement comme tu es avec sid, ton fichier /etc/X11/xorg.conf doit être assez minimal. Je ne crois pas que tu y trouves une section du genre

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "fr"
   Option      "XkbVariant"   "latin9"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection


Avant (avec sid), on pouvait modifier l'agencement du clavier en modifiant les options de ce fichier. Maintenant, cela ne fonctionne plus. On utilise la commande que je t'ai donnée. Comme la commande n'a rien donné pour toi, tu pourrais essayer de modifier ton fichier xorg.conf, on ne sait jamais.

Avec un autre environnement graphique, gnome par exemple, on peut choisir l'agencement de son clavier à partir du menu préférences. Avec lxde on ne peut pas. J'avais moi aussi un problème d'agencement de clavier avec lxde uniquement que j'ai réglé avec la commande mentionné.

Ton problème commence au moment où tu entre ton identifiant et ton mot de passe ou seulement dans lxde ?

Hors sujet un peu. Jusqu'à ces derniers jours, un aptitude safe-upgrade ne pouvait mettre à jour le paquet lxde chez moi (pour la sid). Comme c'est une méta-paquet je l'ai tout simplement enlevé ; il n'est pas nécessaire après tout.

Martin

Dernière modification par martinux_qc (05-07-2009 22:04:05)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#6 05-07-2009 23:34:40

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]clavier en qwerty

résolu après ta manip plus un redémarrage

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#7 06-07-2009 03:03:52

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]clavier en qwerty

Bonne nouvelle !

Tu veux donc dire que la modification du fichier xorg.conf a fonctionné dans ce cas pour la branche sid. C'est inattendu pour moi.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#8 11-07-2009 22:09:32

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]clavier en qwerty

non j'ai suivi la commande
# dpkg-reconfigure -plow console-setup
&après redémarrage clavier de nouveau en AZERTY

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#9 12-07-2009 03:25:21

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]clavier en qwerty

Salut

Merci pour la réponse. C'est celle que j'attendais car c'est la solution pour résoudre ce genre de problème avec sid.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums