Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-10-2016 14:16:29

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

(RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

Bonjour

Je n'arrive pas a mettre a l'heure mon portable sur Jessie bureau XFCE

comment le faire de façon manuel ?
et si possible de manière automatique a chaque démarrage ?

mon portable n'a plus de batterie donc quand il ne sert pas
il n'est plus alimentés

et j'aurais besoin d'avoir l'heure exacte

Merci pour les conseils

smile

Dernière modification par usturus (07-10-2016 19:29:04)

Hors ligne

#2 06-10-2016 15:02:16

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

S'il perd l'heure à chaque redémarrage, ce n'est pas que la batterie qui est morte, mais probablement aussi la petite pile plate tongue

Un moyen est d'utiliser NTP qui va te synchroniser l'heure via l'web. "apt-get install ntp"
Ensuite tu veux être au bon fuseau horaire : "dpkg-reconfigure tzdata"

Ce sont un peu des solutions universelles, pas de rapport avec xfce.

Hors ligne

#3 06-10-2016 16:50:54

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

Bonjour usturus,

Une alternative est d'activer le service systemd-timesyncd :

timedatectl set-ntp true


Pour aller plus loin lire la page sur wiki.archlinux.org.

Hors ligne

#4 06-10-2016 17:23:15

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

j'ai utilisé pour commencer la réponse de (èfpé )
et l'heure s'est mise a jour d'un seul coup

je laisse comme cela quelques jours et je met de coté la réponse de (otyugh )

Merci pour l'aide

Hors ligne

#5 06-10-2016 19:55:59

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

Bonjour,

Si la machine ne conserve pas l'heure lors de la mise hors tension la batterie interne (petite pile plate ou autre) est certainement en fin de vie.

Si je ne m'abuse ça devrait poser problème au prochain reboot car au montage des systèmes de fichiers ça va détecter des fichiers avec des dates dans le futur. Le système de fichier étant monté avant la mise en service des daemons (ntp...) ça risque de coincer.

Un homme averti en vaut deux wink

Hors ligne

#6 06-10-2016 20:18:42

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

@tux12
la  petite pile plate ,doit encore fonctionner car avant la manip l'heure changeait mais n'étais pas a la bonne heure
je viens de faire un reboot et l'heure est exact et le jour aussi

a voir aussi les jours suivants (et cela ne m’empêche pas de changer la pile )

tu pense que j'aurais du installer (NTP ) avant ?

timedatectl set-ntp true



pour désactiver cette commande je fais quoi ?

Merci des conseils

Dernière modification par usturus (06-10-2016 20:23:48)

Hors ligne

#7 06-10-2016 20:44:15

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

Un reboot n'est pas significatif pour le comportement que je décris; il faut que l'énergie stockée dans le PC (condensateurs de la CM et de l'alim)  puisse se dissiper totalement afin que la machine, plus soutenue par la batterie interne du BIOS, perde totalement l'heure (elle revient dans ce cas à une date/heure fixée par le fabricant du BIOS, 1er Janvier 1970 souvent). Donc ça se produit généralement après une mise hors tension plus ou moins prolongée.

Hors ligne

#8 06-10-2016 20:48:32

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

@usturus : if it ain't broke, don't fix it... comme le rappelait raleur il y a quelques jours wink

L'avantage de systemd-timesyncd sur ntpd, outre le fait de n'être qu'un simple client SNTP, est d'écrire la date et l'heure dans un fichier à l'arrêt de la machine... cette fonctionnalité semble pertinente lorsque l'horloge matérielle fait défaut, n'est-il pas ?

Pour aller plus loin, consulter les pages 'man' correspondantes.

Dernière modification par èfpé (07-10-2016 22:56:32)

Hors ligne

#9 06-10-2016 20:51:44

phreg
Membre
Distrib. : Antix MX-15
Noyau : 4.3-0-liquorix-686
(G)UI : Xfce 4.12
Inscription : 02-04-2011

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

pour désactiver cette commande je fais quoi ?

Je ne comprend pas l'intérêt. Mais

timedatectl -help
 

dira que

timedatectl set-ntp FALSE

fait l'affaire.

Hors ligne

#10 06-10-2016 20:53:26

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

èfpé a écrit :

écrire la date et l'heure dans un fichier à l'arrêt de la machine... cette fonctionnalité semble pertinente lorsque l'horloge matérielle fait défaut, n'est-il pas ?

Euh, je trouve pas, moi smile
C'est bien joli d'écrire l'heure qu'il est quand on éteint le PC, mais comment va-t-il savoir combien de temps il s'est écoulé depuis, lorsqu'on le rallume ?


Schokolade ist keine Lüge.

Hors ligne

#11 06-10-2016 22:35:03

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

timedatectl status
 


Local time: jeu. 2016-10-06 22:18:42 CEST
  Universal time: jeu. 2016-10-06 20:18:42 UTC
        RTC time: jeu. 2016-10-06 22:18:42
       Time zone: Europe/Paris (CEST, +0200)
     NTP enabled: yes
NTP synchronized: no
 RTC in local TZ: yes
      DST active: yes
 Last DST change: DST began at
                  dim. 2016-03-27 01:59:59 CET
                  dim. 2016-03-27 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  dim. 2016-10-30 02:59:59 CEST
                  dim. 2016-10-30 02:00:00 CET

Warning: The system is configured to read the RTC time in the local time zone. This
         mode can not be fully supported. It will create various problems with time
         zone changes and daylight saving time adjustments. The RTC time is never updated,
         it relies on external facilities to maintain it. If at all possible, use
         RTC in UTC by calling 'timedatectl set-local-rtc 0'.
 

Hors ligne

#12 06-10-2016 22:37:09

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

une traduction rapide me dit

Avertissement: Le système est configuré pour lire l'heure RTC dans le fuseau horaire local. Ce
          mode ne peut pas être entièrement pris en charge. Il permettra de créer divers problèmes avec le temps
          les changements de zone et des ajustements de temps l'heure d'été. Le temps RTC est jamais mis à jour,
          elle repose sur des installations extérieures pour le maintenir. Si possible, l'utilisation
          RTC en UTC en appelant 'timedatectl set-locale-pac 0'.

Hors ligne

#13 06-10-2016 22:40:13

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

en fait un sujet pus complexe que je ne croyais au début ?

Hors ligne

#14 06-10-2016 23:00:13

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

@usturus : c'est juste que l'horloge matérielle (RTC signifiant real-time clock), parfois appelée horloge du BIOS/CMOS, est en heure locale et pas en UTC ; ce serait éventuellement à corriger... à l'occasion. Cette commande permet de vérifier que tout le monde est bien synchronisé :

hwclock && date +%c


jeu. 06 oct. 2016 22:54:42 CEST  -0.520090 seconds #horloge matérielle
jeu. 06 oct. 2016 22:54:42 CEST #horloge système

Dernière modification par èfpé (07-10-2016 22:56:42)

Hors ligne

#15 06-10-2016 23:08:59

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

Bonsoir

…The system is configured to read the RTC time in the local time zone…

Ce que l'on peut aussi constater dans le retour de la commande timedatectl status :


RTC in local TZ: yes


Pour positionner ce paramètre sur "no" :

timedatectl set-local-rtc 0


Pour positionner ce paramètre sur "yes" :

timedatectl set-local-rtc 1


Pour ces modifications, Le mot de passe du compte root sera demandé.

=======
Par contre :

timedatectl set-locale-pac 0

retourne le message suivant :

Unknown operation set-locale-pac

Peut-être est-ce un bug…

=======
Je te recommande de mettre l'heure de la RTC de ta machine à l'heure UTC

Et si tu utilise aussi Windows sur cette machine,
il faudra faire en sorte que windows ne remette pas la RTC à l'heure locale
en créant la clef de registre suivante avec une valeur de type dword mise à 1 :

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
"RealTimeIsUniversal"=dword:00000001

Dernière modification par MicP (07-10-2016 08:47:39)

Hors ligne

#16 07-10-2016 08:53:19

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

@èfpé

 hwclock && date +%c


ven. 07 oct. 2016 08:51:26 CEST  -0.766227 secondes
ven. 07 oct. 2016 08:51:24 CEST
 

Dernière modification par usturus (07-10-2016 08:56:07)

Hors ligne

#17 07-10-2016 09:36:17

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

timedatectl set-local-rtc 0
 


puis

timedatectl status


Local time: ven. 2016-10-07 09:17:56 CEST
  Universal time: ven. 2016-10-07 07:17:56 UTC
        RTC time: ven. 2016-10-07 07:17:56
       Time zone: Europe/Paris (CEST, +0200)
     NTP enabled: no
NTP synchronized: yes
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  dim. 2016-03-27 01:59:59 CET
                  dim. 2016-03-27 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  dim. 2016-10-30 02:59:59 CEST
                  dim. 2016-10-30 02:00:00 CET
 

Hors ligne

#18 07-10-2016 09:37:59

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

usturus a écrit :

@èfpé

 hwclock && date +%c


Avec cette commande, tu mets la RTC à l'heure locale du système que tu utilise. (EDIT : j'avais mal lu : j'avais zappé le "&&")
Mais il vaudrait mieux que la RTC soit à l'heure UTC

en fait cette ligne de commande affiche la date/heure de la RTC et si la commande hwclock n'a pas retourné d'erreur, la commande date +%c sera lancée et affichera la date/heure locale en cours du système.

Dernière modification par MicP (07-10-2016 10:20:38)

Hors ligne

#19 07-10-2016 09:40:06

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

bon je suis perdu dans mes commandes je verrais tout a l'heure

Dernière modification par usturus (07-10-2016 09:50:51)

Hors ligne

#20 07-10-2016 09:51:37

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

J'ai modifié mon message précédent.

=======

…je vois que l'avertissement a disparus …

À partir du moment où tu as lancé la commande

timedatectl set-local-rtc 0


la RTC n'est plus à l'heure locale (c'est d'ailleurs ce qui était conseillé dans le message d'avertissement).
L'avertissement n'a donc plus aucune raison d'être affiché.

=======
il me semble que le paquetage ntpdate n'est pas installé sur ta machine (à moins que tu ne l'aies installé depuis ton message #11).
Tu peux le vérifier en lançant la commande :

apt-cache policy ntpdate


Ce paquetage permettra à ta machine de synchroniser la RTC à l'heure UTC récupérée depuis un serveur de temps.
Il te faudrait donc l'installer :

apt update && apt install ntpdate



=======
Après avoir positionné RTC in local TZ à 0 et installé ntpdate
le retour de la commande timedatectl devrait ressembler à ce qui suit :

      Local time: ven. 2016-10-07 10:21:24 CEST
  Universal time: ven. 2016-10-07 08:21:24 UTC
        RTC time: ven. 2016-10-07 08:21:24
       Time zone: Europe/Paris (CEST, +0200)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  dim. 2016-03-27 01:59:59 CET
                  dim. 2016-03-27 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  dim. 2016-10-30 02:59:59 CEST
                  dim. 2016-10-30 02:00:00 CET
 

Dernière modification par MicP (07-10-2016 12:37:12)

Hors ligne

#21 07-10-2016 13:37:51

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

la solution du post #2 est elle valable par ( otyugh )

Je viens de la faire  me semble plus facile

j'ai donc installé (ntp )

ntp


dpkg-reconfigure tzdata



que j'ai configuré

pour l'instant (ntpdate ) n'est pas installé

Dernière modification par usturus (07-10-2016 13:38:37)

Hors ligne

#22 07-10-2016 13:42:13

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

[

timedatectl status
 


Local time: ven. 2016-10-07 13:28:24 CEST
  Universal time: ven. 2016-10-07 11:28:24 UTC
        RTC time: ven. 2016-10-07 11:28:24
       Time zone: Europe/Paris (CEST, +0200)
     NTP enabled: no
NTP synchronized: no
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  dim. 2016-03-27 01:59:59 CET
                  dim. 2016-03-27 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  dim. 2016-10-30 02:59:59 CEST
                  dim. 2016-10-30 02:00:00 CET
moi@moi:~$ timedatectl status
      Local time: ven. 2016-10-07 13:39:47 CEST
  Universal time: ven. 2016-10-07 11:39:47 UTC
        RTC time: ven. 2016-10-07 11:39:47
       Time zone: Europe/Paris (CEST, +0200)
     NTP enabled: no
NTP synchronized: yes
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  dim. 2016-03-27 01:59:59 CET
                  dim. 2016-03-27 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  dim. 2016-10-30 02:59:59 CEST
                  dim. 2016-10-30 02:00:00 CET
 

Hors ligne

#23 07-10-2016 13:42:28

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

message à supprimer

Dernière modification par èfpé (07-10-2016 21:32:28)

Hors ligne

#24 07-10-2016 17:16:52

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

Bon avant d'aller plus loin je vais prendre un peu de temps

au fait sur une machine comme la mienne qui avait des problèmes d'heures

@otyugh
me conseille  apt-get install ntp"  et dpkg-reconfigure tzdata

@èfpé
me conseille :Une alternative est d'activer le service systemd-timesyncd : et timedatectl set-ntp true

@MicP
me demande de vérifier si ntpdate est  installé

je vois bien que tous le monde fait un effort pour m’aider !!

mais je suis  coincé
,en plus j'ai changer mes verres de lunettes ce jour, et l'écran m'éblouis
je reprendrais plus tard

Dernière modification par usturus (07-10-2016 17:22:28)

Hors ligne

#25 07-10-2016 17:19:59

usturus
Membre
Distrib. : Jessie -xfce
Noyau : 3.16.0-4-amd64
(G)UI : -xfce
Inscription : 28-04-2014

Re : (RESOLU )mettre a l'heure mon portable Jessie bureau XFCE

par contre l'heure et toujours exact  pour l'instant

quelle solution j'aurais du adopter du départ ?

d'avance Merci

Dernière modification par usturus (07-10-2016 17:21:57)

Hors ligne

Pied de page des forums