Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-10-2016 16:36:56

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Désactiver une deuxième carte graphique

Bonjour!
Mon ordinateur portable possède deux cartes graphiques : http://www.01net.com/tests/hp-pavilion- … 15077.html
J'ai cru comprendre en traînant ici et là sur internet que le fait que mon PC chauffe et que mon ventilo tourne à fond pourrait être expliqué par une mauvais gestion des deux cartes graphiques.
J'ai trouvé sur ce site https://garyservin.wordpress.com/2012/0 … ux-wheezy/ une méthode pour désactiver la carte dite discrète dont je n'aurai pas l'utilité.
En effet, je n'utilise mon PC que pour : surfer, regarder des vidéos en max 1080p, écouter de la musique.
Malheureusement je suis bloqué à l'étape suivante :

lspci | grep VGA


01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470]
 



or, d'après ce que j'ai compris je devrais avoir ceci

lspci | grep VGA


01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] (rev ff)
 


car le (rev ff) devrait signifier que la carte est déconnectée.

Mes questions sont multiples :
- Pensez vous que la déconnexion d'une des deux cartes pourrait soulager mon ventilo et diminuer la chauffe?
- Pensez-vous que la méthode décrite dans le site est pertinente?
- Le cas échéant, pourriez-vous m'aider à aller au bout de cette méthode?

Je m'excuse par avance pour :
- mon ignorance totale du fonctionnement d'un système d'exploitation et du terminal:
        ->je risque de vous poser des questions sur des sujets évidents pour la plupart d'entre vous,
        ->j'ai suivi bêtement une méthode sans comprendre son fonctionnement,
- mes délais de réponse, je n'ai pas mon ordinateur à portée de main en journée pour vous indiquer si vos propositions m'ont fait avancer,
- la mauvais utilisation des balises de code pour retranscrire mes commandes et les réponses du terminal.

Si vous acceptez mes excuses, je serais ravi d'avoir un coup de main à ce sujet smile

Hors ligne

#2 25-10-2016 20:33:26

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Désactiver une deuxième carte graphique

Sic, personne pour accepter mes conditions hmm

Hors ligne

#3 26-10-2016 08:34:51

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Désactiver une deuxième carte graphique

Bonjour
c'est triste a dire mais le probleme c'est un portable en Amd (pour l'instant ils ont toujours des soucis de consommation et de chauffe )
pour ceci =>  (rev ff) c'est un code pour le model révision "ff " .  , ça ne signifie pas que la carte est déconnectée
comme pour nvidia il doit y avoir un utilitaire pour gérer les 2 cartes sur debian.
je connais pas bien ce materiel , donc je peut pas t'en dire plus.

Hors ligne

#4 26-10-2016 10:01:47

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : Désactiver une deuxième carte graphique

Bonjour,

tu peux désactiver certains périphérique PCI PCI/E en utilisant le sysfs mais pas pour tout les types de matériel il faut que le mec qui à coder le pilote pour le noyau l'est implémenter.

example :

Je veux déactiver une carte réseau car j'en ai plusieurs

lspci | grep -i eth

dans ton cas ce sera grep -i vga

il me rend une ligne du genre

07:00.0 Ethernet controller: Intel Corporation blablabla Network Connection

Je localise ou elle est définit dans le sysfs

find /sys -name *07:00.0



Je regarde s'il ya un un "remove" d'implementter

ls /sys/devices/pci0000:00/0000:00:1d.0/0000:07:00.0



puis je la désactive

echo 1 > /sys/devices/pci0000:00/0000:00:dc.0/0000:07:00.0/remove




je vérifie que le noyaux a bien interprété mes ordres

tail -f /var/log/message



Tu devrais vois ton périp avec "disabled" à la fin

@+


" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

Hors ligne

#5 27-10-2016 09:40:51

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Désactiver une deuxième carte graphique

robert2a : je crains que tu aies malheureusement raison, j'ai suivi les procédures de ces deux pages : vga switcheroo et acpi call et il n'y a malheureusement pas de changements hmm
https://help.ubuntu.com/community/HybridGraphics
https://doc.ubuntu-fr.org/vga_switcheroo

greenmerlin: merci pour ta proposition, je vais essayer de voir ça ce soir smile !

Hors ligne

#6 27-10-2016 11:37:23

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : Désactiver une deuxième carte graphique

Bonjour,

Je ne connais pas ta carte mère mais as-tu essayé de faire ce genre de réglage sur le bios
perso j'ai la possibilité de choisir quel Carte graphique je souhaite utilisé

Je suis sur une tour où j'ai une puce comme carte graphique + une Carte que j'ai acheté en supplément plus performante
j'ai désactivé la première par le bios

Dernière modification par Philanthrope (27-10-2016 11:37:48)


La présent est un passé en évolution

Hors ligne

#7 27-10-2016 13:04:34

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Désactiver une deuxième carte graphique

Petite question: quand tu parles de désactiver la carte graphique par le bios, tu parles bien des menus auxquels on a accès au démarrage du PC, par lequel on peut modifier l'ordre du boot?

Hors ligne

#8 27-10-2016 13:11:38

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : Désactiver une deuxième carte graphique

Oui

Normalement tu y as accès en appuyant sur une touche (moi c'est F2)

La présent est un passé en évolution

Hors ligne

#9 28-10-2016 09:12:11

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Désactiver une deuxième carte graphique

ok merci wink, je regarde ça aussi!

Hors ligne

#10 30-10-2016 16:49:06

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Désactiver une deuxième carte graphique

greenmerlin:
J'ai suivi ta procédure, tout s'est passé nickel, il y avait juste à mettre un s à message dans ta dernière ligne de code!

Oct 30 15:44:31 handylinux kernel: [  452.527025] radeon 0000:02:00.0: No connectors reported connected with modes
Oct 30 15:44:31 handylinux kernel: [  452.527040] [drm] Cannot find any crtc or sizes - going 1024x768
Oct 30 15:44:31 handylinux kernel: [  452.528392] [drm] fb mappable at 0xE035E000
Oct 30 15:44:31 handylinux kernel: [  452.528396] [drm] vram apper at 0xE0000000
Oct 30 15:44:31 handylinux kernel: [  452.528399] [drm] size 3145728
Oct 30 15:44:31 handylinux kernel: [  452.528402] [drm] fb depth is 24
Oct 30 15:44:31 handylinux kernel: [  452.528405] [drm]    pitch is 4096
Oct 30 15:44:31 handylinux kernel: [  452.528631] radeon 0000:02:00.0: fb1: radeondrmfb frame buffer device
Oct 30 15:44:31 handylinux kernel: [  452.529789] [drm] Initialized radeon 2.39.0 20080528 for 0000:02:00.0 on minor 1
Oct 30 15:44:36 handylinux kernel: [  458.080524] snd_hda_intel 0000:02:00.1: Disabling via VGA-switcheroo
 



Voilà le retour que j'ai suite à la commande tail sur le var/log/messages, pour moi je comprends que ma carte discrète est bien désactivée mais ça ne change malheureusement rien au fait que mon ventilo souffle bruyamment sad
Merci quand même pour ton aide!

Philantrope: le menu du BIOS au démarrage ne me permet pas de désactiver la carte graphique hmm

Dernière modification par homme mouton (30-10-2016 17:02:30)

Hors ligne

Pied de page des forums