Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-11-2016 13:26:07

hukros
Membre
Inscription : 28-10-2016

[Résolu]réglage du GRUB

Bonsoir,

Je poste car j'ai essayé de régler la page du dualboot qui est à 5s par défaut. Ce que je trouve assez ridicule car quad j'allume mon pc j'ai pas intéret a distrait pendant les 10s qui suivent.

Donc serait il possible d'augementer le temps du choix. J'ai déjà essayé la commande

mano /..../grub/grub.cfg désoler pour les ... mais ma mémoire me fait défaut sur la commandeet ensuite il disait de changer le temps output=5 par le temps souhaiter de quitter et sauvegarder mais hélas quand j'ai reboot le temps était toujours de 5s. J'ai regardé ailleurs par rapport a la commande mais je n'ai rien trouver d'autre a ce qui correspondait à l'image.

Pource quiest du programme tier, j'ai eu des messages d'erreur, mais je ne sais plus à quel moment de la manip ( je suis désoler du peu de donnée que je peux vous donner a ce sujet.)

Hélas je ne pourrai pas voir vos réponse avant demain car chez moi il est 22h30, et ma femme crie pour que je quitte le pc.

D'avance merci

Hukros

Dernière modification par hukros (02-11-2016 05:10:23)

Hors ligne

#2 01-11-2016 13:29:05

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]réglage du GRUB

Il faut modifier la valeur de la variable GRUB_TIMEOUT dans le fichier /etc/default/grub puis exécuter la commande "update-grub" pour appliquer le changement au fichier de configuration /boot/grub/grub/cfg, le tout en root.

Hors ligne

#3 01-11-2016 13:31:57

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu]réglage du GRUB


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 02-11-2016 05:07:07

hukros
Membre
Inscription : 28-10-2016

Re : [Résolu]réglage du GRUB

Salutation et merci a vous 2 pour votre aide

Voilà ce que j'ai fait je suis passé en su
la j'ai tapé la ligne de commande nano /boot/grub/grub.cfg

J'ai cherché les lignes suivantes, tout particulièrement les set timeout que j'ai souligné plus bas.

terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=-1
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=305
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
     set timeout=305
  fi
fi
### END /etc/grub.d/00_header ###

qu'il suffit de modifer c'est ligne en pensant que le nombre que l'on indique exprime des secondes.

Ensuite il suffit de fermer avec Ctrl+X et enregistrer avec O et d'appuyer sur Entrer pour revenir a la console.

Redémarrer pour voir les changements.

En espèrant que la solution que j'ai trouvé sur un autre site pourra aidé d'autre personne.

hukros

Dernière modification par hukros (02-11-2016 05:09:55)

Hors ligne

#5 02-11-2016 07:19:41

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu]réglage du GRUB

Merci hukros, mais cela me semble être un contournement de l'utilisation normale de GRUB.
Que te renvoie maintenant :

cat /etc/default/grub


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 02-11-2016 11:00:24

hukros
Membre
Inscription : 28-10-2016

Re : [Résolu]réglage du GRUB

salut et désoler si j'ai contourné l'utilisation de grub ce n'etait pas mon but je voulais juste avoir plus de temps pour choisir mon système d'exploitation surtout le matin pas bien réveiller.

Voici ce que me retourne ta commande:

If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

si on je dois revenir en arrière comment je peux faire?

D'avance merci

Hukros

Hors ligne

#7 02-11-2016 12:16:35

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu]réglage du GRUB

Non, c'est bon, je m'inquiétais des éventuels répercutions de ton contournement de l'usage de GRUB, apparemment, il n'y en a pas.
character0019.gif

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 02-11-2016 14:30:57

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]réglage du GRUB

L'inconvénient de la modification directe de grub.cfg est que le résultat n'est pas persistant. Tu n'as pas manqué de lire l'avertissement en commentaire au début du fichier disant de ne pas modifier manuellement ce fichier car il est généré automatiquement. A la prochaine exécution de update-grub qui a lieu notamment lors de l'installation, de la mise ou jour ou de la suppression d'un paquet du noyau, le fichier sera regénéré et les modifications manuelles seront écrasées.

Dernière modification par raleur (02-11-2016 14:31:56)

Hors ligne

Pied de page des forums