Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-07-2009 16:28:45

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

[Resolu] Boot impossible sur testing après maj

Bonjour,

suite à une maj de ma Squeeze/Testing l'OS refuse de rebooter.

Apparemment ça bloquerait juste avant l'apparition du logo Nvidia et de KDM
Il n'y a poutant pas eu de maj de kernel.

Je me retrouve avec :
Debian Gnu/Linux Squeeze/Sid debian tty1
debian login:

le mot de passe root est refusé et de plus je ne sais pas à quoi cela m'aurait mené mais j'aurais déjà avancé.

Si je reboote en single user, il m'est demandé le mot de passe root (#) ... qui est refusé.
Pareil en reboot sur le noyau précédent.

Si quelqu'un à une idée ce serait avec plaisir.
Je suis conscient de donner peu d'infos mais je n'en n'ai pas plus.
Pour l'instant je tourne sur la Mandriva qui me sers d'OS de secours mais j'aimerais bien récupérer cette Debian qui est notre OS principal.

Là, tout de suite, je dois sortir jusqu'à 21h00 et je m'y attele dès mon retour.

Dernière modification par Tophe (12-07-2009 23:34:57)


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#2 12-07-2009 18:05:32

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Resolu] Boot impossible sur testing après maj

Bonjour Tophe,

Si tu pouvais accéder à la console, on devrait pouvoir redémarrer le serveur X.
Tu as essayé de taper ton mdp root comme si tu étais sur un clavier Qwerty ?

Hors ligne

#3 12-07-2009 22:12:19

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

Salut,

je viens de rentrer du boulot ... plus de taf que prévu.
En fait quand j'ai le message :
Debian Gnu/Linux Squeeze/Sid debian tty1
debian login:

je tape le mdp et il s'affiche en clair, je vois donc bien que le clavier est en azerty

Quelque chose m'échappe à ce propos car j'ai dépanné la Ubuntu d'un pote aujourd'hui, problème de reconnaissance écran et de pilotes graphique suite à upgrade et j'ai bien réussi à reconfigurer mais je n'arrivais plus à relancer le serveur X ni à rebooter car le même problème de mdp est survenu. Sauf qu'après un reboot sauvage tout est rentré dans l'ordre.

Ce que j'ai envie de faire pour commencer c'est, de la Mandriva, modifier le xorg.conf est mettre "nv" à la place de nvidia. Mais je ne me souviens plus des maj exactes qui ont été effectuées mais il me semble qu'il y avait un truc à propos de X11

à suivre ...

* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#4 12-07-2009 22:38:09

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

En consultant de /var/log/Xorg.0.log de 16h01
je trouve ceci
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Si c'est juste un souci de "nvidia" j'arriverai peut-être à m'en dépétrer.
Je vais tenter de modifier de xorg.conf comme dit dans le message précédent

Dernière modification par Tophe (12-07-2009 22:38:38)


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#5 12-07-2009 22:59:17

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

la belle et la bête ... suite

suite à la modification du xorg.conf (nv à la place de nvidia) à partir de la mandriva, l'OS a rebooté.
Je pense recompiler le module nvidia et reparamétrer l'écran qui  est à nouveau mal reconnu mais je pense (j'espère) que cela devrait aller car je l'ai déjà fait.

* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#6 12-07-2009 23:34:27

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

OK, c'est ok. La bête a récupéré sa belle ...
C'était bien une histoire de pilote nvidia

J'ai donc installé  : apt-get install -t unstable nvidia-kernel-source nvidia-kernel-common
puis
    m-a prepare
    m-a update
    m-a a-i nvidia

puis
$ su
# rm -rf /usr/src/modules/nvidia-kernel/
# cd /usr/src
# tar xjvf nvidia-kernel.tar.bz2
# cd modules/nvidia-kernel/debian
# cp control.template control
# m-a a-i -i nvidia-kernel-source
# apt-get install -t unstable nvidia-glx

puis j'ai mis en place la sauvegarde de l'ancien xorg.conf et c'est désormais ok.
Du coup j'ai les derniers drivers Nvidia SID 185.18.14-2

Bon l'histoire de drivers nvidia et moi ce n'est jamais simple.
J'arrive à m'en tirer mais ça cafouille souvent, tant sur Debian que sur Mandriva.
Faudra tout de même que j'apprenne à me dépanner quand je suis devant un" écran noir" car, là, sans un OS de secours je suis dans la panade.
Si quelqu'un connait un bon tuto. Je sais comment faire sur Mandriva mais pas sur Debian.
Enfin bon, je suis tout de même soulagé car ce n'est vraiment pas la saison qui me laisse beaucoup de temps de libre.

Hasta la vista.

Dernière modification par Tophe (12-07-2009 23:37:53)


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#7 13-07-2009 01:08:41

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

Re,

j'essaie de piger. J'ai donc actuellement :

christophe@debian:~$ dpkg -l | grep nvidia
ii  nvidia-glx                           185.18.14-2                 
ii  nvidia-kernel-2.6-686                173.14.09+3+lenny1 
ii  nvidia-kernel-2.6.26-2-686           185.18.14-2+2.6.26-17
ii  nvidia-kernel-common                 20080825+1   
ii  nvidia-kernel-source                 185.18.14-2     
ii  nvidia-settings                      180.22-1     
ii  nvidia-xconfig                       1.0+20080522-2 

christophe@debian:~$ dpkg -l | grep linux
ii  linux-headers-2.6-686                2.6.26+17+lenny1
ii  linux-headers-2.6.26-2-686           2.6.26-17
ii  linux-headers-2.6.26-2-common        2.6.26-17
ii  linux-image-2.6-686                  2.6.26+17+lenny1
ii  linux-image-2.6.26-1-686             2.6.26-13lenny2
ii  linux-image-2.6.26-2-686             2.6.26-17
rc  linux-image-2.6.29-2-amd64           2.6.29-5
ii  linux-kbuild-2.6.26                  2.6.26-3
ii  linux-libc-dev                       2.6.26-17
ii  linux-sound-base                     1.0.20+dfsg-1
ii  util-linux                           2.15.1~rc1-1

Donc si j'ai tout compris, j'ai tout (?) mais je pourrais désinstaller d'anciennes versions :
nvidia-kernel-2.6-686                173.14.09+3+lenny1
linux-headers-2.6-686                2.6.26+17+lenny1
linux-image-2.6-686                  2.6.26+17+lenny1
linux-image-2.6.26-1-686             2.6.26-13lenny2
linux-image-2.6.29-2-amd64           2.6.29-5

À votre avis, j'ai tout juste là ?
Bonne nuit.

Dernière modification par Tophe (13-07-2009 09:04:00)


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#8 13-07-2009 02:23:32

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Resolu] Boot impossible sur testing après maj

Salut Tophe

1) Pour ma part j'ai l'habitude de conserver seulement deux noyaux. Un qui fonctionne bien et le plus récent (celui qui fonctionne bien est donc l'avant-dernier). Ce que je ne comprend pas dans ton cas c'est que tu as un noyau pour le 32 bits (linux-image-2.6.26-1-686) et un pour le 64 bits (linux-image-2.6.29-2-amd64). Tu as installé ta Debian en 32 bits, alors que fait ce noyau sur ton système ? Comment as-tu fais cela ?

2) Lorsqu'un problème survient avec le pilote NVidia, on fini normalement par se retrouver dans un tty. La manière de s'en sortir alors est de se logguer en root et d'éditer son fichier /etc/X11/xorg.conf (pour ma part j'utilise nano pour cela) pour remplacer le "nvidia" par "nv". On peut alors ouvrir sa session, sans la 3D bien sûr. De cette façon, on fini toujours par retomber sur ses pattes. Après on recompile le pilote NVidia pour son noyau et le tour est joué, si tout se passe bien ; ce qui n'est pas toujours le cas. Pour l'installation du pilote comme tel, il y a le wiki

Si tu as besoin d'autres détails n'hésite pas à poser tes questions.

Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 13-07-2009 09:32:10

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

Salut Martin_MTL,

ce noyau 64 vient d'une de mes lubbies. Un jour que je trainais dans Synaptic j'ai vu un noyau plus récent et je l'ai installé.
Je me suis aperçu ensuite que c'était un 64 mais comme il fonctionnait bien en 2D je l'avais gardé en secours mais il ne sert plus à rien puisqu'il n'apparait plus dans le grub.

C'est bien ce lien du wiki que je suis pour comprendre et il me semble que c'est bien la première méthode (compilation) que je pratique.
J'y rajoute juste quelques lignes qui me paraissent être de "nettoyage" car la simple méthode ( m-a prepare, m-a update, m-a a-i nvidia ) n'a pas suffit la dernière fois.

" Lorsqu'un problème survient avec le pilote NVidia, on fini normalement par se retrouver dans un tty. La manière de s'en sortir alors est de se logguer en root et d'éditer son fichier /etc/X11/xorg.conf (pour ma part j'utilise nano pour cela) pour remplacer le "nvidia" par "nv"."
Ok, d'accord, faut juste se souvenir de bien utiliser Nano et pas Kwrite en tty
En fait je me suis retrouvé devant ce message
Debian Gnu/Linux Squeeze/Sid debian tty1
debian login:

C'est donc que j'était en tty mais il refusait mon mot de passe et là je viens de m'apercevoir que ce n'est pas le passe qu'il demande mais le login.
RRRRRhhhha la bête, la bête vous dis-je .....

Bon bref sur le coup je n'étais pas plus avancé car je n'étais pas certain que cela vienne du pilote nvidia. C'est en rebootant sur l'OS de secours et en lisant les logs que je m'en suis réellement douté.
Merci à vous et merci à toi petit OS de secours qui m'a quelquefois bien dépanné.

Dernière modification par Tophe (13-07-2009 09:44:24)


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#10 01-08-2009 12:59:39

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

Donc pour ne garder que le dernier kernel il faut :
regarder dans /boot ce qu'il y a comme 'config-2.6.xyz'
Aller dans une console et en root, taper :
# apt-get remove --purge linux-image-2.6.xyz
2.6.xyz étant le ou les anciens kernel

donc j'ai fait
# apt-get remove --purge linux-image-2.6.26-1-686
Du coup seul a été supprimé :
ii linux-image-2.6.26-1-686 2.6.26-13lenny2

En fait il ne faut apparemment surtout pas toucher à ceux-ci :
ii nvidia-kernel-2.6-686 173.14.09+3+lenny1
ii linux-headers-2.6-686 2.6.26+17+lenny1
ii linux-image-2.6-686 2.6.26+17+lenny1
qui fonctionnent apparemment avec le kernel actuel

* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#11 01-08-2009 13:04:05

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

Bonjour,

Continuant mon apprentissage je fouine et lis de la doc et il me semble que mon problème est survenu car :
- mon linux-kernel est en testing
mais
- mon kernel nvidia est en Sid (apt-get install -t unstable nvidia-kernel-source nvidia-kernel-common) avec le fichier préférences approprié

Je me demande si les maj ne pourraient pas être automatisées sans avoir à recompilé le Nvidia kernel à chaque fois
http://debian-facile.org/forum/viewtopi … 306#p11306

Car en fait man apt_preferences dit :
100 < P <=500 La version sera installée, sauf s´il existe une version appartenant à une autre distribution ou si la version installée est plus récente.
0 < P <=100 La version sera installée si aucune version du paquet n´est installée.

et il se trouve que que la partie "Sid" de mon fichier préférence donne des Pin-Priority unstable inférieures à 100.

Donc il me faudrait mettre une priorité supérieure à 100 pour unstable. Ainsi, les paquets installés depuis unstable (avec apt-get install -t unstable paquet) seraient mis à jour depuis la branche unstable.

Mais, dans ce cas,
- les maj kernel vont elles bien se faire de pair ?
- ou est-ce que je risque l'inverse, à savoir, me retouver avec un nVidia kernel (de Sid donc) qui ne correspond plus au linux kernel (de testing donc) et ainsi me retrouver à nouveau bloqué ???

Peut-être est il plus sûr de posséder les linux et nVidia kernel issus de Sid.
Ou tout simplemen de ne pas toucher au fichier préférences et continuer ainsi en recompilant le kernel nVidia lorsque c'est nécessaire.

* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#12 01-08-2009 22:34:13

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

à propos de :
100 < P <=500 La version sera installée, sauf s´il existe une version appartenant à une autre distribution ou si la version installée est plus récente.

Je viens de lire sur le wiki :
Si c'est envisageable de le faire individuellement, pour un paquet en particulier, ce n'est pas prudent de le faire pour un fichier preferences générique à cause des dépendances.

Je vois mal alors pourquoi man apt_preferences le proposerait ... mais dans le doute abstiens toi. Ça roule ainsi, autant continuer. Faut savoir reconnaitre lorsqu'on a atteint ses limites. Peut-être y verrai je plus tard.

Dernière modification par Tophe (01-08-2009 22:37:12)


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#13 02-08-2009 05:07:17

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Resolu] Boot impossible sur testing après maj

Salut Tophe

Je viens de lire tes messages, mais là je manque de temps pour y répondre. J'espère pouvoir le faire très bientôt. En très bref, je te suggère d'avoir les fichiers sources.list et preferences pour la branches testing que l'on retrouve dans le wiki. Comme les dépôts pour testing ne sont pas toujours complets tu devrais continuer à compiler le kernel lorsque c'est nécessaire. Normalement cette méthode fonctionne toujours bien.

À la prochaine
Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#14 02-08-2009 09:19:20

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Resolu] Boot impossible sur testing après maj

Ne te tracasse pas pour moi Martin, ça roule.
J'avais un long week de repos et j'en profitais (entre 2 siestes) pour comprendre mieux.
Une question (résolue) en entrainant toujours une autre ...
Mais comme tu le dis, la compilation fonctionne très bien, c'est donc le principal.

Bye.Tophe

* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

Pied de page des forums