Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-07-2009 13:08:24

eeeul'claude
Membre
Inscription : 29-06-2008

pbm pilote nvidia-glx sur qosmio

Salut tatouss...

Je fais une install de debian sur un toshiba qosmio G30-10H
Le bébé servira pour du travail photo donc pas besoin à tout prix
de l'accélération graphique, mais j'ai besoin de la haute résolution
et du rendu des couleurs.

J'ai installé une lenny (rc1)

lspci donne:
---snip---
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce Go 7600] (rev a1)
---snip---

J'ai installé le pilote nvidia-glx avec ses dépendances via aptitude.
comme vu sur les archives du forum j'ai modifié /etc/X11/xorg.conf
en renplaçant Driver "nv" par Driver "nvidia"

gdm plante et l'erreur signalée est la suivante:
__________________________________________________________________________
NVIDIA: could not open the device file /dev/nvidia0 (Input/output error)
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:
(EE) NVIDIA(0):     Please see the COMMON PROBLEMS section in the README
(EE) NVIDIA(0):     additional information.                             
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
__________________________________________________________________________

Le fichier existe, ls -al /dev/nvid* donne:

crw-rw---- 1 root video 195,   0 jui 13 12:04 /dev/nvidia0
crw-rw---- 1 root video 195, 255 jui 13 12:04 /dev/nvidiactl


Les utilisateurs font partie du groupe video!

lsmod | grep nv donne:
nvidia               7086148  0
i2c_core               19828  1 nvidia
agpgart                28776  2 nvidia,intel_agp


voiçi le /etc/X11/xorg.conf modifié par mes soins (tsoin!)
(il marche au poil avec le pilote vesa)
_____________________________________________________________________________
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildd@ninsei)  Fri Sep  5 22:23:08 UTC 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
#    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection


Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
        Option          "XkbOptions"    "lv3:ralt_switch"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection


Section "Device"
     Identifier     "Videocard0"
#     Driver         "nvidia"
#     Driver         "nv"
     Driver         "vesa"
     VendorName     "NVIDIA Corporation"
     BoardName      "GeForce Go 7600"
#    BoardName      "GeForce G70"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
_____________________________________________________________________________


J'ai tenté aussi l'install des pilotes proprio (où pousse le désespoir...?)
sans succès, je vais rester sur le pilote libre (nv).

Après 87 tentatives depuis une semaine, je ne sais plus quoi faire, je suis
peut-être un peu perdu aussi, d'où ce post, ça peut encore marcher.
With a little help from...

Dernière modification par eeeul'claude (13-07-2009 16:20:49)


deeebian-user

Hors ligne

#2 13-07-2009 21:03:36

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : pbm pilote nvidia-glx sur qosmio

Salut,

donne les commandes que tu as effectué pour installer nvidia
celle-ci :

apt-get install module-assistant nvidia-kernel-source nvidia-kernel-common

ensuite

    m-a prepare
    m-a update
    m-a a-i nvidia

et puis si tout c'est bien passé on finit par :

    apt-get install nvidia-glx nvidia-settings

il faudra ensuite éditer le fichier xorg.conf pour changer "nv" par "nvidia" dans la section "Device"

Hors ligne

#3 13-07-2009 21:26:53

eeeul'claude
Membre
Inscription : 29-06-2008

Re : pbm pilote nvidia-glx sur qosmio

Salut NEOS!

Merçi de ta réponse.

En gros cela fait une semaine que je galère avec ce truc et j'ai dû taper au bas mot
un milliard de commandes. Pour ta question précisément: j'ai essayé la procédure pour
le pilote nvidia-glx que j'ai trouvé sur le net.

Grosso modo les symptômes sont identiques avec le serveur nv et le nvidia-glx
gdm affiche sa page et on remarque que le curseur est accompagné d'un carré à la
couleur mal définie lorsqu'il passe sur un fond blanc. Les caractères s'affichent
correctement dans la fenêtre de login mais à la validation, la couleur vire au noir
quasi complet et le système fige (on/off reset obligatoire) où bien le curseur devient
une montre... pour l'éternité.

Le message d'erreur que j'indique pour le serveur X peut correspondre à un conflit
d'IRQ avec un autre périphérique (par exemple la super carte tunerTV que j'ai blacklisté
dans les scripts de détection parcequ'elle foutait la zone au démarrage)

Par contre, avec le pilote vesa ça marche au poil (modulo la résolution d'écran) et je me
demande s'il ne serait pas plus sage de fignoler ce xorg.conf là en attendant d'en
comprendre un peu plus sur les pilotes nvidia. On dirait que c'est un vrai bordel depuis lenny.

amicalement...

deeebian-user

Hors ligne

#4 13-07-2009 21:36:31

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : pbm pilote nvidia-glx sur qosmio

oui les versions récentes de xorg n'ont plus besoin de trop d'options
sous testing j'utilisais simplement ça :

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
    Option        "XkbOptions"    "lv3:ralt_switch"
EndSection

Section "Device"
    Identifier    "GeForce 9800 GT"
    Driver          "nvidia"
       Option        "NoLogo"
EndSection


maintenant les paramètres clavier peuvent être enlever sous sid, car ils sont paramètrables via console-setup.

Hors ligne

#5 13-07-2009 21:58:55

eeeul'claude
Membre
Inscription : 29-06-2008

Re : pbm pilote nvidia-glx sur qosmio

Arrrggh! un xorg.conf simple!!!!

EDITez ce post que je ne saurait voir.:lol:

deeebian-user

Hors ligne

#6 14-07-2009 11:30:13

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : pbm pilote nvidia-glx sur qosmio

Hello,

où tu en es ? réglé ?

Hors ligne

#7 14-07-2009 12:06:26

eeeul'claude
Membre
Inscription : 29-06-2008

Re : pbm pilote nvidia-glx sur qosmio

Salut!


J'y vois un peu plus clair.

Pour l'instant je fignole le xorrg.conf avec le pilote vesa
actuellement il me permet 1280x800 en 24bit, j'ai un affichage utilisable pour la photo.

Ensuite je tâcherais de retirer la carte tunertv dont je me fout éperduement

ensuite je reviendrais à la config du pilote nv quand ça aura l'air de marcher facile

Merci pour ta sollicitude, mais je suis un intermitent du net, je peux mettre longtemps
à répondre... tongue

amicalement

deeebian-user

Hors ligne

#8 15-07-2009 03:05:27

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : pbm pilote nvidia-glx sur qosmio

Salut

Après toutes tes tentatives infructueuses, je serais porté à croire que ton problème est causé par ta carte tunertv qui entre en conflit avec ta carte graphique. Normalement, avec Lenny, on n'a pas besoin de passer par module-assistant pour installer le pilote NVidia. Il suffit simplement d'installer les paquets nécessaires ; tout est déjà compilé.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums