Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-11-2016 01:05:59

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

[Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Salut ; le titre et le code de ma tentative devrait vous expliquer tout !

##Application dont je veux "focus" la fenêtre
$ pgrep pavucontrol
8298

##Listing des fenêtres
$ wmctrl -lp
0x00a00004 -1 545    depannagePc xfce4-panel
0x00c00003 -1 549    depannagePc Bureau
0x0340000d  0 4642           N/A debian32_1 [En fonction] - Oracle VM VirtualBox
0x03600003  0 5063   depannagePc XChat: otyugh_II @ FreeNode / #debian-facile (+cntz)
0x05400d7a  0 7420   depannagePc Terminal - otyugh@depannagePc:~/Desktop
0x04c00003  0 8298   depannagePc Contrôle du volume

##selection de la bonne fenêtre
$ wmctrl -lp | grep 8298
0x04c00003  0 8298   depannagePc Contrôle du volume
##Ok c'est elle

##On essaye maintenant de la "focus"
$ wmctrl -a 0x04c00003
##fait rien d'après la doc, je devrais pas avoir besoin de -i

$ wmctrl -ai 0x04c00003
#changement de focus mais pas sur la bonne fenêtre

##En désespoir de cause
[otyugh@depannagePc Desktop]$ wmctrl -a "Contrôle du volume"
##ça, ça marche. Mais j'aimerais passer par le n° de fenêtre
 



Ça m'étonnerai que ce soit un bug ; y a le même sous debian et archlinux ; je dois passer à côté de quelque chose, non ?

Dernière modification par otyugh (07-11-2016 22:07:32)

Hors ligne

#2 07-11-2016 02:45:32

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Bonjour

Si tu veux faire passer au premier plan la fenêtre depannagePc Contrôle du volume

utilise plutôt :

wmctrl -ai 8298

ou bien :

wmctrl -ai $(pgrep pavucontrol)

Dernière modification par MicP (07-11-2016 12:17:36)

Hors ligne

#3 07-11-2016 03:23:35

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Marche pas ! Ni sous arch, ni sous debian. Ta dernière commande bien entendu.
Tu l'a essayée ?

Serais curieux si c'était sensé marcher, un PID ne correspondant pas forcément à une fenêtre, c'est étrange. Le man est vraiment mauvais pour le coup, ne précisant pas le genre de valeur numérique pouvant correspondre à <WIN>...

Dernière modification par otyugh (07-11-2016 04:11:44)

Hors ligne

#4 07-11-2016 07:55:19

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

bonsoir
essai

wmctrl -i -a 0x04c00003


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#5 07-11-2016 12:20:14

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Bonjour

Marche pas ! Ni sous arch, ni sous debian. Ta dernière commande bien entendu.
Tu l'a essayée ?

Oui, je l'avais essayé, mais, fatigué, je n'avais pas assez vérifié

Désolé.

Dernière modification par MicP (07-11-2016 12:20:32)

Hors ligne

#6 07-11-2016 17:40:53

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

+1 Severian

" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

En ligne

#7 07-11-2016 18:24:47

trentanel
Membre
Lieu : Comtat Venaissin
Distrib. : Raspbian jessie
(G)UI : xfce
Inscription : 17-09-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Bonjour,
Pour trouver son N° en une ligne, on peut aussi :

window=$(wmctrl -l | grep "tout ou partie du texte affiché dans le titre de la fenêtre" | awk '{print $1}')


Ensuite, si la fenêtre est maximisée, il faut d'abord la réduire par :

wmctrl -i -r $window -b remove,maximized_vert,maximized_horz


Après on en fait ce que l'on veut ... enfin presque smile

Dernière modification par trentanel (07-11-2016 18:40:54)

Hors ligne

#8 07-11-2016 19:20:52

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Severian a écrit :


wmctrl -i -a 0x04c00003



T'as fait l'essai ? Parce que c'est la première chose que j'ai essayé ^^'

Hors ligne

#9 07-11-2016 20:02:26

trentanel
Membre
Lieu : Comtat Venaissin
Distrib. : Raspbian jessie
(G)UI : xfce
Inscription : 17-09-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Oui, wmctrl -i -a xxxxxx place bien la fenêtre en dessus et lui donne le focus (sur ma Archlinux). Mais on ne peut pas la redimensionner ou la positionner ailleurs sur l'écran tant qu'elle est maximisée.
C'est pourquoi je proposais de la réduire d'abord.

Dernière modification par trentanel (07-11-2016 20:03:00)

Hors ligne

#10 07-11-2016 21:19:16

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

pour donner le focus à la fenêtre visiblement

wmctrl -ia xxxxxx


fonctionne aussi

je pense qu'il faut que l'option -i soit en premier

après je n'arrive pas non plus à redimensionner les fenêtres perso neutral


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#11 07-11-2016 21:46:52

trentanel
Membre
Lieu : Comtat Venaissin
Distrib. : Raspbian jessie
(G)UI : xfce
Inscription : 17-09-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Severian a écrit :

après je n'arrive pas non plus à redimensionner les fenêtres |



Pour cela, si elles sont maximisées, il faut d'abord les réduire avec :

wmctrl -i -r xxxxxxx -b remove,maximized_vert,maximized_horz

Hors ligne

#12 07-11-2016 22:06:12

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Finallement ça marche maintenant... Je ne *comprends* pas ce qui c'est passé, tout tourne maintenant "sans surprise", c'est zarb.

Valà mon script au passage, il m'a pris une tonne de temps alors que ça aurait dû me prendre 5 minutes, donc je laisse une marque pour plus tard. Résolu.


#!/bin/bash

#Focus plutôt que de relancer les applications comme :
#xchat, pavucontrol, lxtask...
#Usage : "ce_script lxtask"

[ $# -ne 1 ] && exit 1 #si pas/trop d'argument : interruption

pid=$(pgrep "$1" | head -n 1) #recherche pid
if [ -z $pid ]; then $1 &>/dev/null& exit 0; fi #pas trouvé de pid : lancement $

win=$(wmctrl -lp | grep $pid | head -n1 | cut -d' ' -f1) #rechercher *une* fenê$
[ -z $win ] && exit 2 #pas trouvé de fenêtre : interruption

wmctrl -ia $win #focus

 

Hors ligne

#13 08-11-2016 09:15:22

trentanel
Membre
Lieu : Comtat Venaissin
Distrib. : Raspbian jessie
(G)UI : xfce
Inscription : 17-09-2016

Re : [Résolu] wmctrl : j'arrive pas à focus une fenêtre par son numéro

Merci pour le partage.
Cela se rapproche du comportement des icônes d'un dock comme Plank, Docky et d'autres.

Hors ligne

Pied de page des forums