Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-11-2016 19:09:36

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

résolu: adresse sur auto-hebergement

salut

Je viens de rajouter un site sur mon serveur, y m'en restera plus que un à auto héberger, ça avance doucement...

mais il y a une chose qui me plaît pas et que je voudrai changer..
j'accède par

http://monnuage.chezlagrenouille.fr/funambule/

et je voudrai accéder par

http://funambule.chezlagrenouille.fr

comment je m'y suis pris :commençons par le début..

je passe sur l'installation d'un spip et sur le  transfert manuel d'un site spip d'un  serveur a un autre.
ni de l'édition du fichier de zone de l'apikey Gandi pour le sous domaine, ça fonctionne donc j'ai pa du faire trop de conneries.

j'ai créer un deuxième fichier de conf  funambule.conf à coté de monnuage.conf. dans /etc/apache2/sites-available/

je le mets ici et vous me dites si la première partie est vraiment necessaire


cat /etc/apache2/sites-available/funambule.conf
<VirtualHost *:80>
    ServerAdmin contact@chezlagrenouille.fr
    ServerName chezlagrenouille.fr

    DocumentRoot /var/www/chezlagrenouille.fr
    <Directory /var/www/chezlagrenouille.fr>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Require all granted
    </Directory>

    ErrorLog /var/log/apache2/chezlagrenouille.fr_error.log
    LogLevel warn
    CustomLog /var/log/apache2/chezlagrenouille.fr_access.log combined
</VirtualHost>



<VirtualHost *:80>
    ServerAdmin contact@chezlagrenouille.fr
    ServerName chezlagrenouille.fr

    DocumentRoot /var/www/html/funambule.chezlagrenouille.fr
    <Directory /var/www/html/funambule.chezlagrenouille.fr>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Require all granted
    </Directory>

    ErrorLog /var/log/apache2/funambule.chezlagrenouille.fr_error.log
    LogLevel warn
    CustomLog /var/log/apache2/funambule.chezlagrenouille.fr_access.log combined
</VirtualHost>



puis

a2ensite funambule


service apache2 reload

la redirection peut elle se faire  dans ce fichier ??
ou un autre ?? et si oui, lequel ?

ou c'est chez Gandi qu il me faut aller changer ça ?

bon voila autre chose, maintenant ça plante quand je reviens à l'accueil. ..lcahost ???

Dernière modification par lagrenouille (12-11-2016 00:55:29)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#2 09-11-2016 21:41:04

mizapar
Membre
Distrib. : nutyx/debian8/ubuntu
(G)UI : openbox
Inscription : 26-10-2016

Re : résolu: adresse sur auto-hebergement

de ce que je vois c'est juste l'adresse qui change, c'est le meme site?
le premier lien fonctionne l'autre non
d'ailleurs pour avoir acces au site en ligne il faudra soit avoir une connexion a l'exterieur, soit passer par un proxy par ex https://www.proxysite.com/ ; car je n'ai plus acces au localhost non plus sur le miens depuis qu'il est en ligne.

si le document root est bon, il n'y rien a faire de plus sur le serveur perso.

il faudra verifier chez le distributeur dns si les liens sont bons et quel est le nom que tu as d'attribué, et voir un alias si c'est possible.

dans le "doc root" un est avec /var/www/ et l'autre avec var/www/html , cela peut porter a confusion?

j'ai 3serv sur apache la, avec 2 ayant chacun un nom de domaine et cela fonctionne, il faut bien determiner les directions si je peut donner un avis approximatif (faut que je replonge dedans j'ai fait ca de maniere empirique)

qui plus est, il est possible de modifier les parametres du serveur perso pour rediriger le port 443 en port 80 pour etre en https si tu as activé le SSL (apache permet de l'activer tres facilement gratuitement).

liens en plus:
http://wiki.auto-hebergement.fr/ ou il y a un salon de discussion.

donc pour résumé le nom du site est gerée par le serveur DNS et c'est a cet endroit qu'il faudra donner l'adresse souhaitée.

Hors ligne

#3 09-11-2016 22:26:38

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

j'ai réparé
une erreur de dns chez gandi
et 2 erreurs dans /etc/apache2/sites-available/funambule.conf

c'est 

<VirtualHost *:80>
    ServerAdmin contact@chezlagrenouille.fr
    ServerName funambule.chezlagrenouille.fr

    DocumentRoot /var/www/html/funambule
    <Directory /var/www/html/funambule>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Require all granted
    </Directory>

    ErrorLog /var/log/apache2/funambule.chezlagrenouille.fr_error.log
    LogLevel warn
    CustomLog /var/log/apache2/funambule.chezlagrenouille.fr_access.log combined
</VirtualHost>







ça roule maintenant
et j'avais oublié de changer l'adresse d’accueil du site dans spip


ppppppppppfffffffffffffffffffffffffffffffffffffffffffffff
faut penser à tout, et même  plus .......


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#4 10-11-2016 08:31:15

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

ben non
encore une coquille dans les dns

ServerName n'a  pas le bon nom dans /etc/apache2/sites-available

j'y retourne

Dernière modification par lagrenouille (10-11-2016 11:23:14)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#5 10-11-2016 23:20:28

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : résolu: adresse sur auto-hebergement

Mais tu es sur la bonne voie dis donc smile

Tu as deux façon d'organiser ton serveur :

- Dans des sous-dossiers : http://mondomaine.org/blog , http://mondomaine.org/webmail, http://mondomaine.org/forum . Chaque sous-dossier contient une application particulière. C'est pratique chez certains hébergeurs avec lesquels tu ne peux pas faire autrement, tu n'as que "1 adresse". Cependant, certaines applications ne supportent pas bien de ne pas être à la racine du serveur. Par contre, si tu veux activer le chiffrement SSL, c'est nettement plus simple
- Dans des sous-domaines : c'est ce que tu as fait là.
Ça permet de bien scinder ton domaine en plusieurs sites proprement.

Au final, c'est avant tout une question d'organisation, il n'y a pas de meilleur choix.

YA3HGA-H

Hors ligne

#6 10-11-2016 23:46:49

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

j'ai mis le sous domain chez Gandi dans la zone

nom                        type            valeur
funambule                  CNAME            monnuage.chezlagrenouille.fr.



ce qui me ramemnait souvent a ma box ou la page accueil apache scratchhead.gif

Je me suis rappelé d'un coup que j'avais mis à l'installation de Debian Jessie
qu j'avais mis dans /etc/apache2/apache2.conf
à la fin ..
c’était il y a au moins 2 ans ou plus, je m'en rappelai plus

ServerName localhost
je l'ai viré

et en plus un certificat de sécurité dans iceweasel, viré aussi
ça a l'air d'aller pour l'instant

normalement le site devrait fonctionner avec l'adresse

http://funambule.chezlagrenouille.fr/

on va bien wouar peace_flag.gif

sinon je me fais moine yikes

Dernière modification par lagrenouille (10-11-2016 23:48:37)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#7 10-11-2016 23:55:41

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : résolu: adresse sur auto-hebergement

It works! :
nB0i5OsB3Pk1

YA3HGA-H

Hors ligne

#8 11-11-2016 00:00:15

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

ben ma foi, çà a l'air de rouler pour les deux premiers

http://monnuage.chezlagrenouille.fr/owncloud/
http://funambule.chezlagrenouille.fr/?lang=fr

reste fractuscontrarius.fr

pppppfffffffffffffffffffffffffffffffffffffffffff

fractus à un nom de domaine, ça demande plus de réflexion  sos.gif

Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#9 11-11-2016 00:07:00

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : résolu: adresse sur auto-hebergement

Tu dois rajouter un site /etc/apache2/sites-available/fractuscontrarius.conf je suppose?
je dis ça, je n'ai jamais eu à utiliser apache smile nginx et httpd ça marche bien aussi.

Allez, tu y es presque smile

YA3HGA-H

Hors ligne

#10 11-11-2016 00:10:48

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

oui c'est ça mais faut le faire pointer sur monnuage, bah je verrrai
quand j'aurai fini, le serveur va exploser big_smile

faudra recommencer smile
et apprendre BSD lol

Dernière modification par lagrenouille (11-11-2016 00:13:31)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#11 11-11-2016 08:45:21

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

encore  loupé mais à moitié

ce matin' ça repointe sur ma livebox à la première connexion
puis j'ouvre un autre onglet et je colle l’adresse et c'est bon
et je re clique sur accueil et c'est de nouveau la box ????????
retour arrière navigateur et j.y reviens ??
je vais sur 3 articles et le retour à l'accueil se passe bien et au 4èmè
plouf, je me retrouve sur la box    wwouàààhhhhh
et parfois c'est
404 - Not Found

le plus crieux dans tout ça
j'ai mis IP Addrress and Domain information sur mon navigateur
adresse IP Domain IPV4 et my IP  sont les mêmes, ça devrait gazer

host funambule.chezlagrenouille.fr
funambule.chezlagrenouille.fr is an alias for monnuage.chezlagrenouille.fr.
monnuage.chezlagrenouille.fr has address 192.168.1.13

dig funambule.chezlagrenouille.fr

; <<>> DiG 9.9.5-9+deb8u8-Debian <<>> funambule.chezlagrenouille.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32910
;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;funambule.chezlagrenouille.fr.    IN    A

;; ANSWER SECTION:
funambule.chezlagrenouille.fr. 7995 IN    CNAME    monnuage.chezlagrenouille.fr.
monnuage.chezlagrenouille.fr. 0    IN    A    192.168.1.13

;; Query time: 2 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Fri Nov 11 08:02:58 CET 2016
;; MSG SIZE  rcvd: 105


j'ai ce message sur 'extension WordiP de iceweasel

ip address no coincide with the addresses from the external DNS Servers.
This website is located on yor internal network
traduction
Adresse IP ne coïncide pas avec les adresses des serveurs DNS externes.
Ce site Web est situé sur votre réseau interne

Fichier : /etc/hosts 

127.0.0.1       localhost
127.0.1.1       monnuage.home   monnuage

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters






si qulqu.un comprend ???

plouf suis dans ma box big_smile

fppppppppppfffffffffffffffffffffffff

y'à kekchose ki cloche lad,dans
j'y retourne immédiatement  yikes
sachant proche le résultat ........................

commence à vraiment être largué ...crash.gif

Dernière modification par lagrenouille (11-11-2016 09:44:05)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#12 11-11-2016 09:59:30

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

j'ouvre une nouvelle page pour plus de clarté

la même commande

sur mon serveur

dig funambule.chezlagrenouille.fr

; <<>> DiG 9.9.5-9+deb8u7-Debian <<>> funambule.chezlagrenouille.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13382
;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;funambule.chezlagrenouille.fr.    IN    A

;; ANSWER SECTION:
funambule.chezlagrenouille.fr. 4812 IN    CNAME    monnuage.chezlagrenouille.fr.
monnuage.chezlagrenouille.fr. 0    IN    A    192.168.1.13

;; Query time: 3 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Fri Nov 11 08:58:36 CET 2016
;; MSG SIZE  rcvd: 105

sur mon ordi di bureau via le navigateur à cette page
https://toolbox.googleapps.com/apps/dig/#A/

dig funambule.chezlagrenouille.fr



id 50708
opcode QUERY
rcode NOERROR
flags QR RD RA
;QUESTION
funambule.chezlagrenouille.fr. IN A
;ANSWER
funambule.chezlagrenouille.fr. 10799 IN CNAME monnuage.chezlagrenouille.fr.
monnuage.chezlagrenouille.fr. 299 IN A 109.222.221.81
;AUTHORITY
;ADDITIONAL

Dernière modification par lagrenouille (11-11-2016 10:00:08)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#13 11-11-2016 10:25:55

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : résolu: adresse sur auto-hebergement

Bonjour
de chez moi ça donne


dig funambule.chezlagrenouille.fr
 


retour


; <<>> DiG 9.10.3-P4-Debian <<>> funambule.chezlagrenouille.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22239
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1460
;; QUESTION SECTION:
;funambule.chezlagrenouille.fr. IN  A

;; ANSWER SECTION:
funambule.chezlagrenouille.fr. 10800 IN CNAME monnuage.chezlagrenouille.fr.
monnuage.chezlagrenouille.fr. 300 IN  A 109.222.221.81

;; Query time: 55 msec
;; SERVER: 80.10.246.130#53(80.10.246.130)
;; WHEN: Fri Nov 11 09:21:21 CET 2016
;; MSG SIZE  rcvd: 97
 



ce qui me dérange  => monnuage.chezlagrenouille.fr. 0    IN    A    192.168.1.13  sur ton post au dessus
pourquoi une IP privé ?

je joint le site sans probleme .

Dernière modification par robert2a (11-11-2016 10:30:23)

Hors ligne

#14 11-11-2016 10:32:12

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

ce qui me dérange  => monnuage.chezlagrenouille.fr. 0    IN    A    192.168.1.13  sur ton post au dessus
pourquoi une IP privé ?

je joint le site sans problème .



Alors là moi aussi ça me dérange
et je retombe sans cesse sur ma box
et je trouve pas la merde

192.168.1.13 c'est l IP LAN de mon serveur


cat /etc/hosts


127.0.0.1    localhost
127.0.1.1    monnuage.home    monnuage

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters


Je me demande si il ne faut pas modifier le fichier de conf ''upadedns.py''
c'est lui qui va chercher le dns
ça je sais pas faire

je vais voir dans ma box aussi

Dernière modification par lagrenouille (11-11-2016 10:42:37)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#15 11-11-2016 10:59:16

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : résolu: adresse sur auto-hebergement

je vais peut etre dire une bétise , mais sur mes sous-réseau , je lance la commande dig d'un client du réseau local (pas du serveur local chez toi )
idem pour le ping (par nom ou par ip )
selon la configuration de ton serveur au niveau réseau ça peut faire n'importe quoi
toute ta configuration est distante (peut etre un site pour faire des tests en local ? )
mais bon je suis pas trés bon sur ce type de configuration tongue
ps: si tu a un deuxieme pc sur ton réseau local lance la meme commande dig . pour voir le retour


127.0.0.1    localhost
192.168.1.13    monnuage (le nom de ta machine )

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
 



en fonction de ta box (si IP fixe ou dhcp IP réservé pour le serveur)

pour bien te répondre il le contenu du fichier "interfaces"

Dernière modification par robert2a (11-11-2016 11:05:22)

Hors ligne

#16 11-11-2016 11:03:33

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

c'est la même réponse

je nage complètement

de chez toi tout baigne
tu vas sur le site
tu regardes les articles et tu reviens à l'accueil sans probléme plusieurs fois ???

si oui c'est bien chez moi le problème yikes

Dernière modification par lagrenouille (11-11-2016 11:04:16)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#17 11-11-2016 11:06:38

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : résolu: adresse sur auto-hebergement

Oui sans probleme smile , je vais refaire un essaie
lit mon post au dessus j'ai ajouté des choses
le contenu de ton resolv.conf peut etre aussi du serveur

Dernière modification par robert2a (11-11-2016 11:10:12)

Hors ligne

#18 11-11-2016 11:14:59

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

sur mon serveur


cat /etc/resolv.conf
# Generated by NetworkManager
search home
nameserver 192.168.1.1

cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

normal en dhcp
c'est le fichier updatedns.py  qui fait le boulot d'aller chercher  les IP Gandi



là j'ai un peu fait le tour de mes savoirs, suis coincé
besoin de réfléchir ?????

Dernière modification par lagrenouille (11-11-2016 11:16:47)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#19 11-11-2016 11:19:52

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : résolu: adresse sur auto-hebergement

tous fonctionne , a part les fonds d'écran ou la page a l'air trés lourde  cool
je n arrive pas a ping ton nom de domaine et ton IP (109.222.221.81 ) , peut etre normal si bloqué par la config

pour "updatedns.py" je connais pas faudra quelqu un de plus performant que moi tongue  wink

nota: donc tu a une IP réservé dans ta box pour ton serveur (ça pose pas probleme , fonctionne aussi trés bien )

pour ceci :


# Generated by NetworkManager
search home  =>  la je comprends pas
nameserver 192.168.1.1 => je verrai l IP du DNS de ton FAI (ou un DNS externe )
 

Dernière modification par robert2a (11-11-2016 11:33:50)

Hors ligne

#20 11-11-2016 12:42:36

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

je vais essayer une chose momentanément

nano /etc/resolv.conf

# Generated by NetworkManager
search home
nameserver 8.8.8.8
nameserver 192.168.1.1


et je vais refaire dig

pour le site c'est
404 - Not Found

pour le dig ce serait bon

dig funambule.chezlagrenouille.fr

; <<>> DiG 9.9.5-9+deb8u8-Debian <<>> funambule.chezlagrenouille.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21868
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;funambule.chezlagrenouille.fr.    IN    A

;; ANSWER SECTION:
funambule.chezlagrenouille.fr. 10731 IN    CNAME    monnuage.chezlagrenouille.fr.
monnuage.chezlagrenouille.fr. 231 IN    A    109.222.221.81

;; Query time: 57 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Nov 11 11:52:26 CET 2016
;; MSG SIZE  rcvd: 97


PAS BON de mettre les dns google
error
404 no foud

Dernière modification par lagrenouille (11-11-2016 13:13:09)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#21 11-11-2016 14:16:22

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

comme je pipe pas ce qui se passe

je suis allé dans les préférences de iceweasel sur le serveur et sur mon ordi bureau
et
j'ai viré toutes les lignes où il y avait localhost

j'ai de suite après accès au site

combien de temps ????


5 MINUTES big_smile
ça me les brises

bon vais débrancher et rebrancher la box
si elle garde des erreurs ça va les virées
et relancer le script à la main pour récupérer une la nouvelle IP

ça tient 3 à 5 minutes
puis la box

je suis presque à me demander si je laisse tomber ???



old_geek.gif

Dernière modification par lagrenouille (11-11-2016 15:01:17)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#22 11-11-2016 16:29:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : résolu: adresse sur auto-hebergement

tu utilise network-manager (configuration auto ) tongue  , attend des conseils plus averti , je suis pas un référence en la matiere  wink
ton site distant fonctionne bien , un peu de patience et tu va trouver ou ça coince

nota: pour moi non plus plus de réponse de => funambule.chezlagrenouille.fr
avec firefox hmm

Dernière modification par robert2a (11-11-2016 16:34:31)

Hors ligne

#23 11-11-2016 17:28:51

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

sous le conseil d'une personne

je viens de mettre ça dans
/etc/resolv.conf

192.168.1.13 funambule.chezlagrenouile.fr monnuage.chezlagrenouille.fr.



sur le serveur et sur mon ordi

ça remarche pour l’instant ...... et combien de temps ???

hum ! pas toujours
comme dans la chanson

ca s'en va et ça revient ♫ ♪ ♬ ♪ ♩ ♬ ♪ ♫ ♫ ♪ ♬

help.gif

BASTA ! PAS TROUVÉ LA SOLUTION !

Dernière modification par lagrenouille (11-11-2016 21:43:08)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#24 12-11-2016 00:53:13

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : résolu: adresse sur auto-hebergement

je reste donc avec l'adresse

http://monnuage.chezlagrenouille.fr/funambule

Il y a peut-être une façon de rediriger sur un autre nom, mais je n'y suis pas arrivé
et je ne fais plus d'essais............moi j'ai pas trouvé

debian.png

Article ici :
http://monnuage.chezlagrenouille.fr/fun … ?article20

Dernière modification par lagrenouille (12-11-2016 02:26:25)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

Pied de page des forums