Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-07-2009 12:39:28

Charles85
Membre
Inscription : 15-07-2009

[résolu]Clavier QWERTY au lieu d'AZERTY sous Lenny Gnome - 2

Bonjour
J'ai le même problème que totom7 (cf post avec le même titre)

- J'ai fait la manip dans système/préférence/clavier/agencement
Je n'ai qu'un seul clavier, France
Quand je teste les réglages dans la fenêtre, cela fonctionne

- J'ai fait la manip dans dpkg-reconfigure console-data
choisir un codage clavier pour votre architecture
azerty
french
with euro (latin 9)

Résultat
- Dans une console, j'ai un clavier azerty
- Idem sous gnome
- Il n'y a que lors de la saisie du nom de l'utilisateur et du mot de passe que j'ai le clavier qwerty

Merci

Dernière modification par Charles85 (16-07-2009 13:56:53)

Hors ligne

#2 15-07-2009 19:07:02

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [résolu]Clavier QWERTY au lieu d'AZERTY sous Lenny Gnome - 2

Bonjour,

Est-ce que c'est hal et dbus qui gèrent les périphériques d'entrée ? Si oui, il faut copier le fichier fdi qui est sous /usr quelque chose, vers /etc/hal

/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi

vers :
/etc/hal/fdi/policy/10-keymap.fdi

et dedans modifier:
   <merge key="input.xkb.layout" type="string">us</merge>

en
  <merge key="input.xkb.layout" type="string">us</merge>


(Si le problème vient de là... sinon, je crois que je ne sais pas)

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#3 15-07-2009 19:55:30

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu]Clavier QWERTY au lieu d'AZERTY sous Lenny Gnome - 2

Yop ! Melodie...

Les deux lignes à modifier sont semblables :

et dedans modifier:
   <merge key="input.xkb.layout" type="string">us</merge>

en
  <merge key="input.xkb.layout" type="string">us</merge>


Peut-être mettre fr à la place de us ?

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 15-07-2009 21:26:52

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [résolu]Clavier QWERTY au lieu d'AZERTY sous Lenny Gnome - 2

J'ai eu le problème en installant une Lenny nouvelle cuvée dernièrement. Le fichier /etc/X11/xorg.conf étant vide après l'installation, j'ai dû y remettre quelques lignes, et notamment pour le clavier français :

Section "InputDevice"
      Identifier      "Generic Keyboard"
      Driver          "kbd"
      Option          "XkbRules"        "xorg"
      Option          "XkbModel"        "pc105"
      Option          "XkbLayout"       "fr"
      Option          "XkbVariant"      "latin9"
EndSection


En remettant le clavier par défaut dans Gnome (Système > Préférences > Clavier > Agencement), ça fonctionne impeccable.


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#5 16-07-2009 13:56:04

Charles85
Membre
Inscription : 15-07-2009

Re : [résolu]Clavier QWERTY au lieu d'AZERTY sous Lenny Gnome - 2

Merci à tous !
Cela fonctionne à merveille.

Par contre, je ne sais pas quelle est la "bonne" solution :

1 - j'ai commencé par celle de mani => ça ne fonctionnait pas (mais je me suis aperçu ensuite que j'avais oublié de relancer Xserver)

2 - j'ai ensuite fait celle de Melodie avec le fr de smolski => ça fonctionne (mais j'ai relancé xserver)

Encore Merci

Hors ligne

#6 16-07-2009 14:31:05

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu]Clavier QWERTY au lieu d'AZERTY sous Lenny Gnome - 2

Allez... Deux fois vaut mieux qu'une, merci de ton retour Charles85...

Yop ! big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 31-07-2009 18:05:42

laurent27
Membre
Inscription : 31-07-2009

Re : [résolu]Clavier QWERTY au lieu d'AZERTY sous Lenny Gnome - 2

Bonjour à tous,
Pour compléter ce sujet : c'est la piste de xorg.conf, donnée par Mani, qui est la bonne solution. La première n'a pas d'effet.
Merci à tous : mon clavier est désormais un bel azerty !

Hors ligne

Pied de page des forums