Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-11-2016 21:08:28

amaury-guy
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon
Inscription : 15-11-2016

[Débutant] [Installation Cockatrix] dépendances non satisfaites

Bonjour à tous !!

Je viens d'installer debian jessie (ravi de trouver une communauté active) auquel j'ai fait un

apt-get upgrade



... qui s'est bien passé.

En revanche, deux paquets me posent problème: je demande:

apt-get install libqt5svg5-dev qtmultimedia5-dev



qui me renvoie:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 gsettings-desktop-schemas : Casse: gnome-settings-daemon (< 3.19.92) mais 3.14.2-3 devra être installé
                             Casse: mutter (< 3.19.92) mais 3.14.4-1~deb8u1 devra être installé
 gstreamer1.0-plugins-base : Casse: gstreamer1.0-plugins-bad (< 1.7.90) mais 1.4.4-2.1+b1 devra être installé
 libgstreamer-plugins-base1.0-0 : Casse: gstreamer1.0-plugins-bad (< 1.7.1) mais 1.4.4-2.1+b1 devra être installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
 



Ainsi que:

apt-get -t jessie-backports install cmake

après avoir modifié mon source.list et un update (voi ci-dessous)

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 cmake : Dépend: libjsoncpp0 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



Mon source list:


#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 DVD Binary-1 20160917-14:25]/ jessie contrib main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 DVD Binary-1 20160917-14:25]/ jessie contrib main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 DVD Binary-2 20160917-14:25]/ jessie contrib main

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

deb http://ftp.us.debian.org/debian/ stretch main contrib
deb-src http://ftp.us.debian.org/debian/ stretch main contrib

deb http://ftp.debian.org/debian jessie-backports main

# jessie-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb http://ftp.debian.org/debian/ jessie-updates main contrib
# deb-src http://ftp.debian.org/debian/ jessie-updates main contrib
 



J'essaie de trouver ces paquets, le terminal me renvoie que la commande est non valide.

J'ai quand même l'impression que ce logiciel, aussi sympa soit il, a quand même l'air super relou à installer hmm

Merci de vos réponses en tout cas.

Hors ligne

#2 15-11-2016 22:35:21

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Débutant] [Installation Cockatrix] dépendances non satisfaites

Bonjour et Bienvenue smile

Tu as un sources.list problématique, sans dépôts principaux de Jessie, mais avec ceux de Stretch (donc, Debian Testing) hmm Avec un tel sources.list, tu vas te retrouver (si ce n'est déjà fait) en Testing.

Un sources.list proche de celui que tu sembles souhaiter (Jessie avec les backports), c'est comme ça https://debian-facile.org/doc:systeme:a … -backports wink Si tu ne veux pas compiler, les sources (les entrées qui commance par deb-src) ne sont pas nécessaires smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 16-11-2016 00:54:45

amaury-guy
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon
Inscription : 15-11-2016

Re : [Débutant] [Installation Cockatrix] dépendances non satisfaites

merci bendia,

J'ai réussi à installer mon locigiel, je n'ai pas l'air d'être passé en testing.

^^

Hors ligne

#4 16-11-2016 08:57:01

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Débutant] [Installation Cockatrix] dépendances non satisfaites

Cool smile

Supprime bien l'entrée stretch de ton sources.list pour que ça ne se produise pas sans que tu le souhaites wink

Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

Pied de page des forums