Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 10-12-2016 08:35:27

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Bonjour
le driver nvidia nonfree passe a la version 375.20-4 (au lieu de 367.57-2) sur stretch
je pense que ça va etre la version définitive de stretch stable (hors backports )
mise a jour des serveurs-xorg-video-xxx
ça peut  résoudre tes soucis  hmm
il manque le dernier noyau 4.10

ps: avec les dernieres versions de windows , j'ai des problemes avec les drivers nvidia .

je teste la derniere version du driver , la ligne "building" dure environ 5 a 10 mn selon la machine


Paramétrage de nvidia-kernel-dkms (375.20-4) ...
Loading new nvidia-current-375.20 DKMS files...
Building for 4.8.0-1-amd64
Building initial module for 4.8.0-1-amd64          => ici tu compile ton driver (assez long )
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.8.0-1-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.8.0-1-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.8.0-1-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.8.0-1-amd64/updates/dkms/

depmod...

DKMS: install completed.           => ça a l air correct
Paramétrage de libnvidia-ml1:amd64 (375.20-4) ...
Paramétrage de libgles-nvidia1:amd64 (375.20-4) ...
Paramétrage de nvidia-driver-bin (375.20-4) ...
Paramétrage de libgl1-glvnd-nvidia-glx:amd64 (375.20-4) ...
Paramétrage de libglx-nvidia0:amd64 (375.20-4) ...
Paramétrage de nvidia-vulkan-icd:amd64 (375.20-4) ...
Paramétrage de nvidia-egl-icd:amd64 (375.20-4) ...
Paramétrage de nvidia-smi (375.20-4) ...
Paramétrage de libgl1-nvidia-glvnd-glx:amd64 (375.20-4) ...
Paramétrage de nvidia-driver-libs:amd64 (375.20-4) ...
Paramétrage de nvidia-driver (375.20-4) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-7) ...
Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.7.4) ...
Traitement des actions différées (« triggers ») pour update-glx (0.7.4) ...
Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.7.4) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-7) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.125) ...
update-initramfs: Generating /boot/initrd.img-4.8.0-1-amd64        => tu crée la nouvelle image que grub va charger au démarrage
 



bon j ai testé le driver ça fonctionne pas (meme souci qu avec windows )
je compte sur toi Guppy88 pour tester blender et ce driver (avec cuda ) voir si tout est correct
nota: je pense que c est mon application qui est un tantinet trop ancienne et plus compatible avec les nouveaux drivers .
faut que je trouve moyen de bloquer les paquets dans leurs versions
sinon le driver fonctionne , pas testé steam mais je pense que cela doit etre correct

Dernière modification par robert2a (10-12-2016 10:16:21)

Hors ligne

#27 10-12-2016 12:22:39

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Bien j'ai essayéd'installer le driver porpriétaire avec le .run. Ll"intall nvidia m'indique une erreur  il me manque encore quelque chose.
Dans le installer-nvidia log j'ai par exemple cette ligne.
/tmp/selfgz9177/NVIDIA-Linux-x86_64-375.20/kernel/nvidia/nv-frontend.c:1:0: error: code model kernel does not support PIC mode . Je ne sais pas ce que c'est ce PIC mode
Au cas où cela aurait un rapport avec le server XORg, je précise que j'ai pourtant bien fait "service lightdm stop" et je me suis retrouvé avec un écran noir, oùj'ai ouvert une console, pour lancer le .rUn la procédure se déroule rapidement jusqu'à la fin Mais il me manque quelque choseerforming the step: Building kernel modules"

Je te mets un morceau du nvidia-installer.log parceque je n'ai pas été fichu de trouver comment tout mettre avec un ascenseur

/usr/src/linux-headers-4.8.0-1-common/scripts/Makefile.build:294 : la recette pour la cible « /tmp/selfgz9177/NVIDIA-Linux-x86_64-375.20/kernel/nvidia-drm/nvidia-drm-linux.o » a échouée
make[3]: *** [/tmp/selfgz9177/NVIDIA-Linux-x86_64-375.20/kernel/nvidia-drm/nvidia-drm-linux.o] Erreur 1
/usr/src/linux-headers-4.8.0-1-common/scripts/Makefile.build:294 : la recette pour la cible « /tmp/selfgz9177/NVIDIA-Linux-x86_64-375.20/kernel/nvidia-drm/nv-pci-table.o » a échouée
make[3]: *** [/tmp/selfgz9177/NVIDIA-Linux-x86_64-375.20/kernel/nvidia-drm/nv-pci-table.o] Erreur 1
make[3]: La cible « __build » n'a pas été refabriquée à cause d'erreurs.
/usr/src/linux-headers-4.8.0-1-common/Makefile:1488 : la recette pour la cible « _module_/tmp/selfgz9177/NVIDIA-Linux-x86_64-375.20/kernel » a échouée
make[2]: *** [_module_/tmp/selfgz9177/NVIDIA-Linux-x86_64-375.20/kernel] Erreur 2
make[2]: La cible « modules » n'a pas été refabriquée à cause d'erreurs.
make[2] : on quitte le répertoire « /usr/src/linux-headers-4.8.0-1-amd64 »
Makefile:150 : la recette pour la cible « sub-make » a échouée
make[1]: *** [sub-make] Erreur 2
make[1]: La cible « modules » n'a pas été refabriquée à cause d'erreurs.
make[1] : on quitte le répertoire « /usr/src/linux-headers-4.8.0-1-common »
Makefile:81 : la recette pour la cible « modules » a échouée
make: *** [modules] Erreur 2
ERROR: The nvidia kernel module was not created.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at [url=http://www.nvidia.com]www.nvidia.com[/url].


Guppy

Actuellement après avoir purgé mes précédetns essais d'installation, j'ai quité le mode 1920X1080 avec l'écran samsung qui était détecté, pour un écran par défault en 1724X768
La taille est bonne mais l'écran est trouble. Et il n'ya pas de détection d'écran, ni de résolution supérieure possible.

Dernière modification par Guppy88 (10-12-2016 12:44:26)

Hors ligne

#28 10-12-2016 12:28:35

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu]Pb Installation de stretch alpha 8

Guppy88, Messages : 360 et tu n'utilises toujours pas les balises du forum pour aider à la lecture des commandes et retours que tu publies !
Le tuto pour tout expliquer est là :
Voir le tuto : Le code, ça pique moins les yeux en couleur

Si tu as un problème pour le comprendre, indique-nous sur quel point et nous l'améliorerons ainsi pour tous.

Amitié, joel smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#29 10-12-2016 12:43:12

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

il y a un nouveau driver ce matin dans les dépots debian , tu veut pas l essayer ?
je t ai donné ce que tu devrais obtenir dans le log de l installation
le driver du site nvidia me donne des boutons tongue

ps: j ai perdu une machine en stretch , a part de la passer en jessie + backports je vois pas comment retrouvé mon driver 367 (j ai tenté de le récupérer dans les backports mais avec stretch ça coince )
par contre il fonctionne trés bien , je poste depuis cette machine. (j ai le meme probleme sous win donc ce n est pas un probleme driver + cuda mais mon application qui n est plus compatible )

Dernière modification par robert2a (10-12-2016 12:43:40)

Hors ligne

#30 10-12-2016 13:04:41

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

smolski a écrit :

Guppy88, Messages : 360 et tu n'utilises toujours pas les balises du forum pour aider à la lecture des commandes et retours que tu publies !
Le tuto pour tout expliquer est là :
Voir le tuto : Le code, ça pique moins les yeux en couleur

Si tu as un problème pour le comprendre, indique-nous sur quel point et nous l'améliorerons ainsi pour tous.

Amitié, joel smile



@ Smolsky
J'ai expliqué que je ne savais pas comment faire (au moins 4 fois) si je tape

simplement "[code] Mon texte [/code]"

au lieu d'un ascenseur vertical il ya un ascenseur horizontal, comme tu peux le constater sur mon précédent post que j'ai modifié après ton interventtion..
ce qui ne convient pas avecun texte de deux cent lignes, donc je n'ai pas la solution et je ne la trouve pas dans le tuto.

@robert2a, si je vais télécharger le dernier driver nvidia.
Ce qui m'inquiètes un peu, c'est que tu me dis  que la construction du module prend environ 5 mn, chez moi  l'excécution de la commande dure seulement quelques secondes pour passer des lignes de points à l'affichage graphique, ensuite il enchaine les écrans aussi vite que je clique sur OK , la barre verte avec l'affichage construction se déroule jusqu'à 100% en moins de 10 secondes et tout de suite après vient le panneau avec le message ERROR.

Mais je télécharge le dernier driver de ce matin et je te tiens au courant

Dernière modification par Guppy88 (10-12-2016 13:08:29)

Hors ligne

#31 10-12-2016 13:12:48

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

ma premiere impression est toujours la bonne wink
a mon avis la compilation du noyau se passe mal
j ai du ssd en disque , la compilation ne l utilise pas donc toujours aussi long
je pense meme que un dual xeon n est pas plus rapide qu un gros processeur intel genre I7 (la mémoire ne change pas grand chose non plus )
mais bon je suis pas spécialiste dans la compilation , juste que mon bi xeon est aussi long que mon I7 pour le faire (le premier a 24 thread , le second 8 seulement )

Hors ligne

#32 10-12-2016 13:27:59

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Je ne trouve pas la version  375.20-4 , sur le site nvidia, je n'ai trouvé que la 375.20 du 18.11.2016. C'est à dire celle que j'ai essayé ce matin.

Hors ligne

#33 10-12-2016 13:47:14

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

je te parle sur debian , ce matin le driver est passé a la version 375  tongue

Hors ligne

#34 10-12-2016 14:31:47

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu]Pb Installation de stretch alpha 8

@Guppy88 Je comprends ton attente mais bon, c'est codé comme ça dans le forum et il est nécessaire de faire avec, à moins de proposer le recodage fait par soi-même bien sûr. DF est un site d'entraide collaboratif ouvert à tous, collaboratif parce que les posts sont sensés servir à tous et non pas à résoudre seulement des cas individuels, d'une manière individuelle et qui comptent demeurer tels.

Pour ma part, sans les balises, je ne peux lire sans fatigue excessive tes indications, j'imagine que je ne dois pas être le seul...

Amicalement, Joel smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#35 10-12-2016 14:33:32

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Bien, j'ai donc relancé la commande

 nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-s(uname-r)


et au reboot j'obtiens ceci.
captur11.jpg
Donc cela semble réussi (en moins de deux minutes (de 13h07 à 13h09)
Sauf que tu vois la taille de la police qu'utilise mate.
C'est la même chose que la dernière fois et donc c'est peut être un problème à régler avec mate et surtout je pense maintenant que le driver nvidia s'était déjà installé lors de mes précédentes tentatives. Mais pas complétement.
Car ce qui est nouveau c'est que j'obtiens le panneau  Nvidia xserver settings avec Système-> centre de contrôle.
La version de ce matin dans les paquets Debian semble donc bien s'installer.

Mais... je n'ai toujours pas l'option GPu dans Blender.
Et il me reste à régler le problème de la taille des polices utilsées par mate.
A moins que mainteant je puisse installer Gnome...mais prudence.

Guppy

Hors ligne

#36 10-12-2016 14:36:24

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

smolski a écrit :

@Guppy88 Je comprends ton attente mais bon, c'est codé comme ça dans le forum et il est nécessaire de faire avec, à moins de proposer le recodage fait par soi-même bien sûr. DF est un site d'entraide collaboratif ouvert à tous, collaboratif parce que les posts sont sensés servir à tous et non pas à résoudre seulement des cas individuels, d'une manière individuelle et qui comptent demeurer tels.

Pour ma part, sans les balises, je ne peux lire sans fatigue excessive tes indications, j'imagine que je ne dois pas être le seul...

Amicalement, Joel smile


Ben oui mais comment fait robert2a pour publier ses textes longs avec un ascenseur à droite, s'il y arrive je devrais pouvoir le faire aussi, si je savais comment.
Guppy

Hors ligne

#37 10-12-2016 14:38:34

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu]Pb Installation de stretch alpha 8

C'est le nombre de lignes dépassant une certaine quantité qui provoque l'ascenseur montant/descendant.

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#38 10-12-2016 14:47:07

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Si on me dit rien comment je peux savoir ?  t'auras pas de chocolat na!
Guppy

Hors ligne

#39 10-12-2016 15:36:36

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

peut tu modifier la résolution de l ecran dans mate ?
ps: dans le bon sens bien sur , avoir des caractères moins gros tongue

nota: je vois que tu a le matou sur le dos tongue miouuuuu  lol

Dernière modification par robert2a (10-12-2016 15:39:07)

Hors ligne

#40 10-12-2016 16:03:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu]Pb Installation de stretch alpha 8

Moi ? J'ronronne juste.... black_cat_2.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#41 10-12-2016 16:37:32

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Ce n'est pas un poblème de résolution d'écran, il est bien en 1920X1080 ; mais bien un problème spécifique à Mate.

En Allant dans Système->Centre de contrôle->Préférences->Apparence->Police, on constate que malgré leur différence de taille à l'affichage, toutes les polices de Mate sont à 10 alors que dans le titre des fenêtres  ou sur le bureau la police parait être au moins en taille 40.
J'ai donc modifié la taille de police des titres de fenêtre et de l'affichage sur le bureau en le réduisant à 3 seulement, cela devrait être pratiquement illisible, mais ça réduit seulement l'afichage à une taille correcte équivalente à la police 10 dans les autres parties des fenêtres.

Voilà ma stretch commence à être fonctionnelle, reste plus que le poroblème de pilotage du GPU et CUDA pour avoir un Blender qui fonctionneavec toutes ses capacités
Guppy

Hors ligne

#42 10-12-2016 17:09:23

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

pas convaincu  hmm , si ton driver est bien installé gnome + gdm3 fonctionne et je ne suis pas convaincu que cela soit le cas roll
mate n a aucun problème de police je le saurai smile
pour cuda il faut l installer après le driver , et si il ne fonctionne pas , ça confirme que tu a toujours un problème de driver .

Dernière modification par robert2a (10-12-2016 17:10:26)

Hors ligne

#43 10-12-2016 19:56:24

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Voilà en image ce que je t'explique
police10.png
Partout ailleurs la taille de police à 10 est correcte.
Enfin pour linstant je ne fonctionne qu'avec Mate, je n'ai pas installé gnome ni gdm3.

Pour la partie GPu bien qu'elle apparaisse dans nvididia settings, cela n'a aucun effet sur Blender qui ne voit pas cette fonction.

Hors ligne

#44 10-12-2016 20:30:46

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Pour Blender il faut tester avec les derniers drivers nvidia sur windows ou debian voir si il fonctionne toujours avec cuda.
Pour Amd pas de soucis c est OpenGL , enfin je suppose roll
Pour le driver en 367 je n ai aucun soucis avec gnome ou Mate , juste il faut que je verrouille les mises a jours pour ne pas passer en 375 (j ai marqué les paquets en "garder en l état" avec synaptic )
me redonner un extrait du log du Xorg.0.log , mais je pense toujours a un problème de drivers
que retourne cette commande


journalctl -r -p err
 


sur le log que tu a déja posté je trouve rien d' anormal , installe "gnome + gdm3" je pense que c 'est la seule solution pour comprendre ce qu il se passe .
ps: tu a pas mit l ascenseur sur ce log encore  wink   (en post #19 )

petite question , blender n utilise que OpenGL ?  (pas cuda )
et ou tu vois la prise en charge du gpu ?

dans les préférences => systeme => j ai "none" ou "cuda"

si je choisi "cuda" il me propose ma carte installé "GTX750 TI" , mais c est une usine ce logiciel et tout en anglais hmm

Dernière modification par robert2a (10-12-2016 21:07:07)

Hors ligne

#45 10-12-2016 21:44:04

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Pour blender tu vas dans préférences ->system et tu coches "cuda"
Ensuite c'est dans le panneau  Properties à droite, tu as  le bouton "render" avec un petit appareil photo, en dessous il y a display et encore en dessous "features set",
Je viens de vérifier, c'est en dessous de features dislay  dans "Device" que tu trouves l'ooption CPU et GPU Compute
u appuies sur le bouton et tu dois voir GPU et CPU c'est là que tu choisis GPU Compute. Tu n'as alors plus à te préoccuper de ta carte, Blender va l'utiliser tout seul comme un grand, et ça fonctionne très bien sous Jessie avec la même carte graphique et le précédent driver auquel jen'ai pas touché.
Autre chose, pour voir cette option il faut également avoir choisi "Cycles render "

Je ne dispose pas de cette option dans mon installation actuelle sous Stretch, parce que dans System ->préférences de Blender je n'ai que -> none.
Il faudrait peut être poursuivre cette partie sous un autre post relatif à Blender.
Si tu ne saisis pas je te ferai des copies d'écrans sous Jessie.

Guppy


journalctl -r -p err



Logs begin at Sat 2016-12-10 13:10:48 CET, end at Sat 2016-12-10 20:59:17 CET. --
déc. 10 13:11:20 Guppy-PC pulseaudio[1095]: [pulseaudio] pid.c: Daemon already running.
déc. 10 13:11:20 Guppy-PC pulseaudio[1087]: [pulseaudio] pid.c: Daemon already running.
déc. 10 13:10:50 Guppy-PC kernel: sd 7:0:0:0: [sdd] Assuming drive cache: write through
déc. 10 13:10:50 Guppy-PC kernel: sd 7:0:0:0: [sdd] Asking for cache data failed
déc. 10 13:10:49 Guppy-PC kernel: sd 6:0:0:0: [sdc] Assuming drive cache: write through
déc. 10 13:10:49 Guppy-PC kernel: sd 6:0:0:0: [sdc] No Caching mode page found
 

Dernière modification par Guppy88 (10-12-2016 23:36:44)

Hors ligne

#46 11-12-2016 07:48:51

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Bonjour
dans mate => systeme=>preferences=>apparence =>polices=>details=>"résolution 92 points par pouces"

j'ai la meme valeur sur un écran 19 ou un 27  (mode : lissage sous pixel lcd )

ps: journalctl ne renvoie rien d important

je suis allez sur le site nvidia la derniere version disponible est la 375.20 , donc la meme que sur les dépots debian.
il signale 2 bugs
je me pose la question de revenir en arriere , jessie + backports , le noyau 4.7 et le driver 367 posent moins de problème.
j ai juste un souci avec le cuda des backports qui ne fonctionnait pas a l époque avec le driver . (c est une version 7 il me semble )

Dernière modification par robert2a (11-12-2016 10:18:32)

Hors ligne

#47 11-12-2016 11:24:45

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Bonjour
Dans mate j'ai  => système=>preferences=>apparence =>polices=>details=>"résolution 94 points par pouces" lissage LCD également.

Et ce matin suprise ! La taille de la police de bureau à 3 s'affiche effectivement en tout petit, à peine lisible, bon je la remets à 10 et là elle redevient conforme à sa configuration, je ferme et manipule deux ou trois écrans et à son tour la police des titres de fenêtres s'affiche elle aussi en tout  petit, conformément à sa définition !?! Je l'ai donc remis en 10  elle aussi, et elle s'affiche désormais corectement.
Je n'ai pourtant rien fait entre hier soir et ce matin pour que l'affichage change. A part que Stretch a dormi et s'est réveillé tout frais et dispos, je ne vois pas pourquoi il affiche aujourd'hui les polices dans leur bonne défintion.

Pour les autres difficultés rien n'a changé, mais mon problème n'est pas le même que le tien.

Je rappelle que je suis en dual boot, avec Jessie sur sda et Stretch sur sdb, mon but est seulement d'obtenir un bon fonctionnement de stretch/sid avec toutes ses fonctionnalités, même si je n'y arrive pas ce n'est pas fondamentalement bloquant, il me suffit d'utiliser Jessie, cela prend juste quelques instant pour changer de version.
Et c'est même beaucoup mieux que tout ne fonctionne pas du premier coup parceque j'en apprends bien plus. Par exemple l'installation de ma Stretch alpha4 ne m'a rien appris, tout s'était bien installé et configuré automatiquement avec le Cd net install.

Blender 2.78a fonctionne parfaitement bien avec Jessie pilotée par le driver Nvidia propriètaire installé en .run. Sur cette version je peux choisir l'option cuda dans Blender=>"user préférences" et demander le calcul d'un rendu en GPU en choisisanrt l'option "GPU compute" du panneau "Properties"
Donc, je sais, que sur cet ordinateur, quand tout est bien configuré la carte graphique GTX980 est bien gérée.

Il suffit juste de trouver la bonne configuration sous Strecth ...

et j'ai constaté à l'ouverture de stretch que le logo nvidia s'affiche brièvement au départ. Ce qui voudrait dire que le driver est bien pris en compte, comme je peux le vérifier en allant dans système=>Administration qui m'affiche "paramètres du serveur X Nvidia", que je peux ouvrir cet onglet et aller sur l'onglet GPU où je vois que le "Graphics Processor:" est une Geforce GTX 980 et avec "Display Devices:" que mon écran est un Samsung SyncMaster (DFP-7).
Il ne reste plus qu'à savoir pourqoui cela ne se traduit pas dans le fonctionnement de Blender.

Enfin, je ne peux pas tester ce que cela donne sous W10 ou W7 parceque je n'ai plus d'OS Crimosoft, qu'il n'y en a jamais eu sur cette machine et qu'il n'y en aura probablement jamais, que cela fait environ un an que je n'ai pas ouvert mon ancien ordinateur passé en W10. En réalité plus d'un an, j'ai acheté cette machine le 15 septembre 2015 et depuis je ne me suis servi exclusivement que de Debian depuis, soit Stretch alpha4 (parfait), soit Jessie(au point) et maintenant stretch alpha8 pas encore bien configuré.
Guppy

Dernière modification par Guppy88 (11-12-2016 11:29:35)

Hors ligne

#48 11-12-2016 19:58:01

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Bonsoir

le driver et cuda sont deux choses bien distincte (cuda  c est 70 paquets installées environ ).
si il y a un souci quelque part il ne fonctionnera pas , pour le bug des drivers nvidia 375.xx et 376.xx ça touche OpenMM d'aprés ce que j ai pu lire roll
je n ai aucune idée de quoi a besoin Blender (je vois OpenGL et Cuda dans le menu )
enfin tu peut purger Cuda et le réinstaller proprement avec un rebout en fin d installation .
si le probleme persiste , utiliser une version 367 (de nvidia ou debian ) si le probleme disparait c est bien le bug du driver
pour la taille des polices ça tien du miracle tongue
PS: il me semble que la carte vidéo devrait fonctionner avec Cuda ou OpenGL , le driver prend en compte les 2 modes roll

Hors ligne

#49 12-12-2016 12:54:06

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Bonjour
je t ai fait un petit tuto pour installer une debian avec une carte graphique nvidia moderne (ça fonctionne avec jessie ou stretch )
mise a part qu avec stretch tu n utilise pas les backports  mais la procédure reste la meme .

https://debian-facile.org/viewtopic.php?id=16181

Dernière modification par robert2a (12-12-2016 12:54:43)

Hors ligne

#50 12-12-2016 12:55:24

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Ben, j'avais fait une réponse et croyais l'avoir postée mais elle a disparu!
Donc je recommence, Blender a besoin de CUDA activé dans le panneau User préférences, pour qu'il gère la carte graphique.
Dans le Fil sur Blender j'ai posté un montage en image avec tous les endroit liés , et où tu dois aller pour lancer un rendu Cycles Blender avec GPU compute.

Ce montage est réalisé sous Jessie parce que cela fonctionne bien, ça fonctionnait bien également avec la version alpha_4 de Stretch et le driver nvidia des dépôts de l'époque + Cuda (tout installé avec synaptic), mais plus avec alpha _8.
Le problème semble donc bien venir du driver 375.20. sans oublier mon  incompétence qui  y est certainement pour beaucoup.
Remarque j'ai lu dans un Forum Blender que quelqu'un (plusieurs même) avaient rencontré des difficultés avec les drivers nvidia, lenteur,saccades, voire crash lors de rendu utilisant GPU . La résolution indiquée par le dernier que j'ai vu, consiste en la réinstallation complète de Blender avec le dernier driver pour W10 le 376.19

Guppy

J'ai vu ton tuto qui m'est apparu très clair et très familier aussi, parce que je commence à connaître la procédure par coeur.
Il concerne Jessie, et ne me sers pas parce que sous Jessie la carte est bien gérée, et je peux utiliser le mode GPu pour y faire un rendu.
Ce n'est qu'avec Stretch alpha_8 que je rencontre un problème et la même procédure semble fonctionner mais il continue de manquer quelque chose pour que tout soit vraiment opérationnel.
Merci.

Guppy

Dernière modification par Guppy88 (12-12-2016 13:03:47)

Hors ligne

Pied de page des forums