Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 12-12-2016 13:05:00

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Oui c'est pour cela que je vais basculer en jessie  de nouveau , le noyau 4.7 et le driver 367.xx me convient et le test a été concluant
merci pour la confirmation du bug smile
moi qui crier haut et fort de basculer sur stretch tongue  lol  neutral
sur les 2 win qui me reste (vista et win7 ) je crois que j ai le driver 359 tongue  installé wink

ps: le problème avec stretch c est que j ai tous les versions des paquets bloqués du driver et de cuda et les mises a jours de certains paquets sont impossible sans me casser d autres paquets.
donc ça me pose problème hmm

Dernière modification par robert2a (12-12-2016 13:30:44)

Hors ligne

#52 12-12-2016 13:26:11

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch + Jessie
Noyau : Linux 4.9.0-3-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Oui Stretch était parfait pour moi lors de son installation en alpha_4, tout s'installait sans problème à partir des dépôts Debian, et allait plus vite que Jessie sur bien des points, ce n'est plus le cas aujourd'hui pour les dernières versions.

C'est pour cela que dès le début j'ai choisi d'avoir deux disques pour avoir deux versions à ma disposition. Je continuerai d'essayer  Stretch  et je pense que je vais acheter un troisième disque ssd pour y faire des essais ,et ne pas démolir celle qui fonctionne presque bien en ce moment.
Je regrette...
Si je n'avais rien touché, j'aurais toujours une stretch qui faisait tourner blender en GPU, d'où la nécessité d'avoir un  disque supplémentaire pour y faire les essais et bêtises sans rien casser de ce qui fonctionne.

Guppy

Dernière modification par Guppy88 (12-12-2016 13:34:45)

Hors ligne

#53 12-12-2016 13:38:07

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Pas de soucis pour moi avec l alpha-8 de stretch
installation minimale + bureau léger + drivers propriétaires (carte graphique très récente pas pris en charge par nouveau )
ensuite installation de gnome (si besoin )
si le materiel pris en charge , installation normale sauf que parfois j ai une erreur pendant l installation des logiciels hmm

Dernière modification par robert2a (12-12-2016 13:39:22)

Hors ligne

#54 12-12-2016 13:50:03

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch + Jessie
Noyau : Linux 4.9.0-3-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Quand tu dis pas de soucis pour moi avec l'alpha_8 de Stretch, et les drivers propriétaires tu n'as pas testé une GTX 980 dessus ?
Chez moi aussi tant que je ne demande pas à blender d'utiliser le GPu de la carte graphique au lieu du CPu tout semble fonctionner normalement, le driver Nvidia trouve mon écran et le pilote en 1980X1080, et maintenant que le problème d'affichage des polices sous mate est réglé ( réglé tout seul pendant la nuit) tout semble aller très bien !
Je vais tenter une ré installation de CUDA.
Guppy

Dernière modification par Guppy88 (12-12-2016 14:16:15)

Hors ligne

#55 17-12-2016 14:16:13

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch + Jessie
Noyau : Linux 4.9.0-3-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Après moult tentatives, essais, erreurs et scratchhead.gif
J'ai refait une nouvelle fois l'installation de Cuda, après l'avoir désinstallé complétement.
Le résultat était encore le même, pas de CUDA disponible dans Blender.crash.gif

Totuefoisidea.gif, j'ai fait, enfin!!! le rapprochement avec

d'une part, le fait que blender utilise python et
d'autre part, la liaison avec l'existence dans les paquets Debian d'un fichier appelé python tools, paquet que le métapackage boinc n'installe pas.

J'ai donc demandé à Synaptic de l'installer et cela à focntionné(c'est long et Sybaptic signale en cours de route que certains paquets ne peuvent pas être téléchargés.

J'ai répondu "oui" à la question "faut il continuer ? "et j'ai désormais accès à CUDA dans User preferences=>System de blender et au bouton CUDA.
En le cochant j'obtiens le nom de ma carte graphique Geforce GTX 980 et je peux utiliser le mode GPU dans le moteur de rendu Cycles.

Donc mainteant, j'ai une Jessie fonctionnelle sous Gnome et une Stretch (alpha__) fonctionnelle sous Mate.

uname -a


Linux Guppy-PC 4.8.0-1-amd64 #1 SMP Debian 4.8.7-1 (2016-11-13) x86_64 GNU/Linux



cuda_g10.png

Les deux savent désormais gérer complétement ma carte graphique GTX 980.

Merci à robert2a  pour son aide sans laquelle je n'aurais pas pu franchier tout seul la derniière étape.
Maintenant j'ai une autre question, comment fait on, à part comme moi avec la méthode essais et erreurs, pour connaitre les paquets dont une application à besoin.
La liste des paquets disponibles m'effraie toujours tant les fichiers sont nombreux. Lesquels sont nécessaires, sont utiles, superflus ?
Il reste par exemple dans la liste affcihée par Synaptic avec la recherche CUDA bien des paquets que je n'ai pas installé. ils sont peut ête utiles.
Guppy

Dernière modification par Guppy88 (17-12-2016 14:39:25)

Hors ligne

#56 17-12-2016 16:04:20

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

donc tu a réussi a faire fonctionner Blender avec cuda 8 et le driver 375.xx sur stretch
ce qui confirme ma crainte que mon application n est plus compatible hmm
pour boinc et python je n ai pas tout compris  roll
le paquet nvidia-cuda-toolkit installe ce qui est nécessaire au bon fonctionnement de cuda (soit entre 60 et 70 paquets environ ).
avec synaptic tu peut voir ce qui a été "installé ou pas" sur une recherche => "nvidia"

ps: (mode curieux ) le projet boinc te sert a quoi ?  roll
pour les paquets relatif a python , je ne fait pas d installation particulière (je ne trouve pas de paquet python-tools )

Dernière modification par robert2a (17-12-2016 16:21:02)

Hors ligne

#57 17-12-2016 18:20:25

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch + Jessie
Noyau : Linux 4.9.0-3-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

J'ai trouvé tous les fichiers dans les paquets debian et les ais installés avec Synaptic.CUDA je ne sais quel numéro, mais pour le driver nvidia c'est le 375.20.
J'ai plein de paquets installés, qui apparaissent avec la recherche "nvidia" et "CUDA."

Le paquet  python-pytools ne se trouve pas rangé avec Blender dans la section affichée avec une recherche "python", mais dans les fichiers affichés avec "CUDA"
ce n'est qu'après l'avoir installé que j'ai obtenu un résultat avec Blender
J'ai installé  python-pytools parce que dans "propriétés" il y avait "big bag of things supplementing Python standard library"

Quant à boinc je n'en sais rien, c'est apparemment quand je l'ai installé que ça a fonctionné., mais c'est peut être seulement une coïncidence.
Cela rejoint ma question comment fait on pour savoir de quels paquets on a réellement besoin?

Guppy

PS J'ai enlevé boinc, effectivement il ne sert à rien,  le paquet qui sert est bien Python-pytools.

Dernière modification par Guppy88 (17-12-2016 20:57:28)

Hors ligne

#58 18-12-2016 03:27:24

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Bonsoir
boinc est un ensemble de projet libre dans divers domaines , recherche d ondes radio , planète , etc .... je ne le connais pas (jamais testé ) mais un petit tour sur leur site donne quelques infos.
ils utilisent le cpu ou le gpu
pour le paquet Python-pytools il est inutile pour cuda mais je vai tester avec le driver 375.xx
a titre d info c est le driver qui pose problème pas cuda 8 (mais bon le driver a quand meme quelques paquets cuda 375.xx )


Pytools is a big bag of things that are needed by packages created by
Andreas Kloeckner. They are used by python-pycuda and python-pyopencl
packages. They contain, amongst other:
 * A ton of small tool functions such as len_iterable, argmin, tuple
   generation, permutation generation, ASCII table pretty printing,
   GvR's mokeypatch_xxx() hack, the elusive flatten, and much more
 * A time-series logging module, pytools.log
 * Batch job submission, pytools.batchjob
 * A lexer, pytools.lex
 


il existe 2 paquets python-pycuda et python-pyopencl tu les a installé ?
ps: ces paquets sont peut etre une dépendance de boinc

tu dois avoir une journalisation avec pytools.log , mais je sais pas dans quel dossier .

pour cuda la commande "apt-get install nvidia-cuda-toolkit" installe tout ce que tu a besoin (les dépendances sont respectées ) juste que nvidia a modifié quelque chose dans son driver qui pose problème avec certaines applications.
je pense que blender (au travers de opengl ) doit aussi utiliser opencl et cuda pour le calcul
pour moi l application est bien détecté mais le lancement provoque une erreur . (toi a priori blender ne détecte pas cuda )

Python PyCuda


PyCUDA lets you access Nvidia‘s CUDA parallel computation API from Python.
Several wrappers of the CUDA API already exist–so what’s so special about
PyCUDA?
 * Object cleanup tied to lifetime of objects. This idiom, often called
   RAII in C++, makes it much easier to write correct, leak- and crash-free
   code.  PyCUDA knows about dependencies, too, so (for example) it won’t
   detach from a context before all memory allocated in it is also freed.
 * Convenience. Abstractions like pycuda.driver.SourceModule and
   pycuda.gpuarray.GPUArray make CUDA programming even more convenient than
   with Nvidia’s C-based runtime.
 * Completeness. PyCUDA puts the full power of CUDA’s driver API at your
   disposal, if you wish.
 * Automatic Error Checking. All CUDA errors are automatically translated
   into Python exceptions.
 * Speed. PyCUDA’s base layer is written in C++, so all the niceties
   above are virtually free.
 * Helpful Documentation.
 



PS: j ai testé mais dans mon cas ça ne fonctionne pas , par contre j ai oublié de tester blender (sur le noyau 4.8.0-2 avec le 375.xx)  hmm

Dernière modification par robert2a (18-12-2016 05:20:36)

Hors ligne

#59 19-12-2016 01:39:47

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch + Jessie
Noyau : Linux 4.9.0-3-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

j'ai supprimé python pytools et cela n'a rien changé, Blender  m’affiche toujours cuda et ma carte graphique dans le panneau User préférences.

Alors je ne sais pas pourquoi ça fonctionne. J'ai tenté d'installer Gnome et gdm3,
en tapant

apt-get update

puis

apt-get upgrade


et enfin

apt-get instal gdm3 et gnome


il a téléchargé envirion 1Go de paquets

Au milieu de l'installation il affiché un panneau avec un message m'invitant à choisir entre ligthdm et gdm3 j'ai choisi gdm3,  avec un peu d'appréhension.

Mais à la fin cela fonctionne, au démarrage de la session, si je vais dans les options, je peux choisir entre mate gnome gnome classic et encore une autre option.
Guppy

Dernière modification par Guppy88 (19-12-2016 13:44:46)

Hors ligne

#60 19-12-2016 15:04:21

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Bonjour
si tout va bien sur l installation de debian , gnome fonctionne bien smile  , tu viens de le prouver wink
ps: 1 Go de paquets ne m étonne pas pour gnome tongue

Hors ligne

#61 20-12-2016 13:42:34

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch + Jessie
Noyau : Linux 4.9.0-3-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 07-01-2012

Re : [Résolu]Pb Installation de stretch alpha 8

Oui mais il a fallu passer par l'intermédiaire de Mate pour installer d'abord le driver nvdia.
Et seulement Gnome ensuite.
Donc actuellement, pour installer Gnome sous stretch  il faut passer par mate ou faire une installation minimum, installer le driver nvidia et en dernier gnome.
Guppy

Hors ligne

#62 20-12-2016 20:57:49

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu]Pb Installation de stretch alpha 8

Bonsoir
je teste le dernier driver (sid version 375.26 ) , il fonctionne bien (mais ça résoud pas mon problème )
sur le site nvidia pour windows le  376.33   et pour linux64  375.26 (celui qui est dans les dépots de sid ) cuda reste a la version 8

pour gnome non tu ne passe pas par mate , il te suffit d installer stretch en minimal
puis gnome + gdm3 (ne pas redémarrer ) en console
puis le driver nonfree nvidia toujours en console
a la fin tu peut redémarrer la machine
ça évite d avoir le bug de nouveau + gnome + gdm3  avec ta carte.

ps: blender détecte bien ma carte et je coche cuda , pour moi il n y a pas de soucis avec l utilisation de blender sur ce driver

Dernière modification par robert2a (20-12-2016 21:14:41)

Hors ligne

Pied de page des forums