Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-11-2016 11:50:05

fleger
Membre
Inscription : 17-11-2016

Problème pour Mettre en place un serveur Clonezilla via PXE

Bonjour à tous,

J'ai trouvé ce tutoriel clair et bien fait mais   j'ai un soucis avec un seul point.


Où se trouve le fichier pxelinux.0 que je suis sensé copier dans /srv/tftp.

Je travaille avec une jessie et je ne trouve pas ce fichier  pxelinux.0

Dans /usr/lib/syslinux, il y a 3 dossiers : mbr; memdisk; modules.
les fichiers à copier sont présents dans les 3 dossiers sous dossier : bios, efi32; efi64;

je le prends dans bios mais pas de fichier pxelinux.0

Pouvez-vous m'éclairer?

Merci d'avance

Hors ligne

#2 21-11-2016 13:47:22

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Problème pour Mettre en place un serveur Clonezilla via PXE

Bonjour,
Si tu as installé le paquet pxelinux, ce fichier se trouve dans le dossier /usr/lib/PXELINUX/.
Il me semble que c'est quelque chose qui a changé avec Jessie, je vais mettre le tuto à jour en conséquence.

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#3 21-11-2016 15:33:32

fleger
Membre
Inscription : 17-11-2016

Re : Problème pour Mettre en place un serveur Clonezilla via PXE

Bonjour,

Effectivement en réinstallant une version toute récente de jessie, le fichier pxelinux.0 était présent dans /usr/lib/PXELINUX.

J'ai eu le tort de bosser sur une machine fixe et non pas sur une virtuelle.

J'avance sur le tutoriel et merci pour la réponse rapide..

Francis

Hors ligne

#4 23-11-2016 10:01:06

fleger
Membre
Inscription : 17-11-2016

Re : Problème pour Mettre en place un serveur Clonezilla via PXE

Bonjour,

Tout fonctionne correctement.

Une petite remarque sur les fichiers à copier, j'ai pris ceux dans /usr/lib/syslinux/modules/bios et dans PXELINUX pour pxelinux.0
et pour que le boot pxe fonctionne, il faut rajouter libcom32.c32 libutil.c32

Encore merci pour le tutoriel. Ce n'est pas facile d'être concis quand on fait un tutoriel.

Francis

Hors ligne

#5 23-11-2016 11:44:30

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Problème pour Mettre en place un serveur Clonezilla via PXE

Bonjour,
Je t'en prie, ravi de savoir que cela a pu t'être utile et que c'est fonctionnel.
Merci pour ton retour, j'ai mis à jour le tuto sur la base de tes remarques.

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

Pied de page des forums