Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-12-2016 18:04:02

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

[Résolu] Ligne fstab fait tout planter

Bonjour à tous !
Aujourd'hui, en redémarrant ma Jessie, j'ai été envoyé en emergency mode. J'en suis sorti en commentant une ligne du fichier /etc/fstab, qui n'était pas là au démarrage précédent.

UUID=0A5C31115C297402 /media/ddext fuseblk rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096 0 0



Je ne comprends pas où se trouve le problème :
- l'UUID est bonne, et correspond à un disque dur externe en NTFS
- le chemin /media/ddext existe aussi
- les options sont tout simplement celles de /etc/mtab, lorsque je monte le disque à la main, et je les ai d'ailleurs vérifiées.

J'aimerais pouvoir remettre cette ligne, de telle manière que le disque soit monté automatiquement à chaque démarrage, mais je ne vois pas où il y aurait un problème, bien qu'il doive y en avoir un.

Merci d'avance !

Dernière modification par Lancelot du Lac (08-01-2017 10:03:37)


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#2 02-12-2016 18:07:06

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Ligne fstab fait tout planter

tu peux utiliser

mount -a


ça te permet de tester ton fstab sans redémarrer ta machine

Hors ligne

#3 02-12-2016 19:09:55

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Ligne fstab fait tout planter

Je vois plutôt le type "fuseblk" lorsqu'un système de fichiers est monté par l'environnement de bureau et non par fstab.
Je suggère de le remplacer par "ntfs" ou "ntfs-3g", et d'ajouter "nofail" aux options pour éviter que la même chose se produise quand le disque n'est pas branché.

Hors ligne

#4 03-12-2016 15:12:09

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [Résolu] Ligne fstab fait tout planter

Merci de vos propositions. J'ai modifié la ligne comme suggéré par raleur, et lancé la commande de nlQnutn : ça ne renvoie rien. Je suppose donc qu'il n'y a pas d'erreur ?
Il faudra que j'essaie de rallumer l'ordinateur, mais je ne peux pas le faire avant un bout de temps.
Par curiosité, quelle différence y a-t-il entre 'ntfs' et 'ntfs-3g' ? Pour ma part, j'ai mis la première.

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#5 03-12-2016 15:35:28

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Ligne fstab fait tout planter

Pour vérifier si le montage a réussi, il faut afficher les montages avec mount.

Historiquement "ntfs" est le pilote NTFS interne au noyau (initialement en lecture seule puis en écriture limitée, cf. https://www.kernel.org/doc/Documentatio … s/ntfs.txt), alors que "ntfs-3g" est un pilote NTFS hors du noyau utilisant FUSE. Ce dernier est plus avancé et n'a pas les limitations en écriture du pilote interne du noyau. Mais l'installation de ntfs-3g met en place un lien symbolique /sbin/mount.ntfs qui pointe vers /sbin/mount.ntfs-3g, le monteur pour ntfs-3g. Donc si ntfs-3g est installé, par défaut mount va l'utiliser pour le type de système de fichiers "ntfs". Pour forcer le montage avec le pilote ntfs interne, il faut exécuter mount avec l'option -i ; je ne connais pas l'option équivalente pour fstab, si elle existe.

Hors ligne

#6 08-01-2017 10:03:20

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [Résolu] Ligne fstab fait tout planter

J'ai eu l'occasion de redémarrer ma machine, et je passe donc le sujet en résolu. Merci pour toutes vos réponses qui me font toujours progresser !

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

Pied de page des forums