Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-12-2016 13:33:32

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Mediatheque numerique et pipelight

Ola!

Je viens de découvrir que par l'intermédiaire de ma médiathéque, je peux accéder à la médiathèque numerique http://www.mediatheque-numerique.com qui propose des films en streaming.
Malheureusement, le streaming ne fonctionne pas. Il est évoqué l'installation de pipelight dans le mode d'emploi, ce que cette discussion m'a confirmé : https://forum.ubuntu-fr.org/viewtopic.php?id=1644831.
Bon élève, je regarde dans les forums d'handylinux et banco voilà ce que je trouve : https://handylinux.org/forum/viewtopic.php?id=259
Sauf que ça ne marche plus à partir de là :

louis@handylinux ~
$

sudo apt-get install pipelight-multi



[sudo] mot de passe pour louis :    
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 pipelight-multi : Dépend: wine-staging mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



Est-ce que vous avez une idée du problème rencontré?

Edit à toto :
Mis uniquement la commande user et séparée de son retour, c'est plus lisible ainsi.

Dernière modification par homme mouton (07-12-2016 13:34:02)

Hors ligne

#2 07-12-2016 13:37:52

Trefix
Adhérent(e)
Lieu : 48
Distrib. : kiss0s-0.5
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox by arpinux
Inscription : 15-02-2015

Re : Mediatheque numerique et pipelight

Bonjour.
Tu aurais du d'abord rafraîchir la liste des paquets avec un

apt-get update

Dans ton cas, l'effet "root" s'obtient en appelant Sudo, ce qui donnerait donc une commande du type :
sudo apt-get update && sudo apt-get install ce-que-tu-veux.
Si le problème persiste, des plus barbus que moi t'en diront plus wink


Édith me demande très justement si tu as lu en détail la prose du DYP... et précise que je ne te fais pas les gros yeux pour autant wink

.

Dernière modification par Trefix (07-12-2016 13:48:11)


HL > DF // Les cahiers du débutant // DFLinux
.
JE SUIS toujours abonné à CHARLIE

Hors ligne

#3 07-12-2016 14:02:51

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Mediatheque numerique et pipelight

J'ai effectivement fait le


apt-get update
 



avant la ligne de code de mon premier message. Ta remarque fait bien partie du tuto de DYP. J'ai bien relu le tuto au cas où j'étais passé à côté de quelque chose mais à priori j'ai bien suivi la procédure hmm

Hors ligne

#4 07-12-2016 21:08:32

èfpé
Membre
Inscription : 10-07-2016

Re : Mediatheque numerique et pipelight

Bonsoir,

Outre le fait que le non-tutoriel 'eudypien' date maintenant de 18 mois (oui je sais, le bon vin, toussa), il faut noter que le site officiel de Pipelight mentionne une petite subtilité supplémentaire ; quoi qu'il en soit, le paquet wine-staging existe vraiment, dans le dépôt Pipelight du moins.

Par ailleurs je ne comprends pas trop l'impérieuse nécessité d'installer Pipelight : la FAQ de la Médiathèque Numérique nous parle dans un premier temps de « navigateur compatible avec les standards modernes du Web (HTML5 / CSS3) », puis du « plug-in Flash [...] version 15 ou supérieure » ; pas besoin de ce truc pour installer la version 23 stable ou 24 bêta big_smile

Bref, quelle est la version du Flash Player installé sur ta machine, 11.2.202.644 ? autre ? et quelle est l'architecture ? 32 bits (i386) ou 64 bits (amd64) ?

(Note : oui, j'ai tout bien lu le mode d'emploi, il date de mai 2015.)

Dernière modification par èfpé (07-12-2016 21:24:32)

Hors ligne

#5 07-12-2016 23:30:03

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Mediatheque numerique et pipelight

je vais jeter un coup d'oeil au lien du site de pipelight.

Est-ce que tu pourrais m'indiquer comment trouver les informations demandées stp xD?
En allant bêtement sur https://www.adobe.com/software/flash/about/, ma version de flash serait 11,2,202,635 smile

Hors ligne

#6 07-12-2016 23:44:32

èfpé
Membre
Inscription : 10-07-2016

Re : Mediatheque numerique et pipelight

Re-,

Pour l'architecture de la machine du système installé :

dpkg --print-architecture

devrait retourner dans ton cas :

amd64


edit: alors pour le sport, j'ai reproduit le 'souci' sur une session Live HL 2.5 (amd64) ; les instructions du site officiel sont toujours d'actualité malgré l'existence d'un paquet wine-staging-amd64 dans le dépôt Pipelight roll

sudo dpkg --add-architecture i386 && sudo apt-get update


sudo apt-get install pipelight-multi

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  fontconfig-config gcc-4.9-base:i386 libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libattr1:i386 libav-tools
  libavcodec56 libavcodec56:i386 libavdevice55 libavfilter5 libavformat56 libavresample2 libavresample2:i386 libavutil54
  libavutil54:i386 libc-dev-bin libc6 libc6:i386 libc6-dev libc6-i386 libcap2:i386 libdb5.3:i386 libdbus-1-3:i386
  libdrm2:i386 libexif12:i386 libexpat1:i386 libffi6:i386 libflac8:i386 libfontconfig1 libfontconfig1:i386 libfreetype6:i386
  libgcc1:i386 libgcrypt20 libgcrypt20:i386 libgd3 libgd3:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386
  libglu1-mesa:i386 libgmp10:i386 libgnutls-deb0-28:i386 libgpg-error0:i386 libgphoto2-6:i386 libgphoto2-port10:i386
  libgsm1:i386 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libhogweed2:i386 libice6:i386
  libjack-jackd2-0:i386 libjbig0:i386 libjpeg62-turbo:i386 libjson-c2:i386 liblcms2-2:i386 libldap-2.4-2:i386 libltdl7
  libltdl7:i386 liblzma5:i386 libmp3lame0:i386 libmpg123-0:i386 libncurses5:i386 libnettle4:i386 libogg0:i386
  libopenal1:i386 libopenjpeg5:i386 libopus0:i386 liborc-0.4-0:i386 libp11-kit0:i386 libpam-systemd libpcre3:i386
  libpng12-0:i386 libpulse0:i386 libsamplerate0:i386 libsasl2-2:i386 libsasl2-modules-db:i386 libschroedinger-1.0-0:i386
  libselinux1:i386 libsm6:i386 libsndfile1:i386 libspeex1:i386 libspeexdsp1:i386 libstdc++6:i386 libsystemd0
  libsystemd0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386 libtinfo5:i386 libudev1 libudev1:i386 libusb-1.0-0:i386
  libuuid1:i386 libva1:i386 libvorbis0a:i386 libvorbisenc2:i386 libvpx1:i386 libwrap0:i386 libx11-6:i386 libx11-xcb1:i386
  libx264-142:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
  libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxml2
  libxml2:i386 libxpm4:i386 libxshmfence1:i386 libxtst6:i386 libxvidcore4:i386 libxxf86vm1:i386 mesa-utils systemd
  systemd-sysv udev wine-staging wine-staging-amd64 wine-staging-i386:i386 zlib1g:i386
Paquets suggérés :
  frei0r-plugins glibc-doc glibc-doc:i386 locales:i386 rng-tools rng-tools:i386 libgd-tools libgd-tools:i386 gnutls-bin:i386
  gphoto2:i386 gtkam:i386 libvisual-0.4-plugins:i386 gstreamer-codec-install:i386 gnome-codec-install:i386
  gstreamer1.0-tools:i386 jackd2:i386 libportaudio2:i386 opus-tools:i386 speex:i386 systemd-ui
Paquets recommandés :
  manpages-dev libc6-i686:i386 libgl1-mesa-dri:i386 libgphoto2-l10n:i386 gstreamer1.0-plugins-base:i386 libgpm2:i386
  libsasl2-modules:i386 uuid-runtime:i386 va-driver-all:i386 va-driver:i386 tcpd:i386 xml-core xml-core:i386 libcapi20-3
  libodbc1 libosmesa6 libtxc-dxtn-s2tc0 libcairo2:i386 libcapi20-3:i386 libcups2:i386 libgtk-3-0:i386 libodbc1:i386
  libosmesa6:i386 libpcap0.8:i386 libsane:i386 libtxc-dxtn-s2tc0:i386 libv4l-0:i386 libva-drm1:i386 libva-x11-1:i386
  libxcomposite1:i386 libxcursor1:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386
Les paquets suivants seront ENLEVÉS :
  libavcodec-extra-56
Les NOUVEAUX paquets suivants seront installés :
  gcc-4.9-base:i386 libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libattr1:i386 libavcodec56 libavcodec56:i386
  libavresample2:i386 libavutil54:i386 libc6:i386 libcap2:i386 libdb5.3:i386 libdbus-1-3:i386 libdrm2:i386 libexif12:i386
  libexpat1:i386 libffi6:i386 libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt20:i386 libgd3:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386 libgmp10:i386 libgnutls-deb0-28:i386
  libgpg-error0:i386 libgphoto2-6:i386 libgphoto2-port10:i386 libgsm1:i386 libgstreamer-plugins-base1.0-0:i386
  libgstreamer1.0-0:i386 libhogweed2:i386 libice6:i386 libjack-jackd2-0:i386 libjbig0:i386 libjpeg62-turbo:i386
  libjson-c2:i386 liblcms2-2:i386 libldap-2.4-2:i386 libltdl7:i386 liblzma5:i386 libmp3lame0:i386 libmpg123-0:i386
  libncurses5:i386 libnettle4:i386 libogg0:i386 libopenal1:i386 libopenjpeg5:i386 libopus0:i386 liborc-0.4-0:i386
  libp11-kit0:i386 libpcre3:i386 libpng12-0:i386 libpulse0:i386 libsamplerate0:i386 libsasl2-2:i386 libsasl2-modules-db:i386
  libschroedinger-1.0-0:i386 libselinux1:i386 libsm6:i386 libsndfile1:i386 libspeex1:i386 libspeexdsp1:i386 libstdc++6:i386
  libsystemd0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386 libtinfo5:i386 libudev1:i386 libusb-1.0-0:i386
  libuuid1:i386 libva1:i386 libvorbis0a:i386 libvorbisenc2:i386 libvpx1:i386 libwrap0:i386 libx11-6:i386 libx11-xcb1:i386
  libx264-142:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
  libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxml2:i386
  libxpm4:i386 libxshmfence1:i386 libxtst6:i386 libxvidcore4:i386 libxxf86vm1:i386 mesa-utils pipelight-multi wine-staging
  wine-staging-amd64 wine-staging-i386:i386 zlib1g:i386
Les paquets suivants seront mis à jour :
  fontconfig-config libav-tools libavdevice55 libavfilter5 libavformat56 libavresample2 libavutil54 libc-dev-bin libc6
  libc6-dev libc6-i386 libfontconfig1 libgcrypt20 libgd3 libltdl7 libpam-systemd libsystemd0 libudev1 libxml2 systemd
  systemd-sysv udev
22 mis à jour, 108 nouvellement installés, 1 à enlever et 130 non mis à jour.
Il est nécessaire de prendre 103 Mo dans les archives.
Après cette opération, 468 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] n
Annulation.


Télécharger 100+ MB puis en tartiner 460+ sur le disque (dans la mémoire vive en l'occurrence) m'a semblé un petit peu too much et j'ai mis fin à cette bonne plaisanterie. S'il s'agissait de ma machine il est évident que je commencerais par mettre à niveau le plugin Flash en me basant sur un tuto postérieur à Mathusalem (méthode nIQnutn pour la 24 bêta ou méthode forum pour la 23 stable) ; mais puisqu'il faut créer un compte avant de tester quoi que ce soit, ben j'ai pas testé... s'il y a des DRM dans le coin cela ne fonctionnerait sans doute pas. Bon courage smile

Dernière modification par èfpé (08-12-2016 08:44:32)

Hors ligne

#7 08-12-2016 08:34:30

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Mediatheque numerique et pipelight

Tu as raison, j'ai bien eu un retour "amd 64" suite à ta commande concernant l'architecture du système.

Je vais suivre ton conseil et essayer de mettre à jour flash à jour en premier lieu grâce aux liens que tu m'indiques wink

Merci pour votre temps èfpé et Trefix!!

Hors ligne

#8 08-12-2016 09:42:02

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Mediatheque numerique et pipelight

Pipelight ça doit être à cause des drm on peut visionner le film sur une durée limitée je crois.

Hors ligne

#9 08-12-2016 10:26:32

èfpé
Membre
Inscription : 10-07-2016

Re : Mediatheque numerique et pipelight

@chalu : parfois les choses évoluent... Firefox supporte Google Widevine CDM sur Windows/OS X depuis la version 47 et sur Linux depuis la version 49, du coup le couplet sur le « navigateur compatible avec les standards modernes du Web (HTML5 / CSS3) » alors que Flash est imposé peut éventuellement faire sourire.

(edit: je dois semble-t-il préciser que si cette remarque n'est pas un modèle de niaiserie politiquement correcte, ce n'est pas non plus une attaque personnelle ; bonjour également et bonne continuation.)

@homme mouton : il n'est pas certain que les versions NPAPI (24 bêta) et PPAPI (23 stable) du plugin Flash soient égales face aux fameux DRM (les release notes de la version 23 bêta, au début de la reprise du développement de la version NPAPI pour Linux, y font vaguement allusion).

Dernière modification par èfpé (08-12-2016 19:36:32)

Hors ligne

#10 08-12-2016 10:51:19

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Mediatheque numerique et pipelight

Je ne remets pas en cause tes instructions et commandes pour résoudre le problème du fil et j'ai bien vu que Firefox a une case drm à cocher dans ses paramètres.
Je me contentais d'indiquer que la consigne pipelight pour linux (c'est pas précis ça en fait des distributions avec des navigateurs de différentes versions) etait liée à la gestion des droits et ces instructions ne sont sans doute pas actualisées tous les mois.
Bonne journée.

Dernière modification par chalu (08-12-2016 10:52:49)

Hors ligne

#11 09-12-2016 18:51:01

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Mediatheque numerique et pipelight

Désolé pour le temps de retour et merci à tous pour vos messages.

J'ai essayé d'abord de mettre à jour flash player comme évoqué ici https://debian-facile.org/viewtopic.php … =2#p197056
J'ai été bloqué sur la dernière commande :


 apt-get update && apt-get --no-install-recommends --target-release jessie-backports install browser-plugin-freshplayer-pepperflash
 




Atteint http://repo.handylinux.org jessie InRelease
Atteint http://repos.fds-team.de jessie InRelease                              
Ign http://mozilla.debian.net jessie-backports InRelease                      
Atteint http://mozilla.debian.net jessie-backports Release.gpg                
Atteint http://mozilla.debian.net jessie-backports Release                    
Atteint http://security.debian.org jessie/updates InRelease                    
Atteint http://repo.handylinux.org jessie/main amd64 Packages                  
Ign http://httpredir.debian.org jessie InRelease                              
Atteint http://httpredir.debian.org jessie-updates InRelease                  
Atteint http://repo.handylinux.org jessie/main i386 Packages                  
Atteint http://repos.fds-team.de jessie/main amd64 Packages                    
Atteint http://mozilla.debian.net jessie-backports/firefox-release amd64 Packages
Atteint http://mozilla.debian.net jessie-backports/firefox-release i386 Packages
Atteint http://repos.fds-team.de jessie/main i386 Packages                    
Atteint http://httpredir.debian.org jessie Release.gpg                        
Atteint http://security.debian.org jessie/updates/main amd64 Packages          
Atteint http://security.debian.org jessie/updates/contrib amd64 Packages      
Atteint http://security.debian.org jessie/updates/non-free amd64 Packages      
Atteint http://security.debian.org jessie/updates/main i386 Packages          
Atteint http://security.debian.org jessie/updates/contrib i386 Packages        
Atteint http://security.debian.org jessie/updates/non-free i386 Packages      
Atteint http://httpredir.debian.org jessie Release                            
Atteint http://security.debian.org jessie/updates/contrib Translation-en      
Atteint http://security.debian.org jessie/updates/main Translation-en          
Ign http://repo.handylinux.org jessie/main Translation-fr_FR                  
Atteint http://security.debian.org jessie/updates/non-free Translation-en      
Ign http://mozilla.debian.net jessie-backports/firefox-release Translation-fr_FR
Ign http://repo.handylinux.org jessie/main Translation-fr                      
Ign http://mozilla.debian.net jessie-backports/firefox-release Translation-fr  
Ign http://repo.handylinux.org jessie/main Translation-en                      
Ign http://mozilla.debian.net jessie-backports/firefox-release Translation-en  
Réception de : 1 http://httpredir.debian.org jessie-updates/main amd64 Packages/DiffIndex [6 916 B]
Ign http://repos.fds-team.de jessie/main Translation-fr_FR                    
Ign http://repos.fds-team.de jessie/main Translation-fr                        
Ign http://repos.fds-team.de jessie/main Translation-en                        
Atteint http://httpredir.debian.org jessie-updates/contrib amd64 Packages
Réception de : 2 http://httpredir.debian.org jessie-updates/non-free amd64 Packages/DiffIndex [736 B]
Réception de : 3 http://httpredir.debian.org jessie-updates/main i386 Packages/DiffIndex [6 916 B]
Atteint http://httpredir.debian.org jessie-updates/contrib i386 Packages
Réception de : 4 http://httpredir.debian.org jessie-updates/non-free i386 Packages/DiffIndex [736 B]
Atteint http://httpredir.debian.org jessie-updates/contrib Translation-en
Réception de : 5 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [2 704 B]
Réception de : 6 http://httpredir.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Atteint http://httpredir.debian.org jessie/main amd64 Packages            
Atteint http://httpredir.debian.org jessie/contrib amd64 Packages
Atteint http://httpredir.debian.org jessie/non-free amd64 Packages
Atteint http://httpredir.debian.org jessie/main i386 Packages
Atteint http://httpredir.debian.org jessie/contrib i386 Packages
Atteint http://httpredir.debian.org jessie/non-free i386 Packages
Atteint http://httpredir.debian.org jessie/contrib Translation-en
Atteint http://httpredir.debian.org jessie/main Translation-fr
Atteint http://httpredir.debian.org jessie/main Translation-en
Atteint http://httpredir.debian.org jessie/non-free Translation-en
18,7 ko réceptionnés en 4s (3 779 o/s)
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet browser-plugin-freshplayer-pepperflash
 



(Merci toto je commence à comprendre comment structurer mes messages :D)

Bloqué là, je suis revenu sur la solution pipelight. èfpé a raison j'avais effectivement oublié la première ligne décrite sur le site de pipelight. Donc là, cette fois-ci, tout fonctionne tranquillou pilou, j'active flash, shockwave et silverlight, j'accepte toutes les licences :

root@handylinux:/home/louis#

sudo pipelight-plugin --unlock shockwave


Plugin shockwave is now unlocked



root@handylinux:/home/louis#

sudo pipelight-plugin --enable shockwave


The following modules require a license confirmation before they can be enabled:

[*] Adobe Shockwave Player
  By continuing the installation you agree that you've read and accepted the
  ADOBE SOFTWARE LICENSE AGREEMENT:
  http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/legal/licenses-terms/pdf/Shockwave%2011.0.pdf

  To find out more click here:
  http://get.adobe.com/shockwave

Do you accept the 1 license(s) above? [Y/N] y
Plugin shockwave is now enabled
root@handylinux:/home/louis#


root@handylinux:/home/louis#

sudo pipelight-plugin --unlock flash


ERROR: Additional plugin flash is unknown



root@handylinux:/home/louis#

sudo pipelight-plugin --enable flash


The following modules require a license confirmation before they can be enabled:

[*] Adobe Flash Player
  By continuing the installation you agree that you've read and accepted the
  ADOBE Personal Computer Software License Agreement:
  http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/legal/licenses-terms/pdf/Flash%20Player_11.0.pdf

  To find out more click here:
  http://get.adobe.com/flashplayer

Do you accept the 1 license(s) above? [Y/N] y
Plugin flash is now enabled


root@handylinux:/home/louis#
root@handylinux:/home/louis#

sudo pipelight-plugin --enable silverlight


The following modules require a license confirmation before they can be enabled:

[*] Microsoft Silverlight 5.1
  By continuing the installation you agree that you've read and accepted the
  MICROSOFT SOFTWARE LICENSE TERMS:
  http://go.microsoft.com/fwlink/?LinkId=229303

  Microsoft Silverlight Privacy Statement:
  http://go.microsoft.com/fwlink/?LinkId=229306

  To find out more click here:
  http://www.microsoft.com/silverlight/

[*] mpg2splt.ax
  This library is part of the Microsoft DirectX End-User Runtime.
  By continuing the installation you agree that you've read and accepted the
  Microsoft Software License Terms.
  You can find them in /usr/share/pipelight/licenses/license-mpg2splt.txt

  To find out more click here:
  http://www.microsoft.com/en-us/download/details.aspx?id=35

Do you accept the 2 license(s) above? [Y/N] y

The following modules are marked as optional dependencies:

[*] wininet.dll [OPTIONAL]
  This wininet.dll library is a debug version provided for the Microsoft
  Internet Explorer. By continuing the installation you agree that you've
  read and accepted the license terms.
  You can find them in /usr/share/pipelight/licenses/license-wininet.txt

  To find out more click here:
  http://www.microsoft.com/en-us/download/details.aspx?id=11434

  To agree to this license run (for each user who wants to use this module):
  touch $HOME/.config/wine-wininet-installer.accept-license

Plugin silverlight5.1 is now enabled
 



et là paf, http://www.mediatheque-numerique.com me fait toujours attendre...
7kfXr70CxCfq.png

Résultat? Je suis complètement perdu ;)

Edit à toto :
Mis chaque commande user séparée les unes des autres et séparées aussi de son retour. Les balises du forum, c'est un art que beaucoup nous envient sur le net... ;)

Hors ligne

#12 09-12-2016 19:04:14

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Mediatheque numerique et pipelight

Comment fonctionnent les balises du forum, Y'a un tuto pour :
Voir le tuto : Le code, ça pique moins les yeux en couleur

Voilà un point choco df dans la valise au jojo... big_smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 09-12-2016 19:12:28

èfpé
Membre
Inscription : 10-07-2016

Re : Mediatheque numerique et pipelight

Re-,

Le paquet browser-plugin-freshplayer-pepperflash se trouve dans le dépôt jessie-backports (contrib) or ce dépôt ne figure pas, ou n'est pas activé, dans ton fichier sources.list (cf. lien vers doc). Pour ce qui concerne Pipelight, as-tu appliqué le bon conseil de fiche, sur le forum de Papa ?

edit: je dois semble-t-il préciser que l'emploi du terme Papa n'a rien de péjoratif, pas plus que Maman pour désigner Debian.

Dernière modification par èfpé (09-12-2016 20:04:28)

Hors ligne

#14 09-12-2016 19:22:25

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Mediatheque numerique et pipelight

èfpé a écrit :

sur le forum de Papa ?


scratchhead.gif y a un souci ? si oui à voir en direct plutôt que par sous-entendu sur le forum wink

Edit : Ah non pourquoi ? Je trouve tes interventions supers smile et qui aident bien tous les débutants à évoluer comme moi wink
Mais c'est vrai que sur ce coup, j'interprète pas de la même façon que toi pour le "papa" qui désigne une vraie personne et le maman pour parler de la distribution Debian
Je prends bonne note de mon erreur d'interprétation et tant pis, c'est toujours mieux de clarifier smile

Dernière modification par chalu (09-12-2016 19:48:28)

Hors ligne

#15 09-12-2016 22:10:48

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Mediatheque numerique et pipelight

Didiou j'ai toujours pas bon sur les balises, je vais m'appliquer wink

ça communique plutôt bien sur ce forum ma foi smile

je reviens à mes moutons, je m'énerve moi-même à ne rien comprendre!

pipelight : Autant pour moi, èfpé, j'aurais du prendre le temps de parcourir la discussion jusqu'au bout, je me suis permis d'aller regarder par là aussi https://forum.pcastuces.com/debian___ic … s14566.htm et par là http://pipelight.net/cms/faqs/faq-most- … blems.html.
En suivant les instructions de fiche, j'ai supprimé le flashplugin-nonfree et suivi le reste du tuto. Sauf que c'est toujours raté, avec en prime plus aucun plugin flash dans firefox, quand je tape about:plugins dans le navigateur XD

Pepperflash: je suis resté bloqué sur cette phrase big_smile :

Le paquet browser-plugin-freshplayer-pepperflash se trouve dans le dépôt jessie-backports (contrib) or ce dépôt ne figure pas, ou n'est pas activé, dans ton fichier sources.list (cf. lien vers doc)


Est-ce que tu pourrais me détailler plus précisément ce que je dois faire du paquet stp?

Hors ligne

#16 09-12-2016 22:52:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mediatheque numerique et pipelight

Re-,

Bien sûr que je peux détailler un peu : alors avant de pouvoir installer proprement un paquet issu du dépôt jessie-backports il faut commencer par ajouter la ligne adéquate au fichier /etc/apt/sources.list ; la manip est bien décrite dans la documentation dédiée (cf. éditer/rétroportages), mais si tu préfères nous communiquer le contenu actuel dudit fichier :

cat /etc/apt/sources.list


On pourra te dire très précisément quelle commande exécuter.

Pour ce qui concerne Pipelight as-tu envoyé cette commande :

sudo pipelight-plugin --update


Par ailleurs que retourne :

pipelight-plugin --list-enabled


D'après la FAQ de la MN, tu n'as vraisemblablement besoin que du plugin Flash, et tripatouiller la chaîne User-Agent de ton navigateur ne devrait pas être nécessaire roll

edit: pitite typo

Dernière modification par èfpé (10-12-2016 01:28:22)

Hors ligne

#17 09-12-2016 23:15:32

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Mediatheque numerique et pipelight

re!

Pepperflash:
j'ai pas tout à fait compris à quoi servait ce fichier sources mais je sens qu'il faudra que je me penche dessus un jour smile
voilà le résultat de la commande :

cat /etc/apt/sources.list




##DEBIAN Jessie##
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
#deb-src http://httpredir.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://httpredir.debian.org/debian/ jessie-updates main contrib non-free

#deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free
#deb-src http://ftp.debian.org/debian/ jessie-backports main contrib non-free

###pipelight
deb http://repos.fds-team.de/stable/debian/ jessie main
 



Pipelight:

pipelight-plugin −−list−enabled


silverlight5.0
flash
 


J'ai activé silverlight 5.0 suite à la lecture de ce topic : https://forum.ubuntu-fr.org/viewtopic.php?id=1644831

Plusieurs choses me chiffonnent, c'est peut-être idiot mais :

->fiche parle dans ces discussions de l'apparitions de plugins flash dans about:addons sous firefox, or je n'en ai aucune trace quand je m'acharne avec pipelight.

->comme j'avais supprimé le flashplugin-nonfree tantôt, je me suis dit que je pouvais me pencher sur l'installation de flash de la manière dont c'était décrit sur le site communiqué plus tôt https://blog.niqnutn.com/index.php?arti … er-23-beta.
Bonne nouvelle, le site https://www.adobe.com/fr/software/flash/about/ reconnaît la version 23,0,0,198 et je retrouve bien le plugin dans about:addons.
Mauvaise nouvelle, le streaming ne se lance toujours pas mais je n'ai plus le "sablier" avec écrit "Mise à jour" qu'on retrouve sur ma capture d'écran précédente ...

Hors ligne

#18 09-12-2016 23:38:32

èfpé
Membre
Inscription : 10-07-2016

Re : Mediatheque numerique et pipelight

Re,

Pour le sources.list, on verra plus tard... mais :

pipelight-plugin --list-enabled

silverlight5.0
flash


N'est pas le retour demandé :

pipelight-plugin --list-enabled


J'ai un doute sur la pertinence des droits.

Pour ce qui concerne le plugin Flash natif, il semble que tu as téléchargé une vieille version (19/10/2016) ; la version bêta courante (8/12/2016, lien direct pour ton système) étant la 24.0.0.178 hmm

edit: pitite typo

Dernière modification par èfpé (10-12-2016 01:28:32)

Hors ligne

#19 09-12-2016 23:52:30

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Mediatheque numerique et pipelight

Pas faux, j'ai pas installé la bêta, mais du coup, je m'étais dit que ça réglait peut-être le problème du plugin Flash version 15 ou supérieure demandée par médiathèque numérique dans sa FAQ hmm

Je n'avais pas saisi, qu'il y aurait une nuance entre la commande en root ou en user XD, du coup je l'avais lancé en user, mais comme j'ai eu le retour ci-dessous, je t'ai envoyé la réponse à la commande en root :

pipelight-plugin −−list−enabled


ERROR: Unknown argument −−list−enabled.



Je vais au plumard, mon rhume a raison de moi, je reprendrais demain, merci encore pour ton aide smile

Hors ligne

#20 10-12-2016 01:08:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mediatheque numerique et pipelight

Bon'nuit smile

Officiellement, il n'existe pas encore de version 23 NPAPI stable du plugin Flash natif, tu as donc installé une version bêta... obsolète (pas grave, ce n'est pas bien difficile de corriger le tir).

Concernant Pipelight je voulais te proposer d'activer le plugin Flash en user :

sudo pipelight-plugin --disable-all

suivi de :

pipelight-plugin --enable flash


Mais il y a une contradiction flagrante entre la doc et la page man yikes

Concernant le fichier sources.list il te suffira de décommenter la ligne #9 pour activer le dépôt jessie-backports :

#deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free

devient :

deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free


Cette petite intervention peut être effectuée via nano, mousepad, ou encore Synaptic :

sudo nano /etc/apt/sources.list

ou

gksu mousepad /etc/apt/sources.list


Si tu installais ne serait-ce qu'un paquet issu du dépôt jessie-backports, tu devrais laisser ce dépôt activé afin de pouvoir bénéficier automatiquement d'éventuelles mises à jour.

Voili voilo, n'ayant pas la moindre intention d'installer le 'machin' (Pipelight) je n'irai pas beaucoup plus loin dans l'entraide, ne pouvant tester quoi que ce soit neutral

Dernière modification par èfpé (10-12-2016 02:10:42)

Hors ligne

#21 10-12-2016 12:37:19

homme mouton
Membre
Distrib. : HandyLinux-2.5
Noyau : 3.16
(G)UI : XFCE
Inscription : 17-10-2016

Re : Mediatheque numerique et pipelight

En suivant ta modification du fichier sources.list, flash s'est bien installé! J'en ai profité pour supprimer la version bêta installée précédemment, mais malheureusement ça ne fonctionne toujours pas. J'imagine que ça signifie que le problème ne vient pas que de Flash pour lire en streaming les vidéos de la http://www.mediatheque-numerique.com ...

J'ai suivi tes directives pour pipelight en utilisant un terminal user, mais cela ne change pas grand chose sad
J'ai remarqué aussi qu'au lancement de firefox et quand je ne rentrais pas la commande :

sudo pipelight-plugin --create-mozilla-plugins


j'ai la fenêtre suivante qui s'ouvre :
BJ04S4Ud7bCF.png

En tout cas, un grand merci pour ton aide èfpé big_smile

Hors ligne

Pied de page des forums