Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-12-2016 19:41:34

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

[resolu] grub2 sur installation jessie lvm chiffré

Bonjour,
j'ai 'honte' de devoir à nouveau reposer une question d'installation...
installation de debian 8, par clé usb netinstall, seul mais en lvm chiffré, sur samsung nc10 386, bios.
l'étape de l'installation de grub est un échec et je continue l'installation sans.

partitions:
/boot 350MB ext2
gv avec deux lv: swap de 1500MB et '/' du reste sauf 3500MB, gardés libres derrière le groupe de volumes.

redémarrage sur la clé netinstall en mode 'graphic rescue mode' : shell sur la partition racine '/dev/gv/slash_racine' :

grub-install /dev/sda


erreur: attempt to install to encrypted disk without cryptodisk enabled. set 'GRUB_ENABLE_CRYPTODISK=1' in file '/etc/default/grub'


ce que je fais, puis reboot après avoir enlevé la clé netinstall :

erreur: disk 'xxxxxxx' not found. entering rescue mode
grub rescue>



je fais, clavier en mode qwerty :

set pager=1


ls


qui répond:

(hd0) (hd0,msdos5) (hd0,msdos1)



redémarrage avec la clé 'supergrub' :

no 'grub.cfg', no 'menu.lst', no 'core.img' detected

disk:
(hd1) (hd1,msdos5) (h1,msdos1) "boot"



je fais: 'enable grub2 raid and lvm support'
puis 'extra grub functionality: mount encrypted volumes (luks and gelli), ce qui permet de décrypter,
puis: 'boot manually'
succès
j'ouvre un terminal : aptitude versions me confirme que grub2 est installé

update-grub


...fait



reboot : idem: retour sur grub rescue sad

je fais l'opération 'cryptomount -a' 'apprise' smile ici :
https://debian-facile.org/viewtopic.php?id=14461
paragraphe /23
reboot : re 'error disk xxx not found
grub rescue>

qu'est-ce qui m'a (une fois de plus) échappé ? smile
merci d'avance.
cordialement
debianux

Dernière modification par debianux (13-12-2016 19:18:52)

Hors ligne

#2 12-12-2016 20:17:33

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

après re-démarrage avec la clé supergrub :

grub-install /dev/sda


Installing for i386-pc platform.
grub-install : erreur : attempt to install to encrypted disk without cryptodisk enabled. Set `GRUB_ENABLE_CRYPTODISK=1' in file `/etc/default/grub'..



étrange : je vais vérifier ::

nano /etc/default/grub



# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""
GRUB_ENABLE_CRYPTODISK=1

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console
 



mais grub ne le trouve pas...

Hors ligne

#3 12-12-2016 20:23:56

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

un nouveau 'grub-install' donne le même échec.

parted -l



Model: ATA FUJITSU MHZ2160B (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size   Type      File system  Flags
 1      1049kB  351MB  350MB  primary   ext2         boot
 2      351MB   157GB  156GB  extended
 5      351MB   157GB  156GB  logical


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/gv-swap: 1497MB
Sector size (logical/physical): 512B/512B
Partition Table: loop
Disk Flags:

Number  Start  End     Size    File system     Flags
 1      0,00B  1497MB  1497MB  linux-swap(v1)


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/gv-slash_racine: 155GB
Sector size (logical/physical): 512B/512B
Partition Table: loop
Disk Flags:

Number  Start  End    Size   File system  Flags
 1      0,00B  155GB  155GB  ext4


Error: /dev/mapper/sda5_crypt: unrecognised disk label
Model: Linux device-mapper (crypt) (dm)                                  
Disk /dev/mapper/sda5_crypt: 156GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:
 

Hors ligne

#4 12-12-2016 20:29:12

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

mon 'grub.cf', modifié avec les lignes 'crytomount -a' :

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if loadfont unicode ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=fr_FR
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=-1
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=5
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=5
  fi
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
insmod part_msdos
insmod cryptodisk
insmod luks
insmod gcry_rijndael
insmod gcry_rijndael
insmod gcry_sha1
insmod lvm
insmod ext2
set root='lvmid/3QIvW9-LPqj-cZKQ-8Hw1-hESW-NwBf-TeCpjT/ZmBVzs-FLyi-UDv7-kE11-9iBj-MiE0-s99cNy'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint='lvmid/3QIvW9-LPqj-cZKQ-8Hw1-hESW-NwBf-TeCpjT/ZmBVzs-FLyi-UDv7-kE11-9iBj-MiE0-s99cNy'  9a88e1fe-dbdf-4df0-886d-da581cf5d07f
else
  search --no-floppy --fs-uuid --set=root 9a88e1fe-dbdf-4df0-886d-da581cf5d07f
fi
insmod png
if background_image /boot/grub/.background_cache.png; then
  set color_normal=white/black
  set color_highlight=black/white
else
  set menu_color_normal=cyan/blue
  set menu_color_highlight=white/blue
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
  set gfxpayload="${1}"
}
set linux_gfx_mode=
export linux_gfx_mode
menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-9a88e1fe-dbdf-4df0-886d-da581cf5d07f' {
  load_video
  insmod gzio
  if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
  insmod part_msdos
  insmod cryptodisk
  insmod luks
  insmod gcry_rijndael
  insmod gcry_rijndael
  insmod gcry_sha1
  insmod lvm
  insmod ext2
  set root='lvmid/3QIvW9-LPqj-cZKQ-8Hw1-hESW-NwBf-TeCpjT/ZmBVzs-FLyi-UDv7-kE11-9iBj-MiE0-s99cNy'
  if [ x$feature_platform_search_hint = xy ]; then
    search --no-floppy --fs-uuid --set=root --hint='lvmid/3QIvW9-LPqj-cZKQ-8Hw1-hESW-NwBf-TeCpjT/ZmBVzs-FLyi-UDv7-kE11-9iBj-MiE0-s99cNy'  9a88e1fe-dbdf-4df0-886d-da581cf5d07f
  else
    search --no-floppy --fs-uuid --set=root 9a88e1fe-dbdf-4df0-886d-da581cf5d07f
  fi
  echo  'Chargement de Linux 3.16.0-4-686-pae…'
  linux /boot/vmlinuz-3.16.0-4-686-pae root=/dev/mapper/gv-slash_racine ro  quiet
  echo  'Chargement du disque mémoire initial…'
  initrd  /boot/initrd.img-3.16.0-4-686-pae
}
submenu 'Options avancées pour Debian GNU/Linux' $menuentry_id_option 'gnulinux-advanced-9a88e1fe-dbdf-4df0-886d-da581cf5d07f' {
  menuentry 'Debian GNU/Linux, avec Linux 3.16.0-4-686-pae' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.16.0-4-686-pae-advanced-9a88e1fe-dbdf-4df0-886d-da581cf5d07f' {
    load_video
    insmod gzio
    if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
    insmod part_msdos
    insmod cryptodisk
    insmod luks
    insmod gcry_rijndael
    insmod gcry_rijndael
    insmod gcry_sha1
    insmod lvm
    insmod ext2
    set root='lvmid/3QIvW9-LPqj-cZKQ-8Hw1-hESW-NwBf-TeCpjT/ZmBVzs-FLyi-UDv7-kE11-9iBj-MiE0-s99cNy'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint='lvmid/3QIvW9-LPqj-cZKQ-8Hw1-hESW-NwBf-TeCpjT/ZmBVzs-FLyi-UDv7-kE11-9iBj-MiE0-s99cNy'  9a88e1fe-dbdf-4df0-886d-da581cf5d07f
    else
      search --no-floppy --fs-uuid --set=root 9a88e1fe-dbdf-4df0-886d-da581cf5d07f
    fi
    echo  'Chargement de Linux 3.16.0-4-686-pae…'
    linux /boot/vmlinuz-3.16.0-4-686-pae root=/dev/mapper/gv-slash_racine ro  quiet
    echo  'Chargement du disque mémoire initial…'
    initrd  /boot/initrd.img-3.16.0-4-686-pae
  }
  menuentry 'Debian GNU/Linux, with Linux 3.16.0-4-686-pae (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.16.0-4-686-pae-recovery-9a88e1fe-dbdf-4df0-886d-da581cf5d07f' {
    load_video
    insmod gzio
    if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
    insmod part_msdos
    insmod cryptodisk
    insmod luks
    insmod gcry_rijndael
    insmod gcry_rijndael
    insmod gcry_sha1
    insmod lvm
    insmod ext2
    set root='lvmid/3QIvW9-LPqj-cZKQ-8Hw1-hESW-NwBf-TeCpjT/ZmBVzs-FLyi-UDv7-kE11-9iBj-MiE0-s99cNy'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint='lvmid/3QIvW9-LPqj-cZKQ-8Hw1-hESW-NwBf-TeCpjT/ZmBVzs-FLyi-UDv7-kE11-9iBj-MiE0-s99cNy'  9a88e1fe-dbdf-4df0-886d-da581cf5d07f
    else
      search --no-floppy --fs-uuid --set=root 9a88e1fe-dbdf-4df0-886d-da581cf5d07f
    fi
    echo  'Chargement de Linux 3.16.0-4-686-pae…'
    linux /boot/vmlinuz-3.16.0-4-686-pae root=/dev/mapper/gv-slash_racine ro single
    echo  'Chargement du disque mémoire initial…'
    initrd  /boot/initrd.img-3.16.0-4-686-pae
  }
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Hors ligne

#5 13-12-2016 00:41:04

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

set 'GRUB_ENABLE_CRYPTODISK=1' in file '/etc/default/grub'


Si ma mémoire est bonne, ce message est foireux : la bonne valeur est "y" et non "1".

Pour le reste, tu n'aurais pas légèrement oublié de monter la soit-disant partition de boot /dev/sda1 sur /boot lors de l'installation ?
D'après grub.cfg, le noyau et l'initramfs se trouvent dans le répertoire /boot d'un volume logique LVM et non à la racine de la partition (hd0,msdos1) comme cela devrait être si /dev/sda1 avait été montée sur /boot.

Dernière modification par raleur (13-12-2016 00:42:17)

Hors ligne

#6 13-12-2016 11:00:17

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

Bonjour raleur !
ça fait plaisir et ça rassure smile

lors  de l'installation de grub :

1/ premier essai : j'ai répondu 'non' à la proposition d'installation sur le secteur d'amorçage.
au choix manuel j'ai pris : '/dev/sda1
'non' à la proposition de 'forcer l'installation sur le chemin des suppports amovibles efi'

impossible d'installer grub dans /dev/sda1
l'exécution de grub-install /dev/sda1 a échoué, erreur fatale



2/ retour arrière avec l'installer et j'ai suivi l'option par défaut : manuel: /dev/sda qui conduit à /dev/sda1 : re-échec.

3/ ce coup-ci, j'opte pour l'installation sur le secteur d'amorçage : /dev/sda : ok. redémarrage : grrr : pas de chiffrement, me suis planté sad

4/ recommencé le partitionnement et je me retrouve à l'étape 'grub' : 'grub-install /dev/sda' : échec, continuation sans prog de démarrage...

effectivement après relecture du post-à-rallonge smile, j'ai retrouvé ton commentaire sur 'le message foireux'.

donc probablement ai-je

oublié de monter la soit-disant partition de boot /dev/sda1 sur /boot lors de l'installation ?

mais à quel moment ai-je foiré ?

ou la tentative d'installation 'non-chiffrée' a laissé un grub qui n'est plus adapté ?

possibilité de 'nettoyer' grub ? smile

Hors ligne

#7 13-12-2016 11:49:40

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

debianux a écrit :

1/ premier essai : j'ai répondu 'non' à la proposition d'installation sur le secteur d'amorçage.
au choix manuel j'ai pris : '/dev/sda1


Pourquoi sda1 plutôt que sda ? Cela nécessite qu'un autre programme d'amorçage soit présent dans le MBR, et ext2 ne permet pas l'embarquage de la

debianux a écrit :

'non' à la proposition de 'forcer l'installation sur le chemin des suppports amovibles efi'


Si l'installation n'est pas en EFI (pas de partition système EFI), la question n'est pas pertinente. L'installateur ne devrait pas la poser.

debianux a écrit :

2/ retour arrière avec l'installer et j'ai suivi l'option par défaut : manuel: /dev/sda qui conduit à /dev/sda1 : re-échec.


Comment ça, "/dev/sda qui conduit à /dev/sda1" ?

debianux a écrit :

mais à quel moment ai-je foiré ?


Probablement lors de l'étape du partitionnement, tu as créé le volume chiffré dans sd5, configuré LVM, et comme la partition sda1 était déjà créée et formatée, tu as oublié de la configurer pour définir son point de montage (/boot).
Tu peux vérifier dans /etc/fstab s'il y a une ligne pour cette partition.

Il n'est pas trop tard pour réintégrer sda1 : tu peux la monter temporairement sur /mnt, y copier le contenu de /boot, la démonter, modifier /etc/fstab pour la monter sur /boot (récupérer l'UUID avec blkid), la monter et exécuter grub-install puis update-grub à nouveau.

Dernière modification par raleur (13-12-2016 11:51:31)

Hors ligne

#8 13-12-2016 12:29:05

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

Pourquoi sda1 plutôt que sda


j'avais créé cette partition spécialement pour le 'boot' et pensais que c'était là qu'il fallait mettre 'grub'

Comment ça, "/dev/sda qui conduit à /dev/sda1" ?


c'est ce que j'ai 'noté' : après avoir choisi 'sda', sauf erreur, grub a choisi finalement 'sda1' mais j'ai peut-être 'noté' trop vite... smile

tu as oublié de la configurer pour définir son point de montage (/boot).


ouiiii ! :


cat /etc/fstab
 


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/gv-slash_racine /               ext4    errors=remount-ro 0       1
/dev/mapper/gv-swap none            swap    sw              0       0
 



la monter temporairement sur /mnt


ce qui se fait ?
(mount me répond qu'il n'y a pas ce qu'il faut dans le fstab)

Hors ligne

#9 13-12-2016 12:37:02

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

Quand un montage n'est pas dans fstab, il faut spécifier le périphérique et le point de montage.

mount /dev/sda1 /mnt

Hors ligne

#10 13-12-2016 13:06:24

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

debianux a écrit :

j'avais créé cette partition spécialement pour le 'boot' et pensais que c'était là qu'il fallait mettre 'grub'


Ne pas confondre "le boot" et la partition montée sur /boot. /boot contient les fichiers nécessaires à l'amorçage (noyau, initramfs et une partie de GRUB) mais pas tout. L'amorçage commence toujours avec le MBR du disque (ou la partition système EFI dans le cas d'une machine UEFI).
Sur un disque ne contenant qu'un seul système, installer l'amorce de GRUB ailleurs que dans le MBR du disque (/dev/sda) ne fait que compliquer l'amorçage.

Dernière modification par raleur (13-12-2016 13:07:54)

Hors ligne

#11 13-12-2016 13:10:19

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

merci, j'avais trouvé entre-temps smile

cp -R /boot /mnt/sda1
 


vérif à partir de '/mnt/sda1'

ls


config-3.16.0-4-686-pae  initrd.img-3.16.0-4-686-pae  vmlinuz-3.16.0-4-686-pae
grub       System.map-3.16.0-4-686-pae
 


démontage:

umount /dev/sda1 /mnt
 


umount: /mnt : non monté
 


UUID:

blkid /dev/sda1



/dev/sda1: LABEL="boot" UUID="ae8b6696-4789-48cb-88f6-ffa9ccba7f49" TYPE="ext2" PARTUUID="00052e52-01"


fstab: ajout de :

UUID=ae8b6696-4789-48cb-88f6-ffa9ccba7f49 /boot/grub  ext2  defaults 0  2



mais là, j'installe grub sur 'sda' ou 'sda1' ?

Hors ligne

#12 13-12-2016 14:28:55

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

Dans /dev/sda, à moins d'avoir une  bonne raison de faire autrement.

Par contre tu as défini le montage de la partition sur /boot/grub et non sur /boot. Dans ce cas elle ne contiendra que les fichiers de GRUB, et il n'était pas nécessaire d'y copier des fichiers puisqu'ils vont être réinstallés par grub-install et update-grub quand la partition sera montée.

Hors ligne

#13 13-12-2016 16:06:54

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

ok
donc

UUID=ae8b6696-4789-48cb-88f6-ffa9ccba7f49 /boot  ext2  defaults 0  2


mais c'est bien l'UUID de 'sda1', pas celle de 'sda'


grub-install /dev/sda


Installing for i386-pc platform.
Installation terminée, sans erreur.


update-grub
 



Création du fichier de configuration GRUB…
Found background image: .background_cache.png
Image Linux trouvée : /boot/vmlinuz-3.16.0-4-686-pae
Image mémoire initiale trouvée : /boot/initrd.img-3.16.0-4-686-pae
Mac OS X trouvé sur /dev/sdb3
fait
 



je vais rebooter...

Hors ligne

#14 13-12-2016 16:20:29

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

erreur. no such device. 9a88e1fe-dbdf-...
lvmid/3QivW9-LPqj-... non disponible

Hors ligne

#15 13-12-2016 16:28:46

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

GRUB cherche quelque chose dans le LVM alors que tout ce dont il devrait avoir besoin se trouve dans la partition /boot.
Qu'affiche la commande "set" pour les variables $prefix et $root à l'invite de grub ?
Tu avais bien remonté la partition sur /boot avant d'exécuter les commandes grub ?

Dernière modification par raleur (13-12-2016 16:31:03)

Hors ligne

#16 13-12-2016 16:30:51

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

blkid



blkid
/dev/mapper/sda5_crypt: UUID="1RzL1R-O0rg-SnFz-yTI4-wnuR-lYrB-nwZQ37" TYPE="LVM2_member"
/dev/mapper/gv-slash_racine: LABEL="slash_racine" UUID="9a88e1fe-dbdf-4df0-886d-da581cf5d07f" TYPE="ext4"
/dev/sda1: LABEL="boot" UUID="ae8b6696-4789-48cb-88f6-ffa9ccba7f49" TYPE="ext2" PARTUUID="00052e52-01"
/dev/sda5: UUID="638d6655-91fc-42fb-8ec5-bf111cd2b52d" TYPE="crypto_LUKS" PARTUUID="00052e52-05"
/dev/mapper/gv-swap: UUID="502125ac-8be7-48ba-ad6b-321bde81f6e0" TYPE="swap"
/dev/sdb1: PARTLABEL="Gap0" PARTUUID="0d29a6d7-b087-4ddf-95a1-75b9d3f4d39c"
/dev/sdb2: SEC_TYPE="msdos" UUID="17A3-C696" TYPE="vfat" PARTLABEL="EFI boot partition" PARTUUID="0d29a6d7-b087-4ddf-95a0-75b9d3f4d39c"
/dev/sdb3: LABEL="ISOIMAGE" TYPE="hfsplus" PARTLABEL="Gap1" PARTUUID="0d29a6d7-b087-4ddf-95a3-75b9d3f4d39c"
 


il dit ne pas trouver

/dev/mapper/gv-slash_racine


je ne vois pas ce qu'est l'autre évoqué

lvmid/3QivW9-LPqj-

Hors ligne

#17 13-12-2016 16:32:43

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

L'autre doit être l'UUID LVM du volume logique gv/slash_racine. La commande "lvdisplay" devrait l'afficher.

Hors ligne

#18 13-12-2016 16:35:08

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

Peu importe l'UUID, c'est un détail.
Vérifie que sda1 est montée sur /boot, relance les deux commandes grub et redémarre.

Edit : au fait, le message d'erreur de GRUB, c'était avant d'afficher le menu ou après avoir sélectionné le noyau ?

Dernière modification par raleur (13-12-2016 16:36:25)

Hors ligne

#19 13-12-2016 16:45:30

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

Tu avais bien remonté la partition sur /boot avant d'exécuter les commandes grub ?


non, désolé...
et je ne trouve pas comment ouvrir un terminal 'grub'

Hors ligne

#20 13-12-2016 16:54:56

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

le message d'erreur de GRUB, c'était avant d'afficher le menu ou après avoir sélectionné le noyau ?


après : j'avais bien le menu grub, avec en prime une 'offre' macx (venue du la clé 'supergrub' ?)

df -h
 



Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
/dev/dm-2          142G    2,9G  132G   3% /
udev                10M       0   10M   0% /dev
tmpfs              200M    5,0M  195M   3% /run
tmpfs              499M     68K  499M   1% /dev/shm
tmpfs              5,0M    4,0K  5,0M   1% /run/lock
tmpfs              499M       0  499M   0% /sys/fs/cgroup
/dev/sda1          324M     30M  277M  10% /boot
tmpfs              100M    4,0K  100M   1% /run/user/117
tmpfs              100M    8,0K  100M   1% /run/user/1000
 


je relance les cdes grub et reboote...

Hors ligne

#21 13-12-2016 17:00:26

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

là, entrée directe dans le terminal 'grub'


grub>set
...
prefix=(hd0,msdos1)/grub
root=hd0,msdos1
...

Hors ligne

#22 13-12-2016 17:02:39

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

il chercherait '/grub' sur sda1 et je lui propose '/boot'
j'avais modifié le fstab de '/boot/grub' en '/boot'

Dernière modification par debianux (13-12-2016 17:04:17)

Hors ligne

#23 13-12-2016 17:28:42

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

/grub sur /dev/sda1 monté sur /boot, cela correspond à /boot/grub.
Pas de message d'erreur avant ? Si le menu n'est pas affiché, c'est que GRUB ne trouve pas de fichier grub.cfg valide.
Peux-tu donner le contenu du fichier /boot/grub/grub.cfg ?

Dernière modification par raleur (13-12-2016 17:29:57)

Hors ligne

#24 13-12-2016 17:46:13

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

peut-on le faire à partir de la console grub et comment ?

Hors ligne

#25 13-12-2016 17:48:57

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] grub2 sur installation jessie lvm chiffré

Oui, mais tu auras du mal à faire le copier-coller, sans parler du clavier en QWERTY. Il vaut mieux passer par un système de secours.
Mais si tu y tiens :

ls /grub


Pour vérifier que le fichier est bien présent

set pager=1
cat /grub/grub.cfg


Pour afficher le contenu du fichier page par page.

Dernière modification par raleur (13-12-2016 17:51:22)

Hors ligne

Pied de page des forums