Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 14-12-2016 07:06:42

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

Bonmatin chalu/nounours,

Finalement l'utilisation de Firefox avec un lanceur sur le bureau [...] me semble jouable avec les Michus.

Sage décision ; voici donc une proposition honnête qui me semble remplir le 'cahier des charges' smile

Créer sur le bureau un fichier par exemple nommé majflash.sh et le rendre exécutable (clic droit > Propriétés... > Permissions : cocher 'Autoriser ce fichier à être exécuté comme un programme') ; ouvrir ce fichier avec nano ou mousepad en CLI (ou en GUI avec un clic droit > Ouvrir avec "Mousepad") :

nano ~/Bureau/majflash.sh

ou

mousepad ~/Bureau/majflash.sh


Y coller les lignes suivantes :

#!/bin/sh
xfce4-terminal --execute sudo update-flashplugin-nonfree --install --verbose


Puis enregistrer la modification... à l'exécution (clic gauche), une fenêtre de 'Terminal' s'ouvre ; saisir le mot de passe de l'utilisateur courant et valider par <Entrée> ; le script de mise à jour du plugin est lancé et la fenêtre se ferme automatiquement quand c'est terminé.

À noter que tu peux alternativement ajouter un lanceur au panel Xfce. La commande peut alors être simplifiée, à condition bien sûr de cocher 'Exécuter dans un terminal' dans les options :

sudo update-flashplugin-nonfree --install --verbose


La procédure étant abondamment décrite sur le wiki HandyLinux v2, je ne la détaille pas.

Note : l'option --verbose est optionnelle, mais je trouve cool d'être informé de l'avancée du truc tongue

edit4toto: euh... merci, mais la commande est à copier dans une GUI big_smile

Dernière modification par èfpé (14-12-2016 09:24:42)

Hors ligne

#27 14-12-2016 08:01:19

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

Super smile merci je testerai ça ce soir.
C'est un choix de feignasse, je ne me rappelle jamais de la commande et je dois rechercher dans la doc à chaque fois wink
@nounours : j'utilise Firefox dernière version mais le plugin flash et le plugin iced tea Java ne sont pas activés par défaut.
Bonne journée

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#28 14-12-2016 09:04:40

Wilou
Membre
Lieu : Toujours à proximité d'un PC
Distrib. : Debian 8.6 "Jessie"
Noyau : Linux 3.16.0-4-686-pae
(G)UI : OpenBox - LXDE
Inscription : 07-12-2016
Site Web

Re : [Résolu] Votre connexion n'est pas privée !!!

Hello Nounours,

Pour ton problème de connexion non sécurisée à la banque, tu as contourné le problème en utilisant Firefox.
Si tu souhaites utiliser Chromium, il serait intéressant de tester quelque chose que tu n'as pas mentionné. Tu évoquais avoir désactivé toutes les extensions, Effectivement, c'était pertinent. Comme sur Firefox, il existe pour Chromium une extension HTTPS Everywhere, qui va forcer la connexion en HTTPS si ce type de connexion est bien prévu. Pourrais-tu l'essayer ?

- La page de l'extension :
https://www.eff.org/fr/https-everywhere
- Lien pour télécharger directement l'extension :
https://www.eff.org/files/https-everywh … .11.30.crx

Bonne journée,

W.

••• Inventeur du CCMOS mystique (c) ••• Amateur de BM et d'IBM wildfire.gif •••

Hors ligne

#29 14-12-2016 09:48:26

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Votre connexion n'est pas privée !!!

@wilou
Le pb de connexion à la banque c'est résolu tout seul suite à mise à jour. Le malheur c'est que cette mise à jour oblige à utiliser le tuto suivant :

https://debian-facile.org/utilisateurs: … g-22-10-16

qui permet de faire marcher flash et qu'il faut relancer à chaque mise à jour et ce n'est pas commode.

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#30 14-12-2016 10:08:24

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Votre connexion n'est pas privée !!!

@èfpé #26
Ce script utilise sudo et moi j'ai installé jessie Xfce sur la machine à Michu qui utilise su.

J'ai installé Jessie Xfce pour les raisons suivantes :
- Xfce est bien adapté (légèrement mieux que Handylinux) à cette machine qui est vraiment faiblarde,
- j'avais installé ubuntu mate, qui n'est pas aussi performant pour cette machine, mais mon Michu confond mise à jour et mise à niveau et il a tout planté suite à mise à niveau. Avec Xfce désormais, c'est moi qui fait les mises à jour en ligne de commande.

Une question ; est ce que ce script qui sera actionné par un lanceur, oblige l'utilisateur à taper son code root à chaque fois ?

@chalu

@nounours : j'utilise Firefox dernière version mais le plugin flash et le plugin iced tea Java ne sont pas activés par défaut.



Comment on fait ? On va dans module >  plugins (?)


N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#31 14-12-2016 16:44:32

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

@nounours,

Ok, dans ce cas tu dois effectivement employer une syntaxe légèrement différente :

#!/bin/sh
xfce4-terminal --execute su --command 'update-flashplugin-nonfree --install'


C'est le mot de passe root qu'il faut saisir... et non le mot de passe user.

Une autre possibilité est d'employer 'gksu' au lieu de 'su -c'. Sinon il faut installer le paquet sudo, et ajouter le 'Michu' au groupe du même nom. Il n'y a pas de magie, la mise à jour du plugin (qu'elle soit semi-automatique ou manuelle) nécessite la saisie d'un mot de passe, comme l'installation du paquet flashplugin-nonfree.

À noter que tu peux également créer un lanceur directement sur le bureau. On pourrait par ailleurs arguer (1) que la mise à jour du plugin Flash fait partie de la maintenance, (2) que c'est toi qui l'assures, (3) et donc se contenter de faire disparaître le message qui fait peur avec l'astuce citée au post #13 ; c'est à toi de décider...

Dernière modification par èfpé (14-12-2016 18:46:32)

Hors ligne

#32 14-12-2016 19:18:29

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

èfpé a écrit :

À noter que tu peux alternativement ajouter un lanceur au panel Xfce. La commande peut alors être simplifiée, à condition bien sûr de cocher 'Exécuter dans un terminal' dans les options :

sudo update-flashplugin-nonfree --install --verbose


La procédure étant abondamment décrite sur le wiki HandyLinux v2, je ne la détaille pas.


Bonsoir smile
J'ai donc crée un lanceur mais le terminal se ferme tout seul et j'ai à peine le temps de voir ce qu'il raconte.
ça fait pas peur à M Michu certainement mais y a-t-il moyen d'avoir un délai où dans ce cas est-il préférable de passer par le script ?

nounours a écrit :

Comment on fait ? On va dans module >  plugins (?)


Oui c'est ça tu cliques sur les traits horizontaux en haut à droite puis tu choisis Modules > Plugins et là tu cliques sur la flèche pour sélectionner l'option " Demander pour activer"
Dans ce cas, sur un site qui a flash il y a une "barre" en haut de la fenêtre du navigateur pour "Poursuivre le blocage ou bien Autoriser"

Dernière modification par chalu (14-12-2016 19:22:35)


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#33 14-12-2016 19:24:07

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

chalu a écrit :

èfpé a écrit :

À noter que tu peux alternativement ajouter un lanceur au panel Xfce. La commande peut alors être simplifiée, à condition bien sûr de cocher 'Exécuter dans un terminal' dans les options :

sudo update-flashplugin-nonfree --install --verbose


La procédure étant abondamment décrite sur le wiki HandyLinux v2, je ne la détaille pas.


Bonsoir smile
J'ai donc crée un lanceur mais le terminal se ferme tout seul et j'ai à peine le temps de voir ce qu'il raconte.
ça fait pas peur à M Michu certainement mais y a-t-il moyen d'avoir un délai où dans ce cas est-il préférable de passer par le script ?

nounours a écrit :

Comment on fait ? On va dans module >  plugins (?)


Oui c'est ça tu cliques sur les traits horizontaux en haut à droite puis tu choisis Modules > Plugins et là tu cliques sur la flèche pour sélectionner l'option " Demander pour activer"
Dans ce cas, sur un site qui a flash il y a une "barre" en haut de la fenêtre du navigateur pour "Poursuivre le blocage ou bien Autoriser"



Wilou a écrit :

il existe pour Chromium une extension HTTPS Everywhere, qui va forcer la connexion en HTTPS si ce type de connexion est bien prévu. Pourrais-tu l'essayer ?


J'ai rencontré ce bug sur Chromium et l'extension n'y changeait rien, ça vient plus de chromium ou des certificats.


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#34 14-12-2016 19:33:18

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Votre connexion n'est pas privée !!!

Merci à tous.

Je me suis occupé du pc ''Michuesque'' sous Jessie Xfce, cet après midi. J'ai mis en fonction Firefox (qui est installé par défaut) après une mise à jour des dépôts et des paquets soit :

a) mise à jour des dépôts

apt-get update




b) mise à jour des paquets

apt-get upgrade



c) installation de flashplugin-nonfree

apt-get install flashplugin-nonfree



d) mise à jour de flashplugin

update-flashplugin-nonfree --install



e) aller dans module Firefox (les 3 barres en haut à droite) vérifier qu'on la version 24.0...... activer les plugins si besoin.

Je testerai le script plus tard. en attendant je note les ''recettes''.

Débian facile ; c'est vraiment super !!!!!.


N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#35 14-12-2016 19:40:32

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

@chalu,

J'ai donc crée un lanceur mais le terminal se ferme tout seul et j'ai à peine le temps de voir ce qu'il raconte.

Oui c'est normal... si le plugin est déjà à jour, ben il n'y a pas grand-chose à faire de plus. Par contre, si cela ne te gêne pas d'avoir à fermer la fenêtre manuellement, tu peux ajouter l'option --hold :

#!/bin/sh
xfce4-terminal --hold --execute sudo update-flashplugin-nonfree --install --verbose


Cela fonctionnera dans un lanceur aussi, mais dans ce cas il ne faut pas simplifier la commande.

Dernière modification par èfpé (14-12-2016 19:44:42)

Hors ligne

#36 14-12-2016 19:44:15

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

Ah super merci, oui moi je préfère tongue
simplifier tu veux dire quoi ? remplacer --hold par -h ?

Edit : ça ne peut pas se mettre directement dans le lanceur (je n'ai pas fait le script) ?

Dernière modification par chalu (14-12-2016 19:45:31)


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#37 14-12-2016 19:50:28

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

Re-,

Nan, de toute façon la forme courte de --hold est -H (-h étant la forme courte de --help wink) ; ce que je voulais dire, c'est qu'avec l'option --hold, tu dois utiliser exactement la même commande dans un lanceur. Avec les formes courtes :

xfce4-terminal -H -x sudo update-flashplugin-nonfree -i -v


edit: il est inutile de cocher 'Exécuter dans un terminal' dans les options tongue

Dernière modification par èfpé (14-12-2016 20:10:28)

Hors ligne

#38 14-12-2016 19:53:53

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] Votre connexion n'est pas privée !!!

Dans le lanceur, j'ai mis

xfce4-terminal --hold --execute sudo update-flashplugin-nonfree --install --verbose


J'ai coché la case exécuter dans un terminal ( je l'ai laissée en fait)
et c'est bon.
merci.gif pour la paresseuse smile


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

Pied de page des forums