Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-12-2016 14:51:02

delmed
Membre
Inscription : 13-12-2016

probleme maj debian 4 vers 5

Bonjour,
je rencontre un probleme avec la maj de debian 4 vers 5.
j'ai suivi le tuto https://www.cyberciti.biz/tips/howto-up … erver.html
le probleme, c'est que lorsque je tape : apt-get install apt aptitude j'ai des erreurs que je n'arrive pas a resoudre:

WARNING: The following packages cannot be authenticated!
  fonts-dejavu-core ttf-dejavu-core fonts-dejavu-extra fonts-dejavu ttf-dejavu-extra ttf-dejavu tzdata libc6 libc6-i686 multiarch-support libdbus-1-3 libgpg-error0 libgcrypt20
  libffi6 libpcre3 zlib1g libglib2.0-0 libgnome-keyring-common libgnome-keyring0 gsfonts libdb5.3 lsb-base exim4-base libgmp10 libnettle4 libhogweed2 libp11-kit0 libtasn1-6
  libgnutls-deb0-28 exim4 exim4-daemon-light sensible-utils debianutils startpar sysvinit-utils liblzma5 gcc-4.9-base libstdc++6 libapt-pkg4.12 libuuid1
  libboost-iostreams1.55.0 libtinfo5 libncursesw5 libsigc++-2.0-0c2a libssl1.0.0 libattr1 libcap2 libcwidget3 libbsd0 libedit2 libidn11 libkeyutils1 libldap-2.4-2 libsqlite3-0
  libxml2 libart-2.0-2 libasound2-data libasound2 libatk1.0-data libatk1.0-0 libglibmm-2.4-1c2a libatkmm-1.6-1 libaudit-common libaudit1 libbonobo2-0 libbonobo2-common
  liborbit-2-0 libltdl7 libogg0 libtdb1 libvorbis0a libvorbisfile3 libcanberra0 libcap-ng0 libdatrie1 libdbus-glib-1-2 libdconf1 libexpat1 libgck-1-0 gconf-service libgconf2-4
  gconf2-common libgconf-2-4 libgcr-3-common libgcr-base-3-1 libijs-0.35 liblcms2-2 mysql-common libmysqlclient18 libopts25 libthai-data libthai0 libjbig0 aptitude-common
  libxapian22 aptitude apt initscripts aptitude-doc-ru dconf-service dconf-gsettings-backend fontconfig-config libgs9-common libjbig2dec0
Install these packages without verification [y/N]? y
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously deselected package fonts-dejavu-core.
dpkg: regarding .../fonts-dejavu-core_2.34-1_all.deb containing fonts-dejavu-core:
 package uses Breaks; not supported in this dpkg
dpkg: error processing /var/cache/apt/archives/fonts-dejavu-core_2.34-1_all.deb (--unpack):
 unsupported dependency problem - not installing fonts-dejavu-core
(Reading database ...
dpkg: serious warning: files list file for package `ttf-dejavu-core' missing, assuming package has no files currently installed.

dpkg: serious warning: files list file for package `ttf-dejavu' missing, assuming package has no files currently installed.
39609 files and directories currently installed.)
Preparing to replace ttf-dejavu-core 2.34-1 (using .../ttf-dejavu-core_2.34-1_all.deb) ...
Unpacking replacement ttf-dejavu-core ...
dpkg-deb: file `/var/cache/apt/archives/ttf-dejavu-core_2.34-1_all.deb' contains ununderstood data member data.tar.xz     , giving up
E: Sub-process /usr/bin/dpkg received a segmentation fault.
 



j'ai bien sur essayer apt-get install  fonts-dejavu-core  --reinstall ....


y a t'il quelqu’un capable de m'aider svp?
Merci.

Hors ligne

#2 13-12-2016 15:01:52

raleur
Membre
Inscription : 03-10-2014

Re : probleme maj debian 4 vers 5

ttf-dejavu-core 2.34-1 est la version de Jessie (Debian 8), la version stable actuelle, et non de Lenny (Debian 5). Tu as dû faire une erreur dans la modification du fichier /etc/apt/sources.list (peut-être mis "stable" au lieu de "lenny" ? Ne jamais mettre "stable").

Les versions 4 et 5 de Debian sont obsolètes depuis très longtemps, ne sont plus disponibles sur les miroirs Debian courants, et il y a eu beaucoup de changement depuis.
Je suggère de considérer une réinstallation complète plutôt qu'une mise à jour longue et hasardeuse.

Hors ligne

#3 13-12-2016 16:45:18

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : probleme maj debian 4 vers 5

Bonjour,

C'est bien dommage de virer la etch, c'était une très bonne version. smile
Je l'aurais bien gardé en souvenir comme la Dapper à l'époque. wink

Dernière modification par golgot200 (13-12-2016 16:47:09)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#4 13-12-2016 16:46:22

delmed
Membre
Inscription : 13-12-2016

Re : probleme maj debian 4 vers 5

Merci pour votre réponse et conseils.
néanmoins avez vous des miroires pour pouvoir telecharger lenny ? je ne trouve pas sur google !
est il possible de passer de etch vers wheezy ou Jessie directement?

Hors ligne

#5 13-12-2016 16:49:22

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : probleme maj debian 4 vers 5

A mon avis fais comme te dis raleur, fais une installation propre avec Jessie, mais sauvegarde tes données avant. wink

EDIT : au cas où

https://www.debian.org/releases/lenny/debian-installer/

Dernière modification par golgot200 (13-12-2016 16:53:14)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#6 13-12-2016 16:54:49

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : probleme maj debian 4 vers 5


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#7 13-12-2016 17:16:19

delmed
Membre
Inscription : 13-12-2016

Re : probleme maj debian 4 vers 5

j'ai trouvé:
deb http://archive.debian.org/debian/
merci pour tout.
l'installation se déroule bien pour l'instant.
Cordialement,

Hors ligne

#8 13-12-2016 17:16:28

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : probleme maj debian 4 vers 5

Bonjour
c est fou ça tongue , tout est archivé , jessie 8.0 a jessie 8.5 smile
par curiosité c est quoi comme machine ?
et c'est une installation serveur ou bureau ?

Hors ligne

#9 14-12-2016 17:20:19

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : probleme maj debian 4 vers 5

Pour ma part, j'avais fait un dvd-live de mon installation à l'époque de Lenny et je l'ai toujours, il fonctionne encore et je peux même l'installer (sur une vieille machine).

Hors ligne

#10 15-12-2016 11:37:01

delmed
Membre
Inscription : 13-12-2016

Re : probleme maj debian 4 vers 5

robert2a a écrit :

par curiosité c est quoi comme machine ?


attention les yeux: un serveur, mais promis c'est pas le mien lol roll

Hors ligne

Pied de page des forums