Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-12-2016 14:45:27

Atys
Membre
Lieu : e@rth
Distrib. : Debian GNU/Linux 8.7 (jessie) + Backports
Noyau : 3.16.0-4-amd64
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

J'ai un problème de mise à jour - error code (1)

Bonjour,

Je cherche à me dépatouillé avec un paquet, dirmngr, qui ne veut pas se mettre à jour, je vous donne se que ça me renvoie

apt-get update && apt-get dist-upgrade


Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  dirmngr
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 439 ko dans les archives.
Après cette opération, 867 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Réception de:1 http://debian.proxad.net/debian testing/main amd64 dirmngr amd64 2.1.16-3 [439 kB]
439 ko réceptionnés en 1s (321 ko/s)
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 304056 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../dirmngr_2.1.16-3_amd64.deb ...
dpkg-maintscript-helper: error: dpkg: erreur: mauvaise syntaxe de la version «  »: la chaîne de version est vide
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/dirmngr_2.1.16-3_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
dpkg-maintscript-helper: error: dpkg: erreur: mauvaise syntaxe de la version «  »: la chaîne de version est vide
dpkg: error while cleaning up:
 le sous-processus nouveau script post-removal a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/dirmngr_2.1.16-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



J'ai essayé plusieurs solutions mais je tourne en rond, je l'ai gelé avec DPKG, dégelé, je ne peux plus utiliser l'interface Aptitude.
Le retirer et purger j'ai essayé aussi.

dpkg -i --force-all /var/cache/apt/archives/dirmngr_2.1.16-3_amd64.deb


(Lecture de la base de données... 321329 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../dirmngr_2.1.16-3_amd64.deb ...
dpkg-maintscript-helper: error: dpkg: erreur: mauvaise syntaxe de la version «  »: la chaîne de version est vide
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/dirmngr_2.1.16-3_amd64.deb (--install) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
dpkg-maintscript-helper: error: dpkg: erreur: mauvaise syntaxe de la version «  »: la chaîne de version est vide
dpkg: error while cleaning up:
 le sous-processus nouveau script post-removal a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/dirmngr_2.1.16-3_amd64.deb
 



Merci

Dernière modification par Atys (18-12-2016 16:52:16)

Hors ligne

#2 18-12-2016 23:25:32

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : J'ai un problème de mise à jour - error code (1)

Parfois un fichier téléchargé est mauvais (en général sur les mauvaises connexions), et une "apt-get clean; apt-get upgrade" fonctionne.

Mhm.   Après c'est pas du tout dit que c'est ça. Que donne aptitude ? Il a l'avantage de proposer des solutions.

Edit : aputain j'arrête pas les gaffes et les mauvaises pistes en ce moment avais pas vu que c'était du testing et j'ai donc pas pensé à un souçi de paquet X_X

Dernière modification par otyugh (19-12-2016 03:35:41)


L'informaticien sans son vocabulaire spécifique ? Rien d'impressionnant.
Venez les rencontrer en vrai : Agenda du libre

Hors ligne

#3 19-12-2016 02:40:09

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.9.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : J'ai un problème de mise à jour - error code (1)

Salut

Il y a un rapport de bug ouvert à ce sujet : dirmngr_2.1.16-3 fails to update from 2.1.16-2

Avec sid, lorsque ce genre de situation se produit, une chance c'est quand même assez rare, il faut juste être un patient et la correction arrive assez vite normalement vite. Cela fait partie des aléas de la branche sid smile.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#4 19-12-2016 09:15:34

Atys
Membre
Lieu : e@rth
Distrib. : Debian GNU/Linux 8.7 (jessie) + Backports
Noyau : 3.16.0-4-amd64
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : J'ai un problème de mise à jour - error code (1)

Oui, avec Sid, ça ce produit de temps en temps.
Je venais juste de finir une migration et à la fin je suis tombé sur ce bug, j'ai crue être bloqué un moment.

Merci

Dernière modification par Atys (19-12-2016 11:34:33)

Hors ligne

#5 28-12-2016 01:30:23

jps
Membre
Inscription : 04-12-2016

Re : J'ai un problème de mise à jour - error code (1)

Moi dans ma Debian xfce 8.6 avec backports activé ton paquet (dirmngr) est désactivé. Je pense que ça ne pose aucun problème de le laisser désactivé

Hors ligne

Pied de page des forums