Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-12-2016 00:53:21

jps
Membre
Inscription : 04-12-2016

Noyau obsolète suite ?

Bonsoir j'utilise Debian stable 8.6 avec le noyau 4.7.0. Peut on rester sur le meme noyau pendant 5 ans ou est ce indispensable de changer et quel sont les avantages ?

Dernière modification par jps (28-12-2016 02:45:18)

Hors ligne

#2 19-12-2016 01:59:39

zorzi
Membre
Lieu : Côte d'Or
Distrib. : Debian Stretch - Gnome 3.22
Noyau : Linux 4.9.0-1-amd64
Inscription : 30-09-2015

Re : Noyau obsolète suite ?

Bonsoir,

Tu peux garder un même noyau tant que celui-ci est maintenu et reçoit des mises à jour de sécurité (je connais pas la durée de prise en charge du 4.7.0).

Un noyau récent n'a pas de réels avantages autre que la reconnaissance et prise en charge de matériel récent.

Debian Jessie utilisant par défaut le noyau 3.16, tu n'avais peut-être pas réel intérêt à mettre à jour vers le 4.7.0. sauf si ton matériel était mal reconnu.

Chez moi, le noyau 3.16 suffit amplement car j'ai un ordi déjà un peu ancien.

Dernière modification par zorzi (19-12-2016 02:00:58)


Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, DD 500 Go) / Debian Stretch (Gnome)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Jessie (Mate)

Hors ligne

#3 19-12-2016 05:08:14

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Noyau obsolète suite ?

Noyau = kernel.
Voir le tuto qui explique tout ça pas à pas :
https://debian-facile.org/doc:systeme:g … x#le-noyau
... doc.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 19-12-2016 07:24:58

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Noyau obsolète suite ?

Salut,

Il y a des dépêches sur linuxfr pour voir les changements fait sur les nouveaux noyaux .
Pour le 4.8 : https://linuxfr.org/news/sortie-du-noyau-linux-4-8

Bref, ça dépend si tu as besoin des nouvelles fonctionnalités .

Dernière modification par nono47 (19-12-2016 07:25:30)

Hors ligne

#5 19-12-2016 15:18:12

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : Noyau obsolète suite ?

Bonjour
merci pour le lien smile
moi je regarde juste ça wink


Pilotes graphiques libres
AMDGPU

Un ajout notable en ce qui concerne le pilote AMDGPU
est la possibilité de surcadencer son processeur graphique
grâce à la prise en charge d’OverDrive.
Une fonctionnalité qui ravira joueurs et mineurs de tout poil.

La méthode n’est pour le moment pas très conviviale,
car elle consiste à modifier la valeur de certains fichiers en ligne de commande.

Dans le détail, on a typiquement le fichier /sys/class/drm/card0/device/pp_sclk_od
pour la gestion de la fréquence du processeur graphique
et le fichier /sys/class/drm/card0/device/pp_mclk_od
pour la mémoire. Les valeurs possibles vont de 0 à 20 par palier de 1
et représentent le pourcentage d’augmentation de la fréquence.
Nouveau

Début de prise en charge des processeurs graphiques GP100 et GP104.
 


il parle pas de gpu intel , et pour amd ça s améliore pas trop coté libre  hmm

Hors ligne

#6 20-12-2016 00:19:33

yoshi
Membre
Lieu : Normandie
Distrib. : ArchLinux / Slackware
Noyau : 4.9.11 / 4.4.38
(G)UI : Plasma5 / KDE4 & XFCE 4.12
Inscription : 05-03-2014

Re : Noyau obsolète suite ?

Le kernel 4.8 n'a manifestement pas été un grand cru ..... Le 4.9 est sorti le 11 Décembre.
Le 4.8 en est à la version 4.8.15, ce qui me parait énorme pour un kernel aussi récent, et qui ne sera pas LTS.

https://www.kernel.org/

Le kernel 4.4 est la version LTS la plus récente.

ArchLinux KDE Plasma 5.9.2 / Slackware -current KDE 4.14.3 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
Slackware 14.2 XFCE 4.12.3 sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
Slackware 14.2 XFCE 4.12.3+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#7 28-12-2016 01:38:26

jps
Membre
Inscription : 04-12-2016

Re : Noyau obsolète suite ?

Bonsoir les backports m'avaient fait grimper jusqu'au 4.8. je suis redécendu au 4.7 mais j'aurais voulu redéscendre au 4.4 qui est LTS mais il n'apparait plus dans mon synaptic. je n'ai que 3.16, 4.7, 4.8. Ma question c'est est ce que l'on peut redécendre au 4.4 et si oui comment. J'ai essayé avec kernel.org mais je ne sais pas comment faire car c'est des fichiers tar.xz alors que je m'attendais a un .deb

Hors ligne

#8 28-12-2016 12:22:19

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Noyau obsolète suite ?

Salut,

Il y a le dépôt snapshot - http://snapshot.debian.org/ - qui permet de récupérer les paquets qui ne sont plus dans les dépôts .
( avec des explications en anglais )

Le mode d'emploi sur le wiki facile : https://debian-facile.org/doc:systeme:a … n-snapshot
ou chez debian.xyz ( mieux expliqué ) : https://wiki.debian-fr.xyz/Le_d%C3%A9p%C3%B4t_snapshot

Attention aux dépendances, tu peux utiliser l'option -s ( pour simuler ) de apt-get et vérifier avant que ça ne va pas casser .

J'ai essayé avec kernel.org mais je ne sais pas comment faire car c'est des fichiers tar.xz alors que je m'attendais a un .deb


Les développeurs debian patch le noyau, tu as tout intérêt à utiliser un noyau debian plutôt que vanilla ( celui de kernel.org ) à compiler soi même .

Dernière modification par nono47 (28-12-2016 12:32:46)

Hors ligne

#9 28-12-2016 15:26:04

raleur
Membre
Inscription : 03-10-2014

Re : Noyau obsolète suite ?

jps, il faut bien distinguer deux choses : les paquets de noyaux précompilés inclus dans les distributions, et les sources des noyaux amont sur kernel.org.

Il ne faut jamais chercher à installer un paquet de noyau qui n'est plus disponible dans la distribution pour autre chose qu'un test ponctuel car il est obsolète et non maintenu et peut contenir des bugs et failles de sécurité qui ne seront pas corrigés. En règle générale, il faut installer le plus récent noyau disponible dans la distribution *installée* (ça ne veut pas dire d'installer un noyau de testing sur une stable) car c'est lui qui est à jour. Le plus simple est d'installer le méta-paquet linux-image-<arch> (ex: linux-image-amd64, linux-image-686-pae) qui dépend du noyau le plus récent disponible. Peu importe que cette version soit LTS ou pas sur kernel.org, de toute façon elle est maintenue par la distribution.

Les archives tar.xz|bz2|gz disponibles sur kernel.org contiennent les sources officielles ("vanilla", non modifiées par les distributions) des différentes versions du noyau. Il faut les compiler pour installer le noyau correspondant, c'est moins pratique qu'un paquet .deb. Là non plus il ne faut pas prendre n'importe quelle version mais systématiquement la dernière d'une série encore maintenue (si la dernière version d'une série date de plus d'un mois, elle n'est probablement plus maintenue).

Dernière modification par raleur (28-12-2016 15:27:47)

Hors ligne

Pied de page des forums