Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-01-2017 19:27:07

Patrick Debian
Membre
Distrib. : Debian 8.7 stable main_contrib_non-free_backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate et GNOME
Inscription : 14-12-2016

Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Bonsoir,
Alors que je  lit « Le nouveau debianiste qui papillonne » https://debian-facile.org/doc:systeme:c … papillonne, je part dans le terminal et m'essaye dans des commandes, puis je trouve dans : .local/share/nautilus, « nautilus », alors que je pensais ne pas l'avoir, car j'ai « caja » et je ne trouve pas « nautilus » dans mon envirronement de bureau graphique, d'où ma question :
Ai-je nautilus ? Et si oui, pourquoi je ne le trouve pas dans mon environnent graphique ?

Dernière modification par Patrick Debian (03-01-2017 19:07:20)

En ligne

#2 02-01-2017 20:13:02

Mercredi
Membre
Distrib. : Testing
Noyau : 4.9
(G)UI : Gnome
Inscription : 25-09-2015
Site Web

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Bonsoir,
Nautilus c'est, dans le bureau Gnome, l'équivalent de Caja.

As-tu installé Gnome à un moment pour l'essayer, ce qui expliquerait un résidu dans /home/user/.local/share ?
Autre possibilité, Mate est un fork d'une ancienne version de Gnome (Gnome 2 je crois) donc peut-être qu'il y a encore des appellations communes (à faire confirmer par un spécialiste de Mate car je l'ai peu essayé).

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#3 02-01-2017 21:31:09

Patrick Debian
Membre
Distrib. : Debian 8.7 stable main_contrib_non-free_backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate et GNOME
Inscription : 14-12-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

- Je n'ai jamais installé Gnome.

- Je viens de faire:
~/.local/share/nautilus$ tree nautilus
nautilus [error opening dir]
0 directories, 0 files

Estce que cela veut dire qu'il est vide?

En ligne

#4 03-01-2017 13:09:35

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Bonjour smile

Patrick Debian a écrit :

Estce que cela veut dire qu'il est vide?


Non en fait c'est un message qui indique qu'il y a une erreur à l'ouverture de ce dossier ce qui est normal car tu es déjà dedans quand tu passes ta commande
Essaie avec le chemin ~/.local/share$ au lieu de ~/.local/share/nautilus$

~/.local/share$ tree nautilus


ce qui revient au même que

tree ~/.local/share/nautilus

Dernière modification par chalu (03-01-2017 13:14:48)


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#5 03-01-2017 13:36:12

Patrick Debian
Membre
Distrib. : Debian 8.7 stable main_contrib_non-free_backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate et GNOME
Inscription : 14-12-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Ça me donne ceci:
~$ ~/.local/share$ tree nautilus
bash: /home/patrick/.local/share$: Aucun fichier ou dossier de ce type

Pourtant je le trouve ici:
.local/share/nautilus

En ligne

#6 03-01-2017 13:43:42

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Tu as deux fois $
Ouvre un terminal et essaie cette commande en copiant-collant

tree /home/patrick/.local/share/nautilus


mais bon c'est aussi simple de double-cliquer sur le dossier nautilus pour voir ce qu'il y a dedans wink

Dernière modification par chalu (03-01-2017 13:44:31)


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#7 03-01-2017 14:05:36

sogal
Black Metal Modo
Lieu : Nord Isère
Distrib. : openSUSE Leap 42.2
Noyau : Linux 4.4.36
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Patrick Debian a écrit :

Ai-je nautilus ? Et si oui, pourquoi je ne le trouve pas dans mon environnent graphique ?


Pour savoir si un paquet est installé, tu peux simplement le vérifier avec ton gestionnaire de paquet :

apt-cache policy nautilus



Par exemple, chez moi avec le paquet bash :

apt-cache policy bash


bash:
  Installé : 4.3-11+b1
  Candidat : 4.3-11+b1
 Table de version :
 *** 4.3-11+b1 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status


Il me dit qu'il est installé en version 4.3-11+b1

Par contre comme je n'ai pas nautilus, si je fais :

apt-cache policy nautilus


Il me renvoie :

nautilus:
  Installé : (aucun)
  Candidat : 3.14.1-2
 Table de version :
     3.14.1-2 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages


On voit bien : Installé : (aucun).
Nautilus n'est pas installé sur mon système.


1485418338.png Hello IT ! Have you tried turning it off and on again ?

Hors ligne

#8 03-01-2017 15:30:07

Patrick Debian
Membre
Distrib. : Debian 8.7 stable main_contrib_non-free_backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate et GNOME
Inscription : 14-12-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Pour :

tree /home/patrick/.local/share/nautilus



# tree /home/patrick/.local/share/nautilus
/home/patrick/.local/share/nautilus
└── scripts





Pour :

apt-cache policy nautilus



1 directory, 0 files
root@------:/home# apt-cache policy nautilus
nautilus:
  Installé : 3.14.1-2
  Candidat : 3.14.1-2
 Table de version :
 *** 3.14.1-2 0
        500 [url]http://httpredir.debian.org/debian/[/url] jessie/main amd64 Packages
        100 /var/lib/dpkg/status



Si je comprend, il est installé !

Chalu ! Tu m'as demandé de double-cliquer sur le dossier nautilus pour voir ce qu'il y a dedans, or, je ne le trouve que dans mon terminal, pas de trace de lui dans le graphique !

Où est nautilus dans l'environnement de bureau graphique ? À savoir que j'ai « caja ».

Est-ce nautilus qui apparaît avec le nom de « caja » ?

Merci à vous
Edit : mise en conformité avec les balises codes

Dernière modification par Patrick Debian (03-01-2017 15:30:49)

En ligne

#9 03-01-2017 15:47:02

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Patrick Debian a écrit :

Chalu ! Tu m'as demandé de double-cliquer sur le dossier nautilus pour voir ce qu'il y a dedans, or, je ne le trouve que dans mon terminal, pas de trace de lui dans le graphique !


Oui c'est normal, tu vas dans ton dossier personnel nommé patrick
tu remarques que dans le terminal c'est .local
Le point "." précédent le nom d'un dossier ou d'un fichier permet de le cacher, ça évite des suppressions avec une fausse manoeuvre wink et ça allège aussi le visuel.
Tu regardes dans caja, tu dois avoir une option pour montrer les dossiers/fichiers cachés (dans le menu vue ou affichage ou ...)
et une fois l'option activée, tu vas découvrir plusieurs fichiers et dossiers cachés

Edit : j'ai édité ton post pour ajouter les balises codes aux commandes
Tu peux le faire toi-même avec le tuto :
Voir le tuto : Le code, ça pique moins les yeux en couleur


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#10 03-01-2017 15:50:15

Croutons
Membre
Distrib. : Handylinux 2.5 vers debian 8.6
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Bonjour
Le point devant le répertoire local (.local) t'indique que le c'est un dossier caché
Par defaut les fichiers cachés ne sont pas visible en mode graphique
Si tu utilises Thunar comme gestionnaire de fichier tu as le raccourci : Ctrl+H pour affiché ou no les dossiers ou fichiers cachés
ou Vue --->montrer les fichiers caché

arf Chalu ma coupé l'herbe sous le piedold_geek.gif

Dernière modification par Croutons (03-01-2017 15:51:52)

En ligne

#11 03-01-2017 15:54:56

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Non ton raccourci Ctrl+H est peut-être universel pour afficher les dossiers et fichiers cachés et alors bien pratique ton complément wink

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#12 03-01-2017 16:07:13

sogal
Black Metal Modo
Lieu : Nord Isère
Distrib. : openSUSE Leap 42.2
Noyau : Linux 4.4.36
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Patrick Debian a écrit :

Où est nautilus dans l'environnement de bureau graphique ?


Tu le trouveras peut-être sous le nom "Fichiers" dans ton environnement graphique.
Les dev Gnome ont parfois tendance à ne pas appeler un smolski un smolski, euh, un chat un chat.

Sinon l'exécutable Nautilus est /usr/bin/nautilus

chalu a écrit :

Ctrl+H est peut-être universel pour afficher les dossiers et fichiers cachés


C'est le cas dans les navigateurs de fichiers des environnements basés sur GTK (Gnome, Mate, Cinnamon, Xfce et, je crois, LXDE et autres SpaceFM).
Sous KDE (Dolphin donc) et midnight-commande, c'est Alt + .  (Alt et un point).


1485418338.png Hello IT ! Have you tried turning it off and on again ?

Hors ligne

#13 03-01-2017 17:45:14

Mercredi
Membre
Distrib. : Testing
Noyau : 4.9
(G)UI : Gnome
Inscription : 25-09-2015
Site Web

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

sogal a écrit :


Tu le trouveras peut-être sous le nom "Fichiers" dans ton environnement graphique.
Les dev Gnome ont parfois tendance à ne pas appeler un smolski un smolski, euh, un chat un chat.


Malgré qu'il soit désormais sensé s'appeler "Fichiers" sur Gnome 3.22, il est toujours sous le nom de Nautilus dans les différents dossiers où il apparaît.
Idem pour l'ouvrir depuis le terminal il faut toujours taper nautilus, fichiers (ou files) ne fonctionne pas.


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#14 03-01-2017 19:06:15

Patrick Debian
Membre
Distrib. : Debian 8.7 stable main_contrib_non-free_backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate et GNOME
Inscription : 14-12-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Je viens de trouver nautilus dans mes icônes ! Il y était mais sous le nom de « fichier » seulement ?!
Il doit être installé par défaut, mais nommé « fichier » et non pas « nautilus » dans l'icône, ou alors, j'ai fait une manip qui a changé son nom, mais je ne vois pas quand.

Merci à tous pour ce que j'ai pu apprendre sur nautilus ou autre comme : comment mettre de la couleur dans mes posts pour les lignes de commande.

Allez ! Pesé c'est posté. Je le met en résolu.

N'hésitez pas à écrire des compléments qui me seront profitables, merci.

Comme par exemple: j'ai caja et nautilus, est il nécessaire de garder les deux? qui sont tous deux des gestionnaires de fichiers.

debian.png debian.png

Dernière modification par Patrick Debian (03-01-2017 19:09:24)

En ligne

#15 03-01-2017 19:46:52

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Patrick Debian a écrit :

Comme par exemple: j'ai caja et nautilus, est il nécessaire de garder les deux? qui sont tous deux des gestionnaires de fichiers.


Il faudrait savoir si tu as installé nautilus seul ou bien si nautilus s'est installé comme dépendance d'un autre logiciel auquel tu tiens wink
mais pour en savoir plus sur ce sujet, il faut faire un autre fil tongue


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#16 03-01-2017 21:05:31

Patrick Debian
Membre
Distrib. : Debian 8.7 stable main_contrib_non-free_backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate et GNOME
Inscription : 14-12-2016

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

En ligne

#17 03-01-2017 21:40:39

Mercredi
Membre
Distrib. : Testing
Noyau : 4.9
(G)UI : Gnome
Inscription : 25-09-2015
Site Web

Re : Nautilus dans mon terminal, pas dans mon bureau graphique? [résolu]

Patrick Debian a écrit :

Je viens de trouver nautilus dans mes icônes ! Il y était mais sous le nom de « fichier » seulement ?!
Il doit être installé par défaut, mais nommé « fichier » et non pas « nautilus » dans l'icône, ou alors, j'ai fait une manip qui a changé son nom, mais je ne vois pas quand.


Ah oui j'ai oublié de préciser, l'icône se nomme bien "Fichiers" par contre tous le reste est sous le nom de "Nautilus", y compris le paquet pour l'installer wink C'est pareil pour le navigateur "web" de Gnome qui a gardé son ancien nom "Epiphany" pour tout sauf l'icône, Gnome aime bien simplifier ... mais pas là lol


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

Pied de page des forums