Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-01-2017 11:52:05

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

[résolu] erreur "dmesg"

bonjour

une question relative à une commande "de base"
si je fais

dmesg


dmesg: échec de lecture du tampon de noyau: Opération non permise



cette erreur survient depuis que j'ai mis à jour le noyau 4.8 des backports

uname -rv


4.8.0-0.bpo.2-amd64 #1 SMP Debian 4.8.11-1~bpo8+1 (2016-12-14)



avec un noyau plus ancien (4.7) toujours des backports, la commande dmesg en utilisateur fonctionne

avec la version noyau 4.8 je dois passer en root pour avoir le résultat


un bug du noyau ?
des droits en lecture à corriger ?

solution post #3

raleur a écrit :

Il existe une option de compilation du noyau pour restreindre l'accès au tampon des messages du noyau par les utilisateurs non root. Cette option a été activée dans le noyau 4.8 de Debian. Je vois dans le changelog :

* security,printk: Enable SECURITY_DMESG_RESTRICT, preventing non-root users
    reading the kernel log by default (sysctl: kernel.dmesg_restrict)


Je suppose qu'on peut désactiver la restriction en mettant le sysctl kernel.dmesg_restrict à 0.
En direct :

sysctl -w kernel.dmesg_restrict=0
# ou
echo 0 > /proc/sys/kernel/dmesg_restrict



Pour que ce soit fait au démarrage, ajouter ceci dans /etc/sysctl.conf ou un fichier /etc/sysctl.d/*.conf :

# autoriser les utilisateurs non root à lire le tampon des messages du noyau
kernel.dmesg_restrict=0

Dernière modification par Severian (05-01-2017 15:01:13)


"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#2 05-01-2017 12:20:21

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [résolu] erreur "dmesg"

J'ai accès en user à l'utilisation de la commande dmesg.

uname -rv


3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19

Dernière modification par smolski (05-01-2017 12:23:01)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 05-01-2017 13:03:35

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] erreur "dmesg"

Et en root ?

Il existe une option de compilation du noyau pour restreindre l'accès au tampon des messages du noyau par les utilisateurs non root. Cette option a été activée dans le noyau 4.8 de Debian. Je vois dans le changelog :

* security,printk: Enable SECURITY_DMESG_RESTRICT, preventing non-root users
    reading the kernel log by default (sysctl: kernel.dmesg_restrict)


Je suppose qu'on peut désactiver la restriction en mettant le sysctl kernel.dmesg_restrict à 0.
En direct :

sysctl -w kernel.dmesg_restrict=0
# ou
echo 0 > /proc/sys/kernel/dmesg_restrict



Pour que ce soit fait au démarrage, ajouter ceci dans /etc/sysctl.conf ou un fichier /etc/sysctl.d/*.conf :

# autoriser les utilisateurs non root à lire le tampon des messages du noyau
kernel.dmesg_restrict=0

Hors ligne

#4 05-01-2017 13:11:19

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [résolu] erreur "dmesg"

merci raleur,
la commande

sysctl -w kernel.dmesg_restrict=0


fonctionne parfaitement

une petite dernière question
la modification manuel de /etc/sysctl.conf ne va pas poser de problème aux prochaine mises à jour ? (j'ai cru comprendre que qu'il n'était pas recommander de modifier certains fichier de configuration système manuellement)


"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#5 05-01-2017 13:16:42

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [résolu] erreur "dmesg"

Bonjour smile
Faut-il faire ce changement ? car si l'option a été changé dans le noyau 4.8 par rapport aux précédents, est-ce une mesure de sécurité comme je crois le comprendre ?
ou bien juste un changement pour la version 4.8 qui ne sera pas reconduit pour la version suivante ?
En gros, par rapport à la sécurité et stabilité du système, c'est quoi le mieux scratchhead.gif

Hors ligne

#6 05-01-2017 14:44:39

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] erreur "dmesg"

Severian a écrit :

la modification manuel de /etc/sysctl.conf ne va pas poser de problème aux prochaine mises à jour ? (j'ai cru comprendre que qu'il n'était pas recommander de modifier certains fichier de configuration système manuellement)


Pour éviter ce genre de problème, tu peux utiliser un fichier /etc/sysctl.d/*.conf comme mentionné dans mon message précédent.

chalu a écrit :

Faut-il faire ce changement ? car si l'option a été changé dans le noyau 4.8 par rapport aux précédents, est-ce une mesure de sécurité comme je crois le comprendre ?
ou bien juste un changement pour la version 4.8 qui ne sera pas reconduit pour la version suivante ?


C'est une mesure pour augmenter la sécurité par défaut du noyau en partant du principe que les logs du noyau peuvent contenir des informations "sensibles". Je pense que l'option SECURITY_DMESG_RESTRICT existait déjà dans les versions précédentes mais n'était pas activée. Je n'ai pas de quoi vérifier pour le moment, vous pouvez regarder sur vos noyaux antérieurs :

grep SECURITY_DMESG_RESTRICT /boot/config-*

Dernière modification par raleur (05-01-2017 14:46:41)

Hors ligne

#7 05-01-2017 14:54:35

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [résolu] erreur "dmesg"

raleur a écrit :

C'est une mesure pour augmenter la sécurité par défaut du noyau en partant du principe que les logs du noyau peuvent contenir des informations "sensibles". Je pense que l'option SECURITY_DMESG_RESTRICT existait déjà dans les versions précédentes mais n'était pas activée. Je n'ai pas de quoi vérifier pour le moment, vous pouvez regarder sur vos noyaux antérieurs :

grep SECURITY_DMESG_RESTRICT /boot/config-*

Je confirme smile

/boot/config-3.16.0-4-amd64:# CONFIG_SECURITY_DMESG_RESTRICT is not set
/boot/config-3.2.0-2-amd64:# CONFIG_SECURITY_DMESG_RESTRICT is not set
/boot/config-3.2.0-4-amd64:# CONFIG_SECURITY_DMESG_RESTRICT is not set


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#8 05-01-2017 14:57:13

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [résolu] erreur "dmesg"

grep SECURITY_DMESG_RESTRICT /boot/config-*


/boot/config-3.16.0-4-amd64:# CONFIG_SECURITY_DMESG_RESTRICT is not set
/boot/config-4.7.0-0.bpo.1-amd64:# CONFIG_SECURITY_DMESG_RESTRICT is not set
/boot/config-4.8.0-0.bpo.2-amd64:CONFIG_SECURITY_DMESG_RESTRICT=y


"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#9 05-01-2017 14:59:14

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [résolu] erreur "dmesg"

avant que papy smolski passe par ici pour tenter de récupérer un pts choco, je passe en [résolu] tongue

merci raleur smile

"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#10 05-01-2017 15:11:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [résolu] erreur "dmesg"

galopin !

... hobbes.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums