Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-01-2017 15:17:06

Wilinux
Membre
Lieu : On the wild side
Distrib. : "Debian GNU/Linux 9 (stretch)"
Noyau : Linux 4.7.9-64
(G)UI : LXDE
Inscription : 20-12-2016

ACPI Warning ?

un nouveau petit problème...

c'est en faisant un essai que je me suis retrouvé en mode console plein écran (ctrl+alt+f3) et impossible de revenir au mode graphique ops.gif (ne riez pas) j'ai du rebooter (shutdown -r 00) 3 ou 4 fois avant d'avoir le bon RC pour retrouver le mode graphique : alt+f5 en ce qui me concerne smile

donc petit googlage et les uns me disent ceci les autres cela, donc comme à mon habitude j'y vais franco et j'essaye toutes les combinaison possible et surprise j'arrive à ctrl+alt+f12 et là j'ai un écran noir (console) avec plein de log dont un qui m'interpelle :

ACPI Warning: \_SB.PCI0.PEG1.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160422/nsarguments-95)



C'est grave Docteur ?old_geek.gif

les 2 seuls trucs que je comprends c'est :

                                1/ "Warning" : c'est pas bon big_smile
                                2/ "ACPI requires package" : Il veut un paquet wink

c'est là que ça se complique, comment je le trouve ce paquet et ensuite comment je l'installe ?

merci.gif pour votre aide

Dernière modification par Wilinux (10-01-2017 00:17:55)


« Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire. » -- E. Snowden

Hors ligne

#2 09-01-2017 20:39:51

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-2-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : ACPI Warning ?

Bonsoir
tu parle de faire un essai , un essai de quoi ?
ta machine un portable  ?
j ai trouvé quelques liens relatif a bumblebee a partir de ton message d erreur .
tu a gnome + gdm3 ?
tu est en stretch ou en sid ?
bien que le démarrage annonce stretch/sid , ça veut rien dire (c est stretch ) pour sid il faut une ligne dans ton sources.list avec "sid"
ps: surtout maintenant que stretch entre en phase de gel (en fait je veut savoir si tu a fait des mises a jours a partir de sid ou pas )

nota : a priori tu a cassé ton serveur X

Dernière modification par robert2a (09-01-2017 20:44:56)

Hors ligne

#3 09-01-2017 22:13:40

Wilinux
Membre
Lieu : On the wild side
Distrib. : "Debian GNU/Linux 9 (stretch)"
Noyau : Linux 4.7.9-64
(G)UI : LXDE
Inscription : 20-12-2016

Re : ACPI Warning ?

robert2a a écrit :

Bonsoir
tu parle de faire un essai , un essai de quoi ?



un essai de raccourci clavier (pas de quoi casser un serveur wink )

robert2a a écrit :

ta machine un portable  ?



oui

robert2a a écrit :

j ai trouvé quelques liens relatif a bumblebee a partir de ton message d erreur .
tu a gnome + gdm3 ?
tu est en stretch ou en sid ?
bien que le démarrage annonce stretch/sid , ça veut rien dire (c est stretch ) pour sid il faut une ligne dans ton sources.list avec "sid"
ps: surtout maintenant que stretch entre en phase de gel (en fait je veut savoir si tu a fait des mises a jours a partir de sid ou pas )



excuse-moi mais je débute, alors là tu me parles grec ops.gif


robert2a a écrit :

nota : a priori tu a cassé ton serveur X



j'ai rien cassé du tout, l'install est toute fraîche. à peine installé sur l'usb, quand je démarre Knoppix, j'ai ce msg "ACPI Warning"

D'aprés ce que je comprend il manque ce paquet "[Package] (20160422/nsarguments-95)" dans cette version de Knoppix 7.7.1.

Il doit être présent dans Knoppix 7.6.1 puisque je n'ai pas ce "Warning" avec.

Donc je réitère ma question, comment je trouve ce paquet et ensuite comment je l'installe ? sos.gif


« Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire. » -- E. Snowden

Hors ligne

#4 10-01-2017 00:46:42

Wilinux
Membre
Lieu : On the wild side
Distrib. : "Debian GNU/Linux 9 (stretch)"
Noyau : Linux 4.7.9-64
(G)UI : LXDE
Inscription : 20-12-2016

Re : ACPI Warning ?

Bon j'ai bossé un petit peu et j'avance smile

explications :

1/ je lance mon live Knoppix 7.6.1
2/ j'ouvre "Synaptic" et je recherche "acpi". Je trouve 6 paquets tous identiques à ceux qui se trouvent dans Knoppix 7.7.1 sauf 1

le paquet "acpid 2.0.25 alors que dans Knoppix 7.7.1 c'est le "acpid 2.0.28" donc je me dis le problème vient certainement de lui mwahaha.gif

j'ai trouvé ce fameux paquet "acpid-2.0.25.tar.xz" sur https://sourceforge.net/projects/acpid2/files/ qui marche avec Knoppix 7.6.1 yesss-napoleon-dynamite.gif

maintenant je voudrais :

1/désinstaller le 2.0.28
2/télécharger et installer le 2.0.25

mais je ne sais pas comment faire ops.gif

désinstaller : avec Synaptic je devrais y arriver mais si vous pouvez me dire comment faire en ligne de commande ce serait bien sympa cool
télécharger : c'est fait, le fichier est dans mon dossier téléchargements

et c'est maintenant que j'ai besoin de vous...

pour le dezipper car .tar.xz c'est des fichiers compressés je crois, et ensuite pour l'installer là où il faut

merci.gif d'avance pour votre aide

« Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire. » -- E. Snowden

Hors ligne

#5 10-01-2017 06:59:22

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : ACPI Warning ?

Decompresser un fichier.tar se fait avec la commande tar :
https://debian-facile.org/doc:systeme:tar

Installer un fichier.deb se fait avec la commande dpkg :
https://debian-facile.org/doc:systeme:apt:dpkg

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 10-01-2017 09:08:41

Wilinux
Membre
Lieu : On the wild side
Distrib. : "Debian GNU/Linux 9 (stretch)"
Noyau : Linux 4.7.9-64
(G)UI : LXDE
Inscription : 20-12-2016

Re : ACPI Warning ?

smolski a écrit :

Decompresser un fichier.tar se fait avec la commande tar :
https://debian-facile.org/doc:systeme:tar

Installer un fichier.deb se fait avec la commande dpkg :
https://debian-facile.org/doc:systeme:apt:dpkg



Bien matinal aujourd'hui, insomnies ? wink

merci pour les infos, là j'ai pas le temps, j'ai juste jeté un œil vite fait. Je verrai ça plus en détail ce soir en rentrant.

bonne journée


« Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire. » -- E. Snowden

Hors ligne

#7 10-01-2017 09:36:04

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : ACPI Warning ?

Bonjour

Wilinux a écrit :

…pour le dezipper car .tar.xz…

Il faudra vérifier que le paquetage xz-utils est installé,
et faire :

tar Jcvf acpid-2.0.25.tar.xz RépertoireDeDécompression

Dernière modification par MicP (10-01-2017 09:41:14)

Hors ligne

#8 10-01-2017 10:42:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : ACPI Warning ?

Allons 6 plombes du mat', ce n'est plus la nuit, s'pèce de citadin !
... character0143.gif

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 10-01-2017 14:13:23

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : ACPI Warning ?

Je ne pense pas que tu obtiennes un .deb en décompressant le fichier tar.xz
tu trouveras peut-être des instructions pour installer ou compiler une fois le fichier décompressé

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
->Le projet DFlinux (DebianFacileLinux) ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#10 10-01-2017 15:54:45

Croutons
Membre
Distrib. : Handylinux 2.5 vers debian 8.6
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : ACPI Warning ?

Bonjour
Chalu a pas tort , prend le direct en .deb
https://packages.debian.org/fr/sid/acpid
Il te reste a choisir le bon suivant l'architecture de ton ordi

En ligne

#11 10-01-2017 18:25:45

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : ACPI Warning ?

Non il veut revenir à une version précédente qui n'est plus disponible dans les dépôts. Je ne suis pas certaine que ça résoudra son problème dans la mesure où il compare deux versions de knoppix (7.6 vs 7.7) qui n'ont pas le même noyau non plus j'imagine.

Edit : il y a bien un README dans le fichier décompréssé

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
->Le projet DFlinux (DebianFacileLinux) ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#12 11-01-2017 00:24:22

Wilinux
Membre
Lieu : On the wild side
Distrib. : "Debian GNU/Linux 9 (stretch)"
Noyau : Linux 4.7.9-64
(G)UI : LXDE
Inscription : 20-12-2016

Re : ACPI Warning ?

MicP a écrit :

Bonjour
Il faudra vérifier que le paquetage xz-utils est installé,



Alors

apt-cache policy xz-utils

t'as vu chalu, je retiens tes cours wink

xz-utils:
  Installé : 5.1.1alpha+20120614-2.1
  Candidat : 5.2.2-1.2
 Table de version :
     5.2.2-1.2 500
        500 http://ftp.de.debian.org/debian testing/main i386 Packages
        500 http://ftp.de.debian.org/debian unstable/main i386 Packages
 *** 5.1.1alpha+20120614-2.1 100
        100 /UNIONFS/var/lib/dpkg/status
 


Donc Synaptic / recherche xz-utils / sélection pour mise à jour / accepter la gestion des dépendances / appliquer,

ops.gifdsl mais je ne connais pas la commande pour le faire depuis la console et en plus je ne maîtrise pas encore les histoires de dépendances et pi' Synaptic le fait pas trop mal apparemment. Si qq'un veut m'expliquer comment le faire à la console ou au pire à un lien, je suis preneur aussi wink

smolski a écrit :

Allons 6 plombes du mat', ce n'est plus la nuit, s'pèce de citadin !

non plutôt Gau-Xori, 6h du mat c'est l'heure ou je me couchais, avec le chant des oiseaux-canabis-je-vole.gif, j'adorais et j'adore encore ça big_smile

plus sérieusement pour les manips on verra demain si j'ai le temps, pask' là, s'il y a un truc qui merde, j'aurai pas le temps de corriger, ça va me contrarier donc va falloir que je solutionne et donc pas dormir. Je vous tac de ma progression dés que possible

merci.gif à toutétous pour votre aide wink


« Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire. » -- E. Snowden

Hors ligne

#13 11-01-2017 08:10:02

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : ACPI Warning ?

Bonjour smile
Pour l'installation avec une commande, c'est ce que tu as fais pour libreoffice. De par la construction particulière de knoppix quand tu veux mettre à jour, il faut que tu forces l'installion depuis le dépôt testing en utilisant l'option -t. Elle gère correctement les dépendances.
Pour tout savoir sur apt-get, tu as le wiki :
https://debian-facile.org/doc:systeme:apt:apt-get
Ici comme le paquet était déjà installé, tu n'étais pas obligé de le mettre à jour. Tu pouvais décompresser le fichier tar-xz
Tu peux aussi regarder si tu as une entrée avec un clic droit sur le fichier avec le choix "d'extraire" comme sur Windows et sur Debian avec la majorité des environnements.
Bon courage smile

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
->Le projet DFlinux (DebianFacileLinux) ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#14 13-01-2017 13:48:59

Wilinux
Membre
Lieu : On the wild side
Distrib. : "Debian GNU/Linux 9 (stretch)"
Noyau : Linux 4.7.9-64
(G)UI : LXDE
Inscription : 20-12-2016

Re : ACPI Warning ?

Alors j'ai bien réussi à désinstaller le acpid 2.0.28, j'ai également réussi à décompresser le fichier tar.xz et c'est là que ça ce complique sad

je me retrouve avec une multitude de fichier dont je ne sais pas à quoi ils peuvent bien servir.

Donc j'ai lu, relu et essayer de comprendre.

J'ai parcouru également le fichier README qui me dit "makefile" je suppose que c'est graĉe à ça que je devrais pouvoir obtenir un paquet ".deb" dont me parle chalu dans un post un peu plus haut. Mais bon pour l'instant ce n'est pas dans mes compétences ops.gif

Pour l'instant, je vais laisser le sujet ouvert et puis on verra si j'arrive à résoudre mon problème, je reviendrai vous donner ma solution et si entre temps quelqu'un veut bien m'expliquer ce que je peux bien faire de tous ces fichiers extrais  et comment le faire.

D’après ce que je comprends il faut que je compile ces fichiers avec une commande "make" ou "makefile" mais pour un débutant comme moi, c'est trop compliqué sans plus d'explication.

je prends les conseils, les liens, bref tout ce qui peut m'être utile

« Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire. » -- E. Snowden

Hors ligne

#15 13-01-2017 14:12:50

frei
Membre
Lieu : Tours
Distrib. : Stretch
(G)UI : Xfce4
Inscription : 06-01-2017
Site Web

Re : ACPI Warning ?

Voilà une question qu'elle est bonne smile
D'abord non, tu n'auras pas un .deb à la fin wink

Ensuite :
Lecture obligatoire des readme et autre install lisibles

Puis :
Configuration de l'installation :
./configure (param par défaut)
ou
./configure --prefix="nom_du_repertoire" (param personnalisé du répertoire d installation)

Compilation :

make nom_du_programme

Nettoyage :

make clean

Installation :

make install nom_du_programme

Si tu n'as jamais compilé avant il peut te manquer des dépendances...

"Glory. Rotting flower." John Tardy 1989

Hors ligne

#16 13-01-2017 14:18:50

frei
Membre
Lieu : Tours
Distrib. : Stretch
(G)UI : Xfce4
Inscription : 06-01-2017
Site Web

Re : ACPI Warning ?


"Glory. Rotting flower." John Tardy 1989

Hors ligne

#17 13-01-2017 16:23:30

Wilinux
Membre
Lieu : On the wild side
Distrib. : "Debian GNU/Linux 9 (stretch)"
Noyau : Linux 4.7.9-64
(G)UI : LXDE
Inscription : 20-12-2016

Re : ACPI Warning ?

frei a écrit :


Configuration de l'installation :
./configure (param par défaut)
ou
./configure --prefix="nom_du_repertoire" (param personnalisé du répertoire d installation)



knoppix@Microknoppix:~$ ./configure --prefix=/usr
bash: ./configure: Aucun fichier ou dossier de ce type
 



frei a écrit :

Compilation :

make nom_du_programme



knoppix@Microknoppix:~$ make acpid
make: *** Aucune règle pour fabriquer la cible « acpid ». Arrêt.



Apparemment il me manque un truc scratchhead.gif Faut peut être que je lui dise où se trouve le dossier des fichiers décompressés ? ou que je mette ce dossier à un endroit bien spécifique ?


le fichier README :

acpid version 2.0.15 introduced autoconf.  To build versions >= 2.0.15:

  $ ./configure --prefix=/usr
  $ make
  $ sudo make install

il ne m'en dit pas plus sad


« Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire. » -- E. Snowden

Hors ligne

Pied de page des forums