Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#101 13-02-2017 19:24:10

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Soiiiirrrrr smile

Bon alors, j'ai remis mon image de Stretch, apt-listbugs, bloque trois paquets. Firefox ESR, SystemD, et Network manager. Ne connaissant pas Debian, comment cela se passe t'il? Dès que les paquets sont corrigés, ils sont remis automatiquement dans la liste des paquets installable, ou bien une intervention manuelle est nécessaire?

Par contre, je ne vois pas de virtualbox???? Ni même dans les "Debian Packages".

Hors ligne

#102 13-02-2017 20:27:11

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonsoir
pour firefox il y a un problème sur jessie et stretch
pour network manager idem
systemd je sais pas , j'ai rien en attente
avec synaptic tu les décoche et ils vont rester dans la liste a mettre a jour (il y a un message qui te dit la gravité et si une version corrigée )
après il faut le temps que ce soit corrigé , ça peut etre long .....
nota : en console je sais pas comment on gère cela , avec quoi tu fais les mises a jours ?

pour virtualbox et debian packages j'ai pas compris ta question

pour systemd par exemple  => https://packages.qa.debian.org/s/systemd.html
il y a quelques bugs tongue

Dernière modification par robert2a (13-02-2017 20:32:08)

Hors ligne

#103 13-02-2017 20:37:34

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Salut !! smile

Concernant Virtualbox, il n'est pas dans les dépots??

Merci pour l'explication, concernant apt-listbugs wink

Je fais mes mises à jour via la console smile

Seul truc qui "cloche", GUFW qui plante big_smile


root@Debian:/home/seb# gufw
Traceback (most recent call last):
  File "/usr/share/gufw/gufw/gufw.py", line 30, in <module>
    gufw = Gufw(controler.get_frontend())
  File "/usr/share/gufw/gufw/gufw/view/gufw.py", line 81, in __init__
    self.winadd = Add(self)
  File "/usr/share/gufw/gufw/gufw/view/add.py", line 43, in __init__
    self._set_initial_values()
  File "/usr/share/gufw/gufw/gufw/view/add.py", line 101, in _set_initial_values
    for ifaceName in self.gufw.fw.get_net_interfaces():
  File "/usr/share/gufw/gufw/gufw/model/frontend.py", line 126, in get_net_interfaces
    return self.firewall.get_net_interfaces(exclude_iface)
  File "/usr/share/gufw/gufw/gufw/model/firewall.py", line 251, in get_net_interfaces
    all_faces = self.backend.get_net_interfaces()
  File "/usr/share/gufw/gufw/gufw/model/ufw_backend.py", line 462, in get_net_interfaces
    cmd = self._run_cmd(cmd_ifaces)
  File "/usr/share/gufw/gufw/gufw/model/ufw_backend.py", line 37, in _run_cmd
    proc = subprocess.Popen(cmd, shell=False, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
  File "/usr/lib/python3.5/subprocess.py", line 676, in __init__
    restore_signals, start_new_session)
  File "/usr/lib/python3.5/subprocess.py", line 1282, in _execute_child
    raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] Aucun fichier ou dossier de ce type: 'netstat'



Sous XFCE...

Dernière modification par vigen (13-02-2017 20:42:18)

Hors ligne

#104 13-02-2017 20:46:31

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

exact virtualbox absent de stretch , il est dans sid =>  https://packages.debian.org/fr/sid/virtualbox

je connais pas GUFW, il a 2 bugs  =>  https://packages.qa.debian.org/g/gui-ufw.html  (par contre grosse différence de version entre jessie et stretch )

Synaptic fonctionne sous Xfce ? , ( sur mate il n y a pas de soucis a part quelques dépendances de gnome )
il est pratique et simple a utiliser  smile

Dernière modification par robert2a (13-02-2017 20:52:58)

Hors ligne

#105 13-02-2017 21:48:00

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonsoir,

Oui oui, pas de soucis pour Synaptic smile

Concernant Virtualbox, ce qui est interessant c'est qu'un paquet existe pour Stretch sur le site d'Oracle :

https://www.virtualbox.org/wiki/Linux_Downloads

Concernant GUFW, je configure, en attendant, UFW directement via la console wink

J'avais essayer Gnome, mais des applis plantaient...XFCE me va bien, je vais essayer de me faire quelque chose "sur mesure" !! smile

Désolé de ces questions, qui peuvent paraitre "novice", mais Debian, est un nouveau continent pour moi smile

Nous parlions des paquets "bloqués" par apt list-bugs.

Après un apt update && apt upgrade, je me retrouve avec ce retour de commande:

Lecture des informations d'état... Fait
7 packages can be upgraded. Run 'apt list --upgradable' to see them.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libnma0 libsystemd0 libudev1 udev
0 mis à jour, 0 nouvellement installés, 0 à enlever et 4 non mis à jour.
root@Debian:/home/seb# apt list --upgradable
En train de lister... Fait
firefox-esr-l10n-fr/testing 45.7.0esr-1 all [upgradable from: 45.6.0esr-1]
libnma0/testing 1.4.4-1 amd64 [upgradable from: 1.4.2-1]
libpam-systemd/testing 232-15 amd64 [upgradable from: 232-8]
libsystemd0/testing 232-15 amd64 [upgradable from: 232-8]
libudev1/testing 232-15 amd64 [upgradable from: 232-8]
network-manager-gnome/testing 1.4.4-1 amd64 [upgradable from: 1.4.2-1]
udev/testing 232-15 amd64 [upgradable from: 232-8]
root@Debian:/home/seb#
 



Les paquets pointés par apt list --upgradable, sont ils ceux bloqués précédemment?

Par contre, pour revenir a Synaptic, si je veux utiliser l'option "Mettre à niveau", il souhaite me désinstaller la moitié de la distro big_smile

Synaptic

Alors qu'avec Apt, rien...Etrange tout de même.

Dernière modification par vigen (13-02-2017 22:15:32)

Hors ligne

#106 13-02-2017 22:25:41

Mercredi
Membre
Distrib. : Testing
Noyau : 4.12
(G)UI : Gnome
Inscription : 25-09-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonsoir,

Sinon pour rester dans les dépôts, il y virt-manager qui est bien pour faire des Vm smile

Ps : chez moi aptlistbugs n'a pas râlé pour Network-manager (1.6.0-1, je viens de regarde la liste de bugs est longue) scratchhead.gif bon pour l'instant je n'ai rien remarqué de spécial.

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#107 13-02-2017 22:29:55

Mercredi
Membre
Distrib. : Testing
Noyau : 4.12
(G)UI : Gnome
Inscription : 25-09-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Avec le terminal, pour bloquer les paquets signalés par apt-listbugs, il faut répondre p ; le wiki si tu ne l'a pas encore lu : https://debian-facile.org/doc:systeme:apt:apt-listbugs

Elle est ancienne ta version de network-manager, ça fait un moment que tu n'a pas fait les maj ?

Re edit : avec l'épinglage des paquets (p) chez moi ils ne se débloquent pas tout seuls quand le bug est corrigé, faut aller vider le fichier dans /etc/apt/apt/listbugs

Dernière modification par Mercredi (13-02-2017 22:34:27)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#108 13-02-2017 22:53:50

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonsoir Mercredi smile

Merci pour ces réponses.

Concernant Apt-listbugs j'ai lu le wiki smile Et je fait bien attention à mes réponses.

Concernant Network manager, mon image date du 03 Février.

Concernant /etc/apt/apt/listbugs de quel fichier parles-tu?

Edit: /etc/apt/preferences.d/apt-listbugs     C'est bien celui-ci?

virt-manager je ne connais pas, mais j'ai déjà des VM prêtes pour Virtualbox, je ne sais pas si installer le .deb fournis par Oracle, représenterais un problème potentiel de stabilité?

Vigen.

Dernière modification par vigen (13-02-2017 23:07:00)

Hors ligne

#109 14-02-2017 03:43:28

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonsoir
voila le message de apt-listbugs


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
bogues de gravité grave sur network-manager (1.4.4-1 → 1.6.0-1) <Transférés>
 b1 - #854343 - network-manager: The search domain string in resolv.conf is being duplicated leading to problems with DNS
Résumé :
 network-manager(1 bogue)
Êtes-vous certain(e) de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]
 



j'utilise un fichier "interfaces" je peu l enlever si besoin roll
j'ai la version 1.4.4-1 installé

Hors ligne

#110 14-02-2017 06:41:34

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonjour,

Concernant Virtualbox; vu que l'on est en période de freeze, le paquet ne va pas être inclus? Cela me parais étrange, c'est quand même un logiciel très très utilisé.

Vigen.


Edit: En fouinant un peu: https://wiki.debian.org/VirtualBox#Debi … Stretch.22  C'est quand même dommage de passer par un dépot "tiers".

Dernière modification par vigen (14-02-2017 06:48:26)

Hors ligne

#111 14-02-2017 10:22:20

Mercredi
Membre
Distrib. : Testing
Noyau : 4.12
(G)UI : Gnome
Inscription : 25-09-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonjour,

@Vigen oui c'est le fichier /etc/apt/preferences.d/apt-listbugs, j'ai écrit un peu vite hier soir sans vérifier le chemin exact hmm

Concernant Virtualbox; ... c'est quand même un logiciel très très utilisé.


Et je me demande bien pourquoi, je l'ai essayé (et même utilisé pour choisir ma distro sous Windows avant de franchir le pas du dual boot) mais pour la performance/fluidité, j'ai des meilleurs résultats avec Kvm + Virt-manager pour l'interface graphique et conviviale. La force de l'habitude peut-être ou bien moi qui ne sait pas configurer Virtualbox tongue

@Robert merci pour le message de apt-listbugs.
J'ai cherché dans mon historique et c'est moins vieux que je pensais : 1.6.0-1 installé le 5 février. Je fais les majs tous les jours, Il y en avait beaucoup ce jour là ... soit mes yeux ont bogués soit c'est apt-listbugs. Dans le doute je vais le purger et le réinstaller (peux pas faire pareil avec les yeux lol )


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#112 14-02-2017 11:10:19

MisterV
Membre
Distrib. : Debian 9 Stretch X64
Noyau : 4.9LTS
(G)UI : Xfce 4.12
Inscription : 03-01-2017

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Ouais enfin Virtualbox ce n'est pas très gênant qu'il n'y soit pas, il y a avait au moins 5 méthodes différentes pour l'installer sur Jessie !

Il y a par exemple un dépôt Debian spécialement pour Virtualbox sur le site d'Oracle dont 1 spécialement pour Stretch.
(Et l'avantage c'est qu'avec leur dépôt, vous avez toujours la dernière version stable de Virtualbox, elle n'est pas gelé dans une version précise).

(a vrai dire, même sous Jessie, j'utilisais déjà le dépôt d'Oracle pour éviter de rester sur la vieille version 4 de Virtualbox...).

Si vous voulez l'installer :

- Ajouter dans vos sources le dépot suivant :

deb http://download.virtualbox.org/virtualbox/debian stretch contrib



et ajouter la clé de sécurité :

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -



Enfin pour l'installer :

sudo apt update
sudo apt install virtualbox-5.1

Hors ligne

#113 14-02-2017 11:13:54

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

MisterV a écrit :

Ouais enfin Virtualbox ce n'est pas très gênant qu'il n'y soit pas, il y a avait au moins 5 méthodes différentes pour l'installer sur Jessie !

Il y a par exemple un dépôt Debian spécialement pour Virtualbox sur le site d'Oracle dont 1 spécialement pour Stretch.
(Et l'avantage c'est qu'avec leur dépôt, vous avez toujours la dernière version stable de Virtualbox, elle n'est pas gelé dans une version précise).

(a vrai dire, même sous Jessie, j'utilisais déjà le dépôt d'Oracle pour éviter de rester sur la vieille version 4 de Virtualbox...).

Si vous voulez l'installer :

- Ajouter dans vos sources le dépot suivant :

deb http://download.virtualbox.org/virtualbox/debian stretch contrib



et ajouter la clé de sécurité :

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -



Enfin pour l'installer :

sudo apt update
sudo apt install virtualbox-5.1



Bonjour smile

Oui, tout est dans le lien du commentaire #110 wink

Vigen.

Hors ligne

#114 14-02-2017 11:17:42

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Mercredi a écrit :

Bonjour,

@Vigen oui c'est le fichier /etc/apt/preferences.d/apt-listbugs, j'ai écrit un peu vite hier soir sans vérifier le chemin exact hmm

Concernant Virtualbox; ... c'est quand même un logiciel très très utilisé.


Et je me demande bien pourquoi, je l'ai essayé (et même utilisé pour choisir ma distro sous Windows avant de franchir le pas du dual boot) mais pour la performance/fluidité, j'ai des meilleurs résultats avec Kvm + Virt-manager pour l'interface graphique et conviviale. La force de l'habitude peut-être ou bien moi qui ne sait pas configurer Virtualbox tongue

@Robert merci pour le message de apt-listbugs.
J'ai cherché dans mon historique et c'est moins vieux que je pensais : 1.6.0-1 installé le 5 février. Je fais les majs tous les jours, Il y en avait beaucoup ce jour là ... soit mes yeux ont bogués soit c'est apt-listbugs. Dans le doute je vais le purger et le réinstaller (peux pas faire pareil avec les yeux lol )



Bonjour Mercredi smile

Je dirais que j'ai la force de l'habitude avec Virtualbox wink

Merci pour le chemin du fichier.

"Dans le doute je vais le purger et le réinstaller"

Cela arrive souvent avec apt-listbugs ?

Vigen.

Hors ligne

#115 14-02-2017 12:57:14

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonjour
comme c'est très calme , un peu de folie hmm
installation du noyau 4.10 a partir d'experimental (et avec synaptic , chose que je fais en console habituellement )
le souci est les outils du driver non free nvidia , en libre je pense que cela doit etre correct (je suis revenu en arrière , sinon plus de serveur X )


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet linux-headers-4.10.0-rc6-common précédemment désélectionné.
(Lecture de la base de données... 191564 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-headers-4.10.0-rc6-common_4.10~rc6-1~exp2_all.deb ...
Dépaquetage de linux-headers-4.10.0-rc6-common (4.10~rc6-1~exp2) ...
Sélection du paquet linux-kbuild-4.10 précédemment désélectionné.
Préparation du dépaquetage de .../linux-kbuild-4.10_4.10~rc6-1~exp2_amd64.deb ...
Dépaquetage de linux-kbuild-4.10 (4.10~rc6-1~exp2) ...
Sélection du paquet linux-headers-4.10.0-rc6-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../linux-headers-4.10.0-rc6-amd64_4.10~rc6-1~exp2_amd64.deb ...
Dépaquetage de linux-headers-4.10.0-rc6-amd64 (4.10~rc6-1~exp2) ...
Sélection du paquet linux-image-4.10.0-rc6-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../linux-image-4.10.0-rc6-amd64_4.10~rc6-1~exp2_amd64.deb ...
Dépaquetage de linux-image-4.10.0-rc6-amd64 (4.10~rc6-1~exp2) ...
Paramétrage de linux-kbuild-4.10 (4.10~rc6-1~exp2) ...
Paramétrage de linux-image-4.10.0-rc6-amd64 (4.10~rc6-1~exp2) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-4.9.0-1-amd64
I: /initrd.img.old is now a symlink to boot/initrd.img-4.9.0-1-amd64
I: /vmlinuz is now a symlink to boot/vmlinuz-4.10.0-rc6-amd64
I: /initrd.img is now a symlink to boot/initrd.img-4.10.0-rc6-amd64
/etc/kernel/postinst.d/dkms:
Error! Bad return status for module build on kernel: 4.10.0-rc6-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/375.26/build/make.log for more information.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.10.0-rc6-amd64
/etc/kernel/postinst.d/zz-update-grub:
Création du fichier de configuration GRUB…
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Image Linux trouvée : /boot/vmlinuz-4.10.0-rc6-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-rc6-amd64
Image Linux trouvée : /boot/vmlinuz-4.9.0-1-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-1-amd64
Image Linux trouvée : /boot/vmlinuz-4.8.0-2-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.8.0-2-amd64
fait
Paramétrage de linux-headers-4.10.0-rc6-common (4.10~rc6-1~exp2) ...
Paramétrage de linux-headers-4.10.0-rc6-amd64 (4.10~rc6-1~exp2) ...
/etc/kernel/header_postinst.d/dkms:
Error! Bad return status for module build on kernel: 4.10.0-rc6-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/375.26/build/make.log for more information.
 


je suis aller voir le log de dkms mais ça dépasse mes compétences  tongue


echo >&2;             \
echo >&2 "  ERROR: Kernel configuration is invalid.";   \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";  \
echo >&2 ; 
 


je pense qu'avec ce noyau et mesa version 17.xx on va avoir bien plus de matériel vidéo reconnu en natif .
nota : matériel Asrock G41C dual core 6320 1.8Ghz , pas tout jeune smile
ps: a part le linux-image-amd64 et le linux-headers-amd64 (métapaquets ) tout est présent pour l installer

pour passer le temps roll  j'ai basculé cette machine en sid , trouvé un seul paquet contenant un bug (répertorié par apt-listbugs) et qui touche wayland d'après la description


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
bogues de gravité grave sur libwebkit2gtk-4.0-37 (2.14.3-1 → 2.14.4-1) <Transférés>
 b1 - #855103 - Rendering fails on wayland/hidpi
Résumé :
 libwebkit2gtk-4.0-37(1 bogue)
Êtes-vous certain(e) de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]
 


nota: la machine a très peu de programme installé

Dernière modification par robert2a (14-02-2017 15:47:11)

Hors ligne

#116 14-02-2017 22:16:35

Mercredi
Membre
Distrib. : Testing
Noyau : 4.12
(G)UI : Gnome
Inscription : 25-09-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

vigen a écrit :


Merci pour le chemin du fichier.

"Dans le doute je vais le purger et le réinstaller"

Cela arrive souvent avec apt-listbugs ?

Vigen.


Je n'ai pas assez de recul pour dire.
Il a fonctionné normalement il n'y a pas très longtemps (quand je suis allée chercher Firefox 51 dans Sid il m'a bien dit que le paquet était bogué). Je ne pense pas non plus avoir loupé l'avertissement puisqu'il faut valider scratchhead.gif mais va savoir, j'étais peut-être vraiment mal réveillée.

robert2a a écrit :

Bonjour
comme c'est très calme , un peu de folie


lol


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#117 14-02-2017 22:17:39

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonsoir smile

Severian as trouver le problème concernant GUFW.

Il manque le paquet net-tools, qui n'est pourtant pas dans les dépendances.

Un grand merci à lui wink

Si ça peux servir..

Vigen.

Dernière modification par vigen (14-02-2017 23:20:21)

Hors ligne

#118 14-02-2017 23:23:37

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

une idée ....

le paquets net-tools fait parti des paquets installé à la base dans jessie (il fournit entre autre la commande ifconfig)
par contre j'ai constaté qu'il ne fait pas partie des paquets installé de base avec stretch

les personnes chargé d'empackter les packets et d’indiquer leur dépendances auraient elles pu passer à coté de ce fait ??

je ne sais pas trop si j'explique bien ...
exemple :
je suis responsable du paquet gufw, pour jessie je ne fait pas attention à la dépendance qu'a mon paquet à net-tools car il est installé de base avec la distribution.
je fais de même avec le paquet pour stretch, mais problème net-tools ne fait plus partie des paquets de base de la distribution ....

c'est possible un truc du genre ????

Dernière modification par Severian (14-02-2017 23:24:13)


"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

En ligne

#119 15-02-2017 06:18:12

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonjour

le paquet est bien dans stretch  =>  https://packages.debian.org/fr/stretch/net-tools

je vais devoir vérifier sur toutes les machines , le problème si j'ai installé stretch a partir d une jessie (dist-upgrade) ça peut etre un faux positif  roll
j'ai bien compris ce que tu veut dire  hmm  sur une installation nouvelle de stretch le paquet n'est plus installé automatiquement  .


Ce paquet contient des outils importants pour contrôler le sous-système
réseau du noyau Linux. Cela inclut arp, ifconfig, netstat, rarp, nameif et
route.
 

Hors ligne

#120 16-02-2017 11:04:02

MisterV
Membre
Distrib. : Debian 9 Stretch X64
Noyau : 4.9LTS
(G)UI : Xfce 4.12
Inscription : 03-01-2017

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Il me semble que j'avais entendu dire qu'il ne fallait plus utiliser la commande "ifconfig" car c'était "déprécié", sous ArchLinux aussi il n'y a pas ce paquet par défaut si vous installez le système de base + un environnement de bureau.

Sinon j'ai vu sur la liste de diffusion que Icedove disparaît pour être remplacé par le nom/icône originale c'est a dire Thunderbird, cela vient d'être fait dans la version "Sid" qui n'a plus Icedove mais Thunderbird, est ce que ça sera pareil pour Stretch ? Jessie ? logiquement oui vu qu'ils avait changé le nom iceweasel en firefox sur la version stable.

Hors ligne

#121 16-02-2017 11:18:07

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

MisterV a écrit :

Il me semble que j'avais entendu dire qu'il ne fallait plus utiliser la commande "ifconfig" car c'était "déprécié", sous ArchLinux aussi il n'y a pas ce paquet par défaut si vous installez le système de base + un environnement de bureau.



c'est peut être le cas, mais visiblement Gufw est dépendant de ce paquet (net-tools) sans qu'il soit indiqué neutral


"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

En ligne

#122 16-02-2017 11:23:09

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonjour
la version de Mesa de stretch (13) vient de passer dans les backports de jessie , peut intéresser les utilisateurs du driver libre .

Hors ligne

#123 16-02-2017 16:53:22

vigen
Membre
Lieu : Normandie
Distrib. : Debian Stretch/Slackware
Noyau : Linux 4.9/Linux 4.4
(G)UI : Plasma/KDE4
Inscription : 10-10-2015

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Severian a écrit :

MisterV a écrit :

Il me semble que j'avais entendu dire qu'il ne fallait plus utiliser la commande "ifconfig" car c'était "déprécié", sous ArchLinux aussi il n'y a pas ce paquet par défaut si vous installez le système de base + un environnement de bureau.



c'est peut être le cas, mais visiblement Gufw est dépendant de ce paquet (net-tools) sans qu'il soit indiqué neutral




A terme la commande "IP" remplaceras "ifconfig", effectivement. Le paquet "net-tools" (plus particulièrement l'outil netstat) est effectivement nécessaire pour Gufw, du moins dans sa version actuelle. smile

Hors ligne

#124 20-02-2017 15:02:27

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Bonjour
petite mise a jour du noyau 4.9 dans sid , dans 10 jours environ (si tout va bien ) dans stretch .
nota : je vais bien tomber sur la bonne qui m' enlève ces vilains messages au démarrage roll

Hors ligne

#125 20-02-2017 21:29:26

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS / Salix
Noyau : 4.12.13 & 4.9.49 / 4.4.75
(G)UI : Plasma5 / XFCE 4.12
Inscription : 05-03-2014

Re : Debian 9 : noyau définitif 4.9 ou 4.10 ? [edit: c'est le 4.9LTS]

Et le 4.10 est sorti aujourd'hui !


https://www.kernel.org/

PCLinuxOS KDE Plasma 5.10.5 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
PCLinuxOS KDE Plasma 5.10.5 sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
Salix 14.2 XFCE 4.12.3+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

Pied de page des forums