Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-01-2017 11:35:15

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

[résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Bonjour,

Je suis un peu bloqué par les dernières mises à jour.

apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libegl-nvidia0 libegl1-glvnd-nvidia libegl1-nvidia libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgldispatch0-nvidia libgles-nvidia1
  libgles-nvidia2 libgles1-glvnd-nvidia libgles1-nvidia libgles2-glvnd-nvidia libgles2-nvidia libglx-nvidia0 libglx0-glvnd-nvidia
  libnvidia-cfg1 libnvidia-eglcore libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libopengl0-glvnd-nvidia nvidia-alternative
  nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-kernel-dkms nvidia-kernel-support nvidia-vdpau-driver nvidia-vulkan-icd
  xserver-xorg-video-nvidia
0 mis à jour, 0 nouvellement installés, 0 à enlever et 29 non mis à jour.
 



apt full-upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  libegl1-glvnd-nvidia
Les paquets suivants seront mis à jour :
  libegl-nvidia0 libegl1-nvidia libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgldispatch0-nvidia libgles-nvidia1 libgles-nvidia2
  libgles1-glvnd-nvidia libgles1-nvidia libgles2-glvnd-nvidia libgles2-nvidia libglx-nvidia0 libglx0-glvnd-nvidia libnvidia-cfg1
  libnvidia-eglcore libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libopengl0-glvnd-nvidia nvidia-alternative nvidia-driver
  nvidia-driver-bin nvidia-driver-libs nvidia-kernel-dkms nvidia-kernel-support nvidia-vdpau-driver nvidia-vulkan-icd
  xserver-xorg-video-nvidia
28 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 36,0 Mo dans les archives.
Après cette opération, 2 139 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] n
 



j'ai pas mieux avec aptitude.

 aptitude show libegl1-glvnd-nvidia


Paquet : libegl1-glvnd-nvidia                          
Nouveau: oui
État: installé
Automatiquement installé: oui
Multiarchitecture : même
Version : 367.57-2~bpo8+1
Priorité : optionnel
Section : non-free/libs
Responsable : Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Architecture : amd64
Taille décompressée : 190 k
Dépend: nvidia-alternative (= 367.57-2~bpo8+1), glvnd-nvidia-abi-361.45, libc6 (>= 2.2.5), libgldispatch0 | libgldispatch0-nvidia (>=
         361.45)
Pré-dépend: multiarch-support
Casse: libegl1-nvidia (< 355.11-3), libegl1-nvidia (< 355.11-3), libegl1-glvnd-nvidia (!= 367.57-2~bpo8+1)
Remplace: libegl1-nvidia (< 355.11-3), libegl1-nvidia (< 355.11-3), libegl1-glvnd-nvidia (< 367.57-2~bpo8+1)
Description : NVIDIA binary EGL GLVND stub library
 EGL provides a platform-agnostic mechanism for creating rendering surfaces for use with other graphics libraries, such as OpenGL|ES.
 
 This package contains the (binary) GLVND libEGL.so.1 stub library provided by NVIDIA which dispatches to vendor implementations
 (libEGL_*.so.0) via GLVND.
Site : http://www.nvidia.com

Étiquettes: role::shared-lib
 



une solution ou je laisse comme ça ?

Hors ligne

#2 17-01-2017 11:48:24

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Bonjour
tu a quoi comme carte vidéo ?
il est possible de bloquer le driver actuel avec synaptic par exemple et de reprendre la mise a jour plus tard juste pour le driver vidéo.
tu peut donner ta version actuelle du driver et celle qui veut installer
je regarde ton log

tu a le driver des backports ?
un # devant la ligne des backports va t enlever les mises a jour du driver nvidia dans ce cas (personnellement avec jessie je suis en 367.xx que je ne met plus a jour)
je n ai que le driver qui provient des backports

sinon le plus propre si tu a des conflits de paquets, c est purge du driver actuel et ré-installation , ça dépend si le driver proposé apporte quelque chose au fonctionnement de ta carte vidéo.

ma version actuelle sur jessie 367.57.0-2  (bloqué , prend en charge les dernières GTX10xx )

Dernière modification par robert2a (17-01-2017 12:00:41)

Hors ligne

#3 17-01-2017 12:01:59

golgot200
Membre
Inscription : 05-08-2007

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Bonjour,

Vire le paquet je pense, puis mais à jour les 28 autres.

Ma mise à jour au cas où bien que différente avec les backports :

Start-Date: 2017-01-10  14:56:24
Commandline: apt-get upgrade
Upgrade: nvidia-legacy-check:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-vulkan-common:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1)
End-Date: 2017-01-10  14:56:35

Start-Date: 2017-01-10  14:57:57
Commandline: apt-get dist-upgrade
Install: nvidia-egl-icd:amd64 (375.26-1~bpo8+1, automatic), nvidia-egl-common:amd64 (375.26-1~bpo8+1, automatic)
Upgrade: libnvcuvid1:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-alternative:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libopengl0-glvnd-nvidia:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libnvidia-cfg1:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libglx0-glvnd-nvidia:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-vulkan-icd:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-driver:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libegl1-glvnd-nvidia:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), xserver-xorg-video-nvidia:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libnvidia-fatbinaryloader:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libcuda1:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libnvidia-glcore:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libgles1-glvnd-nvidia:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-kernel-support:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-opencl-icd:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libglx-nvidia0:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-driver-libs:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libgles2-glvnd-nvidia:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libgles-nvidia1:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libgles-nvidia2:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libnvidia-compiler:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libgl1-nvidia-glx:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-kernel-dkms:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libnvidia-ml1:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libnvidia-ptxjitcompiler:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libgldispatch0-nvidia:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-vdpau-driver:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-driver-bin:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libegl-nvidia0:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), nvidia-smi:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1), libnvidia-eglcore:amd64 (367.57-2~bpo8+1, 375.26-1~bpo8+1)
End-Date: 2017-01-10  15:03:07

Hors ligne

#4 17-01-2017 12:07:34

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Oui aussi , virer le paquet , donc si je comprend bien ils ont mit aussi le 375 dans les backports de jessie .
donc impossible maintenant de mettre autre chose que ce driver 375.xx (jessie et stretch ) pas cool ça hmm

donc si tu tente de mettre le 375 , ça m étonne pas que tu ai des soucis hmm

la encore , mettre le dernier driver nvidia sur une future old-stable ça impose l utilisation du 340.xx en cas de souci avec des cartes anciennes .
tout ça pour avoir les dernières technologies que la plus part des cartes ne savent pas utiliser ( comme les lunettes 3D et autres gadgets ).
bon je m en doutais un peu tongue , d'ou le blocage de la mise a jour des backports roll

Dernière modification par robert2a (17-01-2017 12:17:02)

Hors ligne

#5 17-01-2017 12:12:01

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Bonjour,
Quel est le problème avec ce driver 375 ?

Hors ligne

#6 17-01-2017 12:12:14

golgot200
Membre
Inscription : 05-08-2007

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Regarde le fichier de control de libegl1-glvnd-nvidia :

Depends: nvidia-alternative (= 375.26-1~bpo8+1), glvnd-nvidia-abi-375.20, libc6 (>= 2.2.5), libgldispatch0 | libgldispatch0-nvidia (>= 375.20)
Conflicts: libegl1-nvidia
Replaces: libegl1-nvidia



Enfin, je sais pas. hmm

Dernière modification par golgot200 (17-01-2017 12:13:11)

Hors ligne

#7 17-01-2017 12:23:12

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

chalu a écrit :

Bonjour,
Quel est le problème avec ce driver 375 ?



aucun en utilisation normale , sauf qu il fait dans l urgence (je parle de nvidia ) , que pour win il est déja en 376.xx (correction de bug )
et que pour linux nvidia prend son temps

ceci pour une prise en charge des gpu pascal (serie GTX10xx ) et des nouvelles technologies.

je ne vois pas pourquoi forcer ce driver dans jessie (ce qui nous laisse le choix entre 340,xx , 367,xx et pour ceux qui veulent le dernier cri stretch et 375.xx )

vous l'avez compris je suis en mode old_geek.gif

hmm
mode / mwahaha.gif
ps: ce serait plus productif de s'occuper de nouveau et du cas des portables
fin mode / mwahaha.gif

cool

@golgot200

par exemple pour toi avec la GTX780TI ce driver ne ce justifie pas , n' apporte rien de plus sur la gestion de la carte . (meme cuda (tu dois utiliser la version 3 avec cette carte , le driver installe la 8 )) et ta carte ne va pas fonctionner en 4K par exemple ( ou du free sync et l autre de chez nvidia )

sur une GTX1060 j utilise le 6.1 pour un driver cuda 8000 avec le driver 367.xx  (sous jessie et stretch )
sous stretch j attend un driver plus propre et uniquement pour gpu pascal (les kepler et maxwell , le 367 est plus que suffisant )
et vous savez que je ne suis pas tendre avec les gpu , aucun ne s'ennuie  wink
d'ailleurs sous win c 'est la meme chose , vous ne savez peut etre pas mais vista par exemple ne prend pas en charge les gpu pascal (vous ne trouverez pas de driver compatible pour vista )

Dernière modification par robert2a (17-01-2017 12:49:54)

Hors ligne

#8 17-01-2017 13:18:30

golgot200
Membre
Inscription : 05-08-2007

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

robert2a a écrit :



@golgot200

par exemple pour toi avec la GTX780TI ce driver ne ce justifie pas , n' apporte rien de plus sur la gestion de la carte . (meme cuda (tu dois utiliser la version 3 avec cette carte , le driver installe la 8 )) et ta carte ne va pas fonctionner en 4K par exemple ( ou du free sync et l autre de chez nvidia )

sur une GTX1060 j utilise le 6.1 pour un driver cuda 8000 avec le driver 367.xx  (sous jessie et stretch )
sous stretch j attend un driver plus propre et uniquement pour gpu pascal (les kepler et maxwell , le 367 est plus que suffisant )
et vous savez que je ne suis pas tendre avec les gpu , aucun ne s'ennuie  wink
d'ailleurs sous win c 'est la meme chose , vous ne savez peut etre pas mais vista par exemple ne prend pas en charge les gpu pascal (vous ne trouverez pas de driver compatible pour vista )




Ce qui veux dire que même pour les corrections de bugs, je ne dois pas installer les versions à venir. C'est pas utile.
Bizarroide ton truc smile

Dernière modification par golgot200 (17-01-2017 13:19:27)

Hors ligne

#9 17-01-2017 13:26:45

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Sérieux tu a des bugs avec cette carte ?

Après tu est libre de choisir ta méthode , pour les corrections de bug commence par stretch mais la aussi ma façon de traiter le problème est la meme , a chaque génération de materiel sa debian .
ce qui ne m empeche pas de tester stretch meme avec du vieux matos plus par curiosité en sachant que je suis pas a l abrit d un pépin éventuel wink

ps: pour la compatibilité de ta carte tu peu vérifier sur le site nvidia avec un driver d une version , après pour le gain apporté je reste sur ma postion .
la course au version pour un driver de carte vidéo n'est pas justifié , a la rigueur si tu a un problème particulier sur un jeux et que un certain driver le corrige oui la mise a jour peut etre utile.
mais te fais pas d illusion nvidia travaille sur le futur donc si tu a encore un bug il ne sera jamais résolu .et pour la compatibilité de ta carte avec la sortie de nouveau jeux elle se réduit a peau de chagin chaque jour
c'est la loi de la consommation et nous en somme tous victime .

Dernière modification par robert2a (17-01-2017 13:36:58)

Hors ligne

#10 17-01-2017 13:32:47

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

@robert2a:
j'ai une nvidia gtx660

pour le driver nvidia, c'est le driver des backports.

aptitude show nvidia-driver


Paquet : nvidia-driver                                  
État: installé
Automatiquement installé: oui
Version : 367.57-2~bpo8+1
Priorité : optionnel
Section : non-free/x11
Responsable : Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Architecture : amd64
Taille décompressée : 1 108 k
Dépend: nvidia-driver-libs (= 367.57-2~bpo8+1), nvidia-driver-bin (= 367.57-2~bpo8+1), xserver-xorg-video-nvidia (= 367.57-2~bpo8+1),
         nvidia-vdpau-driver (= 367.57-2~bpo8+1), nvidia-alternative (= 367.57-2~bpo8+1), nvidia-kernel-dkms (= 367.57-2~bpo8+1) |
         nvidia-kernel-367.57, nvidia-support
Pré-dépend: nvidia-installer-cleanup, nvidia-legacy-check (>= 343)
Recommande: nvidia-settings (>= 367), nvidia-persistenced
Suggère: nvidia-kernel-dkms (>= 367.57) | nvidia-kernel-source (>= 367.57)
Est en conflit: nvidia-driver
Casse: nvidia-glx, nvidia-glx
Remplace: nvidia-glx, nvidia-glx
Fournit: nvidia-glx-any
Description : NVIDIA metapackage
 This metapackage depends on the NVIDIA binary driver and libraries that provide optimized hardware acceleration of OpenGL applications via
 a direct-rendering X Server. AGP, PCIe, SLI, TV-out and flat panel displays are also supported.
 
 Please see the nvidia-kernel-dkms or nvidia-kernel-source packages for building the kernel module required by this package. This will
 provide nvidia-kernel-367.57.
 
 This version only supports GeForce, Quadro, NVS, Tesla, ... GPUs based on the Fermi, Kepler, Maxwell, or newer architectures.  Look at the
 legacy packages for older cards.
 
 See /usr/share/doc/nvidia-driver/README.txt.gz for a complete list of supported GPUs and PCI IDs.
 
 Building the kernel module has been tested up to Linux 4.9.
Site : http://www.nvidia.com
 



virer le paquet pour réinstaller hmm et espérer une intervention divine.
cette version ne pose pas de pb, je peux juste pas mettre à jour les pilotes nvidia.
je peux rester comme ça pour le moment.

pour ce qui est de l’intérêt des derniers drivers, certains jeux ne fonctionnent tout simplement pas ou avec des gros pb de performances.
c'est loin d'être du gadget.

Hors ligne

#11 17-01-2017 13:35:25

golgot200
Membre
Inscription : 05-08-2007

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

@robert2a

Avant la mise à jour de ce driver, j'avais une disparition momentanée des tableaux de bords sur une action de la souris et qui revenaient en une fraction de seconde. Compton activée.
Sans compton, pas de problème.
Après cette mise à jour, plus de soucis et je peux remettre. Je ne peux pas t'en dire plus. wink

Dernière modification par golgot200 (17-01-2017 13:39:31)

Hors ligne

#12 17-01-2017 13:39:56

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

@nIQnutn

oui moi je resterai sur le driver 367
le seul problème si tu a beaucoup de paquets des backports tu n aura plus les mises a jour

sinon avec jessie verrouiller juste les paquets du driver nvidia par synaptic
j'avais une GTX660 aussi remplacé par une gtx1060 sans touché a mon installation debian (driver 367 )

Dernière modification par robert2a (17-01-2017 13:42:13)

Hors ligne

#13 17-01-2017 13:40:49

golgot200
Membre
Inscription : 05-08-2007

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

nIQnutn a écrit :



pour ce qui est de l’intérêt des derniers drivers, certains jeux ne fonctionnent tout simplement pas ou avec des gros pb de performances.
c'est loin d'être du gadget.



aussi smile

Dernière modification par golgot200 (17-01-2017 13:41:14)

Hors ligne

#14 17-01-2017 13:49:55

golgot200
Membre
Inscription : 05-08-2007

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Il y a un truc qui me chagrine quand même, tu as du 355 et du 367 ?

EDIT: Non, j'ai rien dit

Dernière modification par golgot200 (17-01-2017 13:51:44)

Hors ligne

#15 17-01-2017 13:53:35

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

oui comme Tomb Raider par exemple , mais il n accepte pas toutes les cartes voir compatibilité et peut etre réduire les options on en revient a la société de consommation.
avec une gtx660 ne me dit pas que tu joue a des jeux récent ?

enfin faute de vous convertir a ma devise , prenez le comme un conseil smile

la GTX660 fonctionne très bien avec le 340

pour ton souci , supprimer les paquets qui posent problème et lancer la mise a jour , du moment que tu ne redémarre pas
la simulation d une installation avec ré-install peut confirmer que tout va bien
donc avec apt-get et -s et --reinstall et install et -t et jessie-backports et la ligne magique du tuto nvidia

Dernière modification par robert2a (17-01-2017 14:02:55)

Hors ligne

#16 17-01-2017 13:53:35

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

robert2a a écrit :

oui moi je resterai sur le driver 367
le seul problème si tu a beaucoup de paquets des backports tu n aura plus les mises a jour


pourquoi ?

Hors ligne

#17 17-01-2017 13:54:18

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

parce qu il fonctionne bien , mais au dessus je te donne comment installer le 375

aprés avoir enlevé les paquets a problème


apt-get -s --reinstall install -t jessie-backports nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 


si tout va bien lance l installation

tu ne redémarre que si tout c est bien passé

Dernière modification par robert2a (17-01-2017 14:02:01)

Hors ligne

#18 17-01-2017 14:02:27

golgot200
Membre
Inscription : 05-08-2007

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Comme robert2a te dit, vire le paquet qui merdouille.
Il te virera sûrement nvidia-driver puis un -t jessie-backports install remettra tout ça à jour.

Hors ligne

#19 17-01-2017 14:02:58

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Mais pourquoi le paquet   libegl1-glvnd-nvidia pose-t-il problème alors qu'il existe lui aussi en version 375 dans les backports
https://packages.debian.org/search?sear … vnd-nvidia
Pourquoi ne se met-il pas à jour ? Ça ne pouvait pas être un souci temporaire de disponibilité de la version 375 ?

Hors ligne

#20 17-01-2017 14:05:30

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

non il vire rien , pas de autoremove ou autre plaisanteries

il va lui dire "mettre a jour" et "installer" selon qu une vieille version est présente ou pas.

aprés lecture de la simulation il saura si tout va bien ou pas

Hors ligne

#21 17-01-2017 14:08:44

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

@chalu
premièrement parce que c est les backports (je n ai pas eu ce souci sous stretch du 367 au 375 )
ensuite le driver nvidia a eu de gros changement suite a la prise en compte de certaines choses
nouveau paquets , d autres disparaissent , certain mit a jour

double post mince hmm
@nIQnutn
j ai mit a jour la commande au dessus (sans fautes et d'aprés le tuto ) soit vigilant quand meme roll  (en #17 )

ps: je reste bloqué sur la version 367 tant que debian ne passe pas a une version 376.48 ou supérieure (jessie et stretch )
je vais vous manquer tongue lol  => []

Dernière modification par robert2a (17-01-2017 14:16:38)

Hors ligne

#22 17-01-2017 14:15:11

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

Ok bon je vais cogiter ça car ça ne me semble pas logique que ce paquet ne soit pas mis à jour dans sa version 375 des backports.
J'ai le cerveau gelé ça ne doit pas aider ! lol

Hors ligne

#23 17-01-2017 14:16:04

golgot200
Membre
Inscription : 05-08-2007

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

chalu a écrit :


Pourquoi ne se met-il pas à jour ? Ça ne pouvait pas être un souci temporaire de disponibilité de la version 375 ?



Ce paquet (qui n'est que dans jessie-backports) ne se met pas à jour car il est en conflit avec un autre paquet dans jessie (non mis à jour sûrement).

EDIT:
Au cas où :

libegl1-nvidia vire automatiquement libegl1-glvnd-nvidia et vice et versa. Donc pas le choix, faut qu'il y en ai un qui se barre big_smile, et je sais ce que vous allez penser big_smile

Dernière modification par golgot200 (17-01-2017 14:33:42)

Hors ligne

#24 17-01-2017 14:46:55

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

oui, ça doit probablement être ça.


libegl1-glvnd-nvidia: https://packages.debian.org/jessie-back … vnd-nvidia

Vendor neutral GL dispatch library -- libEGL

This is an implementation of the vendor-neutral dispatch layer for arbitrating OpenGL API calls between multiple vendors on a per-screen basis.

This package contains the (binary) GLVND libEGL.so.1 stub library provided by NVIDIA which dispatches to vendor implementations (libEGL_*.so.0) via GLVND.




libegl1-glvnd-nvidia: https://packages.debian.org/jessie-back … gl1-nvidia

NVIDIA binary EGL library (non-GLVND variant)

EGL provides a platform-agnostic mechanism for creating rendering surfaces for use with other graphics libraries, such as OpenGL|ES.

This package contains the driver specific binary EGL implementation by NVIDIA as a non-GLVND alternative.




https://packages.debian.org/jessie-back … a/filelist
https://packages.debian.org/jessie-back … a/filelist

Hors ligne

#25 17-01-2017 14:50:29

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [résolu] Mise à jour nvidia: suppression libegl1-glvnd-nvidia ?

apt-get -s --reinstall install -t jessie-backports nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libnvidia-glcore:i386 nvidia-egl-common
Veuillez utiliser « apt-get autoremove » pour le supprimer.
Les paquets supplémentaires suivants seront installés :
  libegl-nvidia0 libegl1-nvidia libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx libgldispatch0-nvidia libgles-nvidia1 libgles-nvidia2
  libgles1-glvnd-nvidia libgles1-nvidia libgles2-glvnd-nvidia libgles2-nvidia libglx-nvidia0 libglx0-glvnd-nvidia libnvidia-cfg1
  libnvidia-eglcore libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libopengl0-glvnd-nvidia nvidia-alternative nvidia-driver-bin
  nvidia-driver-libs nvidia-kernel-support nvidia-vdpau-driver nvidia-vulkan-icd xserver-xorg-video-nvidia
Paquets suggérés :
  vulkan-utils
Paquets recommandés :
  nvidia-driver-libs-i386
Les paquets suivants seront ENLEVÉS :
  libegl1-glvnd-nvidia libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgl1-nvidia-glx-i386:i386
Les NOUVEAUX paquets suivants seront installés :
  libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx
Les paquets suivants seront mis à jour :
  libegl-nvidia0 libegl1-nvidia libgldispatch0-nvidia libgles-nvidia1 libgles-nvidia2 libgles1-glvnd-nvidia libgles1-nvidia
  libgles2-glvnd-nvidia libgles2-nvidia libglx-nvidia0 libglx0-glvnd-nvidia libnvidia-cfg1 libnvidia-eglcore libnvidia-glcore
  libnvidia-glcore:i386 libnvidia-ml1 libopengl0-glvnd-nvidia nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-driver-libs
  nvidia-kernel-dkms nvidia-kernel-support nvidia-vdpau-driver nvidia-vulkan-icd xserver-xorg-video-nvidia
26 mis à jour, 2 nouvellement installés, 2 réinstallés, 4 à enlever et 157 non mis à jour.
Inst nvidia-driver-bin [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst xserver-xorg-video-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst libgles1-glvnd-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst libgles1-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst libgles-nvidia1 [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst libnvidia-ml1 [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst libnvidia-cfg1 [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst libgles2-glvnd-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst libgles2-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Inst libgles-nvidia2 [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 ]
Remv libegl1-glvnd-nvidia [367.57-2~bpo8+1] [nvidia-driver:amd64 libegl-nvidia0:amd64 ]
Inst libegl1-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 libegl-nvidia0:amd64 ]
Inst libegl-nvidia0 [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Inst nvidia-vdpau-driver [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Inst nvidia-kernel-support [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Inst libglx0-glvnd-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Inst nvidia-vulkan-icd [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Inst libglx-nvidia0 [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Inst nvidia-settings [367.57-1~bpo8+1] (367.57-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Remv libgl1-nvidia-glx-i386:i386 [352.79-8~bpo8+1] [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Remv libgl1-nvidia-glx:i386 [367.57-2~bpo8+1] [nvidia-driver:amd64 nvidia-driver-libs:amd64 ]
Inst nvidia-alternative [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver:amd64 nvidia-driver-libs:amd64 libgl1-nvidia-glx:amd64 ]
Inst nvidia-driver [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [nvidia-driver-libs:amd64 libgl1-nvidia-glx:amd64 ]
Inst nvidia-driver-libs [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [libgl1-nvidia-glx:amd64 ]
Remv libgl1-nvidia-glx [367.57-2~bpo8+1] []
Inst libopengl0-glvnd-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) []
Inst libgldispatch0-nvidia [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) []
Inst libgl1-glvnd-nvidia-glx (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) []
Inst libnvidia-glcore [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) [libnvidia-glcore:amd64 on libnvidia-glcore:i386] [libnvidia-glcore:i386 on libnvidia-glcore:amd64] [libnvidia-glcore:i386 ]
Inst libnvidia-glcore:i386 [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [i386]) []
Inst libgl1-nvidia-glvnd-glx (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) []
Inst nvidia-kernel-dkms [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64]) []
Inst libnvidia-eglcore [367.57-2~bpo8+1] (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Inst linux-headers-3.16.0-4-amd64 [3.16.39-1] (3.16.39-1 Debian:8.7/stable [amd64])
Conf nvidia-alternative (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libnvidia-ml1 (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf nvidia-driver-bin (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libnvidia-glcore (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libnvidia-glcore:i386 (375.26-1~bpo8+1 Debian Backports:jessie-backports [i386])
Conf xserver-xorg-video-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgldispatch0-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgles1-glvnd-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libnvidia-eglcore (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgles-nvidia1 (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgles1-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libnvidia-cfg1 (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgles2-glvnd-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgles-nvidia2 (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgles2-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libegl-nvidia0 (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libegl1-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf nvidia-vdpau-driver (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf nvidia-kernel-support (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libglx0-glvnd-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libglx-nvidia0 (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf nvidia-vulkan-icd (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf nvidia-settings (367.57-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgl1-glvnd-nvidia-glx (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgl1-nvidia-glvnd-glx (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf nvidia-driver-libs (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf nvidia-kernel-dkms (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf nvidia-driver (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libopengl0-glvnd-nvidia (375.26-1~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf linux-headers-3.16.0-4-amd64 (3.16.39-1 Debian:8.7/stable [amd64])
 

Hors ligne

Pied de page des forums