Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-01-2017 19:58:08

tuxis
Membre
Distrib. : DFLinux 64
Noyau : Amd 64
(G)UI : Xfce
Inscription : 19-07-2016

(Resolu) Échec au montage disque dur fat32

Bonsoir,
sous handy tout mes disque ont été formatés fat32 aucun problème ça tourné nickel
je viens d'installer DFlinux et là ils ont tous le même problème :

Error mounting /dev/sdb1 at /media/tuxis/164 Go: Command-line `mount -t "vfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush" "/dev/sdb1" "/media/tuxis/164 Go"' exited with non-zero exit status 32: mount: type de système de fichiers « vfat » inconnu
.
Que puis je faire ?

Merci d'avance pour votre aide

Dernière modification par tuxis (19-01-2017 00:06:44)


REGLE N°1 PROMOUVOIR LE LIBRE
un Linux léger est un Linux rapide ça lui permet d'aller sur toutes les machines

Hors ligne

#2 18-01-2017 20:38:47

tuxis
Membre
Distrib. : DFLinux 64
Noyau : Amd 64
(G)UI : Xfce
Inscription : 19-07-2016

Re : (Resolu) Échec au montage disque dur fat32

si j'enclenche "Disques" j’obtiens après le mot de passe :

Error mounting /dev/sdb1 at /media/tuxis/164 Go: Command-line `mount -t "vfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush" "/dev/sdb1" "/media/tuxis/164 Go"' exited with non-zero exit status 32: mount: type de système de fichiers « vfat » inconnu
(udisks-error-quark, 0)

que puis je faire ?

REGLE N°1 PROMOUVOIR LE LIBRE
un Linux léger est un Linux rapide ça lui permet d'aller sur toutes les machines

Hors ligne

#3 18-01-2017 21:26:10

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : (Resolu) Échec au montage disque dur fat32

Bonsoir
une raison particulière pour que tes disques son formaté en fat32?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#4 18-01-2017 21:48:29

raleur
Membre
Inscription : 03-10-2014

Re : (Resolu) Échec au montage disque dur fat32

Que disent les logs du noyau juste après une tentative de montage ?

dmesg | tail -n 40


Le système de fichiers FAT ou VFAT est-il géré ?

grep fat /proc/filesystems


Sinon, les modules fat et vfat sont-ils chargés ?

/sbin/lsmod | grep fat


Sinon, que donne une tentative de chargement manuel ?

modprobe fat
modprobe vfat
dmesg | tail


Y a-t-il eu une mise à jour du noyau depuis le dernier démarrage ? Si oui, redémarrer.

Dernière modification par raleur (18-01-2017 21:51:05)

Hors ligne

#5 18-01-2017 22:09:18

tuxis
Membre
Distrib. : DFLinux 64
Noyau : Amd 64
(G)UI : Xfce
Inscription : 19-07-2016

Re : (Resolu) Échec au montage disque dur fat32

il y a 3 disque dure qui servent de bibliotheque formater en fat 32 sur Handy avec Gparted
je vais voir et je vous tiendrais au courent

REGLE N°1 PROMOUVOIR LE LIBRE
un Linux léger est un Linux rapide ça lui permet d'aller sur toutes les machines

Hors ligne

#6 18-01-2017 23:35:39

tuxis
Membre
Distrib. : DFLinux 64
Noyau : Amd 64
(G)UI : Xfce
Inscription : 19-07-2016

Re : (Resolu) Échec au montage disque dur fat32

tentative de chargement manuel :

root@Goupil:/home/tuxis# modprobe fat
modprobe: ERROR: could not insert 'fat': Unknown symbol in module, or unknown parameter (see dmesg)
root@Goupil:/home/tuxis# modprobe vfat
modprobe: ERROR: could not insert 'vfat': Unknown symbol in module, or unknown parameter (see dmesg)
root@Goupil:/home/tuxis# dmesg | tail
[ 4728.821361] fat: Unknown symbol setattr_prepare (err 0)
[ 4763.201624] fat: Unknown symbol setattr_prepare (err 0)
[ 4984.680954] fat: Unknown symbol setattr_prepare (err 0)
[ 8669.334075] perf interrupt took too long (2511 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[11832.240949] fat: Unknown symbol setattr_prepare (err 0)
[12462.105597] fat: Unknown symbol setattr_prepare (err 0)
[12469.520380] fat: Unknown symbol setattr_prepare (err 0)
[12472.925784] fat: Unknown symbol setattr_prepare (err 0)
[15254.710773] fat: Unknown symbol setattr_prepare (err 0)
[15266.894860] fat: Unknown symbol setattr_prepare (err 0)

REGLE N°1 PROMOUVOIR LE LIBRE
un Linux léger est un Linux rapide ça lui permet d'aller sur toutes les machines

Hors ligne

#7 18-01-2017 23:37:14

tuxis
Membre
Distrib. : DFLinux 64
Noyau : Amd 64
(G)UI : Xfce
Inscription : 19-07-2016

Re : (Resolu) Échec au montage disque dur fat32

Debian + HandyLinux-2 - prenez le contrôle de votre système
tuxis@Goupil ~
$ dmesg | tail -n 40
[    9.216079] floppy0: no floppy controllers found
[   11.599314] cfg80211: Calling CRDA to update world regulatory domain
[   11.866807] cfg80211: World regulatory domain updated:
[   11.866821] cfg80211:  DFS Master region: unset
[   11.866825] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   11.866832] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   11.866837] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   11.866842] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   11.866847] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   11.866853] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   11.866859] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   11.866863] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   11.866868] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   12.047520] forcedeth 0000:00:08.0: irq 42 for MSI/MSI-X
[   12.047587] forcedeth 0000:00:08.0 eth0: MSI enabled
[ 1073.714494] systemd-udevd[6252]: starting version 215
[ 1274.414911] device-mapper: uevent: version 1.0.3
[ 1274.420343] device-mapper: ioctl: 4.27.0-ioctl (2013-10-30) initialised: dm-devel@redhat.com
[ 1848.048639] fat: Unknown symbol setattr_prepare (err 0)
[ 1857.203959] fat: Unknown symbol setattr_prepare (err 0)
[ 1865.069809] fat: Unknown symbol setattr_prepare (err 0)
[ 1869.667774] fat: Unknown symbol setattr_prepare (err 0)
[ 1978.210960] fat: Unknown symbol setattr_prepare (err 0)
[ 2528.602233] fat: Unknown symbol setattr_prepare (err 0)
[ 2532.907605] fat: Unknown symbol setattr_prepare (err 0)
[ 2539.800983] fat: Unknown symbol setattr_prepare (err 0)
[ 2543.298184] fat: Unknown symbol setattr_prepare (err 0)
[ 2916.214479] fat: Unknown symbol setattr_prepare (err 0)
[ 2923.308211] fat: Unknown symbol setattr_prepare (err 0)
[ 2931.602180] fat: Unknown symbol setattr_prepare (err 0)
[ 3108.668095] fat: Unknown symbol setattr_prepare (err 0)
[ 3179.021376] fat: Unknown symbol setattr_prepare (err 0)
[ 4728.821361] fat: Unknown symbol setattr_prepare (err 0)
[ 4763.201624] fat: Unknown symbol setattr_prepare (err 0)
[ 4984.680954] fat: Unknown symbol setattr_prepare (err 0)
[ 8669.334075] perf interrupt took too long (2511 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[11832.240949] fat: Unknown symbol setattr_prepare (err 0)
[12462.105597] fat: Unknown symbol setattr_prepare (err 0)
[12469.520380] fat: Unknown symbol setattr_prepare (err 0)
[12472.925784] fat: Unknown symbol setattr_prepare (err 0)
tuxis@Goupil ~
$ grep fat /proc/filesystems
tuxis@Goupil ~
$ /sbin/lsmod | grep fat
tuxis@Goupil ~
$ modprobe fat
Command 'modprobe' is available in '/sbin/modprobe'
The command could not be located because '/sbin' is not included in the PATH environment variable.
This is most likely caused by the lack of administrative priviledges associated with your user account.
modprobe: command not found
tuxis@Goupil ~
$ modprobe vfat
Command 'modprobe' is available in '/sbin/modprobe'
The command could not be located because '/sbin' is not included in the PATH environment variable.
This is most likely caused by the lack of administrative priviledges associated with your user account.
modprobe: command not found

REGLE N°1 PROMOUVOIR LE LIBRE
un Linux léger est un Linux rapide ça lui permet d'aller sur toutes les machines

Hors ligne

#8 18-01-2017 23:50:20

raleur
Membre
Inscription : 03-10-2014

Re : (Resolu) Échec au montage disque dur fat32

"Unknown symbol" indique que le module que modprobe tente de charger ne correspond pas avec le noyau qui est actif. Probablement parce qu'il y a eu une mise à jour du noyau non suivie d'un redémarrage, donc ancien noyau encore actif et nouveaux modules sur le disque.

As-tu redémarré comme je l'ai suggéré? Visiblement non d'après l'uptime visible dans les derniers messages du noyau.

Hors ligne

#9 19-01-2017 00:04:43

tuxis
Membre
Distrib. : DFLinux 64
Noyau : Amd 64
(G)UI : Xfce
Inscription : 19-07-2016

Re : (Resolu) Échec au montage disque dur fat32

après mon dernier message j'ai redémarrer  et j'ai de suite fait la maj demander par la machine
et maintenant tout fonctionne

merci.gif beaucoup

ça me rend heureux
merci.gif

REGLE N°1 PROMOUVOIR LE LIBRE
un Linux léger est un Linux rapide ça lui permet d'aller sur toutes les machines

Hors ligne

#10 19-01-2017 00:09:36

raleur
Membre
Inscription : 03-10-2014

Re : (Resolu) Échec au montage disque dur fat32

On a beaucoup critiqué les utilisateurs de Windows pour leur propension à redémarrer au moindre problème, mais les utilisateurs de GNU/Linux semblent souffrir de l'excès inverse.

Hors ligne

#11 19-01-2017 00:16:57

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : (Resolu) Échec au montage disque dur fat32

On peut même changer de kernel sans redémarrer depuis quelques années si je me souviens bien en plus. Encore moins de reboot lol

Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#12 19-01-2017 00:41:34

raleur
Membre
Inscription : 03-10-2014

Re : (Resolu) Échec au montage disque dur fat32

Si tu veux parler de kexec, il faut quand même redémarrer tout le système. Cela évite juste de repasser par le firmware de la machine et le chargeur d'amorçage.

Hors ligne

Pied de page des forums