Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 21-01-2017 12:54:46

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

OK,

Si je regarde les dernières lignes :

sudo cat /var/log/apache2/access.log




192.168.0.56 - - [21/Jan/2017:10:31:32 +0000] "PROPFIND /owncloud/remote.php/webdav HTTP/1.1" 207 2727 "-" "Mozilla/5.0 (Linux) csyncoC/0.91.5 neon/0.30.1"
192.168.0.56 - Pascal [21/Jan/2017:10:31:50 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:32:03 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:32:20 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:32:33 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:32:50 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:33:03 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:33:20 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:33:33 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:33:51 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:34:03 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:34:21 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:34:33 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:34:51 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:35:03 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:35:21 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:35:33 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:35:51 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:36:03 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:36:22 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - - [21/Jan/2017:10:36:33 +0000] "PROPFIND /owncloud/remote.php/webdav HTTP/1.1" 207 2727 "-" "Mozilla/5.0 (Linux) csyncoC/0.91.5 neon/0.30.1"
192.168.0.56 - Pascal [21/Jan/2017:10:36:52 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:37:03 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:37:22 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:37:33 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:37:52 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:38:03 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:38:22 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:38:33 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:38:53 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:39:03 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:39:23 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:39:33 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1928 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
192.168.0.56 - Pascal [21/Jan/2017:10:39:53 +0000] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1183 "-" "Mozilla/5.0 (Linux) mirall/1.6.4"
 


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#27 21-01-2017 13:00:32

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

bendia a écrit :

Ben celui que tu as défini dans ton vhost. Je dirais access.log en regardant les heures d'accès



C'est quoi vhost et où est-ce que j'ai défini le access.log ?


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#28 21-01-2017 13:12:28

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

J'ai trouvé ça aussi et ça me paraît bizarre parce que je n'ai pas de htaccess.txt à cet emplacement :

sudo cat /var/log/apache2/access.log | grep htaccess



192.168.0.60 - - [19/Jan/2017:13:15:20 +0000] "GET /owncloud/data/htaccesstest.txt HTTP/1.0" 403 501 "-" "-"
192.168.0.60 - - [19/Jan/2017:13:15:23 +0000] "GET /owncloud/data/htaccesstest.txt HTTP/1.0" 403 501 "-" "-"
192.168.0.60 - - [19/Jan/2017:13:15:45 +0000] "GET /owncloud/data/htaccesstest.txt HTTP/1.0" 403 501 "-" "-"
192.168.0.60 - - [19/Jan/2017:13:15:46 +0000] "GET /owncloud/data/htaccesstest.txt HTTP/1.0" 403 501 "-" "-"
192.168.0.60 - - [19/Jan/2017:13:16:14 +0000] "GET /owncloud/data/htaccesstest.txt HTTP/1.0" 403 501 "-" "-"
192.168.0.60 - - [20/Jan/2017:11:07:27 +0000] "GET /owncloud/data/htaccesstest.txt HTTP/1.0" 403 7045 "-" "-"
192.168.0.60 - - [20/Jan/2017:11:55:44 +0000] "GET /owncloud/data/htaccesstest.txt HTTP/1.0" 403 7045 "-" "-"
192.168.0.60 - - [21/Jan/2017:02:36:09 +0000] "GET /owncloud/data/htaccesstest.txt HTTP/1.0" 403 7045 "-" "-"
 



Le .htacess est ici :

ls -la /usr/share/owncloud/


total 100
drwxr-xr-x   9 root root  4096 janv. 19 13:05 .
drwxr-xr-x 101 root root  4096 janv. 19 13:08 ..
drwxr-xr-x   9 root root  4096 janv. 19 13:05 3rdparty
drwxr-xr-x  25 root root  4096 janv. 19 13:05 apps
lrwxrwxrwx   1 root root    24 janv.  6  2016 assets -> /var/lib/owncloud/assets
lrwxrwxrwx   1 root root    24 janv.  6  2016 backup -> /var/lib/owncloud/backup
lrwxrwxrwx   1 root root    13 janv.  6  2016 config -> /etc/owncloud
-rw-r--r--   1 root root  1283 déc.   8  2014 console.php
drwxr-xr-x  16 root root  4096 janv. 19 13:05 core
-rw-r--r--   1 root root  3929 déc.   8  2014 cron.php
lrwxrwxrwx   1 root root    22 janv.  6  2016 data -> /var/lib/owncloud/data
-rw-r--r--   1 root root 23751 déc.   8  2014 db_structure.xml
lrwxrwxrwx   1 root root    22 janv.  6  2016 .htaccess -> /etc/owncloud/htaccess
-rw-r--r--   1 root root   179 déc.   8  2014 index.html
-rw-r--r--   1 root root  1281 déc.   8  2014 index.php
drwxr-xr-x   6 root root  4096 janv. 19 13:05 lib
-rwxr-xr-x   1 root root   279 déc.   8  2014 occ
drwxr-xr-x   2 root root  4096 janv. 19 13:05 ocs
-rw-r--r--   1 root root  1753 déc.   8  2014 public.php
-rw-r--r--   1 root root  1735 déc.   8  2014 remote.php
-rw-r--r--   1 root root    26 déc.   8  2014 robots.txt
drwxr-xr-x   6 root root  4096 janv. 19 13:05 search
drwxr-xr-x  10 root root  4096 janv. 19 13:05 settings
-rw-r--r--   1 root root  1406 déc.   8  2014 status.php
lrwxrwxrwx   1 root root    24 janv.  6  2016 themes -> /var/lib/owncloud/themes
-rw-r--r--   1 root root   149 déc.   8  2014 version.php
 

Dernière modification par laguespa (21-01-2017 13:15:44)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#29 21-01-2017 13:51:58

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Resolu] problème https sur raspberry owncloud raspbian

Un vhost, c'est un Virtual host, hôte virtuel donc. Chaque vhost a son fichier de configuration. Ça permet à Apache de servir plusieurs site, et il peut les différencier en fonction du domaine par exemple. En dernier ressort, si une requête ne correspond à aucun site, on sert ce qui correspond à defautl.conf, et default-ssl.conf

Je pense que là, le fait de suivre des tutos différents sans bien savoir à quoi correspond chaque fichier fait qu'on se mélange les crayons. En fait, je ne comprends plus tout là hmm

Quelques questions donc :

  1. Tu n'a que owncloud comme site sur ton RPI ?

  2. Pour l'instant, tu testes ton site en local, dans ton LAN, en y accédant via son adresse IP ?

  3. Qu'as tu modifié exactement comme fichier présent dans /etc/apache2/sites-available ? Peux-tu reposter ici comment sont ces fichiers modifiés

  4. Qu'y a-t-il dans /etc/apache2/sites-enabled ?



Un peu de lecture sur apache2.4 wink https://debian-facile.org/doc:reseau:apache2:apache2.4


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#30 21-01-2017 14:30:01

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

bendia a écrit :


Je pense que là, le fait de suivre des tutos différents sans bien savoir à quoi correspond chaque fichier fait qu'on se mélange les crayons. En fait, je ne comprends plus tout là hmm



Je me dis pareil. Ça vient du fait que owncloud a forké et c'est devenu nextcloud. Owncloud est un peu abandonné, du moins le forum ne donne plus signe de vie. Les tutos d'installation owcloud ne prennent pas en compte son intégration dans les dépôts Debian. Du coup les fichiers peuvent ne pas avoir les mêmes noms et ne pas se trouver au même endroit. Ça met un peu le bazar.

bendia a écrit :


Quelques questions donc :

  1. Tu n'a que owncloud comme site sur ton RPI ?

  2. Pour l'instant, tu testes ton site en local, dans ton LAN, en y accédant via son adresse IP ?

  3. Qu'as tu modifié exactement comme fichier présent dans /etc/apache2/sites-available ? Peux-tu reposter ici comment sont ces fichiers modifiés

  4. Qu'y a-t-il dans /etc/apache2/sites-enabled ?



- Oui, je n'ai que owcloud sur le RPI.

- Oui, pour l'instant je teste en local dans mon LAN en y accédant via l'adresse ip que j'ai fixée dans la box à savoir : http://192.168.0.60/owncloud chez moi.

- Les fichiers modifiés dans /etc/apache2/sites-available sont les suivants et ont été modifiés de cette façon :

création de owncloud.conf

sudo cat /etc/apache2/sites-available/owncloud.conf


#NameVirtualHost *:443
# Port d’écoute
<VirtualHost *:443>
DocumentRoot /var/www/html
# Mode SSL activé
SSLEngine On
# Où est le certificat
SSLCertificateFile /etc/ssl/certs/owncloud.crt
SSLCertificateKeyFile /etc/ssl/private/owncloud.key
</VirtualHost>



/etc/apache2/sites-available/default-ssl.conf contient :

sudo cat /etc/apache2/sites-available/default-ssl.conf


<IfModule mod_ssl.c>
  <VirtualHost _default_:443>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/html

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf

    #   SSL Engine Switch:
    #   Enable/Disable SSL for this virtual host.
    SSLEngine on

    #   A self-signed (snakeoil) certificate can be created by installing
    #   the ssl-cert package. See
    #   /usr/share/doc/apache2/README.Debian.gz for more info.
    #   If both key and certificate are stored in the same file, only the
    #   SSLCertificateFile directive is needed.
    SSLCertificateFile  /etc/ssl/certs/ssl-cert-snakeoil.pem
    SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

    #   Server Certificate Chain:
    #   Point SSLCertificateChainFile at a file containing the
    #   concatenation of PEM encoded CA certificates which form the
    #   certificate chain for the server certificate. Alternatively
    #   the referenced file can be the same as SSLCertificateFile
    #   when the CA certificates are directly appended to the server
    #   certificate for convinience.
    #SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt

    #   Certificate Authority (CA):
    #   Set the CA certificate verification path where to find CA
    #   certificates for client authentication or alternatively one
    #   huge file containing all of them (file must be PEM encoded)
    #   Note: Inside SSLCACertificatePath you need hash symlinks
    #    to point to the certificate files. Use the provided
    #    Makefile to update the hash symlinks after changes.
    #SSLCACertificatePath /etc/ssl/certs/
    #SSLCACertificateFile /etc/apache2/ssl.crt/ca-bundle.crt

    #   Certificate Revocation Lists (CRL):
    #   Set the CA revocation path where to find CA CRLs for client
    #   authentication or alternatively one huge file containing all
    #   of them (file must be PEM encoded)
    #   Note: Inside SSLCARevocationPath you need hash symlinks
    #    to point to the certificate files. Use the provided
    #    Makefile to update the hash symlinks after changes.
    #SSLCARevocationPath /etc/apache2/ssl.crl/
    #SSLCARevocationFile /etc/apache2/ssl.crl/ca-bundle.crl

    #   Client Authentication (Type):
    #   Client certificate verification type and depth.  Types are
    #   none, optional, require and optional_no_ca.  Depth is a
    #   number which specifies how deeply to verify the certificate
    #   issuer chain before deciding the certificate is not valid.
    #SSLVerifyClient require
    #SSLVerifyDepth  10

    #   SSL Engine Options:
    #   Set various options for the SSL engine.
    #   o FakeBasicAuth:
    #  Translate the client X.509 into a Basic Authorisation.  This means that
    #  the standard Auth/DBMAuth methods can be used for access control.  The
    #  user name is the `one line' version of the client's X.509 certificate.
    #  Note that no password is obtained from the user. Every entry in the user
    #  file needs this password: `xxj31ZMTZzkVA'.
    #   o ExportCertData:
    #  This exports two additional environment variables: SSL_CLIENT_CERT and
    #  SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
    #  server (always existing) and the client (only existing when client
    #  authentication is used). This can be used to import the certificates
    #  into CGI scripts.
    #   o StdEnvVars:
    #  This exports the standard SSL/TLS related `SSL_*' environment variables.
    #  Per default this exportation is switched off for performance reasons,
    #  because the extraction step is an expensive operation and is usually
    #  useless for serving static content. So one usually enables the
    #  exportation for CGI and SSI requests only.
    #   o OptRenegotiate:
    #  This enables optimized SSL connection renegotiation handling when SSL
    #  directives are used in per-directory context.
    #SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
    <FilesMatch "\.(cgi|shtml|phtml|php)$">
        SSLOptions +StdEnvVars
    </FilesMatch>
    <Directory /usr/lib/cgi-bin>
        SSLOptions +StdEnvVars
    </Directory>

    #   SSL Protocol Adjustments:
    #   The safe and default but still SSL/TLS standard compliant shutdown
    #   approach is that mod_ssl sends the close notify alert but doesn't wait for
    #   the close notify alert from client. When you need a different shutdown
    #   approach you can use one of the following variables:
    #   o ssl-unclean-shutdown:
    #  This forces an unclean shutdown when the connection is closed, i.e. no
    #  SSL close notify alert is send or allowed to received.  This violates
    #  the SSL/TLS standard but is needed for some brain-dead browsers. Use
    #  this when you receive I/O errors because of the standard approach where
    #  mod_ssl sends the close notify alert.
    #   o ssl-accurate-shutdown:
    #  This forces an accurate shutdown when the connection is closed, i.e. a
    #  SSL close notify alert is send and mod_ssl waits for the close notify
    #  alert of the client. This is 100% SSL/TLS standard compliant, but in
    #  practice often causes hanging connections with brain-dead browsers. Use
    #  this only for browsers where you know that their SSL implementation
    #  works correctly.
    #   Notice: Most problems of broken clients are also related to the HTTP
    #   keep-alive facility, so you usually additionally want to disable
    #   keep-alive for those clients, too. Use variable "nokeepalive" for this.
    #   Similarly, one has to force some clients to use HTTP/1.0 to workaround
    #   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
    #   "force-response-1.0" for this.
    BrowserMatch "MSIE [2-6]" \
        nokeepalive ssl-unclean-shutdown \
        downgrade-1.0 force-response-1.0
    # MSIE 7 and newer should be able to use keepalive
    BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

  </VirtualHost>
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet




J'ai bien sûr un lien qui pointe au bon endroit :

ls -la /var/www/html/


total 20
drwxr-xr-x 2 root root  4096 janv. 20 09:24 .
drwxr-xr-x 3 root root  4096 janv. 19 13:03 ..
-rw-r--r-- 1 root root 10701 janv. 19 13:05 index.html
lrwxrwxrwx 1 root root    20 janv. 20 09:24 owncloud -> /usr/share/owncloud/




Sinon, dans etc/apache2/ j'ai créé le répertoire CertOwncloud pour la sécuristaion SSL.
Je m'y suis placé et j'ai lancé les comamndes suivantes :


sudo openssl genrsa -out owncloud.key 1024
 




sudo openssl req -new -key owncloud.key -out owncloud.csr
 




sudo openssl x509 -req -days 365 -in owncloud.csr -signkey owncloud.key -out owncloud.crt
 



J'ai déplacé tout ça dans /etc/ssl/certs et  /etc/ssl/private


sudo cp owncloud.crt /etc/ssl/certs
 



et


sudo cp owncloud.key /etc/ssl/private
 




ensuite j'ai activé :


sudo a2enmod ssl
 




sudo a2ensite owncloud.conf
 




sudo service apache2 restart
 

Dernière modification par laguespa (21-01-2017 15:42:31)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#31 21-01-2017 14:37:31

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch/buster
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : [Resolu] problème https sur raspberry owncloud raspbian

re

tu as essayé  avec

<VirtualHost *: 80 *:443>

Dernière modification par lagrenouille (21-01-2017 14:38:46)


L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

Hors ligne

#32 21-01-2017 14:48:07

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

Dans quel fichier ?

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#33 21-01-2017 14:51:17

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch/buster
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : [Resolu] problème https sur raspberry owncloud raspbian

ben dans ton VirtualHost



/etc/apache2/sites-available/owncloud.conf

L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

Hors ligne

#34 21-01-2017 14:53:45

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

ok, je m'y perds parce que j'ai aussi un fichier VirtualHost dans  /etc/apache2/sites-available/000-default.conf

J'ai essayé et ça me rend :

Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#35 21-01-2017 14:58:12

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch/buster
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : [Resolu] problème https sur raspberry owncloud raspbian

mais
fais ton fichier pour le cloud et laisse les fichiers de conf par défaut tranquille

L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

Hors ligne

#36 21-01-2017 15:02:12

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

Ok, je pensais qu'il fallait les modifier aussi...

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#37 21-01-2017 15:22:32

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

Du coup j'ai édité mon message où bendia me demande de donner les fichiers modifiés avec quelque chose qui fonctionne au moins en http.

J'ai refait ce que tu m'as dit ici en gardant les fichiers de conf d'apache2 comme ils étaient au départ.

lagrenouille a écrit :

re

tu as essayé  avec

<VirtualHost *: 80 *:443>



Je n'ai plus de message d'erreur mais je ne peux toujours pas activer le https dans le compte administrateur de owncloud.

[Edit] Je dis une connerie. La ligne VirtualHost était commentée donc ça n'avait pas d'effet.

A+

Dernière modification par laguespa (21-01-2017 16:11:00)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#38 21-01-2017 15:37:57

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Resolu] problème https sur raspberry owncloud raspbian

lagrenouille a écrit :

mais
fais ton fichier pour le cloud et laisse les fichiers de conf par défaut tranquille

Ben, en l'occurence, je ferais l'inverse là, si il n'y a que ça sur le RPI, quitte à en faire une sauvegarde au préalable wink

Le fichier de conf par défaut, c'est celui utilisé lorsque une requête ne correspond à aucun autre vhost. Donc, en l'utilisant, si ça foire, tu le sauras, et tu sauras pourquoi.


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#39 21-01-2017 15:49:05

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

Tu veux dire que, après avoir fait une sauvegarde de /etc/apache2/sites-available/default-ssl.conf qui est utilisé pour le https, je le renseingne avec ce qui se trouve dans /etc/apache2/sites-available/owncloud.conf ?
A moins qu'il s'agisse du fichier de conf par défaut d'apache2 qui est 000-default.conf ?

Mais du coup il faut que je recrée le lien symbolique avec a2ensite default-ssl.conf ou 000-default.conf selon le cas non ?

Dernière modification par laguespa (21-01-2017 16:03:53)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#40 21-01-2017 16:07:33

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

Heu, j'ai pas compris pourquoi, mais maintenant ça fonctionne. Je peux activer le https depuis le compte administrateur et lire les pages en https.

Pas compris sur ce coup là. Je vais regarder l'historique de mes commandes.

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#41 21-01-2017 16:36:15

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] problème https sur raspberry owncloud raspbian

Bon, à regarder l'historique il est fort possible que c'est la commande

sudo a2ensite owncloud.conf



qui a réglé le problème.

Dans le tuto que j'ai suivi au départ il fallait créer /etc/apache2/sites-available/owncloud.https et ça ne fonctionnait pas. J'ai trouvé sur un forum qu'il fallait nommer le fichier /etc/apache2/sites-available/owncloud.conf mais pas sûr que j'ai activé enuite avec le nouveau nom.
Bon, je vois pas d'autre explication pour le moment...

Je passe en résolu.
Merci, j'ai appris beaucoup de choses.

A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

Pied de page des forums