Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-01-2017 00:47:37

Mescal81
Membre
Inscription : 12-01-2017

problème glx

Bonjour
Je m adresse a vous pour un problème que je ne comprend pas,j ai réussi après plusieurs échec a installer le driver nvidia 375.26 sur Debian 8.7 ensuite voulu installer X-plane 11 dessus mais voila le message d erreur qui me met.

root@debian:/home/orlon/Téléchargements# ./'X-Plane 11 Installer Linux'
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  39
  Current serial number in output stream:  44
 




je ne sais pas ce que ça veut dire ni comment résoudre ce problème,merci pour toutes solutions

Hors ligne

#2 20-01-2017 11:56:32

èfpé
Membre
Inscription : 10-07-2016

Re : problème glx

Bonjour,

Il y a comme un petit souci avec OpenGL ; tu peux tenter cet upgrade :

apt-get -t jessie-backports install libgl1-mesa-dri libgl1-mesa-glx


Puisque tu as installé le paquet nvidia-driver depuis ce dépôt...

Hors ligne

#3 20-01-2017 13:03:25

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : problème glx

Bonjour
j'ai trouvé ceci assez ancien => https://doc.ubuntu-fr.org/x-plane

@èfpé

je pense que avec "alternatives" (nvidia-alternative) le choix sera sur la version du driver non-free et que mesa ne sert pas a grand chose .
nota : je pense que mesa-glx et dri est déja installé ( par défaut )

@Mescal81

je te propose de vérifier un paquet du driver nvidia , peut etre la solution .

tu dois avoir le paquet libgl1-nvidia-glvnd-glx  essaie de basculer sur le paquet libgl1-nvidia-glx

sans aucune garantie , mais ton driver fonctionne avec l'un ou l'autre , l installation de l un provoque la désinstallation de l autre

Dernière modification par robert2a (20-01-2017 13:22:07)

Hors ligne

Pied de page des forums