Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-01-2017 16:54:51

romy
Membre
Inscription : 24-01-2017

Problème installation paquet pcsx2_1.4.0+dfsg-2_i386.deb

Bonjour,

J'essaie depuis plusieurs temps d'installer le paquet pcsx2_1.4.0+dfsg-2_i386.deb afin d'installer un emulateur PS2. Il est disponible ici: https://packages.debian.org/stretch/pcsx2.

L'installation se fait sous paquet 32 bit, donc:

dpkg --add-architecture i386



Et lorsque je :

dpkg -i pcsx2_1.4.0+dfsg-2_i386.deb



Ca me renvoie:


dpkg: des problèmes de dépendances empêchent la configuration de pcsx2 :
 pcsx2 dépend de libsdl2-2.0-0 (>= 2.0.4) ; cependant :
 Le paquet libsdl2-2.0-0:i386 n'est pas encore configuré.
 pcsx2 dépend de libsoundtouch1 (>= 1.9.2) ; cependant :
 pcsx2 dépend de libstdc++6 (>= 5.2) ; cependant :
  La version de libstdc++6:i386 sur le système est 4.9.2-10.
 pcsx2 dépend de libwxbase3.0-0v5 (>= 3.0.2+dfsg) ; cependant :
 pcsx2 dépend de libwxgtk3.0-0v5 (>= 3.0.2+dfsg) ; cependant :
  Le paquet libwxgtk3.0-0v5 n'est pas installé.

dpkg: erreur de traitement du paquet pcsx2 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Des erreurs ont été rencontrées pendant l'exécution :
 pcsx2



Donc je

 apt-get -f install



Mais rien n'y fait!
Si je comprend bien mes paquets de dépendances non satisfaites sont d'une version inférieur à celle requise...

Comment puis-je les installer afin de pouvoir installer mon émulateur? Je n'arrive pas à les installer manuellement.

Merci d'avance,
romy


OS: Debian 8, Jessie
Arch: amd-64
Machine : Thinkpad T410
Processeur : i5

Hors ligne

#2 24-01-2017 17:12:11

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Problème installation paquet pcsx2_1.4.0+dfsg-2_i386.deb

Bonjour smile
C'est quoi le message d'erreur de ta deuxième commande ?
Sinon tu peux utiliser gdebi qui gère les dépendances et téléchargera les paquets nécessaires s'ils sont disponibles

gdebi nom-du-paquet.deb

Hors ligne

#3 24-01-2017 17:44:15

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : Problème installation paquet pcsx2_1.4.0+dfsg-2_i386.deb

c'est dispo pour la version stretch (version de développement) mais pas pour les versions inférieurs.

que donne la commande

 lsb_release -a

Hors ligne

#4 24-01-2017 17:58:47

romy
Membre
Inscription : 24-01-2017

Re : Problème installation paquet pcsx2_1.4.0+dfsg-2_i386.deb

Merci beaucoup de vos réponses:

Donc @ chalu :

gdebi pcsx2_1.4.0+dfsg-2_i386.deb



Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done
Building data structures... Done
Ce paquet ne peut pas être installé
Dependency is not satisfiable: libsoundtouch1 (>= 1.9.2)



Il reste toujours un truc!! Je vais migrer vers Stretch!


@nIQnutn Voilà ce que donne

lsb_release -a



LSB Version:  core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:desktop-4.0-amd64:desktop-4.0-noarch:desktop-4.1-amd64:desktop-4.1-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch:graphics-4.1-amd64:graphics-4.1-noarch:languages-3.2-amd64:languages-3.2-noarch:languages-4.0-amd64:languages-4.0-noarch:languages-4.1-amd64:languages-4.1-noarch:multimedia-3.2-amd64:multimedia-3.2-noarch:multimedia-4.0-amd64:multimedia-4.0-noarch:multimedia-4.1-amd64:multimedia-4.1-noarch:printing-3.2-amd64:printing-3.2-noarch:printing-4.0-amd64:printing-4.0-noarch:printing-4.1-amd64:printing-4.1-noarch:qt4-3.1-amd64:qt4-3.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID: Debian
Description:  Debian GNU/Linux 8.6 (jessie)
Release:  8.6
Codename: jessie



Oui, je viens de voir que c'est un paquet pour la testing. Je pense y migrer comme un sauvage parce que https://www.debian.org/releases/testing … ng.en.html c'est rude!!!!

Merci!!!!


OS: Debian 8, Jessie
Arch: amd-64
Machine : Thinkpad T410
Processeur : i5

Hors ligne

#5 24-01-2017 18:01:55

romy
Membre
Inscription : 24-01-2017

Re : Problème installation paquet pcsx2_1.4.0+dfsg-2_i386.deb

A oui,

Et

apt-get -f install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libaio1:i386 libatk1.0-0:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libcairo2:i386 libcups2:i386 libdatrie1:i386
  libegl1-mesa:i386 libegl1-mesa-drivers:i386 libfontconfig1:i386 libgbm1:i386 libgdk-pixbuf2.0-0:i386 libgraphite2-3:i386 libgssapi-krb5-2:i386
  libgtk2.0-0:i386 libharfbuzz0b:i386 libjasper1:i386 libjbig0:i386 libjpeg62-turbo:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386
  libkrb5support0:i386 libopenvg1-mesa:i386 libpango-1.0-0:i386 libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386 libpixman-1-0:i386 libsndio6.1
  libsndio6.1:i386 libthai0:i386 libtiff5:i386 libwayland-client0:i386 libwayland-cursor0:i386 libwayland-egl1-mesa:i386 libwayland-server0:i386
  libxcb-render0:i386 libxcb-shape0:i386 libxcb-shm0:i386 libxcb-xfixes0:i386 libxcomposite1:i386 libxkbcommon0:i386 libxrandr2:i386 libxss1:i386
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  libsdl2-2.0-0:i386 pcsx2:i386
0 mis à jour, 0 nouvellement installés, 2 à enlever et 110 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 12,6 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 256336 fichiers et répertoires déjà installés.)
Suppression de pcsx2 (1.4.0+dfsg-2) ...
Suppression de libsdl2-2.0-0:i386 (2.0.5+dfsg1-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u6) ...


OS: Debian 8, Jessie
Arch: amd-64
Machine : Thinkpad T410
Processeur : i5

Hors ligne

#6 24-01-2017 18:33:07

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème installation paquet pcsx2_1.4.0+dfsg-2_i386.deb

romy a écrit :

Bonjour,

J'essaie depuis plusieurs temps d'installer le paquet pcsx2_1.4.0+dfsg-2_i386.deb afin d'installer un emulateur PS2. Il est disponible ici: https://packages.debian.org/stretch/pcsx2.

L'installation se fait sous paquet 32 bit, donc:

dpkg --add-architecture i386



Et lorsque je :

dpkg -i pcsx2_1.4.0+dfsg-2_i386.deb



Ca me renvoie:


dpkg: des problèmes de dépendances empêchent la configuration de pcsx2 :
 pcsx2 dépend de libsdl2-2.0-0 (>= 2.0.4) ; cependant :
 Le paquet libsdl2-2.0-0:i386 n'est pas encore configuré.
 pcsx2 dépend de libsoundtouch1 (>= 1.9.2) ; cependant :
 pcsx2 dépend de libstdc++6 (>= 5.2) ; cependant :
  La version de libstdc++6:i386 sur le système est 4.9.2-10.
 pcsx2 dépend de libwxbase3.0-0v5 (>= 3.0.2+dfsg) ; cependant :
 pcsx2 dépend de libwxgtk3.0-0v5 (>= 3.0.2+dfsg) ; cependant :
  Le paquet libwxgtk3.0-0v5 n'est pas installé.

dpkg: erreur de traitement du paquet pcsx2 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Des erreurs ont été rencontrées pendant l'exécution :
 pcsx2



Donc je

 apt-get -f install



Mais rien n'y fait!
Si je comprend bien mes paquets de dépendances non satisfaites sont d'une version inférieur à celle requise...

Comment puis-je les installer afin de pouvoir installer mon émulateur? Je n'arrive pas à les installer manuellement.

Merci d'avance,
romy



tu a fait un apt-get update ? aprés ta commande  dpkg --add-architecture i386
pour mettre a jour ton cache
et meme un apt-get upgrade ensuite

tu a l option -s pour simuler sans installer
tu a aptitude te donne des solutions
utiliser -f (forcer) reste dangereux roll hmm

en graphique tu a le paquet gdebi (programme ) qui installe les .deb (va vérifier les dépendances avant de te proposer "install"

Dernière modification par robert2a (24-01-2017 18:40:19)

Hors ligne

#7 24-01-2017 19:19:08

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Problème installation paquet pcsx2_1.4.0+dfsg-2_i386.deb

@robert2a : oui mais il veut installer un paquet de stretch téléchargé directement sur jessie et il y a des dépendances qui ne sont que dans stretch donc ça ne passe pas.
il semble vouloir passer sur stretch
sinon il y a aussi la méthode avec pinning : https://debian-facile.org/doc:systeme:apt:pinning
mais est-ce que ça conviendrait ici ?

Hors ligne

#8 24-01-2017 19:42:00

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème installation paquet pcsx2_1.4.0+dfsg-2_i386.deb

ok donc j'ai rien dit  neutral
mélanger des paquets de jessie et stretch je conseillerai pas  hmm

Hors ligne

Pied de page des forums