Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-08-2009 14:35:23

Vassili
Membre
Distrib. : Squeeze (Testing)
Noyau : 2.6.26-2-amd64
(G)UI : Pekwm
Inscription : 27-07-2009

Problème d'affichage avec VLC (à cause de Xorg peut-être)

Bonjour,

J'ai un problème d'affichage en lecture vidéo. J'utilise VLC mais aussi MPlayer et dans les deux cas il m'est impossible de lire correctement un fichier vidéo.

Voici une capture :

[img align=C]http://img7.hostingpics.net/pics/521326vlc_blem_01.png[/img]

Ce qui est étonnant est qu'en faisant une capture avec le raccourci Ctrl+S de VLC, j'obtiens une capture correcte de la vidéo :

[img align=C]http://img7.hostingpics.net/pics/692932vlcsnap_234886.png[/img]

Je me demande si ce n'est pas du coté de Xorg que ça pose problème.
Voici mon xorg.conf :

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "fr"
   Option      "XkbVariant"   "latin9"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection


Qu'en pensez-vous ?

Hors ligne

#2 06-08-2009 03:03:34

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Problème d'affichage avec VLC (à cause de Xorg peut-être)

Salut

Je me souvenais avoir déjà vu un problème semblable au tien. Une petite recherche m'a permis de retrouver le fil de discussion ; c'est . Dans son dernier message la personne a semble-t-il résolu son problème en installant le paquet ffmpeg. Maintenant si elle a le dépôt debian-multimedia dans son sources.list c'est la version présente dans ce dernier qui a été installé sinon c'est celle dans le dépôt officiel debian.

Pour le moment je ne peux en dire plus. En espérant que le lien donné te permettra de te venir en aide.

Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 20-08-2009 19:39:15

Pirhoo
Membre
Lieu : Grenoble, France
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : KDE
Inscription : 19-08-2009
Site Web

Re : Problème d'affichage avec VLC (à cause de Xorg peut-être)

VLC et mplayer subissent le même avec les .avi quand ils sont installé depuis les dépots debian-multimedia. Pour moi la solution la plus simple a été d'installer vlc depuis les backports:

apt-get -t lenny-backports install  vlc


Bien sûr avec ce dépôt dans ton /etc/apt/source.list

#backports
deb http://www.backports.org/debian lenny-backports main contrib non-free


et pour installer la clef d'authentification:

wget -O - http://backports.org/debian/archive.key | apt-key add -


Branche Ton Sonotone, le webzine qui te débouche les oreilles !

Hors ligne

#4 14-08-2010 03:11:46

Einucent
Membre
Lieu : Tolosa
Distrib. : 6.0.4
Noyau : 2.6.32-trunk-686
(G)UI : Gnome 2.28.2
Inscription : 09-02-2009
Site Web

Re : Problème d'affichage avec VLC (à cause de Xorg peut-être)

Désolé pour le déterrage de topic. Il m'arrive exactement la même chose depuis quelques temps (je saurais pas dire) je vois l'image ratatinée dans la fenêtre de VLC mais un snapshot me donne bien l'image dans les bonnes dimensions.
J'ai essayé en lisant un DVD il se passe la même chose, c'est pas lié au format .avi
J'ai essayé avec Totem (2.30.2) qui modifie pas les dimensions mais lit de façon sacccadée, et MPlayer (qui saccade et l'image et le son).

J'ai aucune idée d'où je peux chercher pour trouver une piste. Et je décroche quand je lis ce qui se dis sur l'autre fil dont tu mets le lien Martin.
Par quoi je peux commencer pour savoir quoi corriger ?

Led Zepplin didn't write tunes that everyone liked, they left that to the Bee Gees !
mxl87-br-buton.png

Hors ligne

Pied de page des forums