Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-01-2017 20:09:16

Guy19550
Membre
Inscription : 10-08-2016

[Clos] Easynote xs20 (Packard Bell)

Bonjour,

Easynote xs20 (Packard Bell)

J'en ai un comme neuf encore dans sa boîte d'origine. C'est un disque dur ATA de 1.8" de 30 GB. J'ai déjà Windows XP3 dessus mais c'est horiblement lent (le temps d'accès au disque dur est de 30 ms). Tout marche sous Windows (sans être satisfaisant), à l'exeption de la webcam et Skype. J'ai fait une image disque et je suis passé à DF qui me semble nettement plus approprié pour ce PC dont le CPU tourne à 1.2 GHz.

Je me suis lancé avec l'installation de DF en utilisant la totalité du disque dur (L'installation de debian 7.11 et 8.5 avec CD est impossible). J'ai ensuite réduit la taille de la partition pour en rajouter une partition de Backup et cela pour les deux systèmes). J'ai pas mal de choses qui ne fonctionnent pas avec DF :

- Bluethooth (Toshiba 4.0.2108.0)
- wifi (Realtek 5.1273.11.2...)
- audio (VIA 6.0.1.1240)
- Skype (la cam fonctionne), pas le micro

Deux images des bureaux :

34pjjgh.jpg

20a4ck3.jpg

J'ai fait une image disque et reflashé Windows pour faire un backup des drivers et ensuite reflashé DF. Je suis donc au même point avec les drivers utilisés sous Windows en ma possession.
Pour l'audio, j'ai déjà utilisé pavucontrol et pulsecode et je vois les volumes bouger sans rien entendre, c'est le problème. J'ai l'impression que ce n'est pas raccordé au bon endroit pour que les signaux soient audibles et je suis sans idée pour résoudre ce problème.

Image des drivers Windows :

35krfrp.jpg

Pour bluetooth c'est un driver de Toshiba (4.0.2108.0) et pour la Wifi c'est un driver de Realtek (5.1273.11.2...).
voir image ci-dessous. Aucune des deux fonctions n'est activée avec l'installation.

Je ne sais pas si les problèmes peuvent être résolus...

Je suis toujours dans un état "second" et fort distrait à cause des problèmes personnels, je ne saurais donc pas suivre les réponses de manière assidue et régulière, j'en suis navré mais ma tête a des difficultés en ce moment. J'ai commencé à écrire dans un document texte pour cette raison, histoire d'être le plus complet possible avec un seul message.

Dernière modification par Guy19550 (Aujourd'hui 00:45:10)

Hors ligne

#2 30-01-2017 23:32:32

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Bonsoir Guy19550,

Sacré défi que voilà : ressusciter la curiosité muséographique technologique qu'est le nanobook EasyNote XS20 de Packard Bell ! Les numéros de version des pilotes Windows ne sont pas d'un très grand intérêt ; leur description donne un aperçu de ce qui t'attend sous DFLinux, mais autant employer une méthode éthiquement correcte :

lspci -nnk

lsusb

aplay -l


Histoire de se mettre en bouche... et pour faire plus ample connaissance :

xinput --list

xrandr --query


Difficile d'en écrire un peu plus, sans information concrète sur le matériel :

  • Bluetooth, connais pas, mais il y a de la doc ;

  • WiFi, le contrôleur RTL8187 est en principe pris en charge par le module pilote rtl8187 sans firmware ;

  • Audio, peut-être aller voir 'du côté de chez' AlsaMixer ;

  • Graphique, il semble que la définition native de l'écran est 800x480 (WVGA, 15/9) mais que la définition actuelle est un multiple de 320x240, peut-être 640x480 (VGA, 12/9), d'où une nette ovalisation des 'rondeurs' ;

  • Skype, jamais entendu parler de ce machin...


Espace muséographique du fil (de discussion) :
1485810797.jpg

Dernière modification par èfpé (30-01-2017 23:49:49)

Hors ligne

#3 31-01-2017 14:39:15

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Merci de la réponse, je ne suis pas encore dans mon assiette, je regarderai tout avec attention (c'est bien la bête). Je pense que j'aurai récupéré un peu mieux la semaine prochaine pour compléter ma réponse. Je compléterai ici par la suite, toujours par soucis de rester le plus clair possible. D'une manière générale, internet en LAN marche bien mieux avec DF, la souris est pour sauter au plafond, le pavé à droite et les deux boutons à gauche, faut être chinois pour être aussi tordu.

Hors ligne

#4 01-02-2017 15:17:17

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Re-,

Pour ce qui est du pavé tactile, le poids des mots (ici) est bien 'raccord' avec le choc des photos (ici et ) ! Concernant le Bluetooth, la documentation du projet DFLinux mentionne un 'Gestionnaire Bluetooth' (blueman-manager) mais tu peux néanmoins vérifier que tous les paquets requis sont effectivement installés (la liste des paquets dflinux-jessie, à comparer éventuellement avec la liste des paquets handylinux-2.5, laisse penser le contraire) :

dpkg -l | egrep 'blue(m|z|t)'


et/ou vérifier l'état d'activation du service avec :

systemctl status bluetooth


Quant au souci de définition d'écran, la page 'man' du pilote openchrome n'était point très rassurante :

       Option "PanelSize"  "string"
              Specifies the size (width x height) of the LCD panel attached to
              the system.  The sizes 640x480,  800x600,  1024x768,  1280x1024,
              and 1400x1050 are supported.


Mais Florian Cramer (cf. dernier lien donné au post #2) expliquait en 2008 n'avoir pas rencontré de problème particulier, et donnait même un exemple de fichier xorg.conf neutral

Enfin, la documentation ALSA préconise la configuration suivante (à confirmer) :

nano /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=auto


D'autres compléteront et t'aideront dans la libération de la bête ; bons courage et rétablissement à toi.

Dernière modification par èfpé (04-02-2017 11:53:53)

Hors ligne

#5 07-02-2017 02:22:22

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

J'ai eu le temps de réfléchir après avoir lu les premiers lien. Pour Windows, j'ai refait une image disque avec une installation en FAT32 au lieu de NTFS. J'ai conservé l'image, ça marche tout aussi mal (est instable) et je pense devoir faire appel à un disque virtuel en RAM pour résoudre le problème ou changer le disque dur par une carte SD qui n'acceptera que le FAT32. Cela fait pas mal de changements et j'ai peur de commencer à cela.

Ensuite j'ai lu des liens antérieurs que d'autres ont réussi à installer Debian (alors pourquoi pas moi ?), j'ai donc recommencé une nouvelle fois et j'ai pu installer Debian sur un stick USB (cela me semblait le le plus logique à faire, pour conserver XP) et pour finir j'ai encore une nouvelle installation avec Debian sur le disque dur. C'est une chose étrange, mais j'ai maintenant la Wifi aussi bien pour Debian sur stick USB que pour Debian sur le disque dur. Je n'ai donc plus que le problème audio à résoudre et éventuellement Bluetooth. L'avantage de Debian et est qu'il y a des données en haut de l'écran et en bas et que je peux de la sorte compléter le dock, de sorte que le bureau soit vide (enfin, reste le disque de Backup (et WinXP) si je prends le stick USB avec Debian en ayant XP sur le disque dur. Quand j'étais sous Windows pour les drivers, j'ai mis le bios à jour ce qui n'avais pas été fait au début quand j'avais essayé Debian 7 et Debian 8 sans succès. C'est peut-être une explication. La résolution d'écran est meilleure avec DF qu'avec Debian (640 x 480 au lieu de 320 x 240 - je ne suis plus fort certain des chiffres). Ce n'est pas forcément en avantage d'avoir plus de résolution, vu que l'écran est très petit, mais sous Debian 8, j'ai parfois des cases à sélectionner qui ne sont pas visible (trop bas à l'écran). Debian sur le Stick est légèrement plus rapide que Debian sur le disque dur et j'ai eu deux installations très différentes. L'installation sur le stick m'a forcé d'utiliser le CD de bootrepair après avoir mis le Grub sur SDB et pour l'installation de Debian sur le disque dur j'ai mis le Grub sur SDA1 (pas eu besoin du CD de bootrepair mais j'ai eu d'autres problèmes avec sudoers (résolu avec les informations antérieures dans une autre file). J'ai parfois l'écran qui fresse avec la souris sous Debian sur le disque dur (quand une souris extérieure est connectée). Je vais passer les commandes est donner le résultat, mais je pense que seul l'audio reste à résoudre. Je vais commencer maintenant, je vais changer de PC, introduire les commandes, stocker dans un fichier et repasser sur l'autre PC pour donner les résultats.

Les 5 premières commandes :

guy@debian:~$

lspci -nnk


00:00.0 Host bridge [0600]: VIA Technologies, Inc. CX700/VX700 Host Bridge [1106:0324] (rev 10)
  Subsystem: VIA Technologies, Inc. CX700/VX700 Host Bridge [1106:0324]
  Kernel driver in use: agpgart-via
00:00.1 Host bridge [0600]: VIA Technologies, Inc. CX700/VX700 Host Bridge [1106:1324]
00:00.2 Host bridge [0600]: VIA Technologies, Inc. CX700/VX700 Host Bridge [1106:2324]
00:00.3 Host bridge [0600]: VIA Technologies, Inc. CX700/VX700 Host Bridge [1106:3324]
00:00.4 Host bridge [0600]: VIA Technologies, Inc. CX700/VX700 Host Bridge [1106:4324]
00:00.7 Host bridge [0600]: VIA Technologies, Inc. CX700/VX700 Host Bridge [1106:7324]
00:01.0 PCI bridge [0604]: VIA Technologies, Inc. VT8237/VX700 PCI Bridge [1106:b198]
00:0f.0 IDE interface [0101]: VIA Technologies, Inc. CX700/VX700 RAID Controller [1106:0581]
  Subsystem: Packard Bell B.V. Device [1631:c201]
  Kernel driver in use: pata_via
00:10.0 USB controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 90)
  Subsystem: Packard Bell B.V. Device [1631:c201]
  Kernel driver in use: uhci_hcd
00:10.1 USB controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 90)
  Subsystem: Packard Bell B.V. Device [1631:c201]
  Kernel driver in use: uhci_hcd
00:10.2 USB controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 90)
  Subsystem: Packard Bell B.V. Device [1631:c201]
  Kernel driver in use: uhci_hcd
00:10.4 USB controller [0c03]: VIA Technologies, Inc. USB 2.0 [1106:3104] (rev 90)
  Subsystem: Packard Bell B.V. Device [1631:c201]
  Kernel driver in use: ehci-pci
00:11.0 ISA bridge [0601]: VIA Technologies, Inc. CX700/VX700 PCI to ISA Bridge [1106:8324]
  Subsystem: Packard Bell B.V. Device [1631:c201]
00:11.7 Host bridge [0600]: VIA Technologies, Inc. CX700/VX700 Internal Module Bus [1106:324e]
  Subsystem: VIA Technologies, Inc. CX700/VX700 Internal Module Bus [1106:324e]
00:13.0 PCI bridge [0604]: VIA Technologies, Inc. CX700/VX700 Host Bridge [1106:324b]
00:13.1 PCI bridge [0604]: VIA Technologies, Inc. CX700/VX700 PCI to PCI Bridge [1106:324a]
01:00.0 VGA compatible controller [0300]: VIA Technologies, Inc. CX700/VX700 [S3 UniChrome Pro] [1106:3157] (rev 03)
  Subsystem: Packard Bell B.V. Device [1631:c201]
02:01.0 Audio device [0403]: VIA Technologies, Inc. VT8237A/VT8251 HDA Controller [1106:3288] (rev 10)
  Subsystem: Packard Bell B.V. Device [1631:c201]
  Kernel driver in use: snd_hda_intel
03:09.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter [10ec:8139] (rev 10)
  Subsystem: Packard Bell B.V. Device [1631:c201]
  Kernel driver in use: 8139too



guy@debian:~$


guy@debian:~$

lsusb
 


Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 003: ID 5986:0101 Acer, Inc USB2.0 Camera
Bus 001 Device 002: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


guy@debian:~$


guy@debian:~$

aplay -l


**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: VT82xx [HDA VIA VT82xx], périphérique 0: VT1708 Analog [VT1708 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0



guy@debian:~$


guy@debian:~$

xinput --list


bash: xinput : commande introuvable





guy@debian:~$

xrander --query


bash: xrander : commande introuvable



guy@debian:~$


Les 2 commandes suivantes (j'ai cafouillé un peu) :

guy@debian:~$

dpkg -l | egrep 'blue(m|z|t)'


libbluetooth3:i386                    5.23-2+b1      
                      i386        
Library to use the BlueZ Linux Bluetooth stack




guy@debian:~$

systemctl status bluetooth


● bluetooth.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)



guy@debian:~$

Pour alsa, cela ouvre un fichier vide. alsa installé ou pas ???
j'ai alsa-base installé (et c'est noté comme dummy)
et aussi alsa-utils

Edit à toto :
Mis en ordre de lecture les commandes user et leurs retours.

Dernière modification par Guy19550 (07-02-2017 03:48:21)

Hors ligne

#6 07-02-2017 17:10:11

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Re-,

Alors je ne sais pas trop quelle ISO a finalement été installée... mais pour ce qui concerne le Bluetooth, je peux te donner la liste des paquets présents sur une Debian 8 Jessie Xfce (amd64) :

dpkg -l | egrep 'blue(m|z|t)'

bluetooth            5.23-2     all    Bluetooth support
bluez                5.23-2+b1  amd64  Bluetooth tools and daemons
libbluetooth3:amd64  5.23-2+b1  amd64  Library to use the BlueZ Linux Bluetooth stack


Je te laisse extrapoler et ajouter le paquet graphique si besoin (cf. supra) ;

systemctl status bluetooth

● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: inactive (dead)
     Docs: man:bluetoothd(8)


Le service est inactif, pour la bonne raison qu'il n'y a pas de périphérique...

La commande xinput est fournie par le paquet du même nom et la commande xrandr n'a pas d'alias.

Le fichier alsa-base.conf n'existe pas par défaut sous Jessie, mais il n'est pas interdit de le créer si besoin (note qu'en l'occurrence cela ne devrait pas changer grand-chose, car c'est le comportement par défaut selon la doc). Quoi qu'il en soit, tu peux effectuer une petite recherche sur le codec, et penser au célèbrissime bogue dit de la sourdine, si tu es toujours sous Xfce.

edit: attention avec pavucontrol, le fameux bogue de la sourdine est visualisable sous l'onglet Périphériques de sortie, mais pas sous l'onglet Lecture.

Dernière modification par èfpé (09-02-2017 14:10:11)

Hors ligne

#7 08-02-2017 02:10:34

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Je ne trouve rien pour l'audio qui la fait marcher (j'ai créé le fichier pour Alsa, mais cela ne change rien non plus). J'ai mis pavucontrol encore pour voir, on voit bien que les signaux sont présents mais on n'entend rien. Je me rabats donc sur XP qui me donne tout (y compris les instabilités), dommage. Je vais voir du côté de Ubuntu pour voir s'il existe une version légère pour essayer, mais j'en doute très fort.

Hors ligne

#8 08-02-2017 10:07:43

Coconuts
Membre
Lieu : Ici dans un Rucher d'abeilles
Distrib. : Jessie Gnome/ Stretch/lightdm-XFCE
Noyau : Linux Version 3.16.0-4-amd64/ Linux stretch 4.9.2-
Inscription : 29-06-2014

Re : [Clos] Easynote xs20 (Packard Bell)

Bonjour Guy19550 smile

Guy19550 a écrit :

Je vais voir du côté de Ubuntu pour voir s'il existe une version légère pour essayer, mais j'en doute très fort.



Je n’ai rien contre Ubuntu, mais tu as la possibilité de tester la dernière version de Debian non free.

Images non libres non officielles y compris les progiciels

Traduit par Google :

Voici quelques images supplémentaires, équivalentes aux images normales que nous produisons régulièrement, sauf qu'elles incluent également des microprogrammes non libres pour rendre les choses plus faciles sur certains systèmes nécessitant un firmware propriétaire mais redistribuable. Voir http://wiki.debian.org/Firmware pour plus de détails.

Il y a deux types d'image ici:

Des CD d'installation "netinst" qui incluent également des micrologiciels pour faciliter l'installation https://cdimage.debian.org/cdimage/unof … ch/iso-cd/
    
Des images en direct, y compris des paquetages de micrologiciel préinstallés.

Ici la dernière version https://cdimage.debian.org/cdimage/unof … e+nonfree/

Tu aura ensuite la possibilité d’installer les outils DF

Bonne journée wink

Dernière modification par Coconuts (08-02-2017 10:28:25)


Le chocolat a un effet anti-fatigue et anti-déprime, n’hésitez pas à craquer pour un carré de chocolat, c’est bon pour le moral et pour l'esprit en général.
Des points-choco faciles pour piller la cassette à Smolski – Merci qui ? Merci bendia

Hors ligne

#9 11-02-2017 10:35:22

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Je vais regarder cela à l'occasion, j'ai essayé Lubuntu, l'installation se passe bien mais pendant l'installation on a un message pour l'audio dont on sait qu'on aura des problèmes ensuite vers la fin y a le grub qui refuse de s'installer sur le disque dur.

J'ai conservé une version Debian sur un stick USB (avec l'image du stick faite bit à bit sur mon gros PC)

wuigir.jpg

On a la wifi à la condition que le démarrage antérieur était avec Wifi, rien dans le cas contraire.
Pas d'audio.
Je n'ai donc pas tout abandonné encore, mais je ne compte plus essayer sur le disque dur, trop dur à changer chaque fois.

Hors ligne

#10 12-02-2017 01:43:05

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

J'ai refait une installation avec le CD "T-instal". Cela me donne un écran noir et j'ai donc reflashé sur le stick l'ancienne image qui marche mais sans l'audio.

C'est lié à snd_hda_intel (quasi certain) et j'ai trouvé ce lien : https://linuxquimper.org/forum/index.php?topic=973.0

Cela ressemble assez à mon problème et en suivant le fil, j'ai pu trouver ceci :
http://www.alsa-project.org/db/?f=6708b … 3d601f9d93

Là je trouve rien pour le model, donc coincé également...

Je me demande si ce ne serait pas model=VIA VT1708 à rajouter ??? (ou Pegasus ou encore VT82xx). Au démarrage comme seul message il y a celui-ci : snd_hda_intel 0000:02:01.0: CORB reset timeout#1, CORBRP = 0, les autres ne viennent pas à l'écran.

Dernière modification par Guy19550 (12-02-2017 17:33:52)

Hors ligne

#11 13-02-2017 23:02:09

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

J'ai essayé toutes les options avec "options snd-hda-intel model=" tout d'abord auto ensuite null ensuite Pegasus ensuite VT82xx et pour terminer VIA VT1708. Pour chaque cas, j'ai redémarré et ouvert à la suite de l'autre le mixer et le contrôle de volume pulseaudio pour voir si on avait du changement... aucun résultat.

Cela peut-il faire une différence avec "snd_hda_intel" ???

Hors ligne

#12 13-02-2017 23:24:24

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Bonsoir Guy19550,

Concernant le module snd_hda_intel les seuls 'model' valides sont ceux de la doc ALSA.
As-tu par ailleurs suivi les différentes pistes proposées par le chouette tuto du wiki local ?

Hors ligne

#13 14-02-2017 04:06:46

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

le module est bien snd_hda_intel et j'ai suivi le tuto pour introduire options snd-hda-intel model=auto, mais pas de son
La commande cat (suivi de je ne sais plus quoi, me donne bien ce résultat comme seul module et donc options snd-hda-intel model=auto dans le fichier /etc/modprobe.d/alsa-base.conf aurait du résoudre le problème, mais il n'en est rien.

J'ai commencé avec snd-hda-intel, ça n'a rien donné.
J'ai recommencé avec snd_hda_intel, ça n'a rien donné.
J'ai recommencé avec snd_hda_intel et alsa_base, ça n'a rien donné.

Si déjà je savais quand il faut mettre "_" ou "-", ce serait un gros pas en avant...

Les signaux arrivent bien quelque part, je le vois sur les graphiques avec pavucontrol, mais sur le chemin, il y a des "fils" coupés (image). Faut brancher les HP sur le signal et donc rajouter des fils (encore une image).

Je reflashe la dernière image sur le stick pour être certain qu'il ne reste aucun résidu des tentatives antérieures.

Dernière modification par Guy19550 (14-02-2017 12:07:02)

Hors ligne

#14 14-02-2017 17:28:14

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Bonjour également,

En 2008 avec un noyau 2.6.26, Florian Cramer (cf. dernier lien donné au post #2) avait du son au niveau des haut-parleurs internes, mais pas au niveau de la sortie externe. As-tu testé cette sortie avec un casque ou des enceintes externes, à tout hasard ? Quoi qu'il en soit, il est étonnant de ne pas parvenir au même résultat en 2017 avec un noyau 3.16, à moins d'une régression ou d'un sérieux problème de configuration. Il aurait pu être intéressant d'avoir une trace du message d'erreur (cf. post #9) délivré par l'installateur de Lubuntu.

Note que la sortie du script alsa-info.sh exécuté il y a quelques jours (cf. post #10) montrait quelques contrôles à l'état '[off]' sous AlsaMixer (notamment le casque) ; et puisque tu ne précises pas sous quel onglet de pavucontrol (Périphériques de sortie ? Lecture ? les deux mon capitaine ?) tu constates une activité, il pourrait être pertinent de poster les retours de :

pacmd list-sinks | egrep 'index|name:|volume:|muted|device.description|active'

pacmd list-cards | egrep 'index|name:|alsa.card |alsa.card_name|device.description|active'


Si tu postes le résultat, n'hésite surtout pas à employer les balises adaptées, merci big_smile

Dernière modification par èfpé (14-02-2017 17:48:14)

Hors ligne

#15 15-02-2017 20:35:34

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Non je n'ai pas testé la sortie casque, mais je vais le faire encore ce soir. Aucune trace d'erreur avec LUbuntu (j'ai pris la dernière version pour l'essai), écran noir, je ne savais donc rien faire, à part couper et passer à autre chose. Je vais aussi passer les scripts mais je dois changer de PC pour cela. Je compléterai plus tard. Pas de son non plus sur des écouteurs.
L'activité constatée est pour les haut-parleurs et le micro interne.

pacmd list-sinks | egrep 'index|name:|volume:|muted|device.description|active'


guy@debian:~$ pacmd list-sinks | egrep 'index|name:|volume:|muted|device.description|active'
  * index: 0
  name: <alsa_output.pci-0000_02_01.0.analog-stereo>
  volume: front-left: 54854 /  84% / -4,64 dB,   front-right: 54854 /  84% / -4,64 dB
  base volume: 65536 / 100% / 0,00 dB
  muted: no
    device.description = "VT8237A/VT8251 HDA Controller Stéréo analogique"
  active port: <analog-output-speaker>
guy@debian:~$



pacmd list-cards | egrep 'index|name:|alsa.card |alsa.card_name|device.description|activ


guy@debian:~$ pacmd list-cards | egrep 'index|name:|alsa.card |alsa.card_name|device.description|active'
    index: 0
  name: <alsa_card.pci-0000_02_01.0>
    alsa.card = "0"
    alsa.card_name = "HDA VIA VT82xx"
    device.description = "VT8237A/VT8251 HDA Controller"
  active profile: <output:analog-stereo+input:analog-stereo>
guy@debian:~$


Edit à toto :
Mis les première commandes avec leurs retours séparés dans la balise marquée 'bloc à supprimer...'.

Dernière modification par Guy19550 (15-02-2017 21:24:48)

Hors ligne

#16 15-02-2017 22:10:24

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Bonsoir Guy19550,

L'activité constatée est pour les haut-parleurs et le micro interne.

Ces onglets n'existent pas dans pavucontrol (dans AlsaMixer ce sont des potentiomètres pas des vumètres).

Les signaux arrivent bien quelque part, je le vois sur les graphiques avec pavucontrol, [...]

Donc je réitère ma question : sous quel onglet dans pavucontrol ? Périphériques de sortie ? Lecture ? les 2 ?

Ceci dit, le retour de la commande pacmd list-sinks montre qu'il ne s'agit pas d'un vulgaire cas de bogue dit de la sourdine (muted: no) sous Xfce + PulseAudio ; as-tu ajouté le greffon Audio Mixer au tableau de bord ?

Dernière modification par èfpé (16-02-2017 10:10:24)

Hors ligne

#17 16-02-2017 05:55:39

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

rien en lecture (pas coupé pour autant le trait est bleu à gauche du bouton), oui en périphérique de sortie, oui en périphérique d'entrée pour le micro. Le greffon n'était pas ajouté, maintenant oui, mais ne change rien. Je vais redémarrer pour voir si cela fait une différence. Aucun changement en redémarrant, pas de son.

Dernière modification par Guy19550 (16-02-2017 06:08:22)

Hors ligne

#18 16-02-2017 09:54:32

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Oh je n'ai pas écrit que cela pourrait régler le problème... par contre c'est le bon moyen de se récupérer le fameux bogue de la sourdine ; quelles sont les propositions pour 'Sound card:' dans les propriétés du greffon Audio Mixer, mis à part 'HDA VIA VT82xx (Alsa mixer)' ?

Par ailleurs le fait que tu n'aies rien d'autre que 'Sons système' sous l'onglet Lecture de pavucontrol (quand tu lances un son quelconque via Firefox, VLC ou tout autre machin potentiellement bruyant) m'étonne un peu ; il serait intéressant de lister les paquets GStreamer installés :

dpkg -l | grep ' gstreamer'

Dernière modification par èfpé (16-02-2017 10:14:32)

Hors ligne

#19 16-02-2017 21:57:20

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

quelles sont les propositions pour 'Sound card:' dans les propriétés du greffon Audio Mixer, mis à part 'HDA VIA VT82xx (Alsa mixer)' ?


Aucune alternative à ce choix.

Par ailleurs le fait que tu n'aies rien d'autre que 'Sons système' sous l'onglet Lecture de pavucontrol (quand tu lances un son quelconque via Firefox, VLC ou tout autre machin potentiellement bruyant) m'étonne un peu


Je n'ai effectivement rien d'autres que "sons systèmes" quelque soit l'affichage que je demande (all streams, applications ou virtual streams).

guy@debian:~$

dpkg -l | grep ' gstreamer'


ii  gstreamer0.10-alsa:i386               0.10.36-2                            i386         GStreamer plugin for ALSA
ii  gstreamer0.10-plugins-base:i386       0.10.36-2                            i386         GStreamer plugins from the "base" set
ii  gstreamer1.0-libav:i386               1.4.4-2                              i386         libav plugin for GStreamer
ii  gstreamer1.0-plugins-base:i386        1.4.4-2                              i386         GStreamer plugins from the "base" set
ii  gstreamer1.0-plugins-good:i386        1.4.4-2+deb8u2                       i386         GStreamer plugins from the "good" set
ii  gstreamer1.0-plugins-ugly:i386        1.4.4-2+b1                           i386         GStreamer plugins from the "ugly" set
ii  gstreamer1.0-x:i386                   1.4.4-2                              i386         GStreamer plugins for X11 and Pango
guy@debian:~$



Je ne sais pas si c'est important, mais sous Windows, quand j'ai installé le driver audio, je n'avais pas de son non plus. J'ai du pour l'avoir, rechercher un pilote pour le concentrateur (je pense que c'est le nom correct). Ce pilote, Windows a pu le trouver mais j'ai du faire la manipulation.

Edit à toto :
Déplacé le retour de la commande user (épurée) dans le bloc à supprimer ... qui s'affiche automatiquement pour ça avec les balises Commande user ou root.

Dernière modification par Guy19550 (16-02-2017 22:28:51)

Hors ligne

#20 16-02-2017 22:58:24

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Bonsoir Guy19550,

Alors je pense que dans un premier temps, tu pourrais déjà compléter ta collection de plugins GStreamer, en particulier la série 0.10 (compatible avec xfce4-mixer) : gstreamer0.10-fluendo-mp3, gstreamer0.10-gconf, gstreamer0.10-plugins-good, gstreamer0.10-plugins-ugly et enfin/surtout gstreamer0.10-pulseaudio, qui te permettrait d'échapper au fameux bogue de la sourdine, lors du contrôle du volume de sortie depuis le greffon Audio Mixer (cf. post #18).

Par ailleurs je suis en train de regarder ce qu'il est possible de faire au niveau modules (snd-hda-codec-via ?)

Dernière modification par èfpé (16-02-2017 23:08:24)

Hors ligne

#21 17-02-2017 01:37:51

chad
Membre
Lieu : Rennes
Distrib. : debian 9.0
Noyau : 4.9.0-1-amd64
(G)UI : cinnamon 3.2.7
Inscription : 05-02-2017

Re : [Clos] Easynote xs20 (Packard Bell)

purée j'ai un easy note de 2014 je galere parfois

bravo pour la perf de faire tourner ta bete !
9 ans deja !

quel défi !

félicitations je n'aurais pas le courage

Dernière modification par chad (17-02-2017 01:39:10)

Hors ligne

#22 17-02-2017 03:31:03

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

@Chad : je suis tombé dans la maladie en 1998, j'ai mis 10 ans à récupérer un peu et je sais faire maintenant certaines choses qui 10 ans avant, étaient impossible. J'ai loupé une bonne partie de l'évolution de la technologie et à mon aise, je prends ce que je peux de ce que j'ai loupé. J'avais jamais vu un portable depuis mon Sharp (sur disquettes), ça a bien changé, lol. Je ne sais pas si c'est toujours un mieux car les anciens programmes étaient bien souvent meilleurs que les nouveaux, mais on ne fait pas vraiment la même chose avec un PC qu'avant. Le pire que j'ai vu jusqu'à présent (si j'oublie les PC mal conçus), c'est la fameuse carte PCMCIA pour internet en wifi.

@èfpe : Voilà, les paquets ont été installés (tout ceux qui ont été mentionnés), mais je n'ai toujours pas de son. J'ai plus d'options dans alsa mixer, mais pas de son.

Je ne sais pas si la méthode suivie est bonne et parfois, cela en installe d'autres en plus. Je suis passé par le Synaptic pour les installer et je n'aime pas trop le faire ainsi. Il en reste quelques'uns qui n'ont pas été installés comme par exemple "util" et "bad". "doc" est un de ceux qui est venu en plus. En gros une petite cinquantaine de paquets ont été installés en plus et le nettoyage m'a enlevé pour 150 MB environ de data non utilisées.

Dernière modification par Guy19550 (17-02-2017 03:36:45)

Hors ligne

#23 17-02-2017 08:54:32

èfpé
Membre
Inscription : 10-07-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Bonjour,

Concernant les modules chargés (cf. sortie du script alsa-info.sh), tout ce que j'ai trouvé est un paramètre pour snd-hda-intel, spécifique aux contrôleurs audio VIA :

nano /etc/modprobe.d/alsa-base.conf

options snd-hda-intel position_fix=VIACOMBO

Source : (en) kernel.org

En 2008 sous Debian 4.0 Etch, il est probable que Florian Cramer n'utilisait pas PulseAudio ; peut-être utilisait-il EsounD ? Alors deux idées un peu tordues, pour finir :

  • désinstaller le serveur de son PulseAudio (pour certains c'est la solution) ;

  • installer Debian 7 Wheezy (maintenue encore 15 mois) ou HandyLinux 1.9


Voilà... je déclare forfait, mais je suis certain que d'autres prendront le relais smile

Dernière modification par èfpé (18-02-2017 16:54:32)

Hors ligne

#24 18-02-2017 14:32:32

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

Concernant les modules chargés (cf. sortie du script alsa-info.sh), tout ce que j'ai trouvé est un paramètre pour snd-hda-intel, spécifique aux contrôleurs audio VIA :

nano /etc/modprobe.d/alsa-base.conf

options snd-hda-intel position_fix=VIACOMBO

Source : (en) kernel.org



Cela me donne un message d'erreur au démarrage. Je vais essayer la version 7 à tout hasard et si cela ne donne rien, je pourrai reflasher l'image de la version 8.5 que j'ai, mais sans l'audio.

Un gros merci pour l'aide et les recherches.

Hors ligne

#25 Aujourd'hui 00:43:40

Guy19550
Membre
Inscription : 10-08-2016

Re : [Clos] Easynote xs20 (Packard Bell)

J'ai essayé Debian 7 et j'ai eu les mêmes genres de messages que la toute première fois, ensuite est venu Handylinux 1.9 et même problème que pour Debian 7. La version 2.5 de Handylinux a également été essayée, elle s'installe, mais même problème avec l'audio. Et pour finir, j'ai essayé Antix 13 avec des problèmes similaires que pour Debian 7. Je me contente donc de Debian 8.5 (sans audio pour le moment). Côté XP, j'ai installé un Ramdisk de 40 MB (plus nécessite la licence du programme) et je suis aussi revenu en arrière vu que cela ne permet pas réellement un démarrage plus rapide. Ce qui reste à essayer sous Windows est le remplacement du disque dur par une carte SD via un petit module IDE (déjà testé sur un autre PC et la carte SD est bien reconnue comme disque dur, mais le partitionnement de la carte SD doit se faire en FAT32 exclusivement. Je n'ose pas trop essayer cela sur le XS20, vu mes grosses pattes et le 7". pas sur non plus que le circuit imprimé IDE est compatible avec ce qui est en place pour ce HD d'origine (1.8" et non 2.5"). C'est donc un abandon partiel, car je conserve ce que j'ai avec le stick sous Debian 8.5.

Dernière modification par Guy19550 (Aujourd'hui 00:55:41)

Hors ligne

Pied de page des forums