Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-02-2017 18:16:07

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

[Résolu à 70%] impossible d'avoir l'icone pour connexion wifi

Bonjour,
Je viens d'installer jessie 64bits, bureau mate.
Sur un autre PC avec les paquets : network-manager-gnome et network-manager c'était suffisant pour avoir la sympathique icone de connexion wifi dans la barre des tâches.
Sur ce PC portable (HP) j'ai une puce wifi realtek, j'ai donc chargé le paquet firmware correspondant.
En chargeant le paquet wicd-daemon, j'arrive bien à me connecter en wifi . Mais je n'aime pas cette présentation.
C'est ce que je pensais, puisque ma box était indiquée comme connectée, mais en fait en faisant un ping dessus cela n'aboutit pas...
Merci pour un peu d'aide.

Dernière modification par gargamel79 (11-02-2017 19:56:21)

Hors ligne

#2 02-02-2017 08:27:41

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu à 70%] impossible d'avoir l'icone pour connexion wifi

Bonjour smile
Peux tu donner plus d'infos sur le PC
Et que donne la commande

lspci -k | grep -i network -A 2


Le wiki sur le wifi : https://debian-facile.org/doc:reseau:wifi

Hors ligne

#3 02-02-2017 10:19:39

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu à 70%] impossible d'avoir l'icone pour connexion wifi

Merci pour ta réponse:
voici un extrait du message de retour
....RealtekSemiconducteur ...RTL8723BE PCIe ....Kernel driver in use : rtl8723be
Donc, je pense que le firmware est bien reconnu.
Je vais aller voir le tuto. indiqué, cela paraît très intéressant... smile

Dernière modification par gargamel79 (02-02-2017 10:20:12)

Hors ligne

#4 02-02-2017 10:30:52

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu à 70%] impossible d'avoir l'icone pour connexion wifi

Peut-être bien une piste ici :
https://forum.ubuntu-fr.org/viewtopic.php?id=1986337
pour régler le wifi capricieux

Edit : tu avais bien redémarré après avoir installé de firmware-realtek ?

Hors ligne

#5 02-02-2017 10:35:35

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu à 70%] impossible d'avoir l'icone pour connexion wifi

Dans les petits détails, ne pas oublier de faire gérer le wifi par network-manager, donc de ne pas configurer "en dur" l'interface wifi (virer tout dans /etc/network/interfaces sauf

# The loopback network interface
auto lo
iface lo inet loopback


« Nous vivons dans un monde ou ceux qui gagnent 100000€ par mois persuadent ceux qui gagnent 1800€ par mois que tout va mal à cause de ceux qui gagnent 535€ par mois. Et ça marche ! » - Felix Lobo

Hors ligne

#6 02-02-2017 19:44:02

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu à 70%] impossible d'avoir l'icone pour connexion wifi

J'ai suivi le conseil:
dans /etc/network/interfaces,
j'ai mis en commentaire la ligne :
source /etc/network/interfaces.d/*
Il me semble qu'à partir de ce moment, je n'avais plus de réseau, même en filaire...
J'ai donc décommenté cette ligne: sans résultat (après reboot)
J'ai renommé le fichier /etc/udev/rules.d/70-persistente-net.rules pour qu'il soit recréé au reboot.
Maintenant avec la commande ifconfig j'ai bien une adresse pour eth0
eth0 à une ip 192.168.1.24

mais je n'ai plus accès à ethernet. Un ping sur ma box (192.168.1.1) est OK
A partir d'un autre station, un ping sur 192.168.1.24 est OK

ifup eth0
  -> ignoring unknown interface eth0=eth0

Je n'ai plus d'icone dans la barre des tâche pour le réseau filaire
Lorsque j'utilise l'icone "Gestionnaire réseau Wicd" pour me connecter, ifconfig indique:
une adresse ip :192.168.1.123 pour wlan0
mais je perd l'adresse ip pour eth0

A partir d'une autre station un ping sur 192.168.1.123 n'aboutit pas
**********
Après reboot, l'icone "normale" est présente, j'ai de nouveau accès à inthernet et au WEB. Ouf!
J'ai l'impression que si j'arrivais à supprimer le "Gestionnaire réseau Wicd" l'icone "normale"
reprendrait la main pour le wifi (inaccessible par l'icone "normale").

rfkill list n'indique rien de bloqué sauf pour
1: acer-wireless : Wireless LAN
    soft blocked : yes
Mais je ne peux pas le débloquer avec tfkill unblock 1
j'ai mis en doute la box, j'y suis allé mais je ne vois rien d'anormal..
**************************************************
J'ai réussis à me débarrasser de l'icône qui me déplaît en supprimant tous les paquets wicd. Mais cela ne résout.pas le problème de la connexion wifi...
****************************************************
En allant sur les forums, en particulier : https://forum.ubuntu-fr.org/viewtopic.p … 001004&p=2
J'ai résolu partiellement le problème de :soft blocked : yes pour acer-wireless en éditant le fichier:
/etc/modprobe.d/fbdev-blacklist.conf en ajoutant la ligne:
blacklist acer-wmi
Je peux maintenant me connecter avec un clé usb externe, la même qui est préconisée pour le raspberry (c'est aussi une puce realtek).
Par contre sans cette clé, le fonctionnement du wifi interne est complètement lamentable (un ping sur ma box met des dizaines de secondes à répondre).
J'ai créé un fichier /etc/modprobe.d/rtl8723.conf
avec la ligne :options rtl8723be fwlps=N ips=N ant_sel=1   (ou  ant_sel=2)
Mais cela n'améliore rien, je doute que ce fichier soit pris en compte, même au reboot.
Je passe donc en Résolu à 70%, puisque, moyennant cette clé externe, ma station est utilisable en wifi de manière tout à fait correcte wink

Dernière modification par gargamel79 (11-02-2017 19:54:56)

Hors ligne

Pied de page des forums