Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-02-2017 12:25:04

samy765
Membre
Inscription : 13-09-2016

[resolu] installer wine 1.8.5+ backports en 2017 ?

resolu : bon finalement jai pris le probleme a lenvers, fresh install de la meme debian8.7cinnamon, jactive larchitecture i386 en 1er lieu, jajoutes amd64/i386 dans les depots de base et backports, jessai dinstaller des version 32bit de certains paquets clef en fait surtout de 1 libc6:i386 via la ligne de commande parce que pas visible dans synaptic, finalement jessai dinstaller wine32:i386 comme tout 1er paquet concernant wine, le truc sinstalle mais wine marche pas, ok, jinstalle wine dans synaptic ca casse pas wine32:i386 qui apparait que une fois installer sur la machine...du coup jinstalle wine64 voir si ca pose probleme, aucun probleme ca devient interessant car c'est la meme config que jai sur me debian8.5lxde, je met winetricks sans installer de directx&co via celui ci, je lance un taskmgr dans wine bon wine marche, du coup jinstalle les pilotes 340+nvidia-xconfig qui va bien et reboot, ca va toujours aussi bien, finalement je lance wow et il demarre comme si de rien n'etait....à 60fps casiment, ensuite jme souviens que javais mis a jour cinnamon pi jme dis ouais bon à la rigeur je met tout le systeme a jour dans synaptic (backport me fait un peu peur mais bon au pire je reinstallerais xd) donc cinnamon3.0+ linux-hearders-4.9 en me disant ca se trouve je vais switch sur du testing avec ce noyau bref je fais la grosse maj, reboot, ca marche toujours aussi bien jai acces aux options de cinnamon3.0, je lance wow, au meme endroit jai perdu env 8fps mais ca se lance toujours bien, bref je vais laisser tout ca comme ca on verra ce que ca dit, je laisse mon post comme ca il me servira de methode pour regler ce soucis si jai oublier comment je lai regler et ca servira ptete a dautres wink ps:linux-headers4.9 mais debian toujours marquer comme 8.7 donc pas testing ni rien, je suis sauvé xd


Bonjour, ca fait deja plusieurs fois que jessai dautres environnement de bureau que mon lxde de base, et pour ce faire jinstalle tout simplement ma debian avec le DEnv que je veux essayer dans une autre partition, donc fresh install avec DEnv different, apres linstall je viens pour installer wine via les backports histoire davoir une version assez avancée ET vu que je sais que la version backport 1.8.5 que jai sur ma debian lxde (mon systeme de base) marche tout comme je souhaite du coup je marrange pour installer une version proche de celle-ci sur mes nouvelles install de debian avec un nouveau DEnv

donc comment je fais ca, ben par exemple aujourd'hui jai voulu essayer debian cinnamon donc je chope ca, debian en 8.7 (ma lxde est en 8.5), installation donc en DEnv Cinnamon (jai pris le disc debian-live-8.7-cinnamon en somme, tout sinstalle bien, de là je met la suite de ce que je fais ligne par ligne ce sera plus clair :

_jinstalle les pilotes nvidia apres avoir fouiller un peu dans mon sources.list pour voir apparaitre les drivers nivida dans synaptic jinstalle les drivers dkms en 340 + un petit sudo nvidia-xconfig pour créer le fichier xorg automatiquement qui va bien

_reboot du pc pour mettre en service les nouveau pilotes graphique

_jajoutes larchitecture i386 à mon amd64 et ensuite je vérifies  via la bonne commende foreigntruc quelle apparait bien et en effet elle apparait donc bien installé au systeme

_ de là je fais un 1er try direct dans synaptic pour installer wine, donc je coche wine en backport donc 1.8.6-3bpo8+1 il coche automatiquement tout ce quil a besoin, je met aussi winetricks vu que je men sers sur ma debian8.5lxde et qu'il me permet davoir plus de facilitée a utiliser wine sans pour autant foutre la merde dedans (contrairement a pol pour ma part)

_je fais appliquer, jme sers de wine pour un jeu en fait cest wow...et jai deja mon jeux installé etc, jai juste à le lancer et il demarre direct si wine a ce qu'il lui faut (jai toujours fais comme depuis que je suis passer à linux, ca marchait sur lubuntu, ca marchait sur debian lxde, bref ca marche parfaitement si c'est ok du coter de wine)

_ de là, dans winetricks jinstalle dirext9 et 10 un peu de vcrun/vbrun si possible, bref 2ou3choses que jai dinstaller sur ma debian8.5lxde jinstalle rien dautre tfacon jai pas besoin dinstaller dautres choses que jai pas dinstaller dans ma 8.5 normalement

_ pour finir je ferme et relance winetricks --gui  "vous utiliser une 64bit par defaut oui je sais depuis lubuntu merci" ensuite je fais pour etre sur que wine demarre de facon clean demarre le wine-taskmanager afin davoir acces à lenvironnement de wine pret à demarrer des programmes (normalement jai pas besoin, sur ma 8.5 jme suis fais un petit bash qui lance le jeu en mode wine wow.exe directement je doucleclic dessus comme un raccourcis et le jeu demarre)

_de là je fais nouvelle tache, parcourir, wow.exe ouvrir et là jai generalement le meme soucis quelque soit lenvironnement de bureau que jessai (donc fresh install de debian stable actuel avec nouvel environnement de bureau)
1) le jeu demarre pas et fais une erreur, ca boot pas
2) du coup je lis le terminal là où jai lancer winetricks : et là ca commence a etre le bordel du genre "vous avez pas installer wine32 ou wine32:i386 car dependance manquante mais tfacon on installera pas la dependance manquante ni rien dautre dailleur parce que le(s) paquet(s) sont verrouiller (à ce que je comprends apt installera pas ce quil faut sinon ca va créer des paquet cassés et meme si je force linstall c'est bien jai installer les maquets manquant avec un petit tas de paquet cassés mais je peux toujours pas installer wine32blabla parce que je dois dabord réparé les paquets cassés ....

du coup ca tourne tres vite en rond, je dois faire quoi pour avoir une installation simple de wine 1.8+, jai bien essayer ca apres avoir tout désinstaller  :
sudo apt install \
      wine/jessie-backports \
      wine32/jessie-backports \
      wine64/jessie-backports \
      libwine/jessie-backports \
      libwine:i386/jessie-backports \
      fonts-wine/jessie-backports

memes erreurs, ah non non non dependance incorrect tfacon on changera pas de version de paquets car celle-ci est verrouiller (garder en letat)....et bien evidement c'est sur du wine32


encore un autre test, sudo apt-get install libwine:i386, voici la reponse :
Les paquets suivants contiennent des dépendances non satisfaites :
libwine:i386 : Dépend: libgl1-mesa-glx:i386 mais ne sera pas installé ou
                         libgl1:i386
                Dépend: libglib2.0-0:i386 (>= 2.12.0) mais ne sera pas installé
                Dépend: libglu1-mesa:i386 mais ne sera pas installé ou
                         libglu1:i386
                Dépend: libgstreamer-plugins-base0.10-0:i386 (>= 0.10.22) mais ne sera pas installé
                Dépend: libgstreamer0.10-0:i386 (>= 0.10.26) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

merci davance de votre aide, c'est quand meme assez agacant de voir que c'est toujours les meme soucis que je rencontre a chaque fois que je test un nouvelle environnement de bureau, alors que sur ma lxde ca marche niquel chrome quoi, dommage que le bureau lxde soit pas un peu plus joli/moderne ca me derangerait presque pas dme cantonner a celui-ci hmm

jai essayer kde4 en debian 8.5, marchait pas et encore pire tu viens faire un sudo leafpad ou kwrite ou kmachin il sort des erreur sans meme pouvoir lancer le programme et c'est pas un probleme de sudoers ca va bien plus loin apperement sinon jaurais trouver la solution sur google je penses bref kde joli mais gros soucis de demarrage de programmes en terminal avec sudo/su en plus du fait que wine marchait pas ou tres mal (me semble que javais reussi à le faire marche à genre 10fps là où je suis à 50+ voir 60 sur ma debian lxde,
ensuite jai voulu test debian testing avec plasma5 histoire de test un truc qui pete les yeux, au final cest limite moins joli que kde4 je penses au bleu du contour des fenetres notament, puis là etant donner que cetait du testing equivalent a ubuntu 16.04 jai eu 2ou3soucis pour installer les drivers au point que je savais a peine dire si jetais bien sur les bons pilotes ou le "nouveau"...et coter wine bah en fait cetait le meme shmilblik que là sur debian8.7cinnamon, je vais ptete tester un truc tout en stable pas de backports mais bon jai pas beaucoup despoir:/

Dernière modification par samy765 (05-02-2017 17:12:48)

Hors ligne

Pied de page des forums