Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-02-2017 20:01:22

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

"résolu" stretch casse-suite a mise à jour

dpkg -l | grep -v ^ii



Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                    Version                              Architecture Description
+++-======================================-====================================-============-===============================================================================
iU  cups                                   2.2.1-8                              amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
iU  cups-bsd                               2.2.1-8                              amd64        Common UNIX Printing System(tm) - BSD commands
iU  cups-client                            2.2.1-8                              amd64        Common UNIX Printing System(tm) - client programs (SysV)
iU  cups-common                            2.2.1-8                              all          Common UNIX Printing System(tm) - common files
iU  cups-core-drivers                      2.2.1-8                              amd64        Common UNIX Printing System(tm) - PPD-less printing
iU  cups-daemon                            2.2.1-8                              amd64        Common UNIX Printing System(tm) - daemon
iU  cups-ppdc                              2.2.1-8                              amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
iU  cups-server-common                     2.2.1-8                              all          Common UNIX Printing System(tm) - server common files
it  dbus                                   1.10.14-1                            amd64        simple interprocess messaging system (daemon and utilities)
iU  hplip                                  3.16.11+repack0-2                    amd64        HP Linux Printing and Imaging System (HPLIP)
iU  hplip-data                             3.16.11+repack0-2                    all          HP Linux Printing and Imaging - data files
it  libc-bin                               2.24-9                               amd64        GNU C Library: Binaries
iU  libcups2:amd64                         2.2.1-8                              amd64        Common UNIX Printing System(tm) - Core library
iU  libcupscgi1:amd64                      2.2.1-8                              amd64        Common UNIX Printing System(tm) - CGI library
iU  libcupsimage2:amd64                    2.2.1-8                              amd64        Common UNIX Printing System(tm) - Raster image library
iU  libcupsmime1:amd64                     2.2.1-8                              amd64        Common UNIX Printing System(tm) - MIME library
iU  libcupsppdc1:amd64                     2.2.1-8                              amd64        Common UNIX Printing System(tm) - PPD manipulation library
iU  libhpmud0:amd64                        3.16.11+repack0-2                    amd64        HP Multi-Point Transport Driver (hpmud) run-time libraries
iU  libsane:amd64                          1.0.25-3                             amd64        API library for scanners
iU  libsane-hpaio:amd64                    3.16.11+repack0-2                    amd64        HP SANE backend for multi-function peripherals
it  man-db                                 2.7.6.1-2                            amd64        on-line manual pager
iU  printer-driver-hpcups                  3.16.11+repack0-2                    amd64        HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
iU  printer-driver-hpijs                   3.16.11+repack0-2                    amd64        HP Linux Printing and Imaging - printer driver (hpijs)
iU  printer-driver-postscript-hp           3.16.11+repack0-2                    all          HP Printers PostScript Descriptions
it  systemd                                232-15                               amd64        system and service manager
 


apt-get install --reinstall systemd



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libsane : Dépend: libsane-common (= 1.0.25-3) mais 1.0.25-2 devra être installé
           Recommande: sane-utils (>= 1.0.25-3) mais 1.0.25-2+b1 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



Edit : mise en forme avec les balises codes. Voir le tuto : Le code, ça pique moins les yeux en couleur
ça se lit mieux wink

Dernière modification par lagrenouille (06-02-2017 23:23:27)


L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

En ligne

#2 06-02-2017 20:32:41

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : "résolu" stretch casse-suite a mise à jour

 dpkg -l | grep  sane



i

i  libcommon-sense-perl                   3.74-2                               amd64        module that implements some sane defaults for Perl programs
ii  libfile-slurp-tiny-perl                0.003-1                              all          simple, sane and efficient file slurper
iU  libsane:amd64                          1.0.25-3                             amd64        API library for scanners
ii  libsane-common                         1.0.25-2                             all          API library for scanners -- documentation and support files
ii  libsane-extras:amd64                   1.0.22.4                             amd64        API library for scanners -- extra backends
ii  libsane-extras-common                  1.0.22.4                             amd64        API library for scanners -- documentation and support files
pU  libsane-hpaio:amd64                    3.16.11+repack0-2                    amd64        HP SANE backend for multi-function peripherals
ii  sane                                   1.0.14-11                            amd64        scanner graphical frontends
ii  sane-backends                          1.0.23-1                             amd64        Package created with checkinstall 1.6.2
ii  sane-utils                             1.0.25-2+b1                          amd64        API library for scanners -- utilities
ii  xsane                                  0.999-4                              amd64        featureful graphical frontend for SANE (Scanner Access Now Easy)
ii  xsane-common                           0.999-4                              all          xsane architecture independent files





dpkg -l | grep  cups



iU  cups                                   2.2.1-8                              amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
ii  cups-browsed                           1.11.6-3                             amd64        OpenPrinting CUPS Filters - cups-browsed
iU  cups-bsd                               2.2.1-8                              amd64        Common UNIX Printing System(tm) - BSD commands
iU  cups-client                            2.2.1-8                              amd64        Common UNIX Printing System(tm) - client programs (SysV)
iU  cups-common                            2.2.1-8                              all          Common UNIX Printing System(tm) - common files
iU  cups-core-drivers                      2.2.1-8                              amd64        Common UNIX Printing System(tm) - PPD-less printing
iU  cups-daemon                            2.2.1-8                              amd64        Common UNIX Printing System(tm) - daemon
ii  cups-filters                           1.11.6-3                             amd64        OpenPrinting CUPS Filters - Main Package
ii  cups-filters-core-drivers              1.11.6-3                             amd64        OpenPrinting CUPS Filters - PPD-less printing
ii  cups-pdf                               2.6.1-22                             amd64        PDF writer backend for CUPS (dummy transitional package)
ii  cups-pk-helper                         0.2.6-1                              amd64        PolicyKit helper to configure cups with fine-grained privileges
iU  cups-ppdc                              2.2.1-8                              amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
iU  cups-server-common                     2.2.1-8                              all          Common UNIX Printing System(tm) - server common files
iU  libcups2:amd64                         2.2.1-8                              amd64        Common UNIX Printing System(tm) - Core library
iU  libcupscgi1:amd64                      2.2.1-8                              amd64        Common UNIX Printing System(tm) - CGI library
ii  libcupsfilters1:amd64                  1.11.6-3                             amd64        OpenPrinting CUPS Filters - Shared library
iU  libcupsimage2:amd64                    2.2.1-8                              amd64        Common UNIX Printing System(tm) - Raster image library
iU  libcupsmime1:amd64                     2.2.1-8                              amd64        Common UNIX Printing System(tm) - MIME library
iU  libcupsppdc1:amd64                     2.2.1-8                              amd64        Common UNIX Printing System(tm) - PPD manipulation library
ii  printer-driver-cups-pdf                2.6.1-22                             amd64        printer driver for PDF writing via CUPS
iU  printer-driver-hpcups                  3.16.11+repack0-2                    amd64        HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii  python3-cups                           1.9.73-1                             amd64        Python3 bindings for CUPS
ii  python3-cupshelpers                    1.5.7-2                              all          Python utility modules around the CUPS printing system




dpkg -l | grep  systemd



ii

  dbus-user-session                      1.10.14-1                            all          simple interprocess messaging system (systemd --user integration)
ii  libpam-systemd:amd64                   232-15                               amd64        system and service manager - PAM module
ii  libsystemd0:amd64                      232-15                               amd64        systemd utility library
it  systemd                                232-15                               amd64        system and service manager
ii  systemd-sysv                           232-15                               amd64        system and service manager - SysV links
 




dpkg -r libsane:amd64 sane-backends sane



dpkg: un problème de dépendance empêche la suppression de libsane:amd64 :
 iscan dépend de libsane (>= 1.0.11-3).
 xsane dépend de libsane (>= 1.0.24).
 sane-utils dépend de libsane (>= 1.0.24).
 colord dépend de libsane (>= 1.0.24).
 simple-scan dépend de libsane (>= 1.0.24) ; cependant :
  Le paquet libsane:amd64 doit être supprimé.
 hplip dépend de libsane (>= 1.0.24) ; cependant :
  Le paquet libsane:amd64 doit être supprimé

dpkg: erreur de traitement du paquet libsane:amd64 (--remove) :
 problème de dépendance - suppression ignorée
(Lecture de la base de données... 182339 fichiers et répertoires déjà installés.)
Suppression de sane-backends (1.0.23-1) ...
Suppression de sane (1.0.14-11) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 libsane:amd64
.

Dernière modification par lagrenouille (06-02-2017 22:54:03)


L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

En ligne

#3 06-02-2017 20:38:51

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : "résolu" stretch casse-suite a mise à jour

Bonsoir smile
Est-ce qu'il y a quelque chose qui n'est pas clair dans le tuto sur l'utilisation des balises codes ?
Elles rendent le message plus clair et facile à lire.

Désolée sinon de ne pouvoir t'aider, ça dépasse largement mes compétences.

Hors ligne

#4 06-02-2017 20:44:15

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : "résolu" stretch casse-suite a mise à jour

dpkg --force-depends -r libsane:amd64 sane-backends sane


dpkg: avertissement: requête ignorée : suppression de sane-backends, qui n'est pas installé
dpkg: avertissement: requête pour supprimer sane ignorée, seuls les fichiers
de configuration sont installés ; utiliser --purge pour les supprimer aussi
dpkg: libsane:amd64 : problème de dépendance, mais suppression comme demandé :
 iscan dépend de libsane (>= 1.0.11-3).
 xsane dépend de libsane (>= 1.0.24).
 sane-utils dépend de libsane (>= 1.0.24).
 colord dépend de libsane (>= 1.0.24).
 simple-scan dépend de libsane (>= 1.0.24) ; cependant :
  Le paquet libsane:amd64 doit être supprimé.
 hplip dépend de libsane (>= 1.0.24) ; cependant :
  Le paquet libsane:amd64 doit être supprimé.

(Lecture de la base de données... 181279 fichiers et répertoires déjà installés.)
Suppression de libsane:amd64 (1.0.25-3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-9) ...


je sais pas si je dois désinstaller ceci qui ne vient pas de apt

dpkg -l | grep  iscan


ii  iscan                                  2.30.2-2                             amd64        simple, easy to use scanner utility for EPSON scanners
ii  iscan-data                             1.36.0-1                             all          Image Scan! for Linux data files



 apt full-upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 colord : Dépend: libsane (>= 1.0.24) mais il n'est pas installé
 hplip : Dépend: libsane (>= 1.0.24) mais il n'est pas installé
 iscan : Dépend: libsane (>= 1.0.11-3) mais il n'est pas installé
 sane-utils : Dépend: libsane (>= 1.0.24) mais il n'est pas installé
 simple-scan : Dépend: libsane (>= 1.0.24) mais il n'est pas installé
 xsane : Dépend: libsane (>= 1.0.24) mais il n'est pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution)

Dernière modification par lagrenouille (06-02-2017 21:01:28)


L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

En ligne

#5 06-02-2017 21:04:58

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : "résolu" stretch casse-suite a mise à jour

Bonsoir smile
Est-ce qu'il y a quelque chose qui n'est pas clair dans le tuto sur l'utilisation des balises codes ?
Elles rendent le message plus clair et facile à lire.

Désolée sinon de ne pouvoir t'aider, ça dépasse largement mes compétences.



non tout va bien, c'est moi qui suis très brouillon sur un ordi  tongue


L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

En ligne

#6 06-02-2017 22:29:43

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : "résolu" stretch casse-suite a mise à jour

Bonsoir,
As-tu essayé la commande suggérée ?

apt --fix-broken install


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#7 06-02-2017 22:40:52

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : "résolu" stretch casse-suite a mise à jour

oui et c'est maintenant résolu, sauf que j'ai oublié de paster la commande et la suite avant de rebooter.

je crois que c'est des paquets iscan que j'ai récupéré chez epson qui ont mis la zone ??
suis pas sur à 100%
ujn des paguetsà giclé et l'autre est en rc, mais je peux pas le purger.

le scanner et l'imprimante fonctionne sans, donc c'est bien une nouveauté sous stretch que ce scan
soit pris en charge ..

mais suis incapable de trop expliqué comment systemd à cassé

la commande suivante donné par capnfab à réparé

dpkg   --force-depends -r libsane:amd64 sane-backends sane



puis un

 apt full-upgrade


suite à quoi la commande


apt --fix-broken install



a tout réinstallé

ensuite j'ai pu refaire un update
et j'ai rebooté

je retrouve même pas l'historique des commandes ...ppfffffffffffff

PS: à l'attention de captnfab
au fait j'ai pas migrer de jessie à Stable, mon DD a pété, donc c'est une installation de stretch..

Dernière modification par lagrenouille (06-02-2017 22:58:23)


L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

En ligne

#8 06-02-2017 22:56:58

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : "résolu" stretch casse-suite a mise à jour

Super si c'est résolu cool

Pour l'historique des commandes : /var/log/apt/history.log

Et ... un petit point choco biggreen.gif Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#9 06-02-2017 23:10:12

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : "résolu" stretch casse-suite a mise à jour

j'ai déjà dit

je ne retrouve aucune des commandes qui ont réparés, null part..
et je fouille les logs

j'attends un peu pour mettre résolu  merci.gif

L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

En ligne

#10 07-02-2017 07:39:37

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : "résolu" stretch casse-suite a mise à jour

salut

suite du feuilleton

je continue donc ce matin à chercher comment ma bécane à cassé

dpkg -l | grep -v ^ii


Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                    Version                              Architecture Description
+++-======================================-====================================-============-===============================================================================
ri  iscan                                  2.30.2-2                             amd64        simple, easy to use scanner utility for EPSON scanners




le paquet iscan fait bien partie des deb

apt-cache search iscan



exim4-daemon-heavy - Démon MTA Exim (v4) avec des fonctions étendues, incluant exiscan-acl
sa-exim - SpamAssassin filter for Exim
iscan-data - Image Scan! for Linux data files
iscan - simple, easy to use scanner utility for EPSON scanners
 


il me semblait bien pourtant que je suis allé chercher ces paquets chez epson, mais je ne peux l'affirmer cause
mémoire défaillante..
sous jessie je suis sur que ces paquets n'existaient pas (iscan et iscan-data)

Jai bien tenté il y a quelques temps d'installer des paquets pour mon scanner mustek A3
et changer il me semble le sane-backend , mais depuis des  update et upgrade quotidien n'avaient rien cassé.

 apt-cache depends iscan


iscan
  Dépend: iscan-data
  Dépend: libc6
  Dépend: libgcc1
  Dépend: libglib2.0-0
  Dépend: libgtk2.0-0
  Dépend: libltdl7
  Dépend: libsane
  Dépend: libstdc++6
  Dépend: libusb-1.0-0
  Dépend: libxml2
  Est en conflit avec: <iscan-network-nt>
  Est en conflit avec: <iscan-plugin-cx4400>
  Est en conflit avec: <iscan-plugin-gt-7200>
  Est en conflit avec: <iscan-plugin-gt-7300>
  Est en conflit avec: <iscan-plugin-gt-9400>
  Est en conflit avec: <iscan-plugin-gt-f500>
  Est en conflit avec: <iscan-plugin-gt-f520>
  Est en conflit avec: <iscan-plugin-gt-f600>
  Est en conflit avec: <iscan-plugin-gt-f670>
  Est en conflit avec: <iscan-plugin-gt-f700>
  Est en conflit avec: <iscan-plugin-gt-s600>
  Est en conflit avec: <iscan-plugin-gt-x750>
  Recommande: gimp
  Remplace: libsane-extras
   



dpkg -l | grep libsane-extras


ii  libsane-extras:amd64                   1.0.22.4                             amd64        API library for scanners -- extra backends
ii  libsane-extras-common                  1.0.22.4                             amd64        API library for scanners -- documentation and support files
 






dpkg -r iscan



dpkg: un problème de dépendance empêche la suppression de iscan :
 esci-interpreter-perfection-v330 dépend de iscan (>= 2.25).

dpkg: erreur de traitement du paquet iscan (--remove) :
 problème de dépendance - suppression ignorée
Des erreurs ont été rencontrées pendant l'exécution :
 iscan
 



j'en suis donc là,  le scanner A4 et l'imprimante  epson fonctionnent tous les deux

difficile de croire que le paquet sane-backend  à lui seul ai fait ce massacre ...  old_geek.gif

Dernière modification par lagrenouille (07-02-2017 08:18:47)


L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

En ligne

#11 07-02-2017 08:26:09

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : "résolu" stretch casse-suite a mise à jour

je comprends pas tout  roll
tu parle de stretch
tu parle de nouvelle installation
tu parle de jessie et epson
suis un peu perdu ............  la mise a jour de stretch a posé problème a cause d un scaner epson installé sur jessie  old_geek.gif

Hors ligne

#12 07-02-2017 10:22:44

lagrenouille
Adhérent(e)
Lieu : dans mes rêves
Distrib. : jessie/stretch
Noyau : linux-4.9.0-2-amd64
(G)UI : env- i3-weechat-w3m-clavier bépo
Inscription : 28-03-2012
Site Web

Re : "résolu" stretch casse-suite a mise à jour

robert2a à écrit:

tu parle de stretch
tu parle de nouvelle installation
tu parle de jessie et epson
suis un peu perdu ............  la mise a jour de stretch a posé problème a cause d un scanner epson installé sur jessie



non, lis bien et tu verras,  que je dis que sous  Jessie ces packages n'existaient pas

que lorsque  j'ai installé stretch, je ne rappel pas si ces deux packages existaient  nais je n'en suis pas sur..

je cherche à comprendre ce qui à cassé hier ..et surtout pourquoi
j'ai fait  la bêtise de ne pas tout noter lors des commandes
en console (ce que je fais tout le temps, sauf hier ! allez savoir ? )


L'opinion que l'on suppose d'un être n'est souvent que le miroir de notre propre ignorance à la limiter

En ligne

Pied de page des forums