Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-02-2017 20:28:22

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Allumage led wifi inversé - Problème résolu -

Bonjour,

Sur mon PC un asus N55SL, le wifi fonctionne correctement et peut être activé ou désactivé avec la touche de fonction F2. Le problème est que la led à l'avant du PC est allumée lorsque le wifi est désactivé et éteinte lorsque le wifi est activé.

Pour info, lorsque le wifi est désactivé  :

cat /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/leds/phy0-led/brightness
0



et lorsque le wifi est activé :

cat /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/leds/phy0-led/brightness
1



Quelqu'un a-t-il une idée pour remédier à ce (petit) problème?

Merci

Dernière modification par papy-tux (12-02-2017 22:38:21)

Hors ligne

#2 11-02-2017 20:48:13

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : Allumage led wifi inversé - Problème résolu -

Tu as tenté avec le kernel backporté ?

L'informaticien sans son vocabulaire spécifique ? Rien d'impressionnant.
Venez les rencontrer en vrai : Agenda du libre

Hors ligne

#3 11-02-2017 21:06:06

èfpé
Membre
Inscription : 10-07-2016

Re : Allumage led wifi inversé - Problème résolu -

Bonsoir,

Pour le 'kernel backporté' c'est oui apparemment... peut-être une option du module ?

lspci -nnk | grep Network -A 2


Nous renseignera sur le mystérieux module chargé pour ce contrôleur WiFi.

Hors ligne

#4 11-02-2017 22:18:34

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Allumage led wifi inversé - Problème résolu -

Bonsoir,

Le module wifi est géré par iwlwifi :

lspci -s 3:00 -nnk
03:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34)
  Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN [8086:5305]
  Kernel driver in use: iwlwifi
 



Les valeurs par défaut des paramètres sont :

# systool -v -m iwlwifi
Module = "iwlwifi"

  Attributes:
    coresize            = "151552"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "1"
    taint               = "E"
    uevent              = <store method only>

  Parameters:
    11n_disable         = "0"
    amsdu_size          = "0"
    antenna_coupling    = "0"
    bt_coex_active      = "Y"
    d0i3_disable        = "Y"
    d0i3_timeout        = "1000"
    disable_11ac        = "N"
    fw_monitor          = "N"
    fw_restart          = "Y"
    lar_disable         = "N"
    led_mode            = "0"
    nvm_file            = "(null)"
    power_level         = "0"
    power_save          = "N"
    swcrypto            = "0"
    uapsd_disable       = "3"
........
 



J'ai essayé avec led_mode=1 et led_mode=2 sans changement.

.........

Hors ligne

#5 12-02-2017 18:10:10

èfpé
Membre
Inscription : 10-07-2016

Re : Allumage led wifi inversé - Problème résolu -

Hello,

Alors juste une idée ni testée ni étayée : le petit souci persiste-t-il si le Bluetooth intégré est désactivé ?
Je tenterais au niveau système (service) et au niveau pilote (module iwlwifi, paramètre 'bt_coex_active')

Hors ligne

#6 12-02-2017 22:37:05

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Allumage led wifi inversé - Problème résolu -

Bien vu èfpé!!!!

Effectivement il y a un couplage "inversé" entre le wifi et le bluetooth (que je n'utilise pas pour l'instant) : quand le wifi est allumé, le bluetooth est éteint et inversement et visiblement la led suit le bluetooth (d'après les informations de rfkill).

Comme suggéré, j'ai modifié le paramètre bt_coex_active pour le passer à N. Depuis, le wifi et le bluetooth sont "actifs" ensembles d'après rfkill, et la led est synchronisée.

Wifi désactivé :

# rfkill list
0: phy0: Wireless LAN
  Soft blocked: yes
  Hard blocked: yes
1: asus-wlan: Wireless LAN
  Soft blocked: yes
  Hard blocked: no
2: asus-bluetooth: Bluetooth
  Soft blocked: yes
  Hard blocked: no
 



Wifi activé :

# rfkill list
0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
1: asus-wlan: Wireless LAN
  Soft blocked: no
  Hard blocked: no
2: asus-bluetooth: Bluetooth
  Soft blocked: no
  Hard blocked: no
 



Problème résolu, merci!!

Ceci dit j'aimerais savoir ce que fait ce paramètres bt_coex_active et si le bluetooth pourra fonctionner si un jour j'en ai besoin.

Hors ligne

#7 13-02-2017 09:41:54

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : Allumage led wifi inversé - Problème résolu -

Bonjour smile

Comme suggéré, j'ai modifié le paramètre bt_coex_active pour le passer à N


Est-ce que tu peux expliciter un peu plus comment tu as fait ? Je n'ai pas tout compris pour savoir ce qu'il faudrait faire, quel fichier modifier ops.gif (ça m'arrive souvent lol )
merci.gif


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#8 13-02-2017 12:14:55

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Allumage led wifi inversé - Problème résolu -

Bonjour,

Pour modifier la valeur d'un paramètre d'un module à son chargement, on peut utiliser la ligne de commande du noyau, en ajoutant le paramètre sous la forme module.paramètre=valeur. 

Dans le cas présent, il faut donc ajouter

iwlwifi.bt_coex_active=N



En utilisant la ligne  GRUB_CMDLINE_LINUX_DEFAULT de /etc/default/grub, cela donne :

Avant la modif :

cat /etc/default/grub |grep GRUB_CMDLINE_LINUX_DEFAULT
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"



Après la modif (faite avec les droits root) :

# cat /etc/default/grub |grep GRUB_CMDLINE_LINUX_DEFAULT
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iwlwifi.bt_coex_active=N"



Puis mise à jour de grub.cfg :

update-grub



Au prochain redémarrage, la nouvelle valeur du paramètre sera pris en compte.

PS : je me suis aperçu en refaisant la modif, que désormais même avec le paramètre à Y, le wifi, le bt et la led était désormais synchronisée! Il a donc suffit de faire la manip une fois pour arranger le problème.

Hors ligne

#9 15-02-2017 19:52:26

èfpé
Membre
Inscription : 10-07-2016

Re : Allumage led wifi inversé - Problème résolu -

Bonsoir,

Merci @papy-tux, pour ces divers retours (concernant le paramétrage des modules du noyau, il y a également de la bonne documentation ici, ici ou ) ; pour le paramètre 'bt_coex_active' l'effet observé initialement est l'inverse de l'effet attendu :

WiFi / Bluetooth coexistence

Having WiFi and Bluetooth running at the same time is a challenge. These scenarios have been tested thoroughly on 7260 and up, less so on earlier devices. This is why some people may face issues with devices that are handled by iwldvm. For users of these devices who have problems when WiFi and Bluetooth are running concurrently, we suggest to disable BT Coex by loading iwlwifi with bt_coex_active=0 as a module parameter.

Source : (en) wireless.wiki.kernel.org

Si en plus ce n'est pas reproductible alors le problème est peut-être résolu, mais le mystère s'épaissit big_smile
Note : un bogue semble-t-il toujours d'actualité provoquerait la désactivation du WiFi via Bluetooth GUI.

Dernière modification par èfpé (15-02-2017 20:06:26)

Hors ligne

Pied de page des forums