Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 28-07-2007 19:37:26

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

arf,

je pensais que ça allait résoudre le problème, pour le .run du site officiel il est souvent déconseillé
de l'installer, la cause une mauvaise communication avec le noyau et puis lors d'un upgrade de xorg
ils ne seront plus pris en compte, alors je ne sais pas à voir, je ne les ai jamais utilisé, si tu testes
il faudra d'abord viré ceux déjà installé, mais ça m'étonnerait que ça fonctionne mieux.

les noyaux plus récent sont dans les dépôts sid,

tu peux réessayer de faire :

m-a update
m-a prepare
m-a a-i nvidia

si ça continue je te passe en sid complètement et t'expliquerais la manière de la gérer smile

Hors ligne

#27 28-07-2007 20:28:53

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

J'ai réussi grâce à vous et surtout à toi neos. Tout c'est installé parfaitement, pour ça j'ai rajouté des dépôts etch pour avoir accès à linux-headers-2.6.18-4k7 et tout c'est bien passé. Dois-je mettre ## devant les dépôts etch afin qu'ils ne soient pas pris en compte lors des mises à jours ? ou je les supprime ?

Enfin si ça fonctionnait ça serait trop beau... avec la commande glxinfo j'obtiens direct rendering : no, et avec glxgears les roues tournent de façon saccadée, mon FPS est de 470. Pourtant j'ai suivis la procédure que tu m'as indiqué lors de ton premier message, et tout c'est bien passé, le problème c'est qu'au final l'accélération 3D n'est pas installée ou activée.

J'ai remplacé "vesa" par "nvidia" dans le xorg.conf.

Hors ligne

#28 28-07-2007 20:40:21

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

garde juste les dépots testing parce que comme t'as mis des paquets à jour via testing.

quel driver il t'a installé au final ? -->  dpkg -l | grep nvidia
poste ton xorg.conf aussi.

Hors ligne

#29 28-07-2007 20:46:35

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

debian:/home/franck# dpkg -l | grep nvidia
ii  nvidia-glx                        100.14.11-1                     NVIDIA binary Xorg driver
ii  nvidia-kernel-2.6.18-4-k7         100.14.11-1+2.6.18.dfsg.1-12    NVIDIA binary kernel module for Linux 2.6.18
ii  nvidia-kernel-common              20051028+1                      NVIDIA binary kernel module common files
ii  nvidia-kernel-source              100.14.11-1                     NVIDIA binary kernel module source
ii  nvidia-settings                   1.0+20070502-1                  Tool of configuring the NVIDIA graphics driv
debian:/home/franck#


# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "Device"
    Identifier    "Carte vidéo générique"
    Driver        "nvidia"
    BusID        "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier    "Écran générique"
    Option        "DPMS"
    HorizSync    28-64
    VertRefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Carte vidéo générique"
    Monitor        "Écran générique"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1280x1024"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Hors ligne

#30 28-07-2007 21:03:17

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

je ne vois rien dans ta section files curieux, il devrait y a voir les fonts de listés, on verra.

souvient toi de ce que tu rajoutes au cas ou il y aurait un souci, je ne pense pas, j'ai ces options avec ma 6800gt, si tu veux sauvegardé l'actuel xorg.conf :

cd /etc/X11
cp xorg.conf xorg.bak

rajoute les options en rouge :

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "Module"
    Load           "bitmap"
    Load           "dbe"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "vbe"


Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "Device"
    Identifier    "Carte vidéo générique"
    Driver        "nvidia"
    BusID        "PCI:1:0:0"
    Option         "RenderAccel"           "true"
    Option      "TripleBuffer" "true"

EndSection

Section "Monitor"
    Identifier    "Écran générique"
    Option        "DPMS"
    HorizSync    28-64
    VertRefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Carte vidéo générique"
    Monitor        "Écran générique"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1280x1024"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Hors ligne

#31 28-07-2007 22:57:20

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Debian est à présent inutilisable, au démarrage on m'affiche ceci :

Le démarrage du serveur X (votre interface graphique) a achoué.
Il est probable qu'il ne soit pas configuré correctement. Voulez vous consulter les messages du


Le message ne se terminre pas. A la fin, on me signale qu'avant de relancer gdm il faut que je reconfigure xorg.conf je crois.

Peut être suis-je véritablement mauvais en informatique finalement... j'ai pourtant suivis à la lettre ce que tu m'as dit et tout avait eu l'air de s'installer correctement, mais rien ne fonctionnait.
C'est dommage car sans ces fameux pilotes je ne pourrai pas personnaliser le système comme je le souhaite.

Après peut être que la version Sid ne poserait pas de problème, non ?
Je dis surement une grosse connerie là car si je n'y arrive pas avec une version stable je ne vais surement pas y arriver avec une version instable, mais bon on peut toujours espèrer.

Au passage je suis allé faire un tour sur ton site, et je le trouve vraiment très bien fait, bravo. C'est un peu ce que je souhaiterai obtenir comme bureau.

Hors ligne

#32 29-07-2007 00:23:27

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

je pense que le mélange des dépots a mis un peu le fouilli, j'comprends pas pourquoi sous testing
il n'y a pas de nvidia-kernel-source, tu devrais réinstaller avec le bon cd amd64
je pencherais plutot pour une netinstall, ensuite on avisera pour la sid si je n trouve pas d'infos
sur nvidia et testing.

il y a le chan si tu veux venir discuter --> chan debian-facile

Hors ligne

#33 29-07-2007 11:29:04

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Dépôts, Installation pilotes graphiques, Son

Je ne connais du tout l'architecture 64 bits mais je ne crois pas que ca poserais problème d'installer un version 32 bits, si?
Sur mon architecture 32 bits j'ai installé le plus simplement du monde mon driver nvidia avec (si je me rappel bien) avec la méthode donné par neos.

Et en prime je suis toujours en stable big_smile

+

Hors ligne

#34 29-07-2007 12:22:26

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Il faut voir ça, normalement installer un système 32bits avec un processeur 64bits comme le mien ne devrait pas poser problème, c'est juste qu'il sera sous exploité.

Vous utilisez quelle version de Debian vous ?

Hors ligne

#35 29-07-2007 12:35:15

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Dépôts, Installation pilotes graphiques, Son

Pour moi c'est la version 32 bits et j'ai fait l'installation avec le cd netinstall --> http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/
Si ce n'est qu'une histoire de sous exploiter son processeur, ca vaut peut être le coup de tester? je pense que beaucoup de problèmes seront alors évités (car c'est souvent que l'on peut lire que tel ou tel chose n'est pas encore dispo pour l'architecture 64 bits), après certains diront qu'il ne faut pas ou que c'est bête de ne pas utiliser son processeur au maxi de ses possibilités....dans ce cas qu'ils nous apportent leurs solutions wink lol

@+

Hors ligne

#36 29-07-2007 12:42:40

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Je voulais dire : Quelle version de Debian utilisez-vous, stable ? testing ? instable ?

Sinon j'utilise deja une version 32bits, parce que je sais que les versions 64bits posent certains problèmes.
Mon processeur est peut être sous exploité mais étant donné que le système reste très réatif je n'ai jamais voulu passer à la version 64bits.

Dernière modification par Franck81 (29-07-2007 12:42:57)

Hors ligne

#37 29-07-2007 16:11:42

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Dépôts, Installation pilotes graphiques, Son

syb a écrit :

Et en prime je suis toujours en stable big_smile


wink

Je n'avais pas fait attention a ton sources.list donc si tu es en i386 c'est bizarre...tu aurais dû pouvoir l'installer avec la méthode donné plus haut...je ne comprend pas trop sad

As-tu essayé de remettre le backup de ton xorg.conf en place?

Hors ligne

#38 29-07-2007 16:13:46

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Non je ne me souviens plus de la commande pour faire ça.

Hors ligne

#39 29-07-2007 23:43:40

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Bonne nouvelle pour moi, grâce à votre aide et en particulier à celle de neos, j'ai réussi à installer mes pilotes pour ma carte graphique et ça fonctionne du feu de Dieu. Nickel, rien à dire. Ensuite j'ai installé Beryl, pareil.

Donc à ce niveau là, plus de problème. Je tiens à préciser que je suis passé à la version instable qui porte mal son nom puisque je la trouve très stable. Enfin me direz vous... je l'utilise depuis quelques heures à peine. tongue

J'ai un sources.list complet. Donc il reste le problème du son, et là aucun problème pour la musique ni pour les vidéos sur internet, par contre je n'ai pas les sons du systèmes, puis ma carte à l'air mal configurée.

J'ai fais une netinstall et les seuls paquets à avoir été installés en rapport avec le son sont alsa-base et alsa-utils. Pouvez-vous me s'il vous plait me donner les autres paquets à installer en rapport avec le son ?
Il doit y en avoir, par exemple la commande pour configurer la carte son ne fonctionne pas, donc il manque quelque chose.

Puis, désolé mais là j'ai un nouveau problème, dû à la netinstall surement. J'ai une imprimante dont j'ai besoin d'utiliser assez souvent, j'ai donc intallé le paquets gnome-cups-manager, seulement quand j'essaie de le lancer j'obtiens ce message :

Le serveur CUPS ne peut être contacté


J'aimerai vous poser une autre question, cette imprimante, la HP PSC 1610 Tout-en-un, intègre un scanner, serait-il possible de le faire fonctionner sous Debian ?

Actuellement c'est l'une des raisons qui me force à booter sous Windows.

Voila, je crois qu'on arrive bientôt au bout de mais problèmes mais ce n'est malheureusement pas encore fini.
Et je tiens une nouvelle fois à vous remercier car votre aide m'est vraiment précieuse.

Hors ligne

#40 30-07-2007 00:07:03

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Salut,

Donc il reste le problème du son, et là aucun problème pour la musique ni pour les vidéos sur internet,


donc tu as du son, tu peux peaufiné avec la commande alsamixer, et régler les volumes
ou enlever les mute s'il y en a [MM] avec la touche > du clavier, une fois réglé à ta convenance
tu passes en root et tu saisis :
alsactl store
pour garder ce réglage
installe gnome-alsamixer sinon

ensuite install HPLIP pour ton imprimante et cupsys cupsys-driver-gutenprint 
xsane

Hors ligne

#41 30-07-2007 00:58:01

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Ça ne fonctionne pas.
Pour imprimer un document mon imprimante n'est pas proposée, normal je ne l'ai pas mise en choix par défaut et je ne l'ai même rien fait du tout gnome-cups ne fonctionnait pas.

Pour scanner non plus, disons que sur le petit écran de mon imprimante on me propose de sauvegarder le fichier numérisé avec des logiciels disponibles uniquement sur Windows. On me propose aussi l'option Save To A File, que je choisis seulement rien ne se passe et le scan ne commence pas, et puis en choisissant cet option je me demande bien ou les fichiers scannés attériront.

Mais si gnome-cups-manager fonctionnait je pourrai imprimer comme avant et ça serait deja bient pour commencer.

Pour le son toujours pareil, je n'entends pas les sons du système mais c'est deja mieux qu'avant ou je n'entendais que ça justement. tongue

Bon il se fait tard je vais aller me coucher je verrai ça un peu plus en profondeur demain, je réinstallerai gnome-cups-manager, on verra bien ce que ça donne.

Encore merci vous êtes tous super ici.

Bonne nuit.

Hors ligne

#42 30-07-2007 09:32:30

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Dépôts, Installation pilotes graphiques, Son

Pour faciliter la recherche et la lisibilité du forum je me suis permis de recréer un autre post pour le problème d'imprimante.

La suite du problème concernant l'imprimante par ici

Essayons de ne pas partir dans tous les sens dans nos posts, pour la lisibilité et faciliter la recherche sur le forum, qu'un seul post ne devienne pas un foulli ou l'on aurait du mal a trouver une reponse à nos questions.

Merci de ta compréhension Franck81;)

Hors ligne

#43 30-07-2007 20:34:28

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Même après ce que tu m'as recommandé de faire neos, je n'entends toujours pas les sons du systèmes.
Il n'y aurait pas un autre paquet spécifique pour ça ?

Hors ligne

#44 30-07-2007 20:41:06

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

dans les paramètres de gnome :

SYSTEME > PREFERENCES > SONS onglet son il y a rien genre bip système ?

je viens de fouiller ds les dépots apparement ce serait gnome-audio
que tu recherches gnome-audio - Audio files for Gnome

Hors ligne

#45 30-07-2007 21:47:23

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

J'ai deja installé gnome-audio.

Puis dans système > Préférences > son dans l'onglet son il n'y à rien qui correspond à bip système.

Hors ligne

#46 30-07-2007 22:07:53

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Dépôts, Installation pilotes graphiques, Son

Tu peux peut être aussi contrôler ton péripherique et le volume dans le

gnome-volume-control

Hors ligne

#47 31-07-2007 00:22:23

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Malheureusement il n'est pas installé et introuvable dans mes dépôts.

Pour info voici mon sources.list :

#Depots Sid
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb http://www.debian-multimedia.org/ sid main

#Securite
deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

deb http://debian.beryl-project.org/ etch main

Dernière modification par Franck81 (31-07-2007 00:23:11)

Hors ligne

#48 31-07-2007 11:35:43

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Salut,

gnome-alsamixer te suffit pour régler ton son,
le son chez toi n'est pas un problème il me semble
puisque l'audio fonctionne c'est juste les sons systèmes que tu n'as pas, tout ce qui est musique via ton logiciel audio ou les sons via ton navigateur internet fonctionne non ?

Hors ligne

#49 31-07-2007 17:26:18

Franck81
Membre
Inscription : 27-07-2007

Re : Dépôts, Installation pilotes graphiques, Son

Oui tout fonctionne très bien, sauf les sons du systèmes. C'est étrange comme problème, non ?

Hors ligne

#50 09-08-2007 18:50:26

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Dépôts, Installation pilotes graphiques, Son

Bonjour,
Je n'y comprend plus rien.

Beryl 0.2.0 stable avec les pilotes de la ETCH les glx 8776 Stable vont pas avec le plugin Blur.
http://forum.ubuntu-fr.org/viewtopic.php?id=138950

Efectivement chez moi ça plante. Juste ceci, tout le reste fonctionne.
J'ai cherché et recherché et je suis tombé sur :
http://groups.google.com/group/linux.de … 6?lnk=raot

Puis sur:
http://www.albertomilone.com/nvidia_scripts1.html

J'ai fais un backup de mon système et lancé dans l'installation des derniers pilotes.
( J'ai vu plein d'avertissement sur l'utilisation de Envy sous Debian)
Mais comme je voulais rester en stable, j'ai opté pour cette solution.
Je me lance.

L'installation se passe bien sans erreur, la configuration du xorg.conf OK
Le plugin Blur fonctionne et ne me plante plus le PC.
beryl-manager dans le terminal ne me montre plus : GLX_ETX_texture_from_pixmap:failed.

Est-ce quelqu'un aurait beryl 0.2.0 sur une debian 4.0 ETCH et aurait activé le plugin Blur qui lui est désactivé par défault. nvidia-glx 8776 stable aussi

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

Pied de page des forums