Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-02-2017 12:54:16

Henri IV
Membre
Inscription : 13-02-2017

Freeze au lancement interface graphique / Ati Rage 128

Bonjour,

Pour commencer avec Debian et me faire la main sur ce système, je l'ai installé sur une machine ancienne mais bien fonctionnelle (fonctionne graphiquement sous Windows XP et sous Puppy Linux/Slacko).

L'install (graphique) s'est bien passée mais au lancement de l'interface graphique c'est toujours le freeze avec l'écran dont voici la photo :

https://drive.google.com/file/d/0B-fRw5 … sp=sharing

Si X n'a pas été lancé (boot en mode console), le mode console fonctionne normalement. Mais dès le lancement de l'interface graphique (startx), c'est le freeze avec clavier et souris inopérants (cependant, il y a des accès disque). Seule solution : l'arrêt hard.

Précisions :


Plateforme matérielle HP VECTRA VL420 - P4 - 32bits : http://h10032.www1.hp.com/ctg/Manual/lpv06569.pdf

Carte graphique : ATI RAGE 128 PRO

Iso installé : debian-8.7.1-i386-netinst.iso (l'accès Internet fonctionne sur ce PC - lecteur CD présent, pas DVD - pas de boot USB)

Merci d'avance pour votre aide !
Amicalement
Henri IV

Dernière modification par Henri IV (16-02-2017 12:07:09)

Hors ligne

#2 14-02-2017 13:25:09

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-2-amd64
(G)UI : Mate 1.16.1 Nvidia 375.39-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : Freeze au lancement interface graphique / Ati Rage 128

Bonjour

le bon pilote est le xserver-xorg-video-r128 , mais a vu de nez c'est les années début 2000 (il y a eu plusieurs versions , pro ,ultra , fury etc )

il faudrait voir si tu a des erreurs du noyau

sans lancer le serveur X taper cette commande et noter les erreurs


journalctl -r -p err
 



je pense au noyau qui la détecte mal (KMS) , tu peu visualiser le log /var/log/Xorg.0.log pour voir ce qu il se passe
pas question d'utiliser KDE ou Gnome avec cette carte (et ce PC ) si c'est le cas tu fais :


apt-get install mate-core lightdm
 


et a la question quel lanceur vous voulez utiliser tu répond "lightdm"
aprés il y a l'option nomodeset par grub mais si en console pure tu a la main je pense pas que ce soit la solution
question: au démarrage de debian , après la vérification du disque système tu a un changement de résolution d'écran ?  ( caractères plus petit )
ça voudrait dire que KMS prend bien en charge ta carte
et que c'est un problème du serveur X
dans tous les cas ne t attend pas a avoir un écran fluide sur le bureau , c'est une petite carte .
ps: j'ai pas vérifié mais elle ne doit pas prendre DRI2 en charge , la 3D va etre trés light  roll

PS : j'ai regardé tes liens , je me demande si tu ne devais pas installer wheezy pour tester , le serveur X tourne mais tu a une grosse corruption de l affichage tongue (et surement planté puisque tu perds souris et clavier )

sinon P4 socket 478 , mémoire sdram , carte vidéo  sur bus agp 4x

Dernière modification par robert2a (14-02-2017 14:01:07)

Hors ligne

#3 15-02-2017 21:54:46

Henri IV
Membre
Inscription : 13-02-2017

Re : Freeze au lancement interface graphique / Ati Rage 128

Bonjour robert2a,

Merci pour ta réponse.

J'ai la main en console au boot car je sélectionne "options avancées" et "recovery mode".

J'ai essayé :


journalctl -r -p err
 


Réponse :


P4-VL420 system[424]:Failed at step EXEC spawning /bin/plymc
P4-VL420 kernel:MPU-401 device not found or device busy
 


J'ai installé "lightdm" comme tu me l'as suggéré (ça s'est, à priori, bien passé).

J'ai le même freeze au lancement du serveur X...

question: au démarrage de debian , après la vérification du disque système tu a un changement de résolution d'écran ?  ( caractères plus petit )


Non, en fait, je n'ai pas de changement de taille de caractères.

je pense au noyau qui la détecte mal (KMS) , tu peu visualiser le log /var/log/Xorg.0.log pour voir ce qu il se passe



Le Xorg.0.log est vide
Le Xorg.0.log.old est ici : https://drive.google.com/file/d/0B-fRw5 … sp=sharing

Je ne demande pas de la fluidité ni des effets 3D ! C'est une machine qui me sert à expérimenter et une interface graphique, même très légère, me conviendrait fort bien (en plus du mode console que j'utilise aussi).

Je pourrai essayer la version précédente (wheezy) dès que j'ai un peu de temps, si tu penses que les ressources nécessaires sont mieux en rapport avec ma petite config. Mais, même si je le fais, j'aimerai bien comprendre précisément la raison du blocage. En effet, je passe de Windows à Debian/Linux pour comprendre ce qui se passe dans mes machines  ;-)

NB : je fais régulièrement :


apt-get update
apt-get upgrade
 



Encore merci et à +
Henri IV

Dernière modification par Henri IV (16-02-2017 12:13:56)

Hors ligne

Pied de page des forums