Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-02-2017 13:38:09

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

[Résolu] Mise à jour flashplugin-nonfree

Bonjour,

Pourriez-vous m'indiquer si le mainteneur du paquet flashplugin-nonfree s'en occupe toujours, car, depuis la version 21.0.0.186 du 30/12/2016, il y a eu 2 versions, et aucune mise à jour. Actuellement, c'est la 24.0.0.221, et pas de mise à jour du paquet. Faut-il attendre une éventuelle mise à jour, ou installer le plugin d'une autre façon ? Je ne suis pas un fan de ce plugin, mais, hélas, certains sites sur lesquels je me rends fréquemment ne veulent pas s'en passer. Merci.

Cordialement,

Dernière modification par eric2954 (16-02-2017 21:29:14)

Hors ligne

#2 16-02-2017 14:05:15

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Résolu] Mise à jour flashplugin-nonfree

flashplugin-nonfree est une particularité.
c'est juste un script qui vient récupérer flash pour l'installer.

donc, depuis ton gestionnaire de paquet, une mise à jour ne viendra pas modifier flashplugin-nonfree.

il y a des commandes pour faire la mise à jour de flash.
regarde la doc: https://debian-facile.org/doc:media:fla … in-nonfree

il y a aussi flashplayer-mozilla dans deb-multimédia mais pas testé : https://blog.niqnutn.com/index.php?arti … ta#c0056-2

Hors ligne

#3 16-02-2017 15:57:56

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] Mise à jour flashplugin-nonfree

Merci nlQnutn,

Mais, dans la doc, il est recommandé d'utiliser les paquets venant des dépôts. Or, si le paquet flashplugin-nonfree n'est pas régulièrement mis à jour, ça pose problème. Ceci dit, tu as raison, il existe d'autres moyens d'obtenir le plugin flash.

Cordialement,

Dernière modification par eric2954 (16-02-2017 16:06:43)

Hors ligne

#4 16-02-2017 17:00:37

naguam
Membre
Distrib. : Plusieurs
Noyau : Un kernel
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [Résolu] Mise à jour flashplugin-nonfree

Testes

update-flashplugin-nonfree --install

après avoir installé flashplugin-nonfree, la mise a jour du package ne met pas a jour flash, il l'installe juste automatiquement, après, il faut le mettre à jour soit-même avec la commande indiquée ci-dessus.

Après, en ce moment, chez moi et sûrmement chez d'autres gens, il y a un problème de keyring car le dev du paquet, n'as pas encore publié la bonne keyring.
Du coup, pour passer cela:
https://bugs.debian.org/cgi-bin/bugrepo … bug=842172

Message #10 received at 842172@bugs.debian.org (full text, mbox, reply):


From: Tomas Pospisek <tpo@sourcepole.ch>
To: <842172@bugs.debian.org>
Subject: Newer Upstream not yet packaged...
Date: Thu, 27 Oct 2016 11:46:06 +0200
The problem here is that the current upstream flash version
11.2.202.643 is not yet packaged by our package maintainer:

When the install routine tries to access the place where md5 sums of
the upstream binary are stored for comparison (that is Bart's user
directory at Debian) the download of those md5 sums fails.

I worked around that problem with:


* go to https://www.adobe.com/de/software/flash/about/
* Download the flash tgz
* untar
* cp libflashplayer.so /usr/lib/flashplugin-nonfree/
* update-alternatives --quiet --install
/usr/lib/mozilla/plugins/flash-mozilla.so flash-mozilla.so
/usr/lib/flashplugin-nonfree/libflashplayer.so 50
* cp flash-player-properties /usr/bin/flash-player-properties
* check that you have the new version installed by going to
https://www.adobe.com/de/software/flash/about/


Dans cette citation, c'est avec une ancienne version de flashplugin-nonfree mais cela fonctionne toujours.

Dernière modification par naguam (16-02-2017 17:01:27)

Hors ligne

#5 16-02-2017 17:08:21

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Résolu] Mise à jour flashplugin-nonfree

eric2954 a écrit :

Merci nlQnutn,

Mais, dans la doc, il est recommandé d'utiliser les paquets venant des dépôts. Or, si le paquet flashplugin-nonfree n'est pas régulièrement mis à jour, ça pose problème. Ceci dit, tu as raison, il existe d'autres moyens d'obtenir le plugin flash.

Cordialement,



encore une fois, c'est un cas exceptionnel et tout le monde espère que Fash disparaisse.
c'est pour ça que j'ai cité flashplayer-mozilla qui me semble plus facile d'utilisation que de faire à la main la mise à jour du plugin.

les recommandations, notamment de l'utilisation de dépôts tiers, sont toujours à relativiser avec nos contraintes et les cas particuliers.
il y a plusieurs manières de faire, à toi de décider celle que tu préfères.

Hors ligne

#6 16-02-2017 17:12:54

naguam
Membre
Distrib. : Plusieurs
Noyau : Un kernel
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [Résolu] Mise à jour flashplugin-nonfree

Moi je préfere faire a la main et utiliser flashplugin-nonfree, car je n'aime pas rajouter trop de dépôts. Mais cela dépend du mode de fonctionnement de la personne smile

Hors ligne

#7 16-02-2017 17:41:09

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Mise à jour flashplugin-nonfree

Bonjour,
Actuellement il y a effectivement un bug pour la mise à jour avec la commande indiquée dans le wiki donné par nIQnutn. La version est bloquée à 24.0.0.186
Je fais aussi la mise à jour manuellement et téléchargeant manuellement https://get.adobe.com/fr/flashplayer/otherversions/ le .tar.gz NPAPI
Je décompresse et je copie le fichier libflashplayer.so en écrasant celui qui existe déjà dans le dossier sur/lib/flashplugin-nonfree
Tu peux commencer par rechercher ce fichier libflasherplayer.so pour être sûr du dossier où le mettre.

En ligne

#8 16-02-2017 21:26:18

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] Mise à jour flashplugin-nonfree

Merci à tous pour vos conseils.

    Cordialement,

Hors ligne

#9 17-02-2017 11:07:19

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - XFCE
Inscription : 13-01-2010

Re : [Résolu] Mise à jour flashplugin-nonfree

nIQnutn a écrit :

j'ai cité flashplayer-mozilla qui me semble plus facile d'utilisation que de faire à la main la mise à jour du plugin



Comme la mise à jour ne fonctionnait pas avec flashplugin-nonfree, je l'ai désistallé car imcompatible avec flashplayer-mozilla:

apt-get remove --purge flashplugin-nonfree



Et j'ai voulu tester la version des dépôts deb-multimedia

Dépôts tiers

apt-get install flashplayer-mozilla
 



J'ai de nouveau une version de flash à jour.

A noter qu'il existe aussi dans ce dépôt une version pour chromium.

flashplayer-chromium

Hors ligne

#10 17-02-2017 15:19:21

naguam
Membre
Distrib. : Plusieurs
Noyau : Un kernel
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : [Résolu] Mise à jour flashplugin-nonfree

deuchdeb a écrit :

Comme la mise à jour ne fonctionnait pas avec flashplugin-nonfree


C'est pourquoi smile j'ai une solution manuelle qui fonctionne tongue

Mais flashplugin-mozilla fonctionnne aussi smile

Hors ligne

Pied de page des forums