Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-02-2017 10:50:57

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Utilisation de Geany

Bonjour,

J'ai donné un pc sous Debian (dflinux) à un jeune lycéen et j'aimerais lui faire utiliser Geany pour qu'il apprenne le langage python...

1er question quand je fait python --version j'ai python 2.7.9
Pourtant quand le lance python3 j'ai bien la version 3.4.2
Pourquoi ?

2eme question je n'ai jamais utilisé Geany (étant linuxien de fraîche date) mais j'ai bricolé sous Windows et j'avais un utilitaire Pyscrapter qui permettait dans la même fenêtre d'avoir un éditeur et un interpréteur
pyscripter-editeur1.png

Comment obtient-on cela avec Geany ?
et comment compléter "définir les commandes d'éxécution"

Si il y a plus simple que Geany merci de me l'indiquer...

L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#2 17-02-2017 11:03:43

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Utilisation de Geany

bonsoir
en général les deux version de python sont installé (2.7 et 3.4)
pour l'apprentissage, regarde IDLE qui va permettre d'écrire les scripts, les sauvegarder et les tester directement

à mon avis pour l'apprentissage c'est le plus simple au début, il pourra passer à geany plus tard

(bon ça ne reste qu'un simple avis wink)

"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#3 17-02-2017 11:28:22

frei
Membre
Lieu : Tours
Distrib. : Sid
Noyau : 4.9.0-1-amd64
(G)UI : Mate+Compiz
Inscription : 06-01-2017
Site Web

Re : Utilisation de Geany

Sinon dans geany il te faut voir la console Python :

Menu Outils -> gestionnaire de plugin
Si i ln'y a pas GeanyPy alors il te faut installer le greffon :

apt-get install geany-plugin-py


The following additional packages will be installed:
  geany-plugins-common libc-dev-bin libc6-dev libexpat1-dev libpython2.7-dev linux-libc-dev
  manpages-dev
Paquets suggérés :
  glibc-doc
Les NOUVEAUX paquets suivants seront installés :
  geany-plugin-py geany-plugins-common libc-dev-bin libc6-dev libexpat1-dev libpython2.7-dev
  linux-libc-dev manpages-dev
0 mis à jour, 8 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 34,6 Mo dans les archives.
Après cette opération, 68,7 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]



Ensuite sous GeanyPy tu pourras cocher la sortie console

Pour le choix de ton compilateur exécuteur c'est dans le menu construire -> définir les commandes de construction

Pour lancer directement ton script c'est F5 par défaut.


"Glory. Rotting flower." John Tardy 1989

Hors ligne

#4 17-02-2017 12:11:47

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Utilisation de Geany

Merci pour GeanyPy... il apparait bien dans la liste des plugins, une fois installé, mais si je veux le cocher Geany se ferme scratchhead.gif

L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#5 17-02-2017 15:12:06

frei
Membre
Lieu : Tours
Distrib. : Sid
Noyau : 4.9.0-1-amd64
(G)UI : Mate+Compiz
Inscription : 06-01-2017
Site Web

Re : Utilisation de Geany

Blogus a écrit :

Merci pour GeanyPy... il apparait bien dans la liste des plugins, une fois installé, mais si je veux le cocher Geany se ferme ...



J'en suis navré roll

Que dirais tu de tout virer (geany et son greffon) et de les ré installer ?
En prenant soin de virer le dossier de conf (~/.config/geany) entre les deux ?

Au moins si ça vient d'une bidouille de conf antérieure on sera à l'abri.
Chez moi en clean install ça ne plante pas...
Comme je me barre en vacances dans quelques heures je ne peux pas pousser plus avant la recherche donc je commencerai par là.


Au plaisir (je repasse par là dimanche soir)


"Glory. Rotting flower." John Tardy 1989

Hors ligne

#6 17-02-2017 19:02:32

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Utilisation de Geany

frei a écrit :

Blogus a écrit :

Merci pour GeanyPy... il apparait bien dans la liste des plugins, une fois installé, mais si je veux le cocher Geany se ferme ...



J'en suis navré roll

Que dirais tu de tout virer (geany et son greffon) et de les ré installer ?
En prenant soin de virer le dossier de conf (~/.config/geany) entre les deux ?


Fait ...
Hélas même résultat sad


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#7 17-02-2017 20:02:11

mizapar
Membre
Distrib. : nutyx/debian8/ubuntu
(G)UI : openbox
Inscription : 26-10-2016

Re : Utilisation de Geany

on peut utiliser python directement dans le terminal:
python -- version nous donne la 2.7.9 ; pour utiliser python 3, il faut dans le termianl ecrire python 3
on peut enregistrer un fichier en .py et le lancer dans le terminal
si geny ne fonctionne pas  = soit on a un probleme de version entre le log ou le plug ou il ne se dirige pas vers la version de python souhaité
tu peut aussi essayer un autre editeur comme celui nommé plus haut ou utiliser atom https://atom.io/ avec le plug python https://atom.io/packages/python

mais pour de l'apprentissage a faire des additions ou je ne sait quoi travailler dans le terminal est le plus rapide

Hors ligne

#8 18-02-2017 10:20:32

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Utilisation de Geany

Bonjour,

Bien que je me satisfasse de geany en l'état smile, pour ceux que ça intéresse voici les versions de geany et geany-plugin-py installées (geanypy ne pouvant être activé) :
Version python 3.4.2
Version Geany : 1.24.1+dfsg-1
Version Geanypy : 1.24+dfsg-5

L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

Pied de page des forums